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Proprietary Notice

This document is protected by copyright and other related rights and the practice or
implementation of the information contained in this document may be protected by one or more
patents or pending patent applications. No part of this document may be reproduced in any form
by any means without the express prior written permission of Arm. No license, express or implied,
by estoppel or otherwise to any intellectual property rights is granted by this document unless
specifically stated.

Your access to the information in this document is conditional upon your acceptance that you
will not use or permit others to use the information for the purposes of determining whether
implementations infringe any third party patents.

THIS DOCUMENT IS PROVIDED “AS IS”. ARM PROVIDES NO REPRESENTATIONS AND NO
WARRANTIES, EXPRESS, IMPLIED OR STATUTORY, INCLUDING, WITHOUT LIMITATION,
THE IMPLIED WARRANTIES OF MERCHANTABILITY, SATISFACTORY QUALITY, NON-
INFRINGEMENT OR FITNESS FOR A PARTICULAR PURPOSE WITH RESPECT TO THE
DOCUMENT. For the avoidance of doubt, Arm makes no representation with respect to, and has
undertaken no analysis to identify or understand the scope and content of, patents, copyrights,
trade secrets, or other rights.

This document may include technical inaccuracies or typographical errors.

TO THE EXTENT NOT PROHIBITED BY LAW, IN NO EVENT WILL ARM BE LIABLE FOR

ANY DAMAGES, INCLUDING WITHOUT LIMITATION ANY DIRECT, INDIRECT, SPECIAL,
INCIDENTAL, PUNITIVE, OR CONSEQUENTIAL DAMAGES, HOWEVER CAUSED AND
REGARDLESS OF THE THEORY OF LIABILITY, ARISING OUT OF ANY USE OF THIS
DOCUMENT, EVEN IF ARM HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

This document consists solely of commercial items. You shall be responsible for ensuring that
any use, duplication or disclosure of this document complies fully with any relevant export laws
and regulations to assure that this document or any portion thereof is not exported, directly
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or indirectly, in violation of such export laws. Use of the word “partner” in reference to Arm’s
customers is not intended to create or refer to any partnership relationship with any other
company. Arm may make changes to this document at any time and without notice.

This document may be translated into other languages for convenience, and you agree that if there
is any conflict between the English version of this document and any translation, the terms of the
English version of the Agreement shall prevail.

The Arm corporate logo and words marked with ® or ™ are registered trademarks or trademarks
of Arm Limited (or its affiliates) in the US and/or elsewhere. All rights reserved. Other brands and
names mentioned in this document may be the trademarks of their respective owners. Please
follow Arm'’s trademark usage guidelines at https:/www.arm.com/company/policies/trademarks.
Copyright © 2021 Arm Limited (or its affiliates). All rights reserved.

Arm Limited. Company 02557590 registered in England.

110 Fulbourn Road, Cambridge, England CB1 9NU.
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Confidentiality Status

This document is Non-Confidential. The right to use, copy and disclose this document may be
subject to license restrictions in accordance with the terms of the agreement entered into by Arm
and the party that Arm delivered this document to.

Unrestricted Access is an Arm internal classification.

Product Status

The information in this document is Final, that is for a developed product.

Feedback

Arm® welcomes feedback on this product and its documentation. To provide feedback on the
product, create a ticket on https:/support.developer.arm.com

To provide feedback on the document, fill the following survey: https:/developer.arm.com/
documentation-feedback-survey.
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Inclusive language commitment

Arm values inclusive communities. Arm recognizes that we and our industry have used language
that can be offensive. Arm strives to lead the industry and create change.

We believe that this document contains no offensive language. To report offensive language in this
document, email terms@arm.com.
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Overview

1. Overview

You can add instrumentation to your Unreal Engine game, so that you can analyze different regions
separately in Arm Mobile Studio. For example, when you generate a Performance Advisor report,
the region names can be seen in the Frame rate analysis chart, and the report contains dedicated
analysis sections for each region.

Figure 1-1: Region names in Performance Advisor
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This tutorial describes how to:

o Create a basic project within Unreal Engine

e Integrate Streamline annotations with the code in your project

e Structure the Streamline annotations to create region markers in a Performance Advisor report

o Build your project for Android devices.
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2. Create an Unreal Engine project

Follow these steps to create a new Unreal Engine project for mobile:
1. Launch Unreal Engine, select Games and click Next.
Figure 2-1: Create a new games project in Unreal Engine
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2. Unreal Engine provides some templates that contain already-configured controls for mobile
devices. Or you can create your own by selecting Blank. Choose an option and click Next.
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Figure 2-2: Selecting a template in Unreal Engine

A
Select Template

3. Choose your required graphics settings for the project. For the purposes of this tutorial, here
are some recommended settings:

a. Create a C++ project

b. Choose Mobile/Tablet as the target platform

Choose Maximum Quality

Choose No Starter Content to significantly reduce the size of the APK
Set Raytracing Disabled as this is often too demanding for mobile GPUs

-~ 0o a O

Give your project a name and location.
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Create an Unreal Engine project

Figure 2-3: Project settings in Unreal Engine
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4. Click Create Project.
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Add the Streamline annotation files to your project

3. Add the Streamline annotation files to
your project

To add annotations, you need to include 2 files to your Unreal Engine project. These files are
located in your Arm Mobile Studio installation directory:

¢ <Jinstall location>/streamline/gator/annotate/streamline annotate.c

¢ <install location>/streamline/gator/annotate/streamline annotate.h

There are 2 ways to add these files to your project:

o Copy the files into your project, under <unreal project/Source/<project name> and then add
the following line into any source file where you want to create annotations:

#include "streamline annotate.h"
e Alternatively, build a 1ibstreamline annotate Makefile:

cd <install location>/streamline/gator/annotate
make

Then, copy the 1ibstreamline annotate library into your project, under <unreal project/Source/
<project name> and then add the following line into any source file where you want to create
annotations:

#include "libstreamline annotate"

Some of the libraries that are required to compile the given code aren’t included
by default with Windows or Microsoft Visual Studio. You might need to add them
manually:

e In Microsoft Visual Studio, right-click on your project name within the Solution
Explorer and select Manage NuGet Packages for <project_name>...

e Click Browse, then search for and select the package called pthreads.

e Select all of the options and click Install.
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4. Create region markers in your application

To enable annotation for your application, you must add this line to one of your C++ classes:

ANNOTATE SETUP;

Then, to denote sections of your code as a region, enclose it with ANNOTATE MARKER STR Statements
as follows, replacing <region name> wWith a unique name for that section, to be used in the
Performance Advisor report.

ANNOTATE MARKER STR ("Region Start <region name>");
// some code in your application...
ANNOTATE MARKER STR ("Region End <region name>");

Do not use the same region name multiple times.

When you generate a Performance Advisor report, the region names can be seen in the Frame rate
analysis chart, and the report contains dedicated analysis sections for each region.

Figure 4-1: Region names in Performance Advisor
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Configure your project and build the application

5. Configure your project and build the
application

To build an APK from your Unreal Engine project that can be tested on a mobile device with Arm
Mobile Studio tools, follow these steps:

1. Go to Edit > Project Settings > Platforms > Android SDK and check that the paths to your
Android SDK, NDK and Java JDK are set correctly. These are required in order to compile the
program.

Figure 5-1: Check SDK, NDK and JDK paths in Unreal Engine
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2. Next, go to Platforms > Android and select Configure Now.

Figure 5-2: Configure for Android in Unreal Engine

“ Platforms - Android

3. Consider setting the following options:

a. Android Package Name - change this to something that will identify this application, for
example, com.mycompany.mygame. You will need to look for this name when capturing
data from the device with Arm Mobile Studio tools.

b. Package game data inside .apk? - Choose this setting to combine the OBB data in to the
same file instead of building a separate OBB file.This makes the APK easier to upload to a
device when using Android Debug Bridge (adb).

c. Support armv7/armé4 - Choose whether to support 32-bit (armv7) and or 64-bit (armé4)
architectures. Selecting both significantly increases the size of the APK.

d. Support OpenGL/Vulkan - Choose whether you want to build an OpenGL or Vulkan
compatible application, or both.

Be aware of the following limitation in Performance Advisor when generating
reports for Vulkan applications - Slow capture with lwi_me.py on Vulkan
applications.
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4. In Project Settings > Project > Packaging > Project, ensure that the For Distribution checkbox is
not set. We want the APK to be debuggable, so that Arm Mobile Studio tools can collect data
from it, this can not be done with a production build.

Figure 5-3: Check For Distribution is not set in Unreal Engine
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5. Before packaging your project into an APK, use the Compile button on the Unreal Editor
toolbar to test that your code compiles correctly. This reports any compilation errors in your
code, and provides an output log at the bottom of the editor. Resolve any errors you find
before packaging your project.

Figure 5-4: Compile button in Unreal Editor

Nl

Compile

6. To package your project into an APK, select File > Package Project > Android > Android
(Multi:ASTC, DXT, ETC2) and specify an output directory for the file. Be aware that packaging
might take some time, depending upon the size of your application.

Your APK can now be profiled with Arm Mobile Studio tools, and your markers will be displayed

in Streamline and any Performance Advisor reports you generate. Refer to Get started with
Performance Advisor for instructions on how to profile your application. In addition to the
Performance Advisor report, you can also explore the Streamline capture, to see in detail how your
game uses the CPU and GPU resources in the device.
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Next steps

6. Next steps

Now that you have a debuggable APK of your game, you can use Arm Mobile Studio tools to
profile it, and your markers will be displayed in Streamline and any Performance Advisor reports
you generate.

e Referto Get started with Performance Advisor for instructions on how to profile your
application.

e In addition to the Performance Advisor report, you can also explore the Streamline capture, to
see in detail how your game uses the CPU and GPU resources in the device.

o To see all the graphics API calls your application makes, and investigate how objects are drawn
to the screen, try Graphics Analyzer.

e To see how individual shader programs would perform on any of the available Mali GPUs, use
Mali Offline Compiler.
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