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Preface

 

This preface introduces the Arm® Development Studio Getting Started Guide.

It contains the following:
• About this book on page 11.
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 About this book
This book describes how to get started with Arm® Development Studio. It takes you through the
processes of installing and licensing Arm Development Studio, and guides you through some of the
common tasks that you might encounter when using Arm Development Studio for the first time.

 Using this book

This book is organized into the following chapters:

Chapter 1 Introduction to Arm Development Studio
Arm Development Studio is a professional software development solution for bare-metal
embedded systems and Linux-based systems. It covers all stages in development from boot code
and kernel porting to application and bare-metal debugging, including performance analysis.

Chapter 2 Installing and configuring Arm Development Studio
Arm Development Studio is available for Windows and Linux operating systems. This chapter
describes installation requirements, the installation process, and how to configure Arm
Development Studio.

Chapter 3 Introduction to Arm Debugger
Introduces Arm Debugger and some important debugger concepts.

Chapter 4 Introduction to the Integrated Development Environment
The Arm Development Studio Integrated Development Environment (IDE) is Eclipse-based,
combining the Eclipse IDE from the Eclipse Foundation with the compilation and debug
technology of Arm tools.

Chapter 5 Projects and examples in Arm Development Studio
Describes how to work with projects in Arm Development Studio. Also lists the example projects
we provide, and how to import them into your workspace.

Chapter 6 Writing code
Describes how to use the editors when developing a project for an Arm target.

Chapter 7 Debugging code
Describes how to configure and connect to a debug target using Arm Debugger.

Chapter 8 Tutorials
Contains tutorials to help you get started with Arm Development Studio.

Chapter 9 Troubleshoot Arm Development Studio
Describes how to diagnose problems when debugging applications using Arm Debugger.

Appendix A Terminology and Shortcuts
Supplementary information for new users of Arm Development Studio.

 Glossary

The Arm® Glossary is a list of terms used in Arm documentation, together with definitions for those
terms. The Arm Glossary does not contain terms that are industry standard unless the Arm meaning
differs from the generally accepted meaning.

See the Arm Glossary for more information.

 Typographic conventions

italic
Introduces special terminology, denotes cross-references, and citations.

bold
Highlights interface elements, such as menu names. Denotes signal names. Also used for terms
in descriptive lists, where appropriate.

 Preface
 About this book
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monospace
Denotes text that you can enter at the keyboard, such as commands, file and program names,
and source code.

monospace
Denotes a permitted abbreviation for a command or option. You can enter the underlined text
instead of the full command or option name.

monospace italic
Denotes arguments to monospace text where the argument is to be replaced by a specific value.

monospace bold
Denotes language keywords when used outside example code.

<and>

Encloses replaceable terms for assembler syntax where they appear in code or code fragments.
For example:

MRC p15, 0, <Rd>, <CRn>, <CRm>, <Opcode_2>

SMALL CAPITALS

Used in body text for a few terms that have specific technical meanings, that are defined in the
Arm® Glossary. For example, IMPLEMENTATION DEFINED, IMPLEMENTATION SPECIFIC, UNKNOWN, and
UNPREDICTABLE.

 Feedback

Feedback on this product

If you have any comments or suggestions about this product, contact your supplier and give:
• The product name.
• The product revision or version.
• An explanation with as much information as you can provide. Include symptoms and diagnostic

procedures if appropriate.

Feedback on content

If you have comments on content then send an e-mail to errata@arm.com. Give:

• The title Arm Development Studio Getting Started Guide.
• The number 101469_2021.1_02_en.
• If applicable, the page number(s) to which your comments refer.
• A concise explanation of your comments.

Arm also welcomes general suggestions for additions and improvements.
 Note 

Arm tests the PDF only in Adobe Acrobat and Acrobat Reader, and cannot guarantee the quality of the
represented document when used with any other PDF reader.

 Other information

• Arm® Developer.
• Arm® Documentation.
• Technical Support.
• Arm® Glossary.

 Preface
 About this book
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Chapter 1
Introduction to Arm Development Studio

Arm Development Studio is a professional software development solution for bare-metal embedded
systems and Linux-based systems. It covers all stages in development from boot code and kernel porting
to application and bare-metal debugging, including performance analysis.

It includes:

The Arm Compiler 6 toolchain.

Build embedded and bare-metal embedded applications.

Arm Debugger.

A graphical debugger supporting software development on Arm processor-based targets and
Fixed Virtual Platform (FVP) targets.

Fixed Virtual Platform (FVP) targets.

Single and multi-core simulation models for architectures Armv6-M, Armv7-A/R/M and
Armv8-A/R/M. These enable you to develop software without any hardware.

Arm Streamline.

A graphical performance analysis tool that enables you to transform sampling data and system
trace into reports that present data in both visual and statistical forms.

Graphics Analyzer.

Graphics Analyzer allows graphics developers to trace OpenGL ES, Vulkan and OpenCL API
calls in their applications.

Dedicated examples, applications, and supporting documentation to help you get started with using Arm
Development Studio tools.
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Some third-party compilers are compatible with Arm Development Studio. For example, the GNU
Compiler tools enable you to compile bare-metal, Linux kernel, and Linux applications for Arm targets.

It contains the following sections:
• 1.1 Arm Compiler on page 1-15.
• 1.2 Arm Debugger on page 1-16.
• 1.3 Debug probes on page 1-17.
• 1.4 Fixed Virtual Platform models on page 1-19.
• 1.5 Arm Streamline on page 1-20.
• 1.6 Graphics Analyzer on page 1-21.

1 Introduction to Arm Development Studio
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1.1 Arm Compiler
The Arm Compiler toolchains enable you to build applications and libraries that are suitable for bare-
metal embedded systems.

As part of the download package, Arm Development Studio includes Arm Compiler 6 for compiling
embedded and bare-metal embedded applications. It supports the Armv6-M, Armv7, and Armv8
architectures.

There are two Arm Compiler toolchains that work with Arm Development Studio; the legacy Arm
Compiler 5, and the latest Arm Compiler 6. You can run these toolchains within the Arm Development
Studio IDE, or from the command line.

 Note 

• References to Arm Compiler in the Arm Development Studio documentation refer to Arm Compiler
6, unless otherwise specified

• Arm Compiler 5 is not included in the Arm Development Studio download package. However, you
can download the legacy toolchain from Arm Compiler 5 Downloads. To install, see Add a compiler
to Arm Development Studio on page 2-45,

• The features available to you in Arm Compiler depend on your individual license type.

For example, a license might:
— Limit the use of Arm Compiler to specific processors.
— Place a maximum limit on the size of images that can be produced.

You can enable additional features of Arm Compiler by purchasing a license for the full Arm
Development Studio suite. Contact your tools supplier for details.

Related references
2.14 Register a compiler toolchain on page 2-45

1 Introduction to Arm Development Studio
1.1 Arm Compiler
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1.2 Arm Debugger
Arm Debugger is accessible using either the Arm Development Studio IDE or command-line, and
supports software development on Arm processor-based targets and Fixed Virtual Platform (FVP)
targets.

Using Arm Debugger through the IDE allows you to debug bare-metal and Linux applications with
comprehensive and intuitive views, including:
• Synchronized source and disassembly.
• Call stack.
• Memory.
• Registers.
• Expressions.
• Variables.
• Threads.
• Breakpoints.
• Trace.

The Debug Control view enables you to single-step through applications at source-level or instruction-
level, and see other views update when the code is executed. Setting breakpoints or watchpoints stops the
application and allows you to explore the behavior of the application. You can also use the view to trace
function executions in your application with a timeline showing the sequence of events, if supported by
the target.

You can also debug using the Arm DS Command Prompt command-line console, which allows for
automation of debug and trace activities through scripts.

Related information
Debug control view
Overview of Arm Debugger

1 Introduction to Arm Development Studio
1.2 Arm Debugger
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1.3 Debug probes
Arm Development Studio supports various debug adapters and connections.

Debug adapters

Debug adapters vary in complexity and capability. When you use them with Arm Development Studio,
they provide high-level debug functionality, for example:

• Reading/writing registers
• Setting breakpoints
• Reading from memory
• Writing to memory

Supported Arm debug adapters include:

• Arm DSTREAM
• Arm DSTREAM-ST
• Arm DSTREAM-PT
• Arm DSTREAM-HT
• Arm DSTREAM-XT
• Keil® ULINK™2
• Keil ULINKpro™

• Keil ULINKpro D
• Keil ULINK-Plus

Supported third-party debug adapters include:
• ST-Link
• Cadence virtual debug
• FTDI MPSSE JTAG

 Note 

If you are using the FTDI MPSSE JTAG adapter on Linux, the OS automatically installs an incorrect
driver when you connect this adapter. For details on how to fix this issue, see Troubleshooting: FTDI
probe incompatible driver error in the Arm Development Studio User Guide.

• USB-Blaster II
 Note 

If you are using the USB-Blaster debug units, Arm Debugger can connect to Arria V SoC, Arria 10
SoC, Cyclone V SoC and Stratix 10 boards. To enable the connections, ensure that the environment
variable QUARTUS_ROOTDIR is set and contains the path to the Quartus tools installation directory:
— On Windows, this environment variable is usually set by the Quartus tools installer.
— On Linux, you might have to manually set the environment variable to the Quartus tools

installation path. For example, ~/<quartus_tools_installation_directory>/qprogrammer.

For information on installing device drivers for USB-Blaster and USB-Blaster II, consult your
Quartus tools documentation.

Debug connections

Debug connections allow the debugger to debug a variety of targets.

Supported debug connections include:
• CADI (debug interface for models)
• Iris interface for models
• Ethernet to gdbserver
• CMSIS-DAP

1 Introduction to Arm Development Studio
1.3 Debug probes
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Debug hardware configuration

Use the debug hardware configuration views in Arm Development Studio to update and configure the
debug hardware adapter that provides the interface between your development target and your
workstation.

Arm Development Studio provides the following views:
• Debug Hardware Config IP view

Use this view to configure the IP address on a debug hardware adapter.
• Debug Hardware Firmware Installer view

Use this view to update the firmware on a debug hardware adapter.

 Note 

These views only support the DSTREAM family of devices.

Related information
Troubleshooting: FTDI probe incompatible driver error

1 Introduction to Arm Development Studio
1.3 Debug probes

101469_2021.1_02_en Copyright © 2018–2021 Arm Limited or its affiliates. All rights
reserved.

1-18

Non-Confidential - REL

https://developer.arm.com/docs/101470/latest/perspectives-and-views/debug-hardware-configure-ip-view.html
https://developer.arm.com/docs/101470/latest/perspectives-and-views/debug-hardware-firmware-installer-view.html
https://developer.arm.com/docs/101470/latest/troubleshooting/ftdi-probe-incompatible-driver-error


1.4 Fixed Virtual Platform models
Fixed Virtual Platforms (FVPs) are complete simulations of an Arm system, including processor,
memory and peripherals. FVP targets give you a comprehensive model on which to build and test your
software, from the view of a programmer.

When using an FVP, absolute timing accuracy is sacrificed to achieve fast simulated execution speed.
This means that you can use a model for confirming software functionality, but you must not rely on the
accuracy of cycle counts, low-level component interactions, or other hardware-specific behavior.

Arm Development Studio provides several FVPs, covering a range of processors in the Cortex® family.
You can also connect to a variety of other Arm and third-party simulation models that implement CADI.

Arm Development Studio includes an Armv8-A FVP executable that supports the SVE architecture
extension. The executables are located in <install_directory>\bin\.... You can use them to run
your applications from either the command line or within the Arm Development Studio IDE.

Related information
About the Component Architecture Debug Interface (CADI)

1 Introduction to Arm Development Studio
1.4 Fixed Virtual Platform models

101469_2021.1_02_en Copyright © 2018–2021 Arm Limited or its affiliates. All rights
reserved.

1-19

Non-Confidential - REL

https://developer.arm.com/docs/100963/latest/introduction/about-the-component-architecture-debug-interface


1.5 Arm Streamline
Arm Streamline is a graphical performance analysis tool. It enables you to transform sampling data,
instruction trace, and system trace into reports that present the data in both visual and statistical forms.

Arm Streamline uses hardware performance counters with kernel metrics to provide an accurate
representation of system resources.

Related information
Streamline documentation

1 Introduction to Arm Development Studio
1.5 Arm Streamline
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1.6 Graphics Analyzer
Graphics Analyzer is a tool to help OpenGL ES, EGL, OpenCL, and Vulkan developers get the best out
of their applications through analysis at the API level.

Graphics Analyzer allows developers to trace OpenGL ES, Vulkan and OpenCL API calls in their
application and understand frame-by-frame the effect on the application to help identify possible issues.
Attempted misuse of the API is highlighted, as are recommendations for improvement on a Mali™-based
system. Trace information may also be captured to a file on one system and be analyzed later. The state
of the underlying GPU subsystem is observable at any point.

Related information
Graphics Analyzer documentation

1 Introduction to Arm Development Studio
1.6 Graphics Analyzer
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Chapter 2
Installing and configuring Arm Development Studio

Arm Development Studio is available for Windows and Linux operating systems. This chapter describes
installation requirements, the installation process, and how to configure Arm Development Studio.

It contains the following sections:
• 2.1 Hardware and host platform requirements on page 2-23.
• 2.2 Debug system requirements on page 2-24.
• 2.3 Installing on Windows on page 2-25.
• 2.4 Installing on Linux on page 2-27.
• 2.5 Additional Linux libraries on page 2-28.
• 2.6 Uninstalling Arm Development Studio on Linux on page 2-29.
• 2.7 Licensing Arm Development Studio on page 2-30.
• 2.8 Data collection in Arm Development Studio on page 2-33.
• 2.9 Arm Development Studio IDE analytics data points on page 2-34.
• 2.10 Arm Debugger analytics data points on page 2-35.
• 2.11 Language settings on page 2-38.
• 2.12 Configuring an RSE connection to work with an Arm Linux target on page 2-39.
• 2.13 Launching gdbserver with an application on page 2-44.
• 2.14 Register a compiler toolchain on page 2-45.
• 2.15 Specify plug-in install location on page 2-50.
• 2.16 Development Studio perspective keyboard shortcuts on page 2-51.
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2.1 Hardware and host platform requirements
For the best experience with Arm Development Studio, your hardware and host platform should meet the
minimum requirements.

Hardware requirements

To install and use Arm Development Studio, your workstation must have at least:

• A dual core x86 2GHz processor (or equivalent).
• 2GB of RAM.
• Approximately 3GB of hard disk space.

To improve performance, Arm recommends a minimum of 4GB of RAM when you:
• Debug large images.
• Use models with large simulated memory maps.
• Use Arm Streamline.

Host platform requirements
Arm Development Studio supports the following host platforms:
• Windows 10
• Red Hat Enterprise Linux 7 Workstation
• Ubuntu Desktop Edition 18.04 LTS

 Note 

Arm Development Studio only supports 64-bit host platforms.

Arm Compiler host platform requirements
Arm Development Studio contains the latest version of Arm Compiler 6. The release note provides
information on host platform compatibility:
• Arm Compiler 6

For information on adding other versions of Arm Compiler, including Arm Compiler 5, to Arm
Development Studio, see register a compiler toolchain.

2 Installing and configuring Arm Development Studio
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2.2 Debug system requirements
When debugging bare-metal and Linux targets, you need additional software and hardware.

Bare-metal requirements

You require a debug unit to connect bare-metal targets to Arm Development Studio. For a list of
supported debug units, see Debug Probes.

Linux application and Linux kernel requirements

Linux application debug requires gdbserver version 7.0 or later on your target.

In addition to gdbserver, certain architecture and debug features have minimum Linux kernel version
requirements. This is shown in the following table:

Table 2-1  Linux kernel version requirements

Architecture or debug feature Minimum Arm Linux kernel version

Debug with Arm Debugger 2.6.28

Application debug on Symmetric MultiProcessing (SMP) systems 2.6.36

Access VFP and Arm Neon™ registers 2.6.30

Arm Streamline 3.4

Managing firmware updates
• For DSTREAM, use the debug hardware firmware installer view to check the firmware and update it

if necessary. Updated firmware is available in <install_directory>/sw/debughw/firmware.
• To use ULINK2 debug probe with Arm Debugger, you must upgrade with CMSIS-DAP compatible

firmware. On Windows, the UL2_Upgrade.exe program can upgrade your ULINK2 unit. The
program and instructions are available in <install_directory>/sw/debughw/ULINK2.

• For ULINKpro and ULINKpro D, Arm Development Studio manages the firmware installation.

2 Installing and configuring Arm Development Studio
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2.3 Installing on Windows
There are two ways to install Arm Development Studio, you can use either the installation wizard, or the
command line.

 Note 

You can install multiple versions of Arm Development Studio on Windows platforms. To do this, you
must use different root installation directories.

This section contains the following subsections:
• 2.3.1 Using the installation wizard on page 2-25.
• 2.3.2 Using the command line on page 2-25.

2.3.1 Using the installation wizard

To install Arm Development Studio on Windows using the installation wizard, use the following
procedure.

Prerequisites

• Download the Arm Development Studio installation package.

Procedure
1. Unzip the downloaded .zip file.
2. Run armds-<version>.exe from this location. This opens the Arm Development Studio setup wizard.
3. Follow the on-screen instructions.

 Note 

• During installation, you might be prompted to install device drivers. Arm recommends that you
install these drivers. They allow USB connections to DSTREAM and Energy Probe hardware
units. They also support networking for the simulation models. These drivers are required to use
these features.

• When the drivers are installed, you might see some warnings about driver software. You can
safely ignore these warnings.

2.3.2 Using the command line

To install Arm Development Studio on Windows using the command line, use the following procedure.

Prerequisites

• Download the Arm Development Studio installation package.
• You must have admin privileges on your machine to install from the command line.

Procedure
1. Open the command prompt, with administrative privileges.
2. Run the Microsoft installer, msiexec.exe.

 Note 

• You must provide the location of the .msi file as an argument to msiexec.
• To display a full list of msiexec options, run msiexec /? from the command line.

2 Installing and configuring Arm Development Studio
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Example 2-1  Example using msiexec

An example of how to install Arm Development Studio using msiexec is:

msiexec.exe /i <installer_locationdatainstall.msi> EULA=1 /qn /l*v install.log

Command Definition

/i Performs the installation.

<installer_locationdatainstall.msi> Specifies the full path name of the .msi file to install.

/EULA=1 This is an Arm-specific option. Set EULA to 1 to accept the End
User License Agreement (EULA). You must read the EULA
before accepting it on the command line. This can be found in the
GUI installer, the installation files, or on the Arm Development
Studio downloads page.

/qn Specifies quiet mode; installation does not require user
interaction.

 Note 

Device driver installation requires user interaction. If
you do not require USB drivers, or if you want the
installation to avoid user interaction for USB drivers,
use the SKIP_DRIVERS=1 option on the command line.

/l*v<install.log> Specifies the log file to display all outputs from the installation.

2 Installing and configuring Arm Development Studio
2.3 Installing on Windows
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2.4 Installing on Linux
Install Arm Development Studio on Linux using the installation package provided on the Arm developer
website.

 Note 

You can install multiple versions of Arm Development Studio on Linux platforms. To do this, you must
use different root installation directories.

Prerequisites

Download the Linux installation package from the Arm Developer website.

Procedure
• Run armds-<version>.sh and follow the on-screen instructions.

 Note 

During the installation, Arm Development Studio automatically runs a dependency check and
produces a list of missing libraries. You can safely continue with the installation. Arm recommends
that you install these libraries before using Arm Development Studio.

You can find more details and a full list of required libraries in Additional Linux libraries
on page 2-28.

 Note 

Arm recommends that you run the post install setup scripts during the installation process.

Next Steps

To use the post install setup scripts after installation, with root privileges, run:

run_post_install_for_Arm_DS_IDE_<version>.sh

This script is in the install directory.

Device drivers and desktop shortcuts are optional features that are installed by this script. The device
drivers allow USB connections to debug hardware units, for example, the DSTREAM family. The
desktop menu is created using the http://www.freedesktop.org/ menu system on supported Linux
platforms.

 Note 

Use suite_exec to configure the environment variables correctly for Arm Development Studio. For
example, run <install_directory>/bin/suite_exec <shell> to open a shell with the PATH and
other environment variables correctly configured. Run suite_exec with no arguments for more help.

2 Installing and configuring Arm Development Studio
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2.5 Additional Linux libraries
To install Arm Development Studio on Linux, you need to install some additional libraries, which might
not be installed on your system.

The specific libraries that require installation depend on the distribution of Linux that you are running.
The dependency_check_linux-x86_64.sh script identifies libraries you must install. This script is in
<install_location>/sw/dependency_check.

 Note 

If the required libraries are not installed, some of the Arm Development Studio tools might fail to run.
You might encounter error messages, such as:
• armcc: No such file or directory
• arm-linux-gnueabihf-gcc: error while loading shared libraries: libstdc++.so.6: cannot open shared

object file: No such file or directory

Required libraries

Arm Development Studio depends on the following libraries:

• libasound.so.2
• libatk-1.0.so.0
• libc.so.6 *
• libcairo.so.2
• libfontconfig.so.1
• libfreetype.so.6
• libgcc_s.so.1 *
• libGL.so.1
• libGLU.so.1
• libgthread-2.0.so.0
• libgtk-x11-2.0.so.0
• libncurses.so.5
• libnsl.so.1
• libstdc++.so.6 *
• libusb-0.1.so.4
• libX11.so.6
• libXext.so.6
• libXi.so.6
• libXrender.so.1
• libXt.so.6
• libXtst.so.6
• libz.so.1 *

 Note 

On a 64-bit installation, libraries marked with an asterisk require an additional 32-bit compatibility
library. Tools installed by the 64-bit installer have dependencies on 32-bit system libraries. Arm
Development Studio tools might fail to run, or might report errors about missing libraries if 32-bit
compatibility libraries are not installed.

Some components also render using a browser library. Arm recommends that you install one of these
libraries to ensure all components render correctly:
• libwebkit-1.0.so.2
• libwebkitgtk-1.0.so.0
• libxpcom.so

2 Installing and configuring Arm Development Studio
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2.6 Uninstalling Arm Development Studio on Linux
Arm Development Studio is not installed with a package manager. To uninstall Arm Development Studio
on Linux, you must delete the installation directory. You might also need to delete additional
configuration files manually.

Procedure
1. Locate your Arm Development Studio installation directory.
2. If you ran the optional post-install step during or after installation, up to three additional

configuration files are created outside of the install directory. Delete the following files if they are
present:
• /etc/udev/rules.d/ARM_debug_tools.rules
• /etc/hotplug/usb/armdebugtools
• /etc/hotplug/usb/armdebugtools.usermap

3. If you installed the optional desktop shortcuts during or after installation, you can also remove them:
a. Locate the Arm Development Studio installation directory.
b. Run the following script: remove_menus_for_Arm_DevelopmentStudio_<version>.sh.

4. Delete the Arm Development Studio installation directory.
Related information
Installing Arm Development Studio on Linux

2 Installing and configuring Arm Development Studio
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2.7 Licensing Arm Development Studio
Arm Development Studio uses the FlexNet license management software to enable features that
correspond to specific editions.

To compare Arm Development Studio editions, see Compare editions

This section contains the following subsections:
• 2.7.1 Using Product Setup to add a license on page 2-30.
• 2.7.2 Viewing and managing licenses on page 2-31.

2.7.1 Using Product Setup to add a license

When you first open Arm Development Studio, the Product Setup dialog box opens and prompts you to
add a license.

Prerequisites

• If you have purchased Arm Development Studio, you need one of the following:
— The license server address and port number.
— The license file.

• To obtain an evaluation license, you need an Arm account.

Procedure
1. Add your license:

Figure 2-1  Product Setup dialog box when you first open Arm Development Studio.
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• For a license server, select Add product license, and click Next. Enter the license server address
and port number, in the form <port number> @ <server address>. Click Next.

• For a license file, select Add product license, and click Next. Click Browse… and select the
license file. Click Next.

• For an evaluation license:
1. Select Obtain evaluation license and click Next.
2. Log into your Arm account and click Next.
3. Choose a network interface and click Finish. An evaluation license is generated.

2. Select a product to activate, and click Finish.

2.7.2 Viewing and managing licenses

To view license information within Arm Development Studio, select Help > Arm License Manager.

Adding a license

You can add a license to Arm Development Studio using the Arm License Manager.

Prerequisites

You need the license server address and port number, or the license file.

Procedure
1. Click Help > Arm License Manager to view your license information.
2. Click Add to open the Product Setup wizard.

Figure 2-2  Adding a license in preferences dialog box.
3. Follow the steps in Using Product Setup to add a license on page 2-30 to add your license.

2 Installing and configuring Arm Development Studio
2.7 Licensing Arm Development Studio

101469_2021.1_02_en Copyright © 2018–2021 Arm Limited or its affiliates. All rights
reserved.

2-31

Non-Confidential - REL



Related tasks
2.7.1 Using Product Setup to add a license on page 2-30

Deleting a license

You can use the Arm license manager to delete unwanted licenses from Arm Development Studio.

Procedure
1. Click Help > Arm License Manager to view your license information.
2. Select the license you want to delete, and click Remove.

Figure 2-3  Deleting a license in preferences dialog box.
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2.8 Data collection in Arm Development Studio
Arm periodically collects anonymous information about the usage of our products in order to understand
and analyse what components or features you are using with the goal to improve our products and your
experience with them. Product usage analytics contain information such as system information, settings,
and usage of specific features of the product. You can enable or disable the feature in the product
settings. Product usage analytics do not include any personal information.

Host information includes:

• Operating system name, version, and locale.
• Number of CPUs.
• Amount of physical memory.
• Screen resolution.
• Processor and GPU type.

Feature tracking information includes:
• Events - Records that a feature, described by its category and name, was used. No further information

is collected.
• Numerical data - Tracks information that is related to time or size, expressed as a number. For

example, how long an operation took or the size of a file that is produced by an operation.
• Textual data - Tracks static information. For example, the name of an Arm processor.

Disabling data collection

To disable data collection, from the main menu, select Window > Preferences > Arm DS > General,
and deselect the Allow collection of anonymous analytics data option.

On disabling data collection, Arm Development Studio sends a final message to Arm to record that
analytics capture is disabled. This final message is only used for reporting opt-out statistics, and no
personal or system information is collected.

Related references
2.9 Arm Development Studio IDE analytics data points on page 2-34
2.10 Arm Debugger analytics data points on page 2-35
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2.9 Arm Development Studio IDE analytics data points
We periodically collect anonymous information about your use of the Arm Development Studio IDE.
This information allows us to understand and analyze what features you are using, with the goal to
improve our product and your experience with it.

Table 2-2  Arm DS IDE analytics data points

Category Name Description Since

Utilities

Target Configuration
Editor

Tracked Use of the Target Configuration Editor 2019.0

Reported Percentage of users using the Target Configuration Editor

Data Type Event

Send Policy Once a day

Trigger Points A file opened by the Target Configuration Editor

Projects

IDE build Tracked Use of Eclipse/CDT project build 2019.0

Reported Percentage of users building projects in Eclipse

Data Type Event

Send Policy Once a day

Trigger Points On project build

CMSIS target
software pack

Tracked Use of target software supplied as software packs 2019.0

Reported Percentage of users using each CMSIS target software pack

Data Type Text

Send Policy Once a day per unique value

Trigger Points On project build

Toolchains

Imported toolchain Tracked Imported toolchain identifier, family and version, used to build a
project in the IDE

2019.0

Reported Percentage of users building with each imported toolchain

Data Type Text

Send Policy Once a day per unique value

Trigger Points On project build
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2.10 Arm Debugger analytics data points
We periodically collect anonymous information about your use of Arm Debugger. This information
allows us to understand and analyze what features you are using, with the goal to improve our product
and your experience with it.

Table 2-3  Arm Debugger analytics data points

Category Name Description Since

Feature

Graphical sessions Tracked When a graphical debug session is initiated, not necessarily
successful.

2019.0

Reported Percentage of users using the graphical user interface.

Data Type Event

Send Policy Once a day.

Trigger Points On debug connection with the IDE.

Commandline
sessions

Tracked When commandline debug sessions are initiated, not necessarily
successful.

2019.0

Reported Percentage of users using the commandline debugger.

Data Type Event

Send Policy Once a day.

Trigger Points On debug connection with the CLI debugger.

Trace Tracked This can for instance record usage of the Trace view in the IDE or
usage of the trace dump command.

2019.0

Reported Percentage of users using trace-related features.

Data Type Event

Send Policy Once a day.

Trigger Points • A trace source is processed/decoded by the Trace view.
• Searching for trace events in the Trace view.
• The Export Trace Report action in the Trace view.
• The start, stop, and dump actions in the Trace Control view.
• A trace source is processed/decoded by the Events view.
• Any of the following debugger commands are run:

— trace start
— trace stop
— trace report
— trace dump

2 Installing and configuring Arm Development Studio
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Table 2-3  Arm Debugger analytics data points (continued)

Category Name Description Since

Python scripting Tracked Use of Python scripts, excluding scripting in DTSL. 2019.0

Reported Percentage of users using Python scripting.

Data Type Event

Send Policy Once a day

Trigger Points • A source command is executed for a file with a .py extension.
• A usecase command is executed.
• A breakpoint, with the script property set to a file with a .py

extension, is hit.

OS Awareness Tracked Name of OS awareness configured.
 Note 

If the OS awareness is not supplied by Arm, the name is
obfuscated using a one-way hashing algorithm.

Linux application debug is not considered an OS awareness, but a
target type, tracked with another another analytics data point.

2019.0

Reported Percentage of users for each OS awareness.

Data Type Text

Send Policy Once a day per unique value.

Trigger Points On debug connection.

CPU cache Tracked Use of cache-related features. 2019.0

Reported Percentage of users using cache-related features.

Data Type Event

Send Policy Once a day.

Trigger Points • Cache data is displayed in the Cache Data view.
• Cache data is displayed in the Memory view.
• The cache list or cache print debugger commands are run.

Types Tracked Type of debug target. For example, Hardware, CADI Model,
Linux Application, and so on.

2019.0

Reported Percentage of users for each target type.

Data Type Text

Send Policy Once a day per unique value.

Trigger Points On debug connection.

CPU architectures Tracked Name of the major CPU architecture version and profile
connected to, for example, Armv6-M.

2019.0

Reported Percentage of users for each target type.

Data Type Text

Send Policy Once a day per unique value.

Trigger Points On debug connection.
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Table 2-3  Arm Debugger analytics data points (continued)

Category Name Description Since

Number of cores Tracked Number of cores connected to in a single debug session. 2019.0

Reported Percentage of users for number of cores.

Data Type Number

Send Policy Once a day per unique value.

Trigger Points On debug connection.

Probes Tracked Name of the debug probe.
 Note 

If support for this probe is not supplied by Arm, the name is
obfuscated using a one-way hashing algorithm.

2019.0

Reported Percentage of users for each probe.

Data Type Text

Send Policy Once a day per unique value.

Trigger Points On debug connection.

Platform
manufacturer

Tracked Manufacturer of the platform in a debug session
 Note 

If support for this probe is not supplied by Arm, the name is
obfuscated using a one-way hashing algorithm.

2020.0

Reported Percentage of users for each target type.

Data Type Text

Send Policy Once a day per unique value.

Trigger Points On debug connection.

Platform name Tracked Name of the platform in a debug session
 Note 

If support for this probe is not supplied by Arm, the name is
obfuscated using a one-way hashing algorithm.

2020.0

Reported Percentage of users for each target type.

Data Type Text

Send Policy Once a day per unique value.

Trigger Points On debug connection.
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2.11 Language settings
Only Japanese language packs are currently supported by Arm Development Studio. These language
packs are installed with Arm Development Studio.

Procedure
• Launch the IDE in Japanese using one of the following methods:

— If your operating system locale is set as Japanese, the IDE automatically displays the translated
features.

— If your operating system locale is not set as Japanese, you must specify the -nl command-line
argument when launching the IDE:

armds_ide -nl ja
 Note 

Arm Compiler 6 does not support Japanese characters in source files.
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2.12 Configuring an RSE connection to work with an Arm Linux target
On some targets, you can use a SecureSHell (SSH) connection with the Remote System Explorer (RSE)
provided with Arm Development Studio.

Procedure
1. In the Remote Systems view, click the Define a connection to remote system option on the toolbar.
2. In the Select Remote System Type dialog box, expand the General group and select SSH Only.

Figure 2-4  Selecting a connection type
3. Click Next.
4. In Remote SSH Only System Connection, enter the remote target IP address or name in the Host

name field.
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Figure 2-5  Enter connection information
5. Click Next.
6. Verify if the Sftp Files, Configuration, and Available Services are what you require.
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Figure 2-6  Sftp Files options
7. Click Next.
8. Verify if the Ssh Shells, Configuration, and Available Services are what you require.
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Figure 2-7  Defining the shell services
9. Click Next.
10. Verify if the Ssh Terminals, Configuration, and Available Services are what you require.
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Figure 2-8  Defining the terminal services
11. Click Finish.
12. In the Remote Systems view:

a. Right-click on the target and select Connect from the context menu.
b. In the Enter Password dialog box, enter a UserID and Password if required.
c. Click OK to close the dialog box.

Your SSH connection is now set up. You can copy any required files from the local file system on to the
target file system. You can do this by dragging and dropping the relevant files into the Remote Systems
view.

Related tasks
5.4 Import the example projects on page 5-94
Related information
Debug Configurations - Connection tab
Debug Configurations - Files tab
Debug Configurations - Debugger tab
Debug Configurations - Environment tab
Target management terminal for serial and SSH connections
Remote Systems view

2 Installing and configuring Arm Development Studio
2.12 Configuring an RSE connection to work with an Arm Linux target

101469_2021.1_02_en Copyright © 2018–2021 Arm Limited or its affiliates. All rights
reserved.

2-43

Non-Confidential - REL

https://developer.arm.com/documentation/101470/latest/Perspectives-and-Views/Debug-Configurations---Connection-tab
https://developer.arm.com/documentation/101470/latest/Perspectives-and-Views/Debug-Configurations---Files-tab
https://developer.arm.com/documentation/101470/latest/Perspectives-and-Views/Debug-Configurations---Debugger-tab
https://developer.arm.com/documentation/101470/latest/Perspectives-and-Views/Debug-Configurations---Environment-tab
https://developer.arm.com/documentation/101470/latest/Perspectives-and-Views/Target-management-terminal-for-serial-and-SSH-connections
https://developer.arm.com/documentation/101470/latest/Perspectives-and-Views/Remote-Systems-view


2.13 Launching gdbserver with an application
Describes how to launch gdbserver with an application.

Procedure
1. Open a terminal shell that is connected to the target.
2. In the Remote Systems view, right-click on Ssh Terminals.
3. Select Launch Terminal to open a terminal shell.
4. In the terminal shell, navigate to the directory where you copied the application, then execute the

required commands.

Example 2-2  Example: Launch Gnometris

The following example shows the commands used to launch the Gnometris application.

export DISPLAY=ip:0.0
gdbserver :port gnometris

Where:

ip

is the IP address of the host to display the Gnometris application.

port

is the connection port between gdbserver and the application, for example 5000.

 Note 

If the target has a display connected to it, you do not need to use the export DISPLAY command.
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2.14 Register a compiler toolchain
You can use a different compiler toolchain other than the one installed with Arm Development Studio.

If you want to build projects using a toolchain that is not installed with Arm Development Studio, you
must first register the toolchain you want to use. You can register toolchains:

• Using the Preferences dialog box on page 2-45 in Arm Development Studio.
• Using the add_toolchain utility from the Arm Development Studio Command Prompt

on page 2-47.

You might want to register a compiler toolchain if:

• You want to use a GCC toolchain, or another Arm compiler such as Arm Compiler 5, that is not
included in the Arm Development Studio installation.

• You upgrade your version of Arm Development Studio but you want to use an earlier version of the
toolchain that was previously installed.

• You install a newer version or older version of the toolchain without re-installing Arm Development
Studio.

A variety of other compiler toolchains are available. To find other compiler toolchains, you can do the
following:

• Navigate to Arm Compiler downloads for the latest Arm Compiler toolchain.
• Download a GCC toolchain from Linaro.
• Download the GNU Arm Embedded toolchain for Arm processors.
• If you are using Arm Development Studio 2021.1 or later, and want to use Arm Compiler 5, you can

download it from https://developer.arm.com/tools-and-software/embedded/arm-compiler/arm-
compiler-5/downloads.

When you register a toolchain, the toolchain is available for new and existing projects in Arm
Development Studio.

 Note 

You can only register Arm or GCC toolchains.

This section contains the following subsections:
• 2.14.1 Registering a compiler toolchain using the Arm Development Studio IDE on page 2-45.
• 2.14.2 Register a compiler toolchain using the Arm DS command prompt on page 2-47.
• 2.14.3 Reconfigure existing projects to use a newly registered compiler toolchain on page 2-48.
• 2.14.4 Configure a compiler toolchain for the Arm DS command prompt on page 2-49.

2.14.1 Registering a compiler toolchain using the Arm Development Studio IDE

You can register compiler toolchains using the Preferences dialog box in Arm Development Studio.

Prerequisites

• Download an Arm Compiler or GCC toolchain.

Procedure
1. Open the Toolchains tab in the Preferences dialog box; Windows > Preferences > Arm DS >

Toolchains. Here, you can see the compiler toolchains that Arm DS currently recognizes,
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Figure 2-9  Toolchains Preferences dialog box
2. Click Add and enter the filepath to the toolchain binaries that you want to use. Then click Next to

autodetect the toolchain properties.
3. After the toolchain properties are autodetected, click Finish to register the toolchain. Alternatively,

click Next to manually enter or change the toolchain properties, and then click Finish.
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Figure 2-10  Properties for the new toolchain

 Note 

You must manually enter the toolchain properties if:
• The toolchain properties were not autodetected.
• The family, major version, and minor version of the new toolchain are identical to a toolchain that

Arm DS already knows about.

4. In the Preferences dialog box, click Apply.
5. Restart Arm Development Studio.

• The new toolchain is registered with Arm Development Studio.
• When you create a new project, Arm DS shows the new toolchain in the available list of toolchains.

Related tasks
2.14.3 Reconfigure existing projects to use a newly registered compiler toolchain on page 2-48

2.14.2 Register a compiler toolchain using the Arm DS command prompt

Use the add_toolchain utility from the command prompt to register a new Arm Compiler or GCC
toolchain.
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Prerequisites

• Download an Arm Compiler or GCC toolchain.

Procedure
1. Open the Arm DS <version> Command Prompt, and enter add_toolchain <path>, where <path> is

the directory containing the toolchain binaries. The utility automatically detects the toolchain
properties.

 Note 

By default, the add_toolchain utility is an interactive tool. To use the add_toochain utility as a
non-interactive tool, add the --non-interactive option to the command.

For example, on Windows:
add_toolchain "C:\Program Files (x86)\ARM_Compiler_5.06u7\bin64" --non-interactive

2. The utility prompts whether you want to register the toolchain with the details it has detected. If you
want to change the details, the utility prompts for the details of the toolchain.

3. Restart Arm Development Studio. You must do this before you can use the toolchain in the Arm DS
environment.

 Note 

• The toolchain target only applies to GCC toolchains. It indicates what target platform the GCC
toolchain builds for. For example, if your compiler toolchain binary is named arm-linux-
gnueabihf-gcc, then the target name is the prefix arm-linux-gnueabihf. The target field allows
Arm DS to distinguish different toolchains that otherwise have the same version.

• You must manually enter the toolchain properties if:
— The toolchain properties were not autodetected.
— The type, major version, and minor version of the new toolchain are identical to a toolchain

that Arm DS already knows about.

• The new toolchain is registered with Arm Development Studio.
• When you create a new project, Arm DS shows the new toolchain in the available list of toolchains.

Related tasks
2.14.3 Reconfigure existing projects to use a newly registered compiler toolchain on page 2-48

2.14.3 Reconfigure existing projects to use a newly registered compiler toolchain

When you register a new compiler toolchain in Arm Development Studio, you can reconfigure existing
projects to use the newly registered toolchain.

Prerequisites

Register an Arm Compiler or GCC toolchain. You can use the IDE on page 2-45 or the Arm DS
command prompt on page 2-47.

Procedure
1. Select a new compiler toolchain to use with your project.

a. In the Project Explorer view, right-click your project and select Properties > C/C++ Build >
Tool Chain Editor.

b. Select the new toolchain under the Current toolchain drop-down menu.
c. Click Apply and Close.

2. After you change the toolchain, clean and rebuild the project.
a. In the Project Explorer view, select the project, right-click it and select Clean Project.
b. In the Project Explorer view, select the project, right-click it and select Build Project.
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2.14.4 Configure a compiler toolchain for the Arm DS command prompt

When you want to compile or build from the Arm DS command prompt, you must select the compiler
toolchain you want to use. You can either specify a default toolchain, so that you do not need to select a
toolchain every time you start the Arm DS command prompt, or you can specify a toolchain for the
current session only.

 Note 

By default, the Arm DS command prompt is not configured with a compiler toolchain.

Configure a compiler toolchain for the Arm DS command prompt on Linux

Describes how to specify a compiler toolchain using the Linux command-line utility.

Procedure
1. To set a default compiler toolchain, run <install_directory>/bin/select_default_toolchain

and follow the instructions.
2. To specify a compiler toolchain for the current session, run

<install_directory>/bin/suite_exec --toolchain <toolchain_name>

 Tip 

To list the available toolchains, run suite_exec with no arguments.

 Note 

If you specify a toolchain using the suite_exec --toolchain command, it overwrites the default
compiler toolchain for the current session.

Example 2-3  Example

To use the Arm Compiler toolchain in the current session, run:

<install_directory>/bin/suite_exec --toolchain "Arm Compiler 6" bash --norc

Configure a compiler toolchain for the Arm DS command prompt on Windows

Describes how to specify a compiler toolchain using the Arm DS Command Prompt.

Procedure
1. To set a default compiler toolchain:

a. Select Start > All Programs > Arm DS Command Prompt.
b. To see the available compiler toolchains, enter select_default_toolchain.
c. From the list of available toolchains, select your default compiler toolchain.

2. To specify a compiler toolchain for the current session:
a. Select Start > All Programs > Arm DS Command Prompt.
b. To see the available compiler toolchains, enter select_toolchain.

 Note 

Using this command overwrites the default compiler toolchain for the current session.

c. From the list of available toolchains, select the one that you want to use for this session.
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2.15 Specify plug-in install location
By default, Arm Development Studio installs plug-ins into the user's home area. You can override the
default settings so that the plug-ins are installed into the Arm DS installation directory. Plug-ins available
in the Arm DS installation directory are available to all users of the host workstation.

You override the default Arm Development Studio configuration location using the Eclipse vmargs
runtime option. The Eclipse vmargs runtime option allows you to customize the operation of the Java
VM to run Eclipse. See the Eclipse runtime options documentation for more information about the
Eclipse vmargs runtime option.

Prerequisites

• Installation of Arm Development Studio with appropriate licenses applied.
• Access to your Arm Development Studio install.

Procedure
1. At your operating system command prompt, enter: <armds_install_directory>/bin/armds_ide -

vmargs -Dosgi.configuration.area=<install_directory/sw/ide/configuration> -
Dosgi.configuration.cascaded=false.

 Note 

On Windows, you must run armds_idec.exe from either the Arm DS Command Prompt, or
directly from the <install_directory>/bin directory. Do not run the armds_idec.exe executable
that is in the <install_directory>/sw/eclipse directory.

The armds_idec.exe executable in <install_directory>/bin acts as a wrapper for
armds_idec.exe in <install_directory>/sw/eclipse. Running the executable from the
<install_directory>/bin directory sets up the Arm Development Studio environment (paths,
environment variables, and other similar items) in the same way as the Arm DS Command Prompt.

2. Install your Eclipse plug-in using your preferred plug-in installation option, for example, the Eclipse
Marketplace.

3. Restart Arm Development Studio when prompted to do so.

Your plug-ins are now installed into the Arm Development Studio <install_directory/sw/ide/
configuration> directory and are available to all users of the host workstation.
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2.16 Development Studio perspective keyboard shortcuts
You can use various keyboard shortcuts in the Development Studio perspective.

You can access the dynamic help in any view or dialog box by using the following:
• On Windows, use the F1 key
• On Linux, use the Shift+F1 key combination.

The following keyboard shortcuts are available when you connect to a target:

Commands view

You can use:

Ctrl+Space

Access the content assist for autocompletion of commands.

Enter

Execute the command that is entered in the adjacent field.

DOWN arrow

Navigate down through the command history.

UP arrow

Navigate up through the command history.

Debug Control view

You can use:

F5

Step at source level including stepping into all function calls where there is debug
information.

ALT+F5

Step at instruction level including stepping into all function calls where there is debug
information.

F6

Step at source or instruction level but stepping over all function calls.

F7

Continue running to the next instruction after the selected stack frame finishes.

F8
Continue running the target.

 Note 

A Connect only connection might require setting the PC register to the start of the
image before running it.

F9

Interrupt the target and stop the current application if it is running.

Related information
Commands view
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Chapter 3
Introduction to Arm Debugger

Introduces Arm Debugger and some important debugger concepts.

It contains the following sections:
• 3.1 Overview: Arm Debugger and important concepts on page 3-53.
• 3.2 Debugger concepts on page 3-54.
• 3.3 Overview: Arm CoreSight debug and trace components on page 3-58.
• 3.4 Overview: Debugging multi-core (SMP and AMP), big.LITTLE, and multi-cluster targets

on page 3-59.
• 3.5 Overview: Debugging Arm-based Linux applications on page 3-63.
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3.1 Overview: Arm Debugger and important concepts
Arm Debugger is part of Arm Development Studio and helps you find the cause of software bugs on
Arm processor-based targets and Fixed Virtual Platform (FVP) targets.

From device bring-up to application debug, it can be used to develop code on an RTL simulator, virtual
platform, and hardware, to help get your products to market quickly.

Arm Debugger supports:
• Loading images and symbols.
• Running images.
• Breakpoints and watchpoints.
• Source and instruction level stepping.
• CoreSight™ and non-CoreSight trace (Embedded Trace Macrocell Architecture Specification v3.0 and

above).
• Accessing variables and register values.
• Viewing the contents of memory.
• Navigating the call stack.
• Handling exceptions and Linux signals.
• Debugging bare-metal code.
• Debugging multi-threaded Linux applications.
• Debugging the Linux kernel and Linux kernel modules.
• Debugging multicore and multi-cluster systems, including big.LITTLE™.
• Debugging Real-Time Operating Systems (RTOSs).
• Debugging from the command-line.
• Performance analysis using Arm Streamline.
• A comprehensive set of debugger commands that can be executed in the Eclipse Integrated

Development Environment (IDE), script files, or a command-line console.
• GDB debugger commands, making the transition from open source tools easier.
• A small subset of third party CMM-style commands sufficient for running target initialization scripts.

Using Arm Debugger, you can debug bare-metal and Linux applications with comprehensive and
intuitive views, including synchronized source and disassembly, call stack, memory, registers,
expressions, variables, threads, breakpoints, and trace.
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3.2 Debugger concepts
Lists some of the useful concepts to be aware of when working with Arm Debugger.

AMP

Asymmetric Multi-Processing (AMP) system has multiple processors that may be different
architectures. See Debugging AMP Systems on page 3-61 for more information.

Bare-metal

A bare-metal embedded application is one which does not run on an OS.

BBB

The old name for the MTB.

CADI

Component Architecture Debug Interface. This is the API used by debuggers to control models.

Configuration database

The configuration database is where Arm Debugger stores information about the processors,
devices, and boards it can connect to.

The database exists as a series of .xml files, python scripts, .rvc files, .rcf files, .sdf files,
and other miscellaneous files within the <installation_directory>/sw/debugger/
configdb/ directory.

Arm Development Studio comes pre-configured with support for a wide variety of devices out-
of-the-box, and you can view these in the Debug Configuration dialog box in the Arm
Development Studio IDE.

You can also add support for your own devices using the Platform Configuration Editor (PCE)
tool.

Contexts

Each processor in the target can run more than one process. However, the processor only
executes one process at any given time. Each process uses values stored in variables, registers,
and other memory locations. These values can change during the execution of the process.

The context of a process describes its current state, as defined principally by the call stack that
lists all the currently active calls.

The context changes when:
• A function is called.
• A function returns.
• An interrupt or an exception occurs.

Because variables can have class, local, or global scope, the context determines which variables
are currently accessible. Every process has its own context. When execution of a process stops,
you can examine and change values in its current context.

CTI

The Cross Trigger Interface (CTI) combines and maps trigger requests, and broadcasts them to
all other interfaces on the Embedded Cross Trigger (ECT) sub-system. See Cross-trigger
configuration for more information.

DAP

The Debug Access Port (DAP) is a control and access component that enables debug access to
the complete SoC through system master ports. See About the Debug Access Port for more
information.
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Debugger

A debugger is software running on a host computer that enables you to make use of a debug
adapter to examine and control the execution of software running on a debug target.

Debug agent

A debug agent is hardware or software, or both, that enables a host debugger to interact with a
target. For example, a debug agent enables you to read from and write to registers, read from
and write to memory, set breakpoints, download programs, run and single-step programs,
program flash memory, and so on.

gdbserver is an example of a software debug agent.

Debug session

A debug session begins when you connect the debugger to a target for debugging software
running on the target and ends when you disconnect the debugger from the target.

Debug target

A debug target is an environment where your program runs. This environment can be hardware,
software that simulates hardware, or a hardware emulator.

A hardware target can be anything from a mass-produced development board or electronic
equipment to a prototype product, or a printed circuit board.

During the early stages of product development, if no hardware is available, a simulation or
software target might be used to simulate hardware behavior. A Fixed Virtual Platform (FVP) is
a software model from Arm that provides functional behavior equivalent to real hardware.

 Note 

Even though you might run an FVP on the same host as the debugger, it is useful to think of it as
a separate piece of hardware.

Also, during the early stages of product development, hardware emulators are used to verify
hardware and software designs for pre-silicon testing.

Debug adapter

A debug adapter is a physical interface between the host debugger and hardware target. It acts as
a debug agent. A debug adapter is normally required for bare-metal start/stop debugging real
target hardware, for example, using JTAG.

Examples include DSTREAM, DSTREAM-ST, and the ULINK family of debug and trace
adapters.

DSTREAM
The Arm DSTREAM family of debug and trace units. For more information, see: DSTREAM
family

 Note 

Arm Development Studio supports the Arm DSTREAM debug unit, but it is discontinued and
no longer available to purchase.

DTSL

Debug and Trace Services Layer (DTSL) is a software layer within the Arm Debugger stack.
DTSL is implemented as a set of Java classes which are typically implemented (and possibly
extended) by Jython scripts. A typical DTSL instance is a combination of Java and Jython. Arm
has made DTSL available for your own use so that you can create programs (Java or Jython) to
access/control the target platform.
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DWARF

DWARF is a debugging format used to describe programs in C and other similar programming
languages. It is most widely associated with the ELF object format but it has been used with
other object file formats.

ELF

Executable and Linkable Format (ELF) is a common standard file format for executables, object
code, shared libraries, and core dumps.

ETB

Embedded Trace Buffer (ETB) is an optional on-chip buffer that stores trace data from different
trace sources. You can use a debugger to retrieve captured trace data.

ETF

Embedded Trace FIFO (ETF) is a trace buffer that uses a dedicated SRAM as either a circular
capture buffer, or as a FIFO. The trace stream is captured by an ATB input that can then be
output over an ATB output or the Debug APB interface. The ETF is a configuration option of
the Trace Memory Controller (TMC).

ETM

Embedded Trace Macrocell (ETM) is an optional debug component that enables reconstruction
of program execution. The ETM is designed to be a high-speed, low-power debug tool that
supports trace.

ETR

Embedded Trace Router (ETR) is a CoreSight component which routes trace data to system
memory or other trace sinks, such as HSSTP.

FVP

Fixed Virtual Platform (FVP) enables development of software without the requirement for
actual hardware. The functional behavior of the FVP is equivalent to real hardware from a
programmers view.

ITM

Instruction Trace Macrocell (ITM) is a CoreSight component which delivers code
instrumentation output and specific hardware data streams.

jRDDI

The Java API implementation of RDDI.

Jython

An implementation of the Python language which is closely integrated with Java.

MTB

Micro Trace Buffer. This is used in the Cortex‑M0 and Cortex-M0+.

PTM

Program Trace Macrocell (PTM) is a CoreSight component which is paired with a core to
deliver instruction only program flow trace data.

RDDI

Remote Device Debug Interface (RDDI) is a C-level API which allows access to target debug
and trace functionality, typically through a DSTREAM box, or a CADI model.
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Scope

The scope of a variable is determined by the point within an application at which it is defined.

Variables can have values that are relevant within:
• A specific class only (class).
• A specific function only (local).
• A specific file only (static global).
• The entire application (global).

SMP

A Symmetric Multi-Processing (SMP) system has multiple processors with the same
architecture. See Debugging SMP systems on page 3-59 for more information.

STM

System Trace Macrocell (STM) is a CoreSight component which delivers code instrumentation
output and other hardware generated data streams.

TPIU

Trace Port Interface Unit (TPIU) is a CoreSight component which delivers trace data to an
external trace capture device.

TMC
The Trace Memory Controller (TMC) enables you to capture trace using:
• The debug interface such as 2-pin serial wire debug.
• The system memory such as a dynamic Random Access Memory (RAM).
• The high-speed links that already exist in the System-on-Chip (SoC) peripheral.
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3.3 Overview: Arm CoreSight debug and trace components
CoreSight defines a set of hardware components for Arm-based SoCs. Arm Debugger uses the CoreSight
components in your SoC to provide debug and performance analysis features.

Examples of common CoreSight components include:

• DAP: Debug Access Port
• ECT: Embedded Cross Trigger
• TMC: Trace Memory Controller

— ETB: Embedded Trace Buffer
— ETF: Embedded Trace FIFO
— ETR: Embedded Trace Router

• ETM: Embedded Trace Macrocell
• PTM: Program Trace Macrocell
• ITM: Instrumentation Trace Macrocell
• STM: System Trace Macrocell

 Note 

Trace triggers are not supported on Cortex‑M series processors.

Examples of how these components are used by Arm Debugger include:
• The Trace view displays data collected from PTM and ETM components.
• The Events view displays data collected from ITM and STM components.
• Debug connections can make use of the ECT to provide synchronized starting and stopping of groups

of cores. For example, you can use the ECT to:
— Stop all the cores in an SMP group simultaneously.
— Halt heterogeneous cores simultaneously to allow whole system debug at a particular point in

time.

If you are using an SoC that is supported out-of-the-box with Arm Debugger, select the correct platform
(SoC) in the Debug Configuration dialog box to configure a debug connection. If you are using an SoC
that is not supported by Arm Debugger by default, then you must first define a custom platform in Arm
Debugger's configuration database using the Platform Configuration Editor tool.

For all platforms, whether built-in or manually created, you can use the Platform Configuration Editor
(PCE) to easily define the debug topology between various components available on the platform. See
the Platform Configuration Editor topic for details.
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3.4 Overview: Debugging multi-core (SMP and AMP), big.LITTLE, and multi-
cluster targets

Arm Debugger is developed with multicore debug in mind for bare-metal, Linux kernel, or application-
level software development.

Awareness for Symmetric Multi-Processing (SMP), Asymmetric Multi-Processing (AMP), and
big.LITTLE configurations is embedded in Arm Debugger, allowing you to see which core, or cluster a
thread is executing on.

When debugging applications in Arm Debugger, multicore configurations such as SMP or big.LITTLE
require no special setup process. Arm Debugger includes predefined configurations, backed up by the
Platform Configuration Editor which enables further customization. The nature of the connection
determines how Arm Debugger behaves, for example stopping and starting all cores simultaneously in a
SMP system.

This section contains the following subsections:
• 3.4.1 Debugging SMP systems on page 3-59.
• 3.4.2 Debugging AMP Systems on page 3-61.
• 3.4.3 Debugging big.LITTLE Systems on page 3-61.

3.4.1 Debugging SMP systems

From the point of view of Arm Debugger, Symmetric Multi Processing (SMP) refers to a set of
architecturally identical cores that are tightly coupled together and used as a single multi-core execution
block. Also, from the point of view of the debugger, they must be started and halted together.

Arm Debugger expects an SMP system to meet the following requirements:
• The same ELF image running on all processors.
• All processors must have identical debug hardware. For example, the number of hardware breakpoint

and watchpoint resources must be identical.
• Breakpoints and watchpoints must only be set in regions where all processors have identical physical

and virtual memory maps. Processors with separate instances of identical peripherals mapped to the
same address are considered to meet this requirement. Private peripherals of Arm multicore
processors is a typical example.

Configuring and connecting

To enable SMP support in the debugger, you must first configure a debug session in the Debug
Configurations dialog box. Configuring a single SMP connection is all that you require to enable SMP
support in the debugger.

Targets that support SMP debugging have SMP mentioned against them.

Figure 3-1  Versatile Express A9x4 SMP configuration
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Once connected to your target, use the Debug Control view to work with all the cores in your SMP
system.

Image and symbol loading

When debugging an SMP system, image and symbol loading operations apply to all the SMP processors.

For image loading, this means that the image code and data are written to memory once, through one of
the processors, and are assumed to be accessible through the other processors at the same address
because they share the same memory.

For symbol loading, this means that debug information is loaded once and is available when debugging
any of the processors.

Running, stepping, and stopping

When debugging an SMP system, attempting to run one processor automatically starts running all the
other processors in the system. Similarly, when one processor stops, either because you requested it or
because of an event such as a breakpoint being hit, then all the other processors in the system stop.

For instruction level single-stepping commands, stepi and nexti, the currently selected processor steps
one instruction.

Figure 3-2  Core 0 stopped on step i command

The exception to this is when a nexti operation is required to step over a function call, in which case, the
debugger sets a breakpoint and then runs all processors. All other stepping commands affect all
processors.

Depending on your system, there might be a delay between different cores running or stopping. This
delay can be very large because the debugger must run and stop each core individually. However,
hardware cross-trigger implementations in most SMP systems ensure that the delays are minimal and are
limited to a few processor clock cycles.

In rare cases, one processor might stop, and one or more of the other processors might not respond. This
can occur, for example, when a processor running code in secure mode has temporarily disabled debug
ability. When this occurs, the Debug Control view displays the individual state of each processor,
running or stopped, so you can see which ones have failed to stop. Subsequent run and step operations
might not operate correctly until all the processors stop.

Breakpoints, watchpoints, and signals

By default, when debugging an SMP system, breakpoint, watchpoint, and signal (vector catch)
operations apply to all processors. This means that you can set one breakpoint to trigger when any of the
processors execute code that meets the criteria. When the debugger stops due to a breakpoint,
watchpoint, or signal, then the processor that causes the event is listed in the Commands view.

Breakpoints or watchpoints can be configured for one or more processors by selecting the required
processor in the relevant Properties dialog box. Alternatively, you can use the break-stop-on-cores
command. This feature is not available for signals.
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Examining target state

Views of the target state, including Registers, Call stack, Memory, Disassembly, Expressions, and
Variables contain content that is specific to a processor. Views such as Breakpoints, Signals, and
Commands are shared by all the processors in the SMP system, and display the same contents regardless
of which processor is currently selected.

Trace

If you are using a connection that enables trace support, you can view trace for each of the processors in
your system using the Trace view.

By default, the Trace view shows trace for the processor that is currently selected in the Debug Control
view. Alternatively, you can choose to link a Trace view to a specific processor by using the Linked:
context toolbar option for that Trace view. Creating multiple Trace views linked to specific processors
enables you to view the trace from multiple processors at the same time.

 Note 

The indexes in the different Trace views do not necessarily represent the same point in time for different
processors.

3.4.2 Debugging AMP Systems

From the point of view of Arm Debugger, Asymmetric Multi Processing (AMP) refers to a set of cores
which operate in an uncoupled manner. The cores can be of different architectures or of the same
architecture but not operating in an SMP configuration. Also, from the point of view of the debugger, it
depends on the implementation whether the cores need to be started or halted together.

An example of this might be a Cortex‑A5 device coupled with a Cortex-M4, combining the benefits of
an MCU running an RTOS which provides low-latency interrupt with an application processor running
Linux. These are often found in industrial applications where a rich user-interface might need to interact
closely with a safety-critical control system, combining multiple cores into an integrated SoC for
efficiency gains.

Bare metal debug on AMP Systems

Arm Debugger supports simultaneous debug of the cores in AMP devices. In this case, you need to
launch a debugger connection to each one of the cores and clusters in the system. Each one of these
connections is treated independently, so images, debug symbols, and OS awareness are kept separate for
each connection. For instance, you will normally load an image and its debug symbols for each AMP
processor. With multiple debug sessions active, you can compare content in the Registers, Disassembly,
and Memory views by opening multiple views and linking them to multiple connections, allowing you
to view the state of each processor at the same time.

It is possible to connect to a system in which there is a cluster or big.LITTLE subsystem working in SMP
mode, for example, running Linux, with extra processors working in AMP mode for example, running
their own bare-metal software or an RTOS. Arm Debugger is capable of supporting these devices by just
connecting the debugger to each core or subsystem separately.

3.4.3 Debugging big.LITTLE Systems

A big.LITTLE system optimizes for both high performance and low power consumption over a wide
variety of workloads. It achieves this by including one or more high performance processors alongside
one or more low power processors.
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Awareness for big.LITTLE configurations is built into Arm Debugger, allowing you to establish a bare-
metal, Linux kernel, or Linux application debug connection, just as you would for a single core
processor.

 Note 

For the software required to enable big.LITTLE support in your own OS, visit the big.LITTLE Linaro git
repository.

Bare-metal debug on big.LITTLE systems

For bare-metal debugging on big.LITTLE systems, you can establish a big.LITTLE connection within
Arm Debugger. In this case, all the processors in the big.LITTLE system are brought under the control of
the debugger. The debugger monitors the power state of each processor as it runs and displays it in the
Debug Control view and on the command-line. Processors that are powered-down are visible to the
debugger, but cannot be accessed. The remaining functionality of the debugger is equivalent to an SMP
connection to a homogeneous cluster of cores.

Linux application debug on big.LITTLE systems

For Linux application debugging on big.LITTLE systems, you can establish a gdbserver connection
within Arm Debugger. Linux applications are typically unaware of whether they are running on a big
processor or a LITTLE processor because this is hidden by the operating system. Therefore, there is no
difference when debugging a Linux application on a big.LITTLE system as compared to application
debug on any other system.
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3.5 Overview: Debugging Arm-based Linux applications
Arm Debugger supports debugging Linux applications and libraries that are written in C, C++, and Arm
assembly.

The integrated suite of tools in Arm Development Studio enables rapid development of optimal code for
your target device.

For Linux applications, communication between the debugger and the debugged application is achieved
using gdbserver. See Configuring a connection to a Linux application using gdbserver for more
information.

Related tasks
7.7 Configuring a connection to a Linux kernel on page 7-125
7.6 Configuring a connection to a Linux application using gdbserver on page 7-122
Related information
About debugging shared libraries
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Chapter 4
Introduction to the Integrated Development
Environment

The Arm Development Studio Integrated Development Environment (IDE) is Eclipse-based, combining
the Eclipse IDE from the Eclipse Foundation with the compilation and debug technology of Arm tools.

It includes:

Project Explorer

The project explorer enables you to perform various project tasks such as adding or removing
files and dependencies to projects, importing, exporting, or creating projects, and managing
build options.

Editors

Editors enable you to read, write, or modify C/C++ or Arm assembly language source files.

Perspectives and views

Perspectives provide customized views, menus, and toolbars to suit a particular type of
environment. Arm Development Studio uses the Development Studio perspective by default.
To switch perspectives, from the main menu, select Window > Perspective > Open
Perspective.

It contains the following sections:
• 4.1 Integrated Development Environment (IDE) Overview on page 4-65.
• 4.2 Using the IDE on page 4-66.
• 4.3 Personalize your development environment on page 4-70.
• 4.4 Launch the Arm Development Studio command prompt on page 4-71.
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4.1 Integrated Development Environment (IDE) Overview
The IDE contains a collection of views that are associated with a specific perspective.

Arm Development Studio uses the Development Studio perspective as default.

Figure 4-1  IDE in the Development Studio perspective.

1. The main menu and toolbar are both located at the top of the IDE window. Other toolbars, that are
associated with specific features, are located at the top of each perspective or view.

2. Project Explorer view to create, build, and manage your projects.
3. Editor view to inspect and modify the content of your source code files. The tabs in the editor area

show the files that are currently open for editing.
4. During a debug session this area typically shows the Registers and Breakpoints views. You can drag

and drop other views into this area.
5. Debug Control view to create and control debug connections.
6. During a debug session this area typically shows views that are associated with debug inputs and

outputs, such as the Commands and Console views.

On exit, your settings save automatically. When you next open Arm Development Studio, the window
returns to the same perspective and views.

For further information on a view, click inside it and press F1 to open the Help view.

Customize the IDE

You can customize the IDE by changing the layout, key bindings, file associations, and color schemes.
These settings can be found in Window > Preferences. Changes are saved in your workspace. If you
select a different workspace, then these settings might be different.

Related references
4.2 Using the IDE on page 4-66
Related information
Perspectives in Arm Development Studio
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4.2 Using the IDE
The Arm Development Studio IDE can be customized. It is possible to choose the views you can see by
following the instructions in this section.

This section contains the following subsections:
• 4.2.1 Changing the default workspace on page 4-66.
• 4.2.2 Switching perspectives on page 4-66.
• 4.2.3 Adding views on page 4-67.

4.2.1 Changing the default workspace

The workspace is an area on your file system to store files and folders related to your projects, and your
IDE settings. When Arm Development Studio launches for the first time, a default workspace is
automatically created for you in C:\Users\<user>\Development Studio Workspace.

 Note 

Arm recommends that you select a dedicated workspace folder for your projects. If you select an existing
folder containing resources that are not related to your projects, you cannot access them in Arm
Development Studio. These resources might also cause a conflict later when you create and build
projects.

Arm Development Studio automatically opens in the last used workspace.

Procedure
1. Select File > Switch Workspace > Other.... The Eclipse Launcher dialog box opens.

Figure 4-2  Workspace Launcher dialog box
2. Click Browse… to choose your workspace, and click OK.

Arm Development Studio relaunches in the new workspace.

4.2.2 Switching perspectives

Perspectives define the layout of your selected views and editors in the Arm Development Studio IDE.
Each perspective has its own associated menus and toolbars.
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Procedure
1. Go to Window > Perspective > Open Perspective > Other.... This opens the Open Perspective

dialog box.
2. Select the perspective that you want to open, and click OK.

Figure 4-3  Open Perspective dialog box

Your perspective opens in the workspace.

Related information
Arm Debugger perspectives and views

4.2.3 Adding views

Views provide information for a specific function, corresponding to the active debug connection. Each
perspective has a set of default views. You can add, remove, or reposition the views to customize your
workspace.

Procedure
1. Click the + button in the area you want to add a view.
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Figure 4-4  Adding a view in an area
2. Choose a view to add, or click Other… to open the Show View dialog box to see a complete list of

available views.

Figure 4-5  Adding a view in Arm Development Studio
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3. Select the view you want to open, and click OK.

The view opens in the selected area.

Related information
Arm Debugger perspectives and views
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4.3 Personalize your development environment
Arm Development Studio Integrated Development Environment (IDE) has many settings, called
Preferences, that are available for you to adjust and change. Use these Preferences to adapt the IDE to
best support your own personal development style.

When you launch Arm Development Studio for the first time, the Preferences Wizard takes you through
the process of setting up the IDE.

This wizard presents the most commonly changed Preferences to customize for your requirements.
These include specifying the start-up workspace location, selecting a theme, and tweaking the code
editing format.

 Note 

• If you have upgraded from a previous version of Arm Development Studio and had your workspace
preferences already set up, your preferences remain the same.

• These preferences are only saved in the current workspace. To copy your preferences to another
workspace, select File > Export... to open the Export wizard. Then select General > Preferences
and choose the location you want to export your preferences to.

• You can click Apply and Close at any point during your wizard. The Preferences Wizard applies
changes up to where you have modified the options and leaves the rest of the settings as default.

• There are more IDE configuration options in the Preferences dialog which allow you to make further
in-depth changes to your IDE settings. For example, extra code formatting and syntax highlighting
options. To open the Preferences dialog, from the main menu, select Window > Preferences.

• You can click Skip and ignore the Preferences Wizard and return to the wizard later to make
changes. To restart the wizard later, in the Preferences dialog, select Arm DS > General > Start
Preferences Wizard.

• To disable the Preferences Wizard when you launch Arm Development Studio, add
ARM_DS_DISABLE_PREFS_WIZARD as an environment variable in your operating system.

• When switching Arm Development Studio between the light and dark themes, to apply your selection
you must restart Arm Development Studio.

Related tasks
2.11 Language settings on page 2-38
Related references
Chapter 2 Installing and configuring Arm Development Studio on page 2-22
2.7 Licensing Arm Development Studio on page 2-30
4.2 Using the IDE on page 4-66
Related information
Preferences dialogue box
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4.4 Launch the Arm Development Studio command prompt
To configure the same features of Arm Development Studio that you can configure through the GUI, you
can use the Arm Development Studio command prompt.

The Arm Development Studio command prompt is useful when:

• You want to run scripts or automate tasks.
• You are more comfortable working with the command line in the Linux operating system.

You can use the Arm Development Studio command prompt to perform operations such as:
• Registering and configuring a compiler toolchain.
• Selecting and using a compiler.
• Running a model.
• Launching Graphics Analyzer or Arm Streamline.
• Building Eclipse projects.
• Configuring Arm Debugger.
• Configuring a connection to a built-in Fixed Virtual Platform (FVP).
• Batch updating firmware for the DSTREAM family of products.

Procedure
• Launch the command prompt for your system:

On Windows:
— Select Start > All Programs > Arm Development Studio > Arm Development Studio

Command Prompt.

On Linux:
1. Open a new terminal in your preferred shell.
2. Change directory to the bin directory inside your Arm Development Studio installation

directory. For example: cd /opt/arm/developmentstudio-2020.0/bin.
3. Run ./suite_exec.

Example 4-1  Example: Arm Development Studio command prompt usage scenarios

• Configure a compiler toolchain

On Windows:
— Set a default compiler toolchain:

1. Follow the procedure to launch the command prompt.
2. To see the available compiler toolchains, run select_default_toolchain.
3. Select your preferred default compiler toolchain from the available list.

— Specify a compiler toolchain for the current session:
1. Follow the procedure to launch the command prompt.
2. To see the available compiler toolchains, run select_toolchain.
3. Select your preferred compiler toolchain for this session from the available list.

On Linux:
— Set a default compiler toolchain:

1. Follow the procedure to launch the command prompt.
2. Run ./select_default_toolchain.
3. Select your preferred default compiler toolchain from the available list.

— Set a compiler toolchain for the current session:
1. Follow the procedure to launch the command prompt.
2. Run ./suite_exec --toolchain <toolchain_name> <preferred_shell>.

• Set Arm Compiler 6 as your compiler toolchain
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On Windows:
1. Follow the procedure to launch the command prompt.
2. To see the available compiler toolchains, run select_toolchain.
3. Select Arm Compiler 6 from the list.
4. To verify that the environment has been configured correctly, run armclang --vsn to see

the version information and license details.

On Linux:
1. Follow steps 1 and 2 of the procedure to launch the command prompt.
2. Run ./suite_exec --toolchain "Arm Compiler 6" <preferred_shell>.
3. To verify that the environment has been configured correctly, run ./armclang --vsn to

see the version information and license details.
• Connect to an Arm FVP Cortex-A9x4 model

On Windows:
1. Follow the procedure to launch the command prompt.
2. Run

armdbg --cdb-entry "Arm FVP::VE_Cortex_A9x4::Bare Metal Debug::Bare
Metal Debug::Cortex-A9x4 SMP".

On Linux:
1. Follow the procedure to launch the command prompt.
2. Run ./armdbg --cdb-entry "Arm FVP::VE_Cortex_A9x4::Bare Metal

Debug::Bare Metal Debug::Cortex-A9x4 SMP".
• Connect to an Arm FVP Cortex-A53x1 and specify an image to load

On Windows:
1. Follow the procedure to launch the command prompt.
2. Run

armdbg --cdb-entry "Arm FVP (Installed with Arm DS)::Base_A53x1::Bare
Metal Debug::Bare Metal Debug::Cortex-A53" --cdb-entry-param
model_params="-C bp.secure_memory=false" --image
"C:\<path_to_workspace_folder>\HelloWorld\Debug\HelloWorld.axf".

On Linux:
1. Follow the procedure to launch the command prompt.
2. Run ./armdbg --cdb-entry "Arm FVP (Installed with Arm

DS)::Base_A53x1::Bare Metal Debug::Bare Metal Debug::Cortex-A53" --cdb-
entry-param model_params="-C bp.secure_memory=false" --image
"<path_to_workspace_folder>/HelloWorld/Debug/HelloWorld.axf".

Related information
Configuring debug connections in Arm Debugger
Overview: Running Arm Debugger from the command-line or from a script
Configuring a connection from the command-line to a built-in Fixed Virtual Platform (FVP)
Register a compiler toolchain using the Arm DS command prompt
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Chapter 5
Projects and examples in Arm Development Studio

Describes how to work with projects in Arm Development Studio. Also lists the example projects we
provide, and how to import them into your workspace.

It contains the following sections:
• 5.1 Working with projects on page 5-74.
• 5.2 Importing and exporting projects on page 5-88.
• 5.3 Examples provided with Arm Development Studio on page 5-93.
• 5.4 Import the example projects on page 5-94.
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5.1 Working with projects
Projects are top level folders in your workspace that contain related files and sub-folders. A project must
exist in your workspace before you add a new file or import an existing file.

This section contains the following subsections:
• 5.1.1 Project types on page 5-74.
• 5.1.2 Create a new C or C++ project on page 5-75.
• 5.1.3 Creating an empty Makefile project on page 5-76.
• 5.1.4 Create a new Makefile project with existing code on page 5-77.
• 5.1.5 Setting up the compilation tools for a specific build configuration on page 5-78.
• 5.1.6 Configuring the C/C++ build behavior on page 5-79.
• 5.1.7 Run Arm Development Studio IDE from the command-line to clean and build your projects

on page 5-81.
• 5.1.8 Updating a project to a new toolchain on page 5-82.
• 5.1.9 Adding a source file to your project on page 5-83.
• 5.1.10 Sharing Arm Development Studio projects on page 5-84.
• 5.1.11 Working sets on page 5-84.

5.1.1 Project types

Different project types are provided with Eclipse, depending on the requirements of your project.

 Note 

Bare metal projects require a software license for Arm Compiler to successfully build an ELF image.

Bare-metal Executable

Uses Arm Compiler to build a bare-metal executable ELF image.

Bare-metal Static library
Uses Arm Compiler to build a library of ELF object format members for a bare-metal project.

 Note 

It is not possible to debug or run a stand-alone library file until it is linked into an image.

Executable

Uses the GNU Compilation Tools to build a Linux executable ELF image.

Shared Library

Uses the GNU Compilation Tools to build a dynamic library for a Linux application.

Static library
Uses the GNU Compilation Tools to build a library of ELF object format members for a Linux
application.

 Note 

It is not possible to debug or run a stand-alone library file until it is linked into an image.
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Makefile project
Creates a project that requires a makefile to build the project. However, Eclipse does not
automatically create a makefile for an empty Makefile project. You can write the makefile
yourself or modify and use an existing makefile.

 Note 

Eclipse does not modify Makefile projects.

Build configurations

By default, the new project wizard provides two separate build configurations:

Debug

The debug target is configured to build output binaries that are fully debuggable, at the expense
of optimization. It configures the compiler optimization setting to minimum (level 0), to provide
an ideal debug view for code development.

Release

The release target is configured to build output binaries that are highly optimized, at the expense
of a poorer debug view. It configures the compiler optimization setting to high (level 3).

In all new projects, the Debug configuration is automatically set as the active configuration. You can
change this in the C/C++ Build Settings panel of the Project Properties dialog box.

 Note 

C project

This does not select a source language by default and leaves this decision up to the compiler.
Both GCC and Arm Compiler default to C for .c files and C++ for .cpp files.

C++ project

Selects C++ as the source language by default, regardless of file extension.

In both cases, the source language for the entire project a source directory, or individual source file can
be configured in the build configuration settings.

5.1.2 Create a new C or C++ project

Create a new C or C++ project in Arm Development Studio.

Procedure
1. Select File > New > Project... from the main menu.
2. Expand the C/C++ group, select either C Project or C++ Project, and click Next.

 Note 

C project

This does not select a source language by default and leaves this decision up to the compiler.
Both GCC and Arm Compiler default to C for .c files and C++ for .cpp files.

C++ project

Selects C++ as the source language by default, regardless of file extension.

In both cases, the source language for the entire project, a source directory or individual source file
can be configured in the build configuration settings.

3. Enter a Project name.
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4. Leave the Use default location option selected so that the project is created in the default folder
shown. Alternatively, deselect this option and browse to your preferred project folder.

5. Select the type of project that you want to create.

Figure 5-1  Creating a new C project
6. Select a Toolchain.
7. Click Finish to create your new project.

You can view the project in the Project Explorer view.

5.1.3 Creating an empty Makefile project

Describes how to create an empty C or C++ Makefile project for an Arm Linux target:

Procedure
1. Create a new project:

a. Select File > New > Project... from the main menu.
b. Expand the C/C++ group, select either C Project or C++ Project, and click Next.
c. Enter a project name.
d. Leave the Use default location option selected so that the project is created in the default folder

shown. Alternatively, deselect this option and browse to your preferred project folder.
e. Expand the Makefile project group.
f. Select Empty project in the Project type panel.
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g. Select the toolchain that you want to use when building your project. If your project is for an Arm
Linux target, select the appropriate GCC toolchain. You might need to download a GCC toolchain
if you have not done so already.

h. Click Finish to create your new project. The project is visible in the Project Explorer view.
2. Create a Makefile, and then edit:

a. Before you can build the project, you must have a Makefile that contains the compilation tool
settings. The easiest way to create one is to copy the Makefile from the example project, hello
and paste it into your new project. The hello project is in the Linux examples provided with Arm
Development Studio.

b. Locate the line that contains OBJS = hello.o.
c. Replace hello.o with the names of the object files corresponding to your source files.
d. Locate the line that contains TARGET =hello.
e. Replace hello with the name of the target image file corresponding to your source files.
f. Save the file.
g. Right-click the project and then select Properties > C/C++ Build. In the Builder Settings tab,

ensure that the Build directory points to the location of the Makefile.
3. Add your C/C++ files to the project.

Next Steps

Build the project. In the Project Explorer view, right-click the project and select Build Project.

Related tasks
5.1.4 Create a new Makefile project with existing code on page 5-77

5.1.4 Create a new Makefile project with existing code

You can create a new Makefile project in Arm Development Studio with your existing source code.

The following procedure describes how to create a new Makefile project in the same directory as your
source code.

Procedure
1. Create a Makefile project:

a. Select File > New > Project... from the main menu.
b. Expand the C/C++ group, select Makefile Project with Existing Code, and click Next.
c. Enter a project name and enter the location of your existing source code.
d. Select the toolchain that you want to use for Indexer Settings. Indexer Settings provide source

code navigation in the Arm Development Studio IDE.
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Figure 5-2  Creating a new Makefile project with existing code
e. Click Finish to create your new project. The project and source files are visible in the Project

Explorer view.
2. Create a Makefile:

a. Before you can build the project, you need to have a Makefile that contains the compilation tool
settings. The easiest way to create one is to copy the Makefile from an example project, and
paste it into your new project.

b. Edit the Makefile for your new project.
c. Right-click the project and then select Properties > C/C++ Build to access the build settings. In

the Builder Settings tab, check that the Build directory points to the location of the Makefile.
3. Add any other source files you need to the project.
4. Build the project. In the Project Explorer view, right-click the project and select Build Project.
Related tasks
5.1.3 Creating an empty Makefile project on page 5-76

5.1.5 Setting up the compilation tools for a specific build configuration

The C/C++ Build configuration panels enable you to set up the compilation tools for a specific build
configuration. These settings determine how the compilation tools build an Arm executable image or
library.

Procedure
1. In the Project Explorer view, right-click the source file or project and select Properties.
2. Expand C/C++ Build and select Settings.
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3. The Configuration panel shows the active configuration. To create a new build configuration or
change the active setting, click Manage Configurations….

4. The compilation tools available for the current project, and their respective build configuration
panels, are displayed in the Tool Settings tab. Click on this tab and configure the build as required.

 Note 

Makefile projects do not use these configuration panels. The Makefile must contain all the required
compilation tool settings.

Figure 5-3  Typical build settings dialog box for a C project
5. Click OK.

The updated settings for your build configuration are saved.

5.1.6 Configuring the C/C++ build behavior

A build is the process of compiling and linking source files to generate an output file. A build can be
applied to either a specific set of projects or the entire workspace. It is not possible to build an individual
file or sub-folder.

Arm Development Studio IDE provides an incremental build that applies the selected build configuration
to resources that have changed since the last build. Another type of build is the Clean build that applies
the selected build configuration to all resources, discarding any previous build states.
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Automatic

This is an incremental build that operates over the entire workspace and can run automatically
when a resource is saved. This setting must be enabled for each project by selecting Build on
resource save (Auto build) in the Behaviour tab. By default, this behavior is not selected for
any project.

Figure 5-4  Workbench build behavior

You must also ensure that Build Automatically is selected from the Project menu. By default,
this menu option is selected.

Manual

This is an incremental build that operates over the entire workspace on projects with Build
(Incremental build) selected. By default, this behavior is selected for all projects.

You can run an incremental build by selecting Build All or Build Project from the Project
menu.

 Note 

Manual builds do not save before running so you must save all related files before selecting this
option! To save automatically before building, you can change your default settings by selecting
Preferences... > General > Workspace from the Window menu.
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Clean

This option discards any previous build states including object files and images from the
selected projects. The next automatic or manual build after a clean, applies the selected build
configuration to all resources.

You can run a clean build on either the entire workspace or specific projects by selecting
Clean… from the Project menu. You must also ensure that Clean is selected in the C/C++
Build > Behaviour tab of the Preferences dialog box. By default, this behavior is selected for
all projects.

Build order is a feature where inter-project dependencies are created and a specific build order is defined.
For example, an image might require several object files to be built in a specific order. To do this, you
must split your object files into separate smaller projects, reference them within a larger project to ensure
they are built before the larger project. Build order can also be applied to the referenced projects.

5.1.7 Run Arm Development Studio IDE from the command-line to clean and build your projects

You can run Arm Development Studio IDE from the command-line to clean and build your projects. This
might be useful when you want to create scripts to automate build procedures.

Before you begin, make sure that the Arm Development Studio IDE session is closed.

Use the Arm Development Studio command-line console to load the Arm Development Studio IDE,
make, and other utilities on your PATH environment variable. To launch the console:

• On Windows, select Start > All Programs > Arm Development Studio > Arm DS Command
Prompt.

• On Linux, run <install_directory>/bin/suite_exec <shell> to open a shell.

Run armds_idec.exe (on Windows) or armds_ide (on Linux) with the following Arm Development
Studio IDE arguments as required.

Table 5-1  Arm DS IDE arguments

Argument Description

-nosplash Disables the Arm Development Studio IDE splash screen.

--launcher.suppressErrors Causes errors to be printed to the console instead of being
reported in a graphical dialog box.

-application
com.arm.cmsis.pack.project.headlessbuild

Mandatory argument telling Arm Development Studio IDE to run
the headless builder.

-data <workspaceDir> Specify the location of your workspace.

-import <projectDir> Import the project from the specified directory into your
workspace.

Use this option multiple times to import multiple projects.

-build <projectName>[/<configName>] | all Build the project with the specified name, or all projects in your
workspace.

By default, this argument builds all the configurations within each
project. You can limit this action to a single configuration, such as
Debug or Release, by specifying the configuration name
immediately after your project name, separated with '/'.

Use this option multiple times to build multiple projects.
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Table 5-1  Arm DS IDE arguments (continued)

Argument Description

-cleanBuild <projectName>[/<configName>] | all Clean and build the project with the specified name, or all projects
in your workspace.

By default, this argument cleans and builds all the configurations
within each project. You can limit this action to a single
configuration, such as Debug or Release, by specifying the
configuration name immediately after your project name,
separated with '/'.

Use this option multiple times to clean and build multiple
projects.

-cmsisRoot <path> Set the path to the CMSIS Packs root directory

 Note 

On Windows, you must run armds_idec.exe from either the Arm DS Command Prompt, or directly
from the <install_directory>/bin directory. Do not run the armds_idec.exe executable that is in the
<install_directory>/sw/eclipse directory.

The armds_idec.exe executable in <install_directory>/bin acts as a wrapper for armds_idec.exe
in <install_directory>/sw/eclipse. Running the executable from the <install_directory>/bin
directory sets up the Arm Development Studio environment (paths, environment variables, and other
similar items) in the same way as the Arm DS Command Prompt.

For example:

"C:\Program Files\Arm\Development Studio <version>\bin\armds_idec.exe" -nosplash -
application com.arm.cmsis.pack.project.headlessbuild -data "C:\path\to\your
\workspace" -cleanBuild startup_Cortex-R8

Examples

On Windows, to list and view the full set of available options, use the command:

armds_idec.exe -nosplash -consoleLog --launcher.suppressErrors -application
com.arm.cmsis.pack.project.headlessbuild -help

On Windows, to clean and build all the projects in a specific workspace, use the command:

armds_idec.exe -nosplash -application com.arm.cmsis.pack.project.headlessbuild -data
C:<\path\to\workspace> -cleanBuild all

On Linux, to build the Release configuration of project MyProject in a specific workspace, use the
command:

armds_ide -nosplash -application com.arm.cmsis.pack.project.headlessbuild -data </
path/to/workspace> -build MyProject/Release

5.1.8 Updating a project to a new toolchain

If you have several products installed, only the latest toolchain is listed in the New Project wizard.
Therefore, if you have projects that use an older toolchain, you must update them to the latest toolchain.

Procedure
1. Right-click on the project in the Project Explorer view, and select Properties.
2. Expand C/C++ Build and select Tool Chain Editor.
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3. Select the toolchain from the Current toolchain drop-down list and click OK.

5.1.9 Adding a source file to your project

You can add new and existing source files to your Arm Development Studio project.

There are several ways to add source files to your project:
• Using your operating system's file system, you can create source files and then drag and drop the files

into a project in the Project Explorer view of Arm Development Studio. To update the views in Arm
Development Studio, click the relevant project in the Project Explorer view, and select File >
Refresh from the main menu.

• You can import existing source files by selecting File > Import > General > File System.
• Or, you can do the following:

Procedure
1. In the Development Studio perspective, right-click on the project and select New > Source File to

display the New Source File dialog box.
a. Alternatively, from the main menu, select File > New > Source File.

Figure 5-5  Adding a new source file to your project
2. The Source folder field tells you the project where the new source file will be saved. If you want to

save it to a different project, click Browse…, and select another project.
3. In the Source file field, enter a name for the new source file and include the file extension.
4. Select a source file template from the Template drop-down list. The default options are:

• <None>
• Default C++ source template
• Default C++ test template
• Default C source template

The default templates only provide basic metadata about the newly created file, that is, the author and
the date it was created.

To use your own source file template, click Configure and the Code Templates preference panel
opens, where you can add or configure your own templates.

Figure 5-6  Code template configuration
5. Click Finish.
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The new source file is visible in the Project Explorer view.

Related information
Perspectives and Views
Eclipse online documentation: Code templates

5.1.10 Sharing Arm Development Studio projects

You can share Arm Development Studio projects between users if necessary.

 Note 

• There are many different ways to share projects and files, for example, using a source control tool.
This topic covers the general principles of sharing projects and files using Arm Development Studio,
and not the specifics of any particular tool.

• To share files, it is recommended to do so at the level of the project and not the workspace. Your
source files within Arm Development Studio are organized into projects, and projects exist within
your workspace. A workspace contains many files, including files in the .metadata directory, that
are specific to an individual user or installation.

Within each project, the files that must be shared beyond just your source code are:
• .project - Contains general information about the project type, and the Arm Development Studio

plug-ins to use to edit and build the project.
• .cproject - Contains C/C++ specific information, including compiler settings.

Arm Development Studio places built files into the project directory, including auto-generated makefiles,
object files, and image files. Not all files have to be shared. For example, sharing an auto-generated
makefile might be useful to allow building the project outside of Arm Development Studio, but if
projects are only built within Arm Development Studio then this is not necessary.

You must be careful when creating and configuring projects to avoid hard-coded references to tools and
files outside of Arm Development Studio that might differ between users.

To ensure that files outside of Arm Development Studio can be referenced in a user agnostic way, use the
${workspace_loc} built-in variable or custom environment variables.

5.1.11 Working sets

Describes what working sets are, and how to use them in Arm Development Studio.

About working sets

A working set enables you to group projects together and display a smaller subset of projects.

The Project Explorer view usually displays a full list of all your projects associated with the current
workspace. If you have a lot of projects it can be difficult to navigate through the list to find the project
that you want to use.

To make navigation easier, group your projects into working sets. You can select one or more working
sets at the same time, or you can use the Project Explorer View Menu to switch between one set and
another. To return to the original view, select the Deselect Working Sets options in the View Menu.

Working sets are also useful to refine the scope of a search or build projects in a specific working set.

Creating a working set

Create a working set to group related projects together.

Procedure
1. Click the View Menu hamburger icon in the Project Explorer view toolbar.
2. Select the Select Working Set… option.
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3. In the Select Working Set dialog box, click New….

Figure 5-7  Creating a new working set
4. Under Working set type, select Resource and click Next.

Figure 5-8  Selecting the resource type for the new working set
5. In the Working set name field, enter a suitable name.
6. In the Working set contents panel, you can select existing projects that you want to associate with

this working set, or you can return to the wizard later to add projects.
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Figure 5-9  Adding new resources to a working set
7. Click Finish.
8. If required, repeat these steps to create more working sets.
9. In the Select Working Set dialog box, select the working sets that you want to display in the Project

Explorer view.

Figure 5-10  Select the required working set
10. Click OK.
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The filtered list of projects are displayed in the Project Explorer view. Another feature of working sets
that can help with navigation is the option to change the top level element in the Project Explorer view.

Changing the top-level element when displaying working sets

In the Project Explorer view, if you have more than one working set then you might want to display the
projects in a hierarchical tree with the working set names as the top level element. This is not selected by
default.

Procedure
1. In the Project Explorer view toolbar, click the View Menu hamburger icon.
2. Select Top Level Elements from the context menu.
3. Select either Projects or Working Sets.

Deselecting a working set

You can change the display of projects in the Project Explorer view and return to the full listing of all
the projects in the workspace.

Procedure
1. Click on the View Menu icon in the Project Explorer view toolbar.
2. Select Deselect Working Set from the context menu.
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5.2 Importing and exporting projects
Describes how to import resources from existing projects and how to export resources to use with tools
external to Arm Development Studio.

This section contains the following subsections:
• 5.2.1 Importing and exporting options on page 5-88.
• 5.2.2 Using the Import wizard on page 5-88.
• 5.2.3 Using the Export wizard on page 5-89.
• 5.2.4 Import an existing Eclipse project on page 5-90.

5.2.1 Importing and exporting options

A resource must exist in a project within Arm Development Studio before you can use it in a build.

If you want to use an existing resource from your file system in one of your projects, the recommended
method is to use the Import wizard. To do this, select Import… from the File menu.

If you want to use a resource externally, the recommended method is to use the Export wizard. To do
this, select Export… from the File menu.

There are several options available in the import and export wizards:

General
This option enables you to import and export the following:
• Files from an archive zip file.
• Complete projects.
• Selected source files and project sub-folders.
• Preference settings.

C/C++
This option enables you to import the following:
• C/C++ executable files.
• C/C++ project settings.
• Existing code as Makefile project.

You can also export C/C++ project settings and indexes.

Remote Systems

This option enables you to transfer files between the local host and the remote target.

Run/Debug
This option enables you to import and export the following:
• Breakpoint settings.
• Launch configurations.

Scatter File Editor

This option enables you to import the memory map from a BCD file and convert it into a scatter
file for use in an existing project.

For information on the other options not listed here, use the dynamic help.

5.2.2 Using the Import wizard

In addition to breakpoint and preference settings, you can use the Import wizard to import complete
projects, source files, and project sub-folders.

Select Import… from the File menu to display the Import wizard.
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Importing complete projects

To import a complete project either from an archive zip file or an external folder from your file system,
you must use the Existing Projects into Workspace wizard. This ensures that the relevant project files
are also imported into your workspace.

Importing source files and project sub-folders

Individual source files and project sub-folders can be imported using either the Archive File or File
System wizard. Both options produce a dialog box similar to the following example. Using the options
provided you can select the required resources and specify the relevant options, filename, and destination
path.

Figure 5-11  Typical example of the import wizard

With the exception of the Existing Projects into Workspace wizard, files and folders are copied into
your workspace when you use the Import wizard. To create a link to an external file or project sub-
folder you must use the New File or New Folder wizard.

5.2.3 Using the Export wizard

You can use the Export wizard to export complete projects, source files and, project sub-folders in
addition to breakpoint and preference settings.

Select Export… from the File menu to display the Export wizard.

The procedure is the same for exporting a complete project, a source file, and a project sub-folder. If you
want to create a zip file you can use the Archive File wizard, or alternatively you can use the File
System wizard. Both options produce a dialog box similar to the example shown here. Using the options
provided you can select the required resources and specify the relevant options, filename, and destination
path.
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Figure 5-12  Typical example of the export wizard

5.2.4 Import an existing Eclipse project

If you have an existing Eclipse project, you can import it into your workspace.

Procedure
1. Select File > Import... > Existing Project into Workspace. Click Next
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Figure 5-13  Selecting the import source type
2. Click Browse and navigate to the folder that contains the project that you want to import.
3. In the Projects panel, select the project that you want to import.
4. Select Copy projects into workspace if required, or deselect to create links to your existing

project(s) and associated files.
5. If you are not using working sets to group your projects then you can skip this step.

a. Select Add project to working sets.
b. Click Select….
c. Select an existing working set or create a new one and then select it.
d. Click OK.

6. Click Finish.
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Figure 5-14  Selecting an existing Eclipse projects for import

 Note 

If your existing project contains project settings from an older version of the build system, you are
given the option to update your project. Using the latest version means that you can access all the
latest toolchain features.

The imported project is visible in the Project Explorer view.

5 Projects and examples in Arm Development Studio
5.2 Importing and exporting projects

101469_2021.1_02_en Copyright © 2018–2021 Arm Limited or its affiliates. All rights
reserved.

5-92

Non-Confidential - REL



5.3 Examples provided with Arm Development Studio
Arm Development Studio provides a selection of examples to help you get started:

• Bare-metal software development examples for Armv7 that show:
— Compilation with Arm Compiler 6.
— Compilation with GCC bare-metal compiler.
— Armv7 bare-metal debug.

The code is located in the archive file <examples_directory>\Bare-metal_examples_Armv7.zip.
• Bare-metal software development examples for Armv8 that show:

— Compilation with Arm Compiler 6.
— Compilation with GCC bare-metal compiler.
— Armv8 bare-metal debug.

The code is located in the archive file <examples_directory>\Bare-metal_examples_Armv8.zip.
 Note 

The debug and compilation features that are available to you depends on which version of Arm
Development Studio you have installed. For detailed information on which features are available in
the different Arm Development Studio editions, see: Arm Development editions

• Bare-metal software development examples for SVE using Arm Compiler 6.

The code is located in the archive file <examples_directory>\SVE_examples.zip.
• Arm Linux examples built with GCC Linux compiler that show build, debug, and performance

analysis of simple C/C++ console applications, shared libraries, and multi-threaded applications. The
files are located in the archive file, <examples_directory>\Linux_examples.zip.

• Examples for Keil RTX version 5 RTX Real-Time Operating System (RTX-RTOS) are located in the
archive file, <examples_directory>\RTX5_examples.zip.

• Software examples for Arm Debugger's Debug and Trace Services Layer (DTSL). The examples are
located in the archive file, <examples_directory>\DTSL_examples.zip.

• Jython examples for Arm Debugger. The examples are located in the archive file,
<examples_directory>\Jython_examples.zip.

• The CoreSight Access Library is available as a github project at https://github.com/ARM-software/
CSAL. A recent snapshot of the library from github is located in the archive file,
<examples_directory>\CoreSight_Access_Library.zip.

• Optional packages with source files, libraries, and pre-built images for running the examples can be
downloaded from the Arm Development Studio downloads page . You can also download the Linux
distribution project with header files and libraries for the purpose of rebuilding the Arm Linux
examples from the Arm Development Studio downloads page.

You can extract these examples to a working directory and build them from the command-line, or you
can import them into Arm Development Studio IDE using the import wizard. All examples provided
with Arm Development Studio contain a pre-configured IDE launch script that enables you to easily load
and debug example code on a target.

Each example provides instructions on how to build, run, and debug the example code. You can access
the instructions from the main index, <examples_directory>\docs\index.html.

Related tasks
5.4 Import the example projects on page 5-94
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5.4 Import the example projects
To use the example projects provided with Arm Development Studio, you must first import them.

Procedure
1. Launch Arm Development Studio IDE.
2. Arm recommends that you create another workspace for example projects, so that they remain

separate from your own projects. To do this, select File > Switch Workspace > Other > Browse >
Make new folder, and enter a suitable name.

Result: Arm Development Studio IDE relaunches.
3. In the main menu, select File > Import....
4. Expand the Arm Development Studio group, select Examples and Programming Libraries and

click Next.

Figure 5-15  Import dialog box
5. Select the examples and programming libraries you want to import. If a description for the selected

example exists, you can view it in the Description pane.

5 Projects and examples in Arm Development Studio
5.4 Import the example projects
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Figure 5-16  Select items to import
6. Click Finish.

You can browse the imported examples in the Project Explorer.

Each example contains a readme.html which explains how you can work with the example.

Related concepts
About working sets on page 5-84

5 Projects and examples in Arm Development Studio
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Chapter 6
Writing code

Describes how to use the editors when developing a project for an Arm target.

It contains the following sections:
• 6.1 Editing source code on page 6-97.
• 6.2 About the C/C++ editor on page 6-98.
• 6.3 About the Arm assembler editor on page 6-99.
• 6.4 About the ELF content editor on page 6-100.
• 6.5 ELF content editor - Header tab on page 6-101.
• 6.6 ELF content editor - Sections tab on page 6-102.
• 6.7 ELF content editor - Segments tab on page 6-103.
• 6.8 ELF content editor - Symbol Table tab on page 6-104.
• 6.9 ELF content editor - Disassembly tab on page 6-105.
• 6.10 About the scatter file editor on page 6-106.
• 6.11 Creating a scatter file on page 6-107.
• 6.12 Importing a memory map from a BCD file on page 6-109.
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6.1 Editing source code
You can use the editors provided with Arm Development Studio to edit your source code or you can use
an external editor. If you work with an external editor you must refresh Development Studio to
synchronize the views with the latest updates.

To do this, in the Project Explorer view, select the updated project, sub-folder, or file and click File >
Refresh. Alternatively, enable automatic refresh options under General > Workspace in the
Preferences dialog box. Configure your automatic refresh settings by selecting either Refresh using
native hooks or polling or Refresh on access options.

When you open a file in Development Studio, a new editor tab appears with the name of the file. An
edited file displays an asterisk (*) in the tab name to show that it has unsaved changes.

To view two or more editor tabs side-by-side, click on one of the tabs and drag it over an editor border.

In the left-hand margin of the editor tab you can find a vertical bar that displays markers relating to the
active file.

Navigating

There are several ways to navigate to a specific resource within Development Studio. You can use the
Project Explorer view to open a resource by browsing through the resource tree and double-clicking on
a file. An alternative is to use the keyboard shortcuts or use the options from the Navigate menu.

Searching

To locate information or specific code contained within one or more files in Development Studio, you
can use the options from the Search menu. Textual searching with pattern matching and filters to refine
the search fields are provided in a customizable Search dialog box. You can also open this dialog box
from the main workbench toolbar.

Content assist

The C/C++ editor, Arm assembler editor, and the Arm Debugger Commands view provide content
assistance at the cursor position to auto-complete the selected item. Using the Ctrl+Space keyboard
shortcut produces a small dialog box with a list of valid options to choose from. You can filter the list by
partially typing a few characters before using the keyboard shortcut. From the list you can use the Arrow
Keys to select the required item and then press the Enter key to insert it.

Bookmarks

You can use bookmarks to mark a specific position in a file or mark an entire file so that you can return
to it quickly. To create a bookmark, select a file or line of code that you want to mark and select Add
Bookmark from the Edit menu. The Bookmarks view displays all the user defined bookmarks. To
access the bookmarks, select Window > Show View > Bookmarks from the main menu. If the
Bookmarks view is not listed then select Others… for an extended list.

To delete a bookmark, open the Bookmarks view, click on the bookmark that you want to delete, and
select Delete from the Edit menu.

6 Writing code
6.1 Editing source code
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6.2 About the C/C++ editor
The standard C/C++ editor is provided by the CDT plug-in that provides C and C++ extensions to
Eclipse. It provides syntax highlighting, formatting of code and content assistance when editing C/C++
code.

Embedded assembler in C/C++ files is supported by the Arm Compiler but this editor does not support it
and so an error is displayed. This type of code is Arm-specific and accepted Eclipse behavior so you can
ignore the syntax error.

If this is not the default editor, right-click on a source file in the Project Explorer view and select Open
With > C/C++ Editor from the context menu.

See the C/C++ Development User Guide for more information. Select Help > Help Contents from the
main menu.

6 Writing code
6.2 About the C/C++ editor
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6.3 About the Arm assembler editor
The Arm assembler editor provides syntax highlighting, formatting of code and content assistance for
labels in Arm assembly language source files. You can change the default settings in the dialog box.

If this is not the default editor, right-click on your source file in the Project Explorer view and select
Open With > Arm Assembler Editor from the context menu.

The following shortcuts are also available for use:

Table 6-1  Arm assembler editor shortcuts

Content assist Content assist provides auto-completion on labels existing in the
active file. When entering a label for a branch instruction,
Partially type the label and then use the keyboard shortcut Ctrl
+Space to display a list of valid auto-complete options. Use the
Arrow Keys to select the required label and press Enter to
complete the term. Continue typing to ignore the auto-complete
list.

Editor focus The following options change the editor focus:
• Outline View provides a list of all areas and labels in the

active file. Click on an area or label to move the focus of the
editor to the position of the selected item.

• Select a label from a branch instruction and press F3 to move
the focus of the editor to the position of the selected label.

Formatter activation Press Ctrl+Shift+F to activate the formatter settings.

Block comments Block comments are enabled or disabled by using Ctrl
+Semicolon. Select a block of code and apply the keyboard
shortcut to change the commenting state.

6 Writing code
6.3 About the Arm assembler editor
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6.4 About the ELF content editor
The ELF content editor creates forms for the selected ELF file. You can use this editor to view the
contents of image files and object files. The editor is read-only and cannot be used to modify the contents
of any files.

If this is not the default editor, right-click on your source file in the Project Explorer view and select
Open With > ELF Content Editor from the context menu.

The ELF content editor displays one or more of the following tabs depending on the selected file type:

Header

Form view showing the header information.

Sections

Tabular view showing the breakdown of all section information.

Segments

Tabular view showing the breakdown of all segment information.

Symbol Table

Tabular view showing the breakdown of all symbols.

Disassembly

Textual view of the disassembly with syntax highlighting.

6 Writing code
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6.5 ELF content editor - Header tab
The Header tab provides a form view of the ELF header information.

Figure 6-1  Header tab

6 Writing code
6.5 ELF content editor - Header tab
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6.6 ELF content editor - Sections tab
The Sections tab provides a tabular view of the ELF section information.

To sort the columns, click on the column headers.

Figure 6-2  Sections tab

6 Writing code
6.6 ELF content editor - Sections tab
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6.7 ELF content editor - Segments tab
The Segments tab provides a tabular view of the ELF segment information.

To sort the columns, click on the column headers.

Figure 6-3  Segments tab

6 Writing code
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6.8 ELF content editor - Symbol Table tab
The Symbol Table tab provides a tabular view of the symbols.

To sort the columns, click on the column headers.

Figure 6-4  Symbol Table tab

6 Writing code
6.8 ELF content editor - Symbol Table tab
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6.9 ELF content editor - Disassembly tab
The Disassembly tab displays the output with syntax highlighting. The color schemes and syntax
preferences use the same settings as the Arm assembler editor.

There are several keyboard combinations that you can use to navigate around the output:
• Use Ctrl+F to open the Find dialog box to search the output.
• Use Ctrl+Home to move the focus to the beginning of the output.
• Use Ctrl+End to move the focus to the end of the output.
• Use Page Up and Page Down to navigate through the output one page at a time.

You can also right-click in the Disassembly view and select the Copy and Find options in the context
menu.

Figure 6-5  Disassembly tab

6 Writing code
6.9 ELF content editor - Disassembly tab
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6.10 About the scatter file editor
The scatter file editor enables you to easily create and edit scatter files for use with the Arm linker to
construct the memory map of an image.

It provides a text editor, a hierarchical tree, and a graphical view of the regions and output sections of an
image. You can change the default syntax formatting and color schemes in the Preferences dialog box.

If the scatter file editor is not the default editor, right-click on your source file in the Project Explorer
view and select Open With > Scatter File Editor from the context menu.

The scatter file editor displays the following tabs:

Source

Textual view of the source code with syntax highlighting and formatting.

Memory Map

A graphical view showing load and execute memory maps. Although these maps are not
editable, you can select a load region to show the related memory blocks in the execution
regions.

The scatter file editor also provides a hierarchical tree with associated toolbar and context menus using
the Outline view. Clicking on a region or section in the Outline view moves the focus of the editor to the
relevant position in your code. If this view is not visible, select Show View > Outline from the Window
menu.

 Note 

The linker documentation for Arm Compiler describes in more detail how to use scatter files.

Before you can use a scatter file you must add the --scatter=file option to the project in the C/C++
Build > Settings > Tool settings > Arm Linker > Image Layout panel of the Properties dialog box.

6 Writing code
6.10 About the scatter file editor

101469_2021.1_02_en Copyright © 2018–2021 Arm Limited or its affiliates. All rights
reserved.

6-106

Non-Confidential - REL



6.11 Creating a scatter file
Create a scatter file to specify more complex memory maps that cannot be specified using compiler
command-line memory map options.

Prerequisites

Before you can use a scatter file, you must add the --scatter=file option to the project in the C/C++
Build > Settings > Tool settings > Arm Linker > Image Layout panel of the Properties dialog box.

Procedure
1. Open an existing project, or create a new project.
2. In your project, add a new empty text file with the extension .scat. For example scatter.scat.
3. In the Outline view, click the Add load region toolbar icon, or right-click and select Add load

region from the context menu.
4. Enter a load region name, for example, LR1.

Figure 6-6  Add load region dialog box
5. Click OK.
6. Modify the load region as shown in the following example.

LR1 0x0000 0x8000
{
   LR1_er1 0x0000 0x8000
   {
       * (+RO)
   }
   LR1_er2 0x10000 0x6000
   {
       * (+RW,+ZI)
   }
}

7. Select the Regions/Sections tab to view a graphical representation.

6 Writing code
6.11 Creating a scatter file
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Figure 6-7  Graphical view of a simple scatter file
8. Save your changes.

6 Writing code
6.11 Creating a scatter file
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6.12 Importing a memory map from a BCD file
If you have a BCD file that defines a memory map, you can import this into the Scatter File Editor.

Prerequisites

Before you can use a scatter file, you must add the --scatter=file option to the project in the C/C++
Build > Settings > Tool settings > Arm Linker > Image Layout panel of the Properties dialog box.

Procedure
1. Select File > Import > Scatter File Editor > Memory from a BCD File.
2. Enter the location of the BCD file, or click Browse… to select the folder.
3. Select the file that contains the memory map that you want to import.
4. If you want to add specific memory regions to an existing scatter file, select Add to current scatter

file.
 Note 

The scatter file must be open and active in the editor view before you can use this option.

5. If you want the wizard to create a new file with the same name as the BCD file but with a .scat file
extension, select Create new scatter file template.

6. Select the destination project folder.
7. By default, all the memory regions are selected. Edit the selections and table content as required.

6 Writing code
6.12 Importing a memory map from a BCD file
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Figure 6-8  Memory block selection for the scatter file editor
8. Click Finish.

6 Writing code
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Chapter 7
Debugging code

Describes how to configure and connect to a debug target using Arm Debugger.

It contains the following sections:
• 7.1 Overview: Debug connections in Arm Debugger on page 7-112.
• 7.2 Using Fixed Virtual Platform (FVP)s with Arm Development Studio on page 7-113.
• 7.3 Configuring a connection from the command-line to a built-in Fixed Virtual Platform (FVP)

on page 7-114.
• 7.4 Configuring a connection to an external Fixed Virtual Platform (FVP) for bare-metal application

debug on page 7-115.
• 7.5 Configuring a connection to a bare-metal hardware target on page 7-118.
• 7.6 Configuring a connection to a Linux application using gdbserver on page 7-122.
• 7.7 Configuring a connection to a Linux kernel on page 7-125.
• 7.8 Configuring trace for bare-metal or Linux kernel targets on page 7-128.
• 7.9 Configuring an Events view connection to a bare-metal target on page 7-131.
• 7.10 Exporting or importing an existing Arm Development Studio launch configuration

on page 7-133.
• 7.11 Disconnecting from a target on page 7-137.

101469_2021.1_02_en Copyright © 2018–2021 Arm Limited or its affiliates. All rights
reserved.

7-111

Non-Confidential - REL



7.1 Overview: Debug connections in Arm Debugger
You can set up connections to debug bare-metal targets, Linux kernel, and Linux applications. You can
also use the Snapshot View feature to view previously captured application states.

Bare-metal debug connections
Bare-metal targets run without an underlying operating system. To debug bare-metal targets using Arm
Debugger:
• If debugging on hardware, use a debug hardware adapter that is connected to the host workstation and

the debug target.
• If debugging on a model, use a CADI-compliant connection between the debugger and a model.

Linux kernel debug connections

Arm Debugger supports source-level debugging of a Linux kernel or a Linux kernel model. For example,
you can set breakpoints in the kernel code, step through the source, inspect the call stack, and watch
variables. The connection method is similar to bare-metal debug connections.

Linux application debug connections

For Linux application debugging in Arm Debugger, you can connect to your target with a TCP/IP
connection.

Before you attempt to connect to your target, ensure that:
• gdbserver is present on the target. If gdbserver is not installed on the target, either see the

documentation for your Linux distribution or check with your provider.
• For Armv8 AArch64 targets, you need to use the AArch64 gdbserver.
• ssh daemon (sshd) must be running on the target to use the Remote System Explorer (RSE) in

Development Studio.
• sftp-server must be present on the target to use RSE for file transfers.

Snapshot Viewer

Use the Snapshot Viewer to analyze and debug a read-only representation of the application state of
your processor using previously captured data. This is useful in scenarios where interactive debugging
with a target is not possible. For more information, see Working with the Snapshot Viewer.

Related tasks
7.5 Configuring a connection to a bare-metal hardware target on page 7-118
7.6 Configuring a connection to a Linux application using gdbserver on page 7-122
7.7 Configuring a connection to a Linux kernel on page 7-125
7.4 Configuring a connection to an external Fixed Virtual Platform (FVP) for bare-metal application
debug on page 7-115
Related information
Working with the Snapshot Viewer
About the Snapshot Viewer

7 Debugging code
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7.2 Using Fixed Virtual Platform (FVP)s with Arm Development Studio
A Fixed Virtual Platform (FVP) is a software model of a development platform, including processors and
peripherals. FVPs are provided as executables, and some are included in Development Studio.

Depending on your requirements, you can:
• Create a new model configuration
• Configure a connection to an FVP for bare-metal application debug on page 7-115
• From the command-line, configure a connection to an FVP for bare-metal application debug

on page 7-114
• Configure a connection to an FVP for Linux application debug on page 7-122
• Configure a connection to an FVP for Linux kernel debug on page 7-125

7 Debugging code
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7.3 Configuring a connection from the command-line to a built-in Fixed Virtual
Platform (FVP)

You can configure a connection to a Fixed Virtual Platform (FVP) using the command-line only mode
available in Arm Development Studio.

Prerequisites

• The FVP model that you connect to must be available in the Development Studio configuration
database so that you can select it. If the FVP model is not available, you must first import it and
create a new model configuration. See Create a new model configuration for information.

• To load and execute the application on your FVP model using Development Studio, your application
must first be built with the appropriate compiler and linker options so that it can run on your model.
To locate the options and parameters required to build your application, see the documentation for
your compiler and linker.

• You must have the appropriate licenses installed to run your FVP model from the command line.
• If you use the command-line only mode, you can automate debug and trace activities. By automating

a debug session, you can save significant time and avoid repetitive tasks such as stepping through
code at source level.

Procedure
1. Open the Arm Development Studio command prompt:

• On Windows, select Start > All Programs > Arm Development Studio > Arm Development
Studio Command Prompt.

• On Linux, add the <install_directory/bin> location to your PATH environment variable and
then open a UNIX bash shell.

2. To connect to the Arm FVP Cortex-A9x4 FVP model and specify an image to load from your
workspace, at the command prompt, enter:
• On Windows:

debugger --cdb-entry "Arm FVP::VE_Cortex_A9x4::Bare Metal Debug::Bare Metal
Debug::Debug Cortex-A9x4 SMP" --image "C:\Users\<user>\developmentstudio-
workspace\HelloWorld\Debug\HelloWorld.axf"

• On Linux:
debugger --cdb-entry "Arm FVP::VE_Cortex_A9x4::Bare Metal Debug::Bare Metal
Debug::Debug Cortex-A9x4 SMP" --image "/home/<user>/developmentstudio-
workspace/HelloWorld/Debug/HelloWorld.axf"

Development Studio starts the Arm FVP Cortex-A9x4 FVP and loads the image. When you are
connected to your target, use any of the Arm Debugger commands to access the target and start
debugging.

For example, info registers displays all application level registers.

See Running Arm Debugger from the operating system command-line or from a script for more
information about how to use Arm Debugger from the operating system command-line or from a script.

7 Debugging code
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7.4 Configuring a connection to an external Fixed Virtual Platform (FVP) for bare-
metal application debug

You can use Arm Development Studio to connect to an external Fixed Virtual Platform (FVP) model for
bare-metal debugging.

This task explains how to:
• Create a model connection to connect to the Base_AEMv8A_AEMv8A FVP model and load your

application on the model.
• Start up the Base_AEMv8A_AEMv8A FVP model separately with the appropriate settings.
• Start a debug session in Development Studio to connect and attach to the running

Base_AEMv8A_AEMv8A FVP model.

 Note 

• Configuring a connection to a built-in FVP model follows a similar sequence of steps. Development
Studio launches built-in FVPs automatically when you start up a debug connection.

• FVPs available with your edition of Development Studio are listed under the Arm FVP (Installed
with Arm DS) tree. To see which FVPs are available with your license, compare Arm Development
Studio editions.

Prerequisites

• The FVP model that you are connecting to must be available in the Development Studio
configuration database so that you can select it in the Model Connection dialog box. If the FVP
model is not available, you must first import it and create a new model configuration. See Create a
new model configuration for information.

• To load and execute the application on your FVP model using Development Studio, your application
must first be built with the appropriate compiler and linker options so that it can run on your model.
To locate the options and parameters required to build your application, check the documentation for
your compiler and linker.

• You must have the appropriate licenses installed to run your FVP model from the command line.

Procedure
1. From the Arm Development Studio main menu, select File > New > Model Connection.
2. In the Model Connection dialog box, specify the details of the connection:

a. Give the connection a name in Debug connection name, for example:
my_external_fvp_connection.

b. If you want to associate the connection to an existing project, select Associate debug connection
with an existing project and click Next.

c. In Target Selection browse and select Base_AEMv8A_AEMv8A and click Finish to complete the
initial configuration of the connection.

3. In the displayed Edit Configuration dialog box, use the Connection tab to select the target and
connection settings:
a. In the Select target panel confirm the target selected.
b. If required, specify Model parameters under Connections.
c. If required, Edit the Debug and Trace Services Layer (DTSL) settings in the DTSL

Configuration dialog box to configure additional debug and trace settings for your target.
4. Use the Files tab to specify your application and additional resources to download to the target:

7 Debugging code
7.4 Configuring a connection to an external Fixed Virtual Platform (FVP) for bare-metal application debug

101469_2021.1_02_en Copyright © 2018–2021 Arm Limited or its affiliates. All rights
reserved.

7-115

Non-Confidential - REL

https://developer.arm.com/products/software-development-tools/arm-development-studio/editions
https://developer.arm.com/products/software-development-tools/arm-development-studio/editions
https://developer.arm.com/documentation/101470/latest/Platform-Configuration/Model-targets/Create-a-new-model-configuration
https://developer.arm.com/documentation/101470/latest/Platform-Configuration/Model-targets/Create-a-new-model-configuration


a. In Target Configuration > Application on host to download, specify the application that you
want to load on the model.

b. If you want to debug your application at source level, select Load symbols.
c. If you want to load additional resources, for example, additional symbols or peripheral description

files from a directory, use the Files area to add them. Click + to add resources, click - to remove
resources.

5. Use the Debugger tab to configure debugger settings.
a. In the Run control area:

• Choose if you want to Connect only to the target or Debug from entry point. If you want to
start debugging from a specific symbol, select Debug from symbol.

• If you need to run target or debugger initialization scripts, select the relevant options and
specify the script paths.

• If you need to specify at debugger start up, select Execute debugger commands options and
specify the commands.

b. The debugger uses your workspace as the default working directory on the host. If you want to
change the default location, deselect the Use default option under Host working directory and
specify a new location.

c. In the Paths area, use the Source search directory field to enter any directions on the host to
search for your application files.

d. If you need to use additional resources, click Add resource (+) to add resources, click Remove
resources (-) to remove resources.

6. If required, use the Arguments tab to enter arguments that are passed, using semihosting, to the
main() function of the application when the debug session starts.

7. If required, use the Environment tab to create and configure environment variables to pass into the
launch configuration when it is executed.

8. Click Apply and then Close to save the configuration settings and close the Debug Configurations
dialog box.

You have now created a debug configuration to connect to the Base_AEMv8A_AEMv8A FVP target. You
can view this debug configuration in the Debug Control view.

9. The next step is to start up the Base_AEMv8A_AEMv8A FVP with the appropriate settings so that
Development Studio can connect to it when you start your debugging session.
a. Open a terminal window and navigate to the installation directory of the Base_AEMv8A_AEMv8A

FVP.
b. Start up the Base_AEMv8A_AEMv8A separately with the appropriate options and parameters.

For example, to run the FVP_Base_AEMv8A-AEMv8A.exe FVP model on Windows platforms, at the
command prompt enter:

FVP_Base_AEMv8A-AEMv8A.exe -S -C cluster0.NUM_CORES=0x1 -C
bp.secure_memory=false -C cache_state_modelled=0

Where:
• FVP_Base_AEMv8A-AEMv8A.exe - The executable for the FVP model on Windows platforms.
• -S or --cadi-server - Starts the CADI server so that Arm Debugger can connect to the FVP

model.
• -C or --parameter - Sets the parameter you want to use when running the FVP model.
• cluster0.NUM_CORES=0x1 - Specifies the number of cores to activate on the cluster in this

instance.
• bp.secure_memory=false - Sets the security state for memory access. In this example,

memory access is disabled.
• cache_state_modelled=0 - Sets the core cache state. In this example, it is disabled.

 Note 

The parameters and options that are required depend on your specific requirements. Check the
documentation for your FVP to locate the appropriate parameters.
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You can find the options and parameters that are used in this example in the Fixed Virtual
Platforms FVP Reference Guide. You can also enter --list-params after the FVP executable
name to print available platform parameters.

The FVP is now running in the background awaiting incoming CADI connection requests from
Arm Debugger.

10. In the Debug Control view, double-click the debug configuration that you created.

This action starts the debug connection, loads the application on the model, and loads the debug
information into the debugger.

11. Click Continue running application to continue running your application.
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7.5 Configuring a connection to a bare-metal hardware target
To configure a connection to a bare-metal hardware target, create a hardware debug connection. Then,
connect to your hardware target using JTAG or Serial Wire Debug (SWD) using DSTREAM-ST or a
similar debug hardware adapter.

Prerequisites

• Ensure that your target is powered on. Refer to the documentation supplied with the target for more
information.

• Ensure that the debug hardware adapter connecting your target with your workstation is powered on
and working.

• If using DSTREAM-ST, ensure that your target is connected correctly to the DSTREAM-ST unit. If
the target is connected and powered on, the TARGET LED illuminates green.

• If using DSTREAM, ensure that your target is connected correctly to the DSTREAM unit. If the
target is connected and powered on, the TARGET LED illuminates green, and the VTREF LED on
the DSTREAM probe illuminates.

Procedure
1. From the Arm Development Studio main menu, select File > New > Hardware Connection.
2. In the Hardware Connection dialog box, specify the details of the connection:

a. In Debug Connection enter a debug connection name, for example my_hardware_connection
and click Next.

b. In Target Selection select a target, for example Juno Arm Development Platform (r2) and
click Finish to complete the initial connection configuration.

3. In the displayed Edit Configuration dialog box, click the Connection tab to specify the target and
connection settings:
a. In the Select target panel confirm the target selected.
b. Select your debug hardware unit in the Target Connection list. For example, DSTREAM

Family.
c. If required, Edit the Debug and Trace Services Layer (DTSL) settings in the DTSL

Configuration Configuration dialog box to configure additional debug and trace settings for
your target.

d. In the Connections area, enter the Connection name or IP address of your debug hardware
adapter. If your connection is local, click Browse and select the connection using the Connection
Browser.
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Figure 7-1  Edit the Connection tab
4. Click the Files tab to specify your application and additional resources to download to the target:

a. If you want to load your application on the target at connection time, in the Target Configuration
area, specify your application in the Application on host to download field.

b. If you want to debug your application at source level, select Load symbols.
c. If you want to load additional resources, for example, additional symbols or peripheral description

files from a directory, add them in the Files area. Click + to add resources, click - to remove
resources.
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Figure 7-2  Edit the Files tab
5. Use the Debugger tab to configure debugger settings.

a. In the Run control area:
• Specify if you want to Connect only to the target or Debug from entry point. If you want to

start debugging from a specific symbol, select Debug from symbol.
• If you need to run target or debugger initialization scripts, select the relevant options and

specify the script paths.
• If you need to specify at debugger start up, select Execute debugger commands options and

specify the commands.
b. The debugger uses your workspace as the default working directory on the host. If you want to

change the default location, deselect the Use default option under Host working directory and
specify the new location.

c. In the Paths area, specify any directories on the host to search for files of your application in the
Source search directory field.

d. If you need to use additional resources, click Add resource (+) to add resources, click Remove
resources (-) to remove resources.
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Figure 7-3  Edit the Files tab
6. If required, use the Arguments tab to enter arguments that are passed to the main() function of the

application when the debug session starts. The debugger uses semihosting to pass arguments to
main().

7. If required, use the Environment tab to create and configure environment variables to pass into the
launch configuration when it is executed.

8. Click Apply to save the configuration settings.
9. Click Debug to connect to the target and start the debugging session.
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7.6 Configuring a connection to a Linux application using gdbserver
For Linux application debugging, you can configure Arm Debugger to connect to a Linux application
using gdbserver.

Prerequisites

• Set up your target with an Operating System (OS) installed and booted. Refer to the documentation
supplied with your target for more information.

• Obtain the target IP address or name for the connection between the debugger and the debug
hardware adapter. If the target is in your local subnet, click Browse and select your target.

• If required, set up a Remote Systems Explorer (RSE) connection to the target.

 Note 

• If you are connecting to an already running gdbserver, then you must ensure that it is installed and
running on the target. To run gdbserver and the application on the target use: gdbserver port
path/myApplication. Where port is the connection port between gdbserver and the application
and path/myApplication is the application that you want to debug.

• If you are connecting to an Armv8 target, select the options under Connect via AArch64 gdbserver.

Procedure
1. From the Arm Development Studio main menu, select File > New > Linux Application Connection.
2. In the Linux Application Connection dialog box, specify the details of the connection:

a. Give the debug connection a name, for example my_linux_app_connection.
b. If using an existing project, select Use settings from an existing project option.
c. Click Finish.

3. In the Edit Configuration dialog box displayed:
• If you want to connect to a target with the application and gdbserver already running on it:

1. In the Connection tab, select Connect to already running application.
2. In the Connections area, specify the address and port details of the target.
3. If you want to terminate the gdbserver when disconnecting from the FVP, select Terminate

gdbserver on disconnect.
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Figure 7-4  Edit Linux app connection details
4. In the Files tab, use the Load symbols from file option in the Files panel to specify symbol

files.
5. In the Debugger tab, specify the actions that you want the debugger to perform after

connecting to the target.
6. If required, click the Arguments tab to enter arguments that are passed to the application

when the debug session starts.
7. If required, click the Environment tab to create and configure the target environment

variables that are passed to the application when the debug session starts.
• If you want to download your application to the target system and then start a gdbserver session to

debug the application, select Download and debug application. This connection requires that
ssh and gdbserver is available on the target.
1. In the Connections area, specify the address and port details of the target you want to connect

to.
2. In the Files tab, specify the Target Configuration details:

— Under Application on host to download, select the application to download onto the
target from your host filesystem or workspace.

— Under Target download directory, specify the download directory location.
— Under Target working directory, specify the target working directory.
— If required, use the Load symbols from file option in the Files panel to specify symbol

files.
3. In the Debugger tab, specify the actions that you want the debugger to perform after it

connects to the target.
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4. If required, click the Arguments tab to enter arguments that are passed to the application
when the debug session starts.

5. If required, click the Environment tab to create and configure the target environment
variables that are passed to the application when the debug session starts.

• If you want to connect to your target, start gdbserver, and then debug an application already
present on the target, select Start gdbserver and debug target resident application, and
configure the options.
1. In the Model parameters area, the Enable virtual file system support option maps

directories on the host to a directory on the target. The Virtual File System (VFS) enables the
FVP to run an application and related shared library files from a directory on the local host.
— The Enable virtual file system support option is selected by default. If you do not want

virtual file system support, deselect this option.
— If the Enable virtual file system support option is enabled, your current workspace

location is used as the default location. The target sees this location as a writable mount
point.

2. In the Files tab, specify the location of the Application on target and the Target working
directory. If you need to load symbols, use the Load symbols from file option in the Files
panel.

3. In the Debugger tab, specify the actions that you want the debugger to perform after
connecting to the target.

4. If required, click the Arguments tab to enter arguments that are passed to the application
when the debug session starts.

5. If required, click the Environment tab to create and configure the target environment
variables that are passed to the application when the debug session starts.

4. Click Apply to save the configuration settings.
5. Click Debug to connect to the target and start debugging.
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7.7 Configuring a connection to a Linux kernel
Use these steps to configure a connection to a Linux target and load the Linux kernel into memory. The
steps also describe how to add a pre-built loadable module to the target.

Prerequisites

For a Linux kernel module debug, a Remote Systems Explorer (RSE) connection to the target might be
required. If so, you must know the target IP address or name.

Procedure
1. From the Arm Development Studio main menu, select File > New > Hardware Connection.
2. In the Hardware Connection dialog box, specify the details of the connection:

a. In Debug Connection give the debug connection a name, for example
my_linux_kernel_connection and click Next.

b. In Target Selection select a target, for example Juno Arm Development Platform (r2) and
click Finish to complete the initial configuration of the connection.

Figure 7-5  Name the Linux kernel connection
3. In the Edit Configuration dialog box, use the Connection tab to specify the target and connection

settings:
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a. In the Select target panel, browse and select Linux Kernel and/or Device Driver Debug
operation, and further select the processor core you require.

b. Select your debug hardware unit in the Target Connection list. For example, DSTREAM
Family.

c. If you need to, Edit the Debug and Trace Services Layer (DTSL) settings in the DTSL
Configuration Editor to configure additional debug and trace settings for your target.

d. In the Connections area, enter the Connection name or IP address of your debug hardware
adapter. If your connection is local, click Browse and select the connection using the Connection
Browser.

4. Use the Files tab to specify your application and additional resources to download to the target:
a. If you want to load your application on the target at connection time, in the Target Configuration

area, specify your application in the Application on host to download field.
b. If you want to debug your application at source level, select Load symbols.
c. If you want to load additional resources, for example, additional symbols or peripheral description

files from a directory, add them in the Files area. Click Add resource to add resources, click
Remove resources to remove resources.

5. Select the Run control area in the Debugger tab to configure debugger settings:
a. Select Connect only and set up initialization scripts as required.

 Note 

Operating System (OS) support is automatically enabled when a Linux kernel vmlinux symbol
file is loaded into the debugger from the Arm Debugger launch configuration. However, you can
manually control this using the set os command.

For example, if you want to delay the activation of operating system support until the kernel has
booted and the Memory Management Unit (MMU) is initialized, then you can configure a
connection that uses a target initialization script to disable operating system support.

b. Select Execute debugger commands option.
c. In the field provided, enter commands to load debug symbols for the kernel and any kernel

modules that you want to debug, for example:

add-symbol-file <path>/vmlinux S:0

add-symbol-file <path>/modex.ko
 Note 

• The path to the vmlinux must be the same as your build environment.
• In the example above, the kernel image is called vmlinux, but this could be named differently

depending on your kernel image.
• In the example above, S:0 loads the symbols for secure space with 0 offset. The offset and

memory space prefix is dependent on your target. When working with multiple memory
spaces, ensure that you load the symbols for each memory space.

d. The debugger uses your workspace as the default working directory on the host. If you want to
change the default location, deselect the Use default option under Host working directory and
specify a new location.

e. In the Paths area, specify any directories on the host to search for files of your application using
the Source search directory field.

f. If you need to use additional resources, click Add resource (+) to add resources, click Remove
resources (-) to remove resources.

6. If required, use the Arguments tab to enter arguments that are passed to the main() function of the
application when the debug session starts. The debugger uses semihosting to pass arguments to
main().

7. If required, use the Environment tab to create and configure environment variables to pass into the
launch configuration when it is executed.
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8. Click Apply to save the configuration settings.
9. Click Debug to connect to the target and start the debugging session.

 Tip 

By default, for this type of connection, all processor exceptions are handled by Linux on the
target. Once connected, you can use the Manage Signals dialog box in the Breakpoints view

menu to modify the default handler settings.
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7.8 Configuring trace for bare-metal or Linux kernel targets
You can configure trace for bare-metal or Linux kernel targets using the DTSL options that Arm
Debugger provides.

After configuring trace for your target, you can connect to your target and capture trace data.

Procedure
1. In Arm Debugger, select Window > Perspective > Open Perspective > Other > Development

Studio .
2. Select Run > Debug Configurations to open the Debug Configurations launcher panel.
3. Select the Arm Debugger debug configuration for your target in the left-hand pane.

If you want to create a new debug configuration for your target, then select Arm Debugger from the
left-hand pane, and then click the New button. Then select your bare-metal or Linux kernel target
from the Connection tab.

Figure 7-6  Select the debug configuration
4. After selecting your target in the Connection tab, click the DTSL Options Edit button. This shows

the DTSL Configuration dialog box where you can configure trace.
5. Depending on your target platform, the DTSL Configuration dialog box provides different options

to configure trace.
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Figure 7-7  Select Trace capture method

a. For Trace capture method select the trace buffer you want to use to capture trace.
b. The DTSL Configuration dialog box shows the processors on the target that are capable of trace.

Click the processor tab you require. Then, select the option to enable trace for the individual
processors you want to capture trace.

c. Select any other trace related options you require in the DTSL Configuration dialog box.
d. Click Apply and then click OK. This configures the debug configuration for trace capture.

6. Use the other tabs in the DTSL Configuration dialog box to configure the other aspects of your
debug connection.

7. Click Apply to save your debug configuration. When you use this debug configuration to connect,
run, and stop your target, you can see the trace data in the Trace view.

 Note 

The options to enable trace might be nested. In this example, you must select Enable Cortex-A15
core trace to enable the other options. Then you must select Enable Cortex-A15 0 trace to enable
trace on core 0 of the Cortex‑A15 processor cluster.
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Figure 7-8  Select the processors you want to trace

Related information
Configure DSTREAM-PT trace mode
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7.9 Configuring an Events view connection to a bare-metal target
The Events view allows you to capture and view textual logging information from bare-metal
applications. It also allows you to view packets generated by the Data Watchpoint and Trace (DWT) unit
on M-profile targets. Logs are captured from your application using annotations that you must add to the
source code.

Prerequisites

• On M-profile targets, set the registers appropriately to enable the required DWT packets. See the
Armv7-M Architecture Reference Manual for more information.

• Annotate your application source code with logging points and recompile it. See the ITM and Event
Viewer Example for Versatile Express Cortex-A9x4 provided with Arm Development Studio
examples for more information.

Procedure
1. Select Debug Configurations… from the Run menu.
2. Select Generic Arm C/C++ Application from the configuration tree and then click New to create a

new configuration.
3. In the Name field, enter a suitable name for the new configuration, for example, events_view_debug
4. Use the Connection tab to specify the target and connection settings:

a. Select the required platform in the Select target panel. For example, ARM Development Boards
> Versatile Express A9x4 > Bare Metal Debug > Debug Cortex-A9x4 SMP.

b. Select your debug hardware unit in the Target Connection list. For example, DSTREAM
Family.

c. In DTSL Options, click Edit to configure DSTREAM trace and other target options. This
displays the DTSL Configuration dialog box.
• In the Trace Capture tab, either select On Chip Trace Buffer (ETB) (for a JTAG cable

connection), or DSTREAM 4GB Trace Buffer (for a Mictor cable connection).
• In the ITM tab, enable or disable ITM trace and select any additional settings you require.

5. Click the Files tab to define the target environment and select debug versions of the application file
and libraries on the host that you want the debugger to use.
a. In the Target Configuration panel, specify your application in the Application on host to

download field.
b. If you want to debug your application at source level, select Load symbols.
c. If you want to load additional resources, for example, additional symbols or peripheral description

files from a directory, use the Files area to add them. Click + to add resources, click - to remove
resources.

6. Use the Debugger tab to configure debugger settings.
a. In the Run control area:

• Specify if you want to Connect only to the target or Debug from entry point. If you want to
start debugging from a specific symbol, select Debug from symbol.

• If you need to run target or debugger initialization scripts, select the relevant options and
specify the script paths.

• If you need to specify at debugger start up, select Execute debugger commands options and
specify the commands.

b. The debugger uses your workspace as the default working directory on the host. If you want to
change the default location, deselect the Use default option under Host working directory and
specify a new location.

c. In the Paths area, specify any directories on the host to search for files of your application using
the Source search directory field.

d. If you need to use additional resources, click Add resource (+) to add resources, click Remove
resources (-) to remove resources.
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7. If required, click the Arguments tab to enter arguments that are passed, using semihosting, to the
application when the debug session starts.

8. Click Apply to save the configuration settings.
9. Click Debug to connect to the target. Debugging requires the Development Studio perspective. If the

Confirm Perspective Switch dialog box opens, click Yes to switch perspective.

When connected and the Development Studio perspective opens, you are presented with all the
relevant views and editors.

10. Set up the Events view to show output generated by the System Trace Macrocell (STM) and
Instruction Trace Macrocell (ITM) events.
a. From the main menu, select Window > Show view > Events

b. In the Events view, click  , and select Events Settings.
c. In Select a Trace Source, ensure that the trace source matches the trace capture method specified

earlier.
d. Select the required Ports/Channels.
e. On M-profile targets, if required, select any DWT packets.
f. Click OK to close the dialog box.

11. Run the application for a few seconds, and then interrupt it.

You can view the relevant information in the Events view. For example:

Figure 7-9  Events view with data from the ITM source
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7.10 Exporting or importing an existing Arm Development Studio launch
configuration

In Arm Development Studio, a launch configuration contains all the information to run or debug a
program. An Arm Development Studio debug launch configuration typically describes the target to
connect to, the communication protocol or probe to use, the application to load on the target, and debug
information to load in the debugger.

 Note 

• To use a launch configuration from the Development Studio command-line, you must create a launch
configuration file using the Export tab in the Debug Configurations dialog box.

• You cannot import Development Studio command-line launch configurations.
• When exporting a launch configuration, Arm Development Studio resolves any Eclipse variables that

you have used. Arm Development Studio does not resolve Eclipse variables when scripting or when
using the Commands view.

Exporting an existing launch configuration
1. From the File menu, select Export….
2. In the Export dialog box, expand the Run/Debug group and select Launch Configurations.
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Figure 7-10  Export Launch Configuration dialog box
3. Click Next.
4. In the Export Launch Configurations dialog box:

a. Depending on your requirements, expand the CMSIS C/C++ Application group or the Generic
Arm C/C++ Application and select one or more launch configurations.

b. Click Browse… and select the required location on your local file system and click OK.
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Figure 7-11  Select Launch Configurations for export
5. If necessary, select Overwrite existing file(s) without warning.
6. Click Finish.

The launch configuration files are saved in your selected location with an extension of .launch.
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Importing an existing launch configuration
1. From the File menu, select Import….
2. In the Import dialog box, expand the Run/Debug group and select Launch Configurations.
3. Click Next.
4. In the Import Launch Configurations dialog box:

a. In From Directory, click Browse and select an import directory.
b. In the selection panels, select the folder and the specific launch configurations you want.

Figure 7-12  Import launch configuration selection panel
c. If necessary, select Overwrite existing file(s) without warning.
d. Click Finish to complete the import process.

You can view the imported launch configurations in the Debug Control panel.
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7.11 Disconnecting from a target
To disconnect from a target, you can use either the Debug Control or the Commands view.

• If you are using the Debug Control view, on the toolbar, click  .

Figure 7-13  Disconnecting from a target using the Debug Control view
• If you are using the Commands view, enter quit in the Command field and click Submit.

Figure 7-14  Disconnecting from a target using the Commands view

The disconnection process ensures that the target's state does not change, except for the following:
• Any downloads to the target are canceled and stopped.
• Any breakpoints are cleared on the target, but are maintained in Arm Development Studio.
• The DAP (Debug Access Port) is powered down.
• Debug bits in the DSC (Debug Status Control) register are cleared.

If a trace capture session is in progress, trace data continues to be captured even after Arm Development
Studio has disconnected from the target.
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Chapter 8
Tutorials

Contains tutorials to help you get started with Arm Development Studio.

It contains the following sections:
• 8.1 Tutorial: Hello World on page 8-139.
• 8.2 Tutorial: Using Fixed Virtual Platforms (FVPs) on page 8-154.
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8.1 Tutorial: Hello World
The Hello World tutorial is for new users, taking them through each step in getting their first project up
and running.

This section contains the following subsections:
• 8.1.1 Open Arm Development Studio for the first time on page 8-139.
• 8.1.2 Create a project in C/C++ on page 8-140.
• 8.1.3 Configure your project on page 8-141.
• 8.1.4 Build your project on page 8-141.
• 8.1.5 Configure your debug session on page 8-142.
• 8.1.6 Application debug with Arm Debugger on page 8-149.
• 8.1.7 Disconnecting from a target on page 8-152.

8.1.1 Open Arm Development Studio for the first time

The first time you open Arm Development Studio, you are prompted to add your license details. When
you have completed the tasks in this section, you are ready to use Arm Debugger.

Arm Development Studio is available for both Linux and Windows platforms on page 2-23.

Prerequisites

• Download and install Arm Development Studio, for either:
— Linux: Installing on Linux on page 2-27
— Windows: Installing on Windows on page 2-25

• If you have purchased Arm Development Studio, you need either your license file, or the address and
port number of the license server you would like to connect to.

Procedure
1. Open Arm Development Studio:

• On Windows, select Windows menu > Arm Development Studio <version>
• On Linux:

— GUI: Use your Linux variant's menu system to locate Arm Development Studio.
— Command line: Run <installation_directory>/bin/armds_ide

2. The first time you open Arm Development Studio, the Product Setup dialog box opens, which
prompts you to add your product license. You can either:
• Add product license - select this option if you have purchased Arm Development Studio.
• Obtain evaluation license - select this option if you would like to evaluate the product.

3. Click Next.
4. If you selected Add product license:

a. Enter the location of your license file, or the address and port number of your license server, and
click Next.

b. The Arm Development Studio editions that you are entitled to use are listed. Select the edition
that you require, and click Next.

c. Check the details on the summary page. If they are correct, click Finish.
5. If you selected Obtain evaluation license:

a. Log into your Developer account using your Arm Developer account email address and password.
If you do not have an account, click Create an account.

b. Select a network interface to which your license will be locked.
c. Click Finish.
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Arm Development Studio opens. See Integrated Development Environment (IDE) Overview
on page 4-65, which describes the main features of the user interface.

 Note 

The workspace is automatically set by default, to either:
• Windows: <userhome>\Development Studio Workspace
• Linux: <userhome>/developmentstudio-workspace

You can change the default location by selecting File > Switch Workspace.

8.1.2 Create a project in C/C++

After installing and licensing Arm Development Studio, we are going to create a simple Hello World C
project and show you how to specify the base RAM address for a target. For the remainder of this
tutorial, we are going to use the Arm Compiler 6 toolchain and our target is a Cortex‑A53 Fixed Virtual
Platform, provided with Arm Development Studio.

Prerequisites

• Complete Open Arm Development Studio for the first time on page 8-139
• Ensure you are in the Development Studio Perspective. This is the default perspective when Arm

Development Studio is first opened. To return to it, click the Development Studio button in the top
right corner.

Figure 8-1  Screenshot highlighting the button for the Development Studio Perspective.

Procedure
1. To create a new C project, select: File > New > Project....
2. Expand the C/C++ menu, and select C project, then click Next.
3. In the C Project dialog box:

a. In the Project name field, enter HelloWorld.
b. Under Project type, select Executable > Hello World ANSI C Project.
c. Under Toolchains, select Arm Compiler 6.
d. Click Finish.
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Figure 8-2  The IDE after creating a new project

8.1.3 Configure your project

Before you build the HelloWorld project, you must specify some configuration settings.

You must specify:
• The target you want to compile for.
• The linker base RAM address for your FVP target.
• That the Arm Debugger must add debug symbols into the image file.

This ensures that the application is built and loaded correctly on to your target, and that you can debug
the image.

Prerequisites

Complete Create a project in C/C++ on page 8-140

Procedure
1. In the Project Explorer view, right-click the HelloWorld project and select Properties. The

Properties for HelloWorld dialog box opens.
2. Add debug symbols into the image file:

a. Expand C/C++ Build, and select Build Variables.
b. Set Configuration to Debug [Active].

3. Configure the target. In the Tool Settings tab, select All Tools Settings > Target:
a. From the Target CPU dropdown, select Cortex-A53 AArch64.
b. From the Target FPU dropdown, select Armv8 (Neon).

4. Configure the image layout. In the Tool Settings tab, select Arm Linker 6 > Image Layout:
a. In the RO base address field, enter 0x80000000.

5. Click Apply and Close.
6. If you are prompted to rebuild the index, click Yes.

8.1.4 Build your project

You can now build your HelloWorld project!
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Prerequisites

Complete these tasks:
• Create a project in C/C++ on page 8-140
• Configure your project on page 8-141

Procedure
• In the Project Explorer view, right-click the HelloWorld project and select Build Project.

When the project has built, in the Project Explorer view, under Debug, locate the HelloWorld.axf file.

The .axf file contains the object code and debug symbols that enable Arm Debugger to perform source-
level debugging.

 Note 

Debug symbols are added at build time. You can either specify this manually, using the -g option when
compiling with Arm Compiler 6, or you can set this to be default behavior. See Configure your project
on page 8-141 for details.

8.1.5 Configure your debug session

In Arm Development Studio, you configure a debugging session by creating a debug connection to your
target using the New Debug Connection wizard.

Depending on your requirements, you can:
• Configure a connection to an FVP for bare-metal application debug on page 7-115
• From the command-line, configure a connection to an FVP for bare-metal application debug

on page 7-114
• Configure a connection to an FVP for Linux application debug on page 7-122
• Configure a connection to an FVP for Linux kernel debug on page 7-125

The following example takes you through configuring a bare-metal Model Connection to a Cortex‑A53
Fixed Virtual Platform (FVP), using the project you created in the previous section of this tutorial.

Procedure
1. Create a .ds script so that the FVP handles semihosting, instead of Arm Debugger:

a. From the main menu, select File > New > Other....
b. In the New dialog box, select Arm Debugger > Arm Debugger Script and click Next.
c. Click Workspace… and select the HelloWorld project as the location for this script. Click OK.
d. In the File Name field, name this script use_model_semihosting and click Finish. The empty

script opens in the Editor window.
e. Add the following code to the script and press Ctrl + S to save:

set semihosting enabled off
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Figure 8-3  Editor window with semihosting script.
 Note 

You can also add existing source files to your project by:
• Dragging and dropping the file into the project folder.
• Selecting File > Import > General > File System.

2. From the main menu, select File > New > Model Connection.
3. In the Model Connection dialog box, specify the details of the connection:

a. Enter a name for the debug connection, for example HelloWorld_FVP.
b. Select Associate debug connection with an existing project, and select the project that you

created and built in the previous section Build your project on page 8-141.
c. Click Next.

4. In the Target Selection dialog box, specify the details of the target:
a. Select Arm FVP (Installed with Arm DS) > Base_A53x1.
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Figure 8-4  Select Base_A53x1 model
b. Click Finish.

5. In the Edit Configuration dialog box, ensure the right target is selected, the appropriate application
files are specified, and the debugger knows where to start debugging from:
a. Under the Connection tab, ensure that Arm FVP (Installed with Arm DS) > Base_A53x1 >

Bare Metal Debug > Cortex-A53 is selected.
b. Under Bare Metal Debug, in the Model parameters field, add the following parameter:

-C bp.secure_memory=false

This parameter disables the TZC-400 TrustZone memory controller included in the Base_A53x1
FVP. By default, the memory controller refuses all accesses to DRAM memory.
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Figure 8-5  Edit configuration Connection tab
c. In the Files tab, select Target Configuration > Application on host to download > Workspace.
d. Click and expand the HelloWorld project and from the Debug folder, select HelloWorld.axf and

click OK.

8 Tutorials
8.1 Tutorial: Hello World

101469_2021.1_02_en Copyright © 2018–2021 Arm Limited or its affiliates. All rights
reserved.

8-145

Non-Confidential - REL



Figure 8-6  Select helloworld.axf file
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Figure 8-7  Edit configuration Files tab
e. In the Debugger tab, select Debug from symbol.
f. Enable Run target initialization debugger script (.ds/.py) and click Workspace….
g. Select the use_model_semihosting.ds script and click OK.
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Figure 8-8  Debug from symbol main
6. Click Debug to load the application on the target, and load the debug information into the debugger.

Arm Development Studio connects to the model and displays the connection status in the Debug
Control view.

Figure 8-9  Debug Control View

The application loads on the target, and stops at the main() function, ready to run.
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Figure 8-10  main () in code editor

8.1.6 Application debug with Arm Debugger

Now that you have created a debug configuration and the application is loaded on the target, it is time to
start debugging and stepping through your application.

Running and stepping through the application

Use the controls provided in the Debug Control view to debug your application. By default, these
controls do source level stepping.

 - Click to continue running the application after loading it on the target.

 - Click to interrupt or pause executing code.

 - Click to step through the code.

 - Click to step over a source line.

 - Click to step out.

 - This is a toggle. Click this to toggle between stepping instructions and stepping source code. This
applies to the above step controls.

Other views display information relevant to the debug connection
• Target Console view displays the application output.
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Figure 8-11  Target console output
• Commands view displays messages output by the debugger. Also use this view to enter Arm

Debugger commands.

Figure 8-12  Commands view
• C/C++ Editor view shows the active C, C++, or Makefile. The view updates when you edit these

files.
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Figure 8-13  Code Editor view
• Disassembly view shows the built program as assembly instructions, and their memory location.

Figure 8-14  Disassembly view
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 indicates the location in the code where your program is stopped. In this case, it is at the main()
function.

• Memory view shows how the code is represented in the target memory. For example, to view how
the string Hello World from the application is represented in memory:
1. Open the Memory view.
2. In the Address field, enter &main and press Enter on your keyboard. The view displays the

contents of the target's memory.
3. Change the displayed number of bytes to 96 and press Enter.
4. Right-click on the column headings, and select Characters.

Figure 8-15  Adding Characters column to Memory view
5. Select and highlight the words Hello World.

Figure 8-16  Memory view

In the above example, the Memory view displays the hexadecimal values for the code and the ASCII
character encoding of the memory values, which enable you to view the details of the code.

After completing your debug activities, you can disconnect the target on page 8-152.

8.1.7 Disconnecting from a target

To disconnect from a target, you can use either the Debug Control or the Commands view.

• If you are using the Debug Control view, click Disconnect from Target on the toolbar.
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Figure 8-17  Disconnecting from a target using the Debug Control view
• If you are using the Commands view, enter quit in the Command field, then click Submit.

Figure 8-18  Disconnecting from a target using the Commands view

The disconnection process ensures that the state of the target does not change, except for the following
case:
• Any downloads to the target are canceled and stopped.
• Any breakpoints are cleared on the target, but are maintained in Arm Development Studio.
• The DAP (Debug Access Port) is powered down.
• Debug bits in the DSC (Debug Status Control) register are cleared.

If a trace capture session is in progress, trace data continues to be captured even after Arm Development
Studio has disconnected from the target.
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8.2 Tutorial: Using Fixed Virtual Platforms (FVPs)
The tutorial for using Fixed Virtual Platforms (FVPs) takes new users through basic scenarios of using
FVPs with Arm Development Studio.

This section contains the following subsections:
• 8.2.1 Overview: Fixed Virtual Platforms on page 8-154.
• 8.2.2 Launch and connect to a Fixed Virtual Platform in Arm Development Studio on page 8-154.
• 8.2.3 Configure a connection to a Fixed Virtual Platform for debug on page 8-157.
• 8.2.4 Run applications on a Fixed Virtual Platform on page 8-157.
• 8.2.5 Capture trace output from a Fixed Virtual Platform on page 8-159.
• 8.2.6 Add an external Fixed Virtual Platform to Arm Development Studio on page 8-161.

8.2.1 Overview: Fixed Virtual Platforms

A Fixed Virtual Platform (FVP) is a simulated model of a development platform, including processor,
memory, and peripherals.

You can use FVPs for bare-metal debugging and application development instead of a physical target.
You can also capture trace output from an FVP. Some FVPs are provided with Arm Development Studio.
If required, you can manually add other FVPs to Arm Development Studio.

This tutorial builds on the Hello world tutorial on page 8-139 and guides you through some of these
usage scenarios.

Related information
Fast Models Fixed Virtual Platform Reference Guide

8.2.2 Launch and connect to a Fixed Virtual Platform in Arm Development Studio

You can launch and connect to Arm FVPs (Fixed Virtual Platforms) in Arm Development Studio. This
tutorial shows you how to launch an FVP, that is included with Arm Development Studio, using the
Development Studio IDE.

Procedure
1. Create a new model connection.

a. Open the Debug Connection dialog box. From the main menu, select File > New > Model
Connection. You can also select Create a debug connection in the Debug Control view to
create a new connection.

b. In the Debug Connection dialog box, specify the details of the connection. Enter a name for the
debug connection and click Next.

 Note 

If you have an existing project, select Associate debug connection with an existing project, and
select the project that you want to debug.

c. In the Target Selection dialog box, specify the details of the target. Under Arm FVP (Installed
with Arm DS), select the FVP you want to connect to and click Finish. For example, if you want
to connect to a single-core Cortex‑A53 Base Platform FVP, select Arm FVP (Installed with
Arm DS) > Base_A53x1.
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2. Edit your model configuration.
a. In the Edit Configuration dialog box, under the Connection tab, ensure that you select the

correct target for your debug operation. For example, to select a single-core Cortex-A53 for bare-
metal debug, select Arm FVP (Installed with Arm DS) > Base_A53x1 > Bare Metal Debug >
Cortex-A53.

b. Under Bare Metal Debug, in the Model parameters field, specify parameters for the connection.
If you are connecting to an A-class or M-class model, you must specify certain parameters that
enable access to model RAM.
• For Cortex-A models, add the parameter -C bp.secure_memory=false
• For Cortex-M models, add the parameter -C fvp_mps2.DISABLE_GATING=1

c. Click Debug to launch the connection to the FVP.
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• By default, the CLCD window launches. You can disable this default action with the parameter -C
bp.vis.disable_visualisation=1. See Using the CLCD window for more information.

• The Debug Control view displays the status of the connection.

Related information
Create a new model configuration
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8.2.3 Configure a connection to a Fixed Virtual Platform for debug

In Arm Development Studio, you can create and change configurations for a debugging session on an
FVP connection using the Debug Configurations dialog box.

Procedure
• To open the Debug Configurations dialog box, right-click the FVP you want to configure in the

Debug Control view, then click Debug Configurations….

In this dialog box, the tabs contain further options for your connection. For more information on the
functionality of these tabs, see the following topics in the Perspectives and Views chapter of the Arm
Development Studio User Guide.
• Connection tab
• Files tab
• Debugger tab
• OS Awareness tab
• Arguments tab
• Environment tab
• Export tab

8.2.4 Run applications on a Fixed Virtual Platform

Arm FVPs (Fixed Virtual Platforms) can run applications in a simulation of real hardware.

Procedure
1. Link your project with the model configuration you are using and launch the model connection.

• For new model connections:
1. Open the Debug Connection dialog box. From the main menu, select File > New > Model

Connection. You can also select Create a debug connection in the Debug Control view to
create a new connection.

2. In the Debug Connection dialog box, specify the details of the connection. Select Associate
debug connection with an existing project and then select the project that you want to
debug. Enter a name for the debug connection and click Next.
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3. In the Target Selection dialog box, specify the details of the target. Under Arm FVP
(Installed with Arm DS), select the FVP you want to connect to and click Finish.

• For existing model connections:
1. Open the Debug Configurations window. Right-click your connection in the Debug Control

view and select Debug Configurations....
2. In the Files tab, specify the location of the executable file for the project you want to debug.

Click Apply then Debug.
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2. To run the application, click  . Use the controls provided in the Debug Control view to debug
your application. See Application debug with Arm Debugger on page 8-149 for more information.

3. When you are finished, disconnect from the target.
• If you are using the Debug Control view, click Disconnect from Target on the toolbar.
• If you are using the Commands view, enter quit in the Command field, then click Submit.

8.2.5 Capture trace output from a Fixed Virtual Platform

Trace capture provides you with a detailed output of all the instructions that are executed in a debug
session. You can enable trace capture in the Debug and Trace Services Layer (DTSL) Configuration
dialog box.

Procedure
1. Open the DTSL Configuration dialog box. In the Debug Control view, right-click on the model

configuration you want to enable trace capture on and select DTSL Options.
2. In the Debug and Trace Services Layer (DTSL) Configuration dialog box, select the Model Trace

option under the Trace Buffer tab.
 Note 

Here you can also change the trace buffer size in the Trace Buffer Size drop-down menu.
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3. In the Core Trace tab, select the processor on which you want to enable trace capture.

4. Apply your settings and close the dialog box, select Apply and then OK.

Next Steps

In the Trace view, you can see all the instructions that are executed in a debug session.
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8.2.6 Add an external Fixed Virtual Platform to Arm Development Studio

Some Fixed Virtual Platforms (FVPs) are included with the installation of Arm Development Studio. To
use an Arm FVP that is not provided with Development Studio, you must first add it to the PATH
environment variable of your OS.

Procedure
1. Add the <install_directory>/bin directory to your PATH environment variable and restart Arm

Development Studio.
• For Windows, enter set PATH=<your model path>\bin;%PATH%
• For Linux, enter export PATH=<your model path>/bin:$PATH

2. Ensure that the modified path is available for future sessions:
• For Windows, right-click This PC, select Properties > Advanced system settings, then click

Environment Variables. Then under User Variables, append ;<your model path>\bin to any
existing PATH variable.

• For Linux, set up the PATH in the appropriate shell configuration file. For example, in .bashrc,
add the line export PATH=<your model path>/bin:$PATH.
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Chapter 9
Troubleshoot Arm Development Studio

Describes how to diagnose problems when debugging applications using Arm Debugger.

It contains the following sections:
• 9.1 Arm Linux problems and solutions on page 9-163.
• 9.2 Enabling internal logging from the debugger on page 9-164.
• 9.3 FTDI probe: Incompatible driver error on page 9-165.
• 9.4 Target connection problems and solutions on page 9-166.
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9.1 Arm Linux problems and solutions
Lists possible problems when debugging a Linux application.

You might encounter the following problems when debugging a Linux application.

Arm Linux permission problem

If you receive a permission denied error message when starting an application on the target then you
might have to change the execute permissions on the application:

chmod +x <myImage>

A breakpoint is not being hit

You must ensure that the application and shared libraries on your target are the same as those on your
host. The code layout must be identical, but the application and shared libraries on your target do not
require debug information.

Operating system support is not active

When Operating System (OS) support is required, the debugger activates it automatically where possible.
If OS support is required but cannot be activated, the debugger produces an error. :

ERROR(CMD16-LKN36):
! Failed to load image "gator.ko"
! Unable to parse module because the operating system support is not active

OS support cannot be activated if:

• Debug information in the vmlinux file does not correctly match the data structures in the kernel
running on the target.

• It is manually disabled by using the set os enabled off command.

To determine whether the kernel versions match:
• stop the target after loading the vmlinux image
• enter the print init_nsproxy.uts_ns->name command
• check that the $1 output is correct:

$1 = {sysname = "Linux", nodename = "(none)", release = "3.4.0-rc3", version = "#1 SMP 
Thu Jan 24 00:46:06 GMT 2013", machine = "arm", domainname = "(none)"}

Related information
Configuring a connection to a Linux application using gdbserver
Configuring a connection to a Linux kernel
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9.2 Enabling internal logging from the debugger
Describes how to enable internal logging to help diagnose error messages.

On rare occasions an internal error might occur, which causes the debugger to generate an error message
suggesting that you report it to your local support representatives. You can help to improve the debugger,
by giving feedback with an internal log that captures the stacktrace and shows where in the debugger the
error occurs. To find out your current version of Arm Development Studio, you can select Help > About
Arm Development Studio IDE in the IDE, or open the product release notes.

To enable internal logging within the IDE, enter the following in the Commands view of the
Development Studio perspective:
1. To enable the output of logging messages from the debugger using the predefined DEBUG level

configuration: log config debug
2. To redirect all logging messages from the debugger to a file: log file <debug.log>

 Note 

Enabling internal logging can produce very large files and slow down the debugger significantly. Only
enable internal logging when there is a problem.

Related information
Commands view

9 Troubleshoot Arm Development Studio
9.2 Enabling internal logging from the debugger

101469_2021.1_02_en Copyright © 2018–2021 Arm Limited or its affiliates. All rights
reserved.

9-164

Non-Confidential - REL

https://developer.arm.com/documentation/101470/latest/Perspectives-and-Views/Commands-view


9.3 FTDI probe: Incompatible driver error
When connecting your FTDI probe to Arm Development Studio, you might see an error message when
browsing for the probe.

The error is specific to Linux installations of Arm Development Studio:

Browsing failed: Incompatible virtual COM port driver (ftdi_sio) must be unloaded to
use FTDI MPSSE JTAG probe. See AN_220 FTDI Drivers Installation Guide for Linux.

Cause

The Linux operating system automatically loads an incompatible driver when the FTDI probe is plugged
in.

Solution
1. To unload the incompatible driver, enter the following commands in your Terminal:

sudo rmmod ftdi_sio
sudo rmmod usbserial

2. Browse for your FTDI probe again, and it is now listed in the Connection Browser.
Related information
FTDI Drivers Installation Guide for Linux
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9.4 Target connection problems and solutions
Lists possible problems when connecting to a target.

Failing to make a connection
The debugger might fail to connect to the selected debug target for the following reasons:
• You do not have a valid license to use the debug target.
• The debug target is not installed or the connection is disabled.
• The target hardware is in use by another user.
• The connection has been left open by software that exited incorrectly.
• The target has not been configured, or a configuration file cannot be located.
• The target hardware is not powered up ready for use.
• The target is on a scan chain that has been claimed for use by something else.
• The target hardware is not connected.
• You want to connect through gdbserver but the target is not running gdbserver.
• There is no ethernet connection from the host to the target.
• The port number in use by the host and the target are incorrect.

Check the target connections and power up state, then try and reconnect to the target.

Debugger connection settings
When debugging a bare-metal target the debugger might fail to connect for the following reasons:
• Heap Base address is incorrect.
• Stack Base (top of memory) address is incorrect.
• Heap Limit address is incorrect.
• Incorrect vector catch settings.

Check that the memory map settings are correct for the selected target. If set incorrectly, the application
might crash because of stack corruption or because the application overwrites its own code.

Related information
Configuring a connection to a Linux application using gdbserver
Configuring a connection to a Linux kernel

9 Troubleshoot Arm Development Studio
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Appendix A
Terminology and Shortcuts

Supplementary information for new users of Arm Development Studio.

It contains the following sections:
• A.1 Terminology on page Appx-A-168.
• A.2 Keyboard shortcuts on page Appx-A-170.
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A.1 Terminology
Arm Development Studio documentation uses a range of terms. These are listed below.

Device

A component on a target that contains the application that you want to debug.

Dialog box

A small page that contains tabs, panels, and editable fields which prompt you to enter
information.

Editor

A view that enables you to view and modify the content of a file, for example source files. The
tabs in the editor area show files that are currently open for editing.

Flash Program

A term used to describe the storing of data on a flash device.

IDE

The Integrated Development Environment. A window that contains perspectives, menus, and
toolbars. This is the main development environment where you can manage individual projects,
associated sub-folders, and source files. Each window is linked to one workspace.

Panel

A small area in a dialog box or tab to group editable fields.

Perspective

Perspectives define the layout of your selected views and editors in Eclipse. They also have their
own associated menus and toolbars.

Project

A group of related files and folders in Eclipse.

Resource

A generic term used to describe a project, file, folder, or a combination of these.

Send To

A term used to describe sending a file to a target.

Tab

A small overlay page that contains panels and editable fields within a dialog box to group
related information. Clicking on a tab brings it to the top.

Target

A development platform on a printed circuit board or a software model that emulates the
expected behavior of Arm hardware.

View

Views provide related information, for a specific function, corresponding to the active file in the
editor. They also have their own associated menus and toolbars.

Wizard

A group of dialog boxes to guide you through common tasks. For example, creating new files
and projects.

A Terminology and Shortcuts
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Workspace

An area on your file system used to store files and folders related to your projects.
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A.2 Keyboard shortcuts
A list of the most common keyboard shortcuts available for use with Arm Development Studio.

F3

Click an assembly instruction and press F3 to see help information about the instruction.

F10

Press F10 to access the main menu. You can then navigate the main menu using the arrow keys.

Alt+F4

Exit Arm Development Studio.

Alt+Left arrow

Go back in navigation history.

Alt+Right arrow

Go forward in navigation history.

Ctrl+Semicolon

In the Arm assembler editor, add comment markers to a selected block of code in the active file.

Ctrl+Home

Move the editor focus to the beginning of the code.

Ctrl+End

Move the editor focus to the end of the code.

Ctrl+B

Build all projects in the workspace that have changed since the last build.

Ctrl+F

Open the Find or Find/Replace dialog box to search through the code in the active editor. Some
editors are read-only and therefore disable this functionality.

Ctrl+F4

Close the active file in the editor view.

Ctrl+F6

Cycle through open files in the editor view.

Ctrl+F7

Cycle through available views.

Ctrl+F8

Cycle through available perspectives.

Ctrl+F10

Use with the arrow keys to access the drop-down menu.

Ctrl+L

Move to a specified line in the active file.

Ctrl+Q

Move to the last edited position in the active file.
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Ctrl+Space

Auto-complete selected functions in editors.

Shift+F10

Use with the arrow keys to access the context menu.

Ctrl+Shift+F

Activate the code style settings in the Preferences dialog box and apply them to the active file.

Ctrl+Shift+L

Open a small page with a list of all keyboard shortcuts.

Ctrl+Shift+R

Open the Open resource dialog box.

Ctrl+Shift+T

Open the Open Type dialog box.

Ctrl+Shift+/

In the C/C++ editor, add comment markers to the start and end of a selected block of code in the
active file.

A Terminology and Shortcuts
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