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1 Introduction

1.1 Conventions
The following subsections describe conventions used in Arm documents.

Glossary
The Arm Glossary is a list of terms used in Arm documentation, together with definitions for
those terms. The Arm Glossary does not contain terms that are industry standard unless the Arm
meaning differs from the generally accepted meaning.

See the Arm® Glossary for more information: developer.arm.com/glossary.

Typographic conventions
Arm documentation uses typographical conventions to convey specific meaning.

Convention Use

italic Introduces special terminology, denotes cross-references, and citations.

bold Highlights interface elements, such as menu names. Denotes signal names. Also used for terms in
descriptive lists, where appropriate.

monospace Denotes text that you can enter at the keyboard, such as commands, file and program names, and source
code.

monospace italic Denotes arguments to monospace text where the argument is to be replaced by a specific value.

monospace bold Denotes language keywords when used outside example code.

monospace underline Denotes a permitted abbreviation for a command or option. You can enter the underlined text instead of
the full command or option name.

<and> Encloses replaceable terms for assembler syntax where they appear in code or code fragments. For ex-
ample:

MRC p15, 0, <Rd>, <CRn>, <CRm>, <Opcode_2>

SMALL CAPITALS Used in body text for a few terms that have specific technical meanings, that are defined in the
Arm Glossary. For example, IMPLEMENTATION DEFINED, IMPLEMENTATION SPECIFIC, UNKNOWN, and
UNPREDICTABLE.

This represents a recommendation which, if not followed, might lead to system failure or damage.

This represents a requirement for the system that, if not followed, might result in system failure or
damage.

This represents a requirement for the system that, if not followed, will result in system failure or damage.
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Convention Use
This represents an important piece of information that needs your attention.

This represents a useful tip that might make it easier, better or faster to perform a task.

This is a reminder of something important that relates to the information you are reading.

1.2 Feedback
Arm welcomes feedback on this product and its documentation.

Feedback on this product
If you have any comments or suggestions about this product, contact your supplier and give:

• The product name.

• The product revision or version.

• An explanation with as much information as you can provide. Include symptoms and diagnostic
procedures if appropriate.

Feedback on content
If you have comments on content then send an e-mail to errata@arm.com. Give:

• The title Arm Keil Studio Cloud User Guide.

• The number 102497_1.5_03_en.

• If applicable, the page number(s) to which your comments refer.

• A concise explanation of your comments.

Arm also welcomes general suggestions for additions and improvements.

Arm tests the PDF only in Adobe Acrobat and Acrobat Reader, and cannot
guarantee the quality of the represented document when used with any other PDF
reader.
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1.3 Other information
See the Arm website for other relevant information.

• Arm® Developer.

• Arm® Documentation.

• Technical Support

• Arm® Glossary.
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2 Arm Keil Studio
Arm Keil Studio is a free to use, browser-based IDE for the evaluation and development of
embedded, IoT, and Machine Learning software for Cortex-M devices. With a cloud-hosted
workspace for your code, comprehensive source control integration, and a powerful C/C++ editor,
you can edit your projects from any computer, share them with colleagues and export them for
desktop usage in Keil µVision. You can compile projects using Arm Compiler 6, flash the projects
directly to supported development boards, and debug from supported browsers without the need
to install any software.

Our goal is to make it quicker and easier for you to evaluate reference designs, reducing the time it
takes to get your embedded projects to market, while also providing a point of integration for Arm
ecosystem partners who provide professional software, tools, and services.

Arm Keil Studio demonstrates next generation IDE technology and new concepts for CMSIS
project formats. We support a range of software examples, showcasing Keil RTX, FreeRTOS, and
IoT connectors for Amazon AWS IoT, Microsoft Azure IoT Hub, and Google Cloud. Keil Studio is
also the successor to the Mbed Online Compiler, and allows you to develop Mbed OS 5 and 6
projects on supported Mbed Enabled boards. To get started, you can import Mbed projects from
your Online Compiler workspace or mbed.com.

You can access Keil Studio today using an Arm or Mbed account and get started by opening a
reference design to evaluate.

To find out which development boards are supported, check the Supported hardware page.

Keil Studio is a new software tool under constant development, and we regularly
publish bug fixes and feature updates. To use flash and debug capabilities, you must
use Google Chrome or Microsoft Edge (Chromium).
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3 Prerequisites
This section presents the system and account requirements you need to access Keil Studio.

3.1 System requirements
To work with development boards over USB, you must use Keil Studio in a desktop browser that
supports the WebUSB standard: Google Chrome or Microsoft Edge (Chromium). All other features
are supported in the latest versions of the following desktop browsers: Google Chrome, Microsoft
Edge, Opera, Safari, and Mozilla Firefox.

Keil Studio supports Mbed OS 5.12 and newer, and Mbed OS 6 and newer. Keil Studio also
provides limited support for Mbed OS 2 (you can build your Mbed OS 2 projects but not modify
their libraries).

If you are moving a project from Mbed OS 5 to Mbed OS 6, note the deprecated
APIs.

3.2 Access Keil Studio
You need an Arm account to work with Keil Studio. If you already have an Mbed account, you can
use it to access Keil Studio.

You can create an Arm account from the Keil Studio page at: studio.keil.arm.com.

Copyright © 2021 Arm Limited (or its affiliates). All rights reserved.
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4 Tutorials
In this section, you will find tutorials to help you learn how to use Keil Studio.

4.1 Get started with a CMSIS Blinky example
This tutorial explains how to start a project using a CMSIS example. Blinky is a simple application
that blinks the LED on your development board. Learn how to import a project, and then build and
flash Blinky to your board.

Before you begin
1. Go to keil.arm.com.

2. Scroll down to see the list of supported hardware and click the Get Started button for your
development board.

If you do not already have an Arm account, create one and log into Keil Studio with
it. Alternatively, you can use your Mbed account.

Once the support page of your development board opens, you can select an example project that
you can either download or import directly into Keil Studio. In this topic, the example is based on
the NXP FRDM-K32L3A6, but can be applied to any of the supported development boards.

Procedure
1. Select an example project and click Create project.
2. Log into Keil Studio if you are not already logged in.

Copyright © 2021 Arm Limited (or its affiliates). All rights reserved.
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3. Keil Studio opens. Confirm the project name in the Import project dialog box. Keil Studio sets
the newly-imported project as the active project by default.

Figure 4-1: Import project
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4. Click Add Project.
The project loads to your workspace and is the active project. The README.md file of the
project displays. Review the file to learn more about project settings and board requirements.

Figure 4-2: Open project showing README.md
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5. Inspect the software components that are used in the project and access their documentation:

Figure 4-3: Manage components
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6. The Target hardware is automatically set to the build target of the project:

Figure 4-4: Target hardware

A build target tells Keil Studio how to build the project so that it matches your hardware. To

build the project, click the Build project button, . Build project builds Blinky and
stops.

7. Connect your board to your computer. The first time you connect your board, you have to
click the Find target button to the right of the Target hardware drop-down list. After the first
successful connection, Keil Studio detects the board and suggests a matching target:

Figure 4-5: Target connected

The green USB icon to the left of the target hardware name shows that the target is connected.

The serial number also displays in the tooltip. Now, the Run project  button is enabled.
Click the Run project button to build Blinky and flash it to your board.
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4.2 Debug a CMSIS Blinky example
This tutorial explains how to debug a project using the CMSIS Blinky example available for the NXP
FRDM-K32L3A6 board. Learn how to start a debug session, set breakpoints, step through your
code, inspect variables, and examine threads and call stacks.

Before you begin
1. Check that you have imported the Blinky_FRDM-K32L3A6_RTX example and set it as the

active project (right-click the project and select Set Active Project).

2. Connect your board to your computer. The first time you connect your board, you have to
click the Find target button to the right of the Target hardware drop-down list. After the first
successful connection, Keil Studio detects the board and suggests a matching target.

3. Check that the correct build target is set in the Target hardware drop-down list.

Procedure
1.

Click the Debug project  button to start a debug session.
Keil Studio automatically builds and flashes the project to your board. The debug session starts:
Keil Studio switches to the Debug view and the status bar turns orange. The Debug Console
view displays and shows debugging output. The execution stops at main().

Figure 4-6: Start a debug session

2. While the debug session is still running: go to the Explorer view, open the Blinky_FRDM-
K32L3A6_RTX project folder, and look for the Blinky.c file.

Copyright © 2021 Arm Limited (or its affiliates). All rights reserved.
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3. Open that file and in the thrLED: blink LED block of code, set a breakpoint on the if
(active_flag == 1U) { statement by clicking the left margin.
A red dot displays where you set the breakpoint.

4. Return to the Debug view. You can see that your breakpoint has been added to the Breakpoints
list on the left of the Debug view.

5.

Click the Continue button  to start debugging.
The debugger runs to the breakpoint you set and stops. A yellow arrow displays next to the
statement on which the debugger paused. The statement highlights in yellow.

Figure 4-7: Set a breakpoint

6. Go to the Variables list and check the local variables which are grouped under Local.
The active_flag variable for thrLED is set at 0.

7. Locate, but do not press, the SW2 button on your board. See the FRDM-K32L3A6 guide to
find the SW2 button. Prepare to press the SW2 button then:

a.

Click the Continue button .

b. Press the SW2 button on your board before the debugger hits the breakpoint set earlier.

Copyright © 2021 Arm Limited (or its affiliates). All rights reserved.
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8. Check the active_flag variable again.
The active_flag variable is now set at 1.

Figure 4-8: Check variables

9.

Click the Step Over button  three times to go straight to osDelay(100U);.
10.

Click the Step Into button  to check this function.
This opens the rtx_delay.c file where the function is called.

11. You can now examine what happens in the Threads and Call Stack lists.
In the current version of Keil Studio, there is only one thread (Main). The call stack shows the
execution flow of your code. In this example, you can see that osDelay; is called by thrLED
in the Blinky.c file and osStatus_t in the rtx_delay.c file.

12.

Click the Step Into button  again several times to check the execution flow.

Copyright © 2021 Arm Limited (or its affiliates). All rights reserved.
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13.

Click the Stop button  to stop the debugger and return to the editor.

Figure 4-9: Examine the call stack

4.3 Get started with an Mbed OS Blinky example
This tutorial explains how to start a project using an Mbed OS example. Blinky is a simple
application that blinks the LED on your development board. Learn how to create a new project, and
then build and flash Blinky to your board.

Before you begin
Go to studio.keil.arm.com and log into Keil Studio using your Arm or Mbed account.

Procedure
1. Create a new project, select File > New Project….

The New project dialog box opens.
2. Click the Example project drop-down list and go to the Mbed list. Select mbed-os-example-

blinky under MBED OS 6.
3. Confirm the project name. Keil Studio sets the newly-created project as the active project by

default.
4. Click Add Project.

The project loads to your workspace and is the active project. The README.md file of the
project displays. Review the file to learn more about project settings and board requirements.

Copyright © 2021 Arm Limited (or its affiliates). All rights reserved.
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5. The Target hardware drop-down list shows the build target set for the project. A build target
tells Keil Studio how to build Mbed OS so that it matches your hardware. To select a build
target, you can either:

• Use the Target hardware drop-down list. Your target hardware name most likely matches
the board name.

• Connect your board to your computer. The first time you connect your board, you have to
click the Find target button to the right of the Target hardware drop-down list. After the
first successful connection, Keil Studio detects the board and suggests a matching target.

6.

To build the project, click the Build project button, . Build project builds Blinky and
stops.

7.

If you have a board connected, click Run project . Run project builds Blinky and flashes it
to your board.
You might have to restart your board for Blinky to run.

Copyright © 2021 Arm Limited (or its affiliates). All rights reserved.
Non-Confidential

Page 23 of 101



Arm Keil Studio Cloud User Guide Document ID: 102497_1.5_03_en
1.5

Create or import a project

5 Create or import a project
This section describes how to create CMSIS or Mbed projects, or import an existing Mbed project,
in Keil Studio.

Arm recommends that you create CMSIS projects from the example projects provided. The
examples use predefined .cprj templates. For more information on CMSIS-Build and the CMSIS
Project description format (.cprj), see the Build section of the CMSIS documentation.

You can create a new project as a CMSIS or Mbed OS example project. For Mbed OS, you can also
create new projects as an:

• Empty Mbed project with the latest supported version of Mbed OS.

• Empty folder with a manually selected version of Mbed OS.

You can import existing Mbed projects from:

• Your local file system. See Import an Mbed OS example from your file system.

• (As a URL) os.mbed.com/code or a Git hosting service (GitHub).

• Your Mbed Online Compiler workspace.

If you do not already have an Arm account, create one and log into Keil Studio with
it. Alternatively, you can use your Mbed account.

5.1 Your Keil Studio workspace
Keil Studio provides you with a cloud-hosted workspace for your code. Your workspace is the
location that contains all your CMSIS and Mbed projects.
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5.2 Create a CMSIS or Mbed example project or an empty
Mbed project

You can create a CMSIS project from an example, or create an Mbed project from an example or an
empty project (either for Mbed OS 5 or Mbed OS 6).

Procedure
1. Create a new project, either:

• In the Explorer view, click the Active project dropdown then click the New project button

.

• Select File > New Project….

The New project dialog box opens.
2. Click the Example project drop-down list and select an example from the CMSIS or the Mbed

list. Each example has a readme.md file that explains the details of that example.
To create an Mbed project with no content (other than Mbed OS), go to the Mbed list and
select empty Mbed OS project under Mbed OS 6 or Mbed OS 5.

3. In the Project name field, edit the name of the new project or keep the name provided by
default.
Keil Studio sets the newly created project as the active project by default. Build and run
commands only apply to the active project. Clear the checkbox if you do not want to make the
new project active.

4. Click Add Project. Keil Studio creates the project in your workspace.

5.3 Create a blank Mbed project
You can create a blank project that has no Mbed OS and no standard files, such as main.cpp. You
must manually add a version of Mbed OS to a blank project.

Procedure
1. To create an empty folder that is not associated with an existing project, right-click an empty

area in the file list and select New folder.
An empty folder is created.
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2. You must add a copy of Mbed OS to make your folder a project.

a. Right-click the folder name and select Add Mbed Library….

b. In the Git or os.mbed.com URL field, enter git@github.com:ARMmbed/mbed-os.git
and click Next.

c. From the drop-down list, select the branch or tag of Mbed OS you want to use. You can use
any supported version, including patch versions.

Note that release tags are listed on the Mbed OS releases page.

d. Click Finish. The selected branch or tag is added to the folder, and you can now use it as a
project.

5.4 Import an Mbed project
There are some important points to consider when you import an Mbed project, for example,
whether the project has all the required libraries and default configuration files. This topic describes
how to import an Mbed project, and what to consider when you import.

Notes about importing Mbed projects:

• If you import an Mbed project that has an unsupported version of Mbed OS, or that has no
mbed-os library in it, to use the project in Keil Studio you must add a supported version of the
mbed-os library.

• Imported Mbed projects have an .mbed file storing their settings, such as a default build target
and toolchain. The settings of a file can override the UI. A build target set in .mbed overrides
the build target (target hardware) selection in the UI.

Import an Mbed project from a URL

You can import from public repositories without setting up your Git credentials.
If you want to import from a private repository on Git, set up Git credentials.
Mercurial uses your Arm account (or Mbed account) credentials, so you have access
to the same Mercurial repositories you do on os.mbed.com.

To import a project from a URL:

1. Open the File menu and select Import Project….
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2. Paste the full HTTPS or SSH URL of the relevant web page and (optionally) edit the project
name.

The relevant web page can be a page listed on os.mbed.com/code or from another Git hosting
service.

Keil Studio sets the newly imported project as the active project by default. Build and run
commands only apply to the active project. Clear the checkbox if you do not want to make the
new project active.

Note: If your project does not have the mbed-os library, Keil Studio cannot set it as active or
use it. Add a supported version of the library.

3. Click Add Project. Keil Studio imports the project with the version of Mbed OS it was originally
created with.

When you import a project from os.mbed.com or a Git hosting service, Keil Studio
clones the repository. You can push changes back to the remote repository from Keil
Studio. For more information, see Source control.

Import an Mbed OS example from your file system
You might already have Mbed projects on your file system. For example, you might have
downloaded an Mbed project from os.mbed.com/code or another online location.

To import a project from your file system, drag and drop your project folder to the Explorer view.

Import an Mbed project from the Mbed Online Compiler
To import a project from the Mbed Online Compiler:

1. From the Mbed Online Compiler, export your project:

• Export Target: Your export contains only the part of Mbed OS that the selected target
needs. To be able to work with other targets in Keil Studio, you must repopulate the mbed-
os library with the missing file. See step 3.

• Export Toolchain: Select Zip Archive (with repositories). Specify the export target.

The project exports as a ZIP file.

2. Unzip the file and add it to Keil Studio. You can:

• Copy and paste the unzipped folder to your current workspace folder.

• Change your Keil Studio workspace to the unzipped folder.
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3. Update the mbed-os library to:

• Remove existing libraries and automatically download the latest versions, using the
information contained in the {library_name}.lib file or files included in your project.

• Repopulate the mbed-os library with the files for all supported targets.

To update the library:

a. Make your project active: right-click the project and select Set Active Project.

b. Open the Mbed Libraries view: select View > Mbed Libraries.

c.

Click the Fix all problems button .

Keil Studio downloads a clean copy of Mbed OS, with all libraries, for the same version the
project was already using. If that version of Mbed OS is not supported in Keil Studio, you
must change to a supported version.

5.5 Further resources about creating and importing
projects

You are now ready to work on your project. You can learn more about CMSIS and find out more
about Mbed OS APIs and programming on the Mbed OS documentation site.

When you are ready, build and run your project.
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6 Build and run a project
Describes how to build and run a project with Keil Studio.

6.1 Select a build target
Describes how to select a build target (or target hardware) for your project in Keil Studio. A build
target tells Keil Studio how to build the RTOS so that it matches your hardware.

Procedure
• To select a build target, either:

◦ Connect your board to your computer. The first time you connect your board, you have to
click the Find target button to the right of the Target hardware drop-down list. After the
first successful connection, Keil Studio detects the board and suggests a matching target
hardware.

◦ Use the Target hardware drop-down list. Your target hardware name most likely matches
the board name.

If you have an unsupported board, see the Custom targets page.

6.2 Build and flash a project to the board
Describes how to build and flash a project.

Procedure
1. Ensure the project you want to build and flash is set to active.

To make the project active, right-click the project name in the Explorer view and select Set
Active Project.

2. Select one of these options:

• Build project: Build the project, without flashing it to the board.

◦

Build project (hammer) : Checks the BUILD subdirectory (where the
previous build is stored) and optimizes build time by using as much as it can from the
last build. For example, if two consecutive builds are for the same target hardware, the
build rebuilds only the files that actively changed between the two builds, or from the
point at which you stopped the previous build attempt.

◦ Clean build (click the drop-down next to the hammer): Ignore all previous builds. A clean
build is slower than reusing a previous build, but guarantees that your build has no old
artifacts.
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•

Run project : Build the project and flash it to the board.

Note that there is only one default build profile.

6.3 Output view
The output of a build displays in the Output view. This topic describes how you can copy, search
the contents of the Output view, look for errors and warnings, and clear the Output view.

To open the Output view, select View > Output.

To turn auto scrolling on, click the Turn Auto Scrolling On  icon. To turn auto scrolling off,
click the Turn Auto Scrolling Off icon. When the auto scrolling is off, you can read the output or
copy content from the output while the build is running and new output content is logged.

To copy the output, right-click in the Output view and select Copy or Copy All:

• Copy: Copies the line where your cursor is.

• Copy All: Copies the whole output.

To search the content of the output, right-click in the Output view and select Find. When the
Output view is in focus, you can also go to the Edit menu and select Find.

Errors display in red and warnings display in yellow. If a link is available, use Cmd + mouse click to
follow the error or warning to the relevant part of the code:

Figure 6-1: The error text is a link to the relevant line of code

To clear the build output, click the Clear Output icon  or right-click and select Clear Output.
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6.4 Configuring compile-time customizations
Describes how to configure compile-time customizations in Keil studio.

For Mbed projects only: The Arm Mbed OS configuration system, a part of the Arm Mbed OS
build tools that underpin Keil Studio, customizes compile-time configuration parameters. Each
library might define various configuration parameters in its mbed_lib.json. The project-level
mbed_app.json might override the values of these configuration parameters. At compile-time,
the configuration system gathers and interprets the configurations defined in all mbed_lib.json
files and the mbed_app.json file, and creates a single header file, mbed_config.h. In
mbed_config.h, the defined configuration parameters are converted into C preprocessor macros.

Some examples of configuration parameters:

• The sampling period for a data acquisition application.

• The default stack size for a newly created OS thread.

• The receive buffer size of a serial communication library.

• The flash and RAM memory size of an Mbed target.

• Bare metal profile and small C-library use.

To use the configuration system, see the Mbed OS documentation about the configuration system.
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7 Search
Keil Studio can search the content of files, quickly find a specific file, or find and execute
commands. This section describes searching in Keil Studio in more detail.

7.1 Search the content of files
You can search the content of multiple files for the active project or for a specific folder. You can
also search the content of a single file. Keil Studio searches through both saved and unsaved
changes.

7.1.1 Search the content of multiple files

Describes how to search for a term or a regular expression across all files in an active project.

Procedure
1. Click the Search icon or go to the Edit menu and select Find in Files. You can also press Ctrl

+Shift+F (Windows) or Cmd+Shift+F (macOS).
The Search view opens. Enter text in the search box.

2. To search inside a single folder, go to the Explorer view, right-click the folder, and select Find in
Folder.
The lower part of the view displays the search results, sorted under the files in which they
appear.

3. To view only the list of files in which the text you searched for appears, click the Collapse All

icon .
Note: If the Search view is hiding the Explorer view, you can click the Keil Studio icon or press
Ctrl+Shift+E (Windows) or Cmd+Shift+E (macOS) to return to it.

Example 7-1: Search examples

• Including or excluding files, folders and path segments in your search:

To specify which files to include or exclude in your search:

1.
Click the ellipsis (Toggle Search Details) .

2. In the files to include and files to exclude search boxes, enter file names, separated by
commas, to include or exclude in your search.

For example, if you enter resources, sources in the files to exclude search box, the
search excludes all files and folders named resources or sources.
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• Find and replace:

To replace the searched-for text with new text, click Toggle Replace , and enter your new
text.

Click Replace All  to replace all instances of the text in all files.

To replace all instances of the text in a specific file, hover the cursor over the file name in the
search results, and click the Replace All button that appears near the file name.

7.1.2 Search the content of a specific file

Describes how to search for a term or a regular expression in a specific file.

Procedure
1. Go to the Edit menu and select Find. You can also press Ctrl+F (Windows) or Cmd+F (macOS).

A search box opens at the top of the file tab. Enter text in the search box.
2. To do a search on one part of the file only, enter text in the search box, then select the lines

you want to check and click the Find in selection button .

Example 7-2: Find and replace

To replace the searched-for text with new text, click the Toggle Replace mode arrow and enter your
new text. The replace mode is also available from the Edit menu > Replace option.

To replace a single instance or all instances of the text in the file, click the Replace or Replace All
buttons .

7.1.3 Include or exclude search patterns

You can include or exclude search patterns in files, folders, and path segments using glob syntax
(wildcards). You can also search using regular expressions.

Wildcard Description

* Matches zero or more characters. For example, *.html matches all HTML files.

** Matches zero or more path segments. For example, tools** matches tools/python and tools/python/Scripts.

? Matches any single character. For example, 3.? matches 3.4.

[] Matches one character in the bracket. For example, 3.[0-9] matches 3.1 and 3.2.

{} Matches any of the conditions in the bracket. For example,{*.html,*.json} matches all HTML and JSON files.
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Regular expression example: With LED\d you can find all instances of the string LED followed by a
one number character, for example LED1 and LED2.

7.2 Find and navigate to a file
Describes how to quickly search for and open a file by name.

Procedure
• Press Ctrl+P (Windows) or Cmd+P (macOS). Recently opened files appear first automatically,

then file results are based on the string you enter in the search bar.

7.3 Find and execute a command
Describes how to quickly search for and execute any command in Keil Studio.

Procedure
• Select Find Command… from the View menu or press Ctrl+Shift+P (Windows) or Cmd+Shift+P

(macOS). Recently-used commands appear when you open the quick command search. Search
results appear when you begin to enter a string in the search bar.
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8 IntelliSense
In this section, you will learn how to quickly navigate your code, how to use the IntelliSense code
editing features to update and improve your code, and how to enable and use linting.

8.1 Code editing
Keil Studio provides C and C++ language support using the clangd language server and the
Language Server Protocol (LSP). Keil Studio includes various navigation features and IntelliSense
code editing features to help you code faster and more efficiently.

The IntelliSense code editing features are available for standalone files or for multiple files, for all
your projects.

You must set a build target (target hardware) to get all IntelliSense features.

8.1.1 Navigate your code

This section describes how to quickly navigate your code, and how to use the highlighting, in-tool
pop up information, and focused-searching functionality in Keil Studio.

8.1.1.1 Quick file navigation

Describes how to quickly navigate your files using keyboard shortcuts in Keil Studio.

Procedure
• To follow a link included in your code or find a file where a code element has been defined,

hold Cmd (macOS) or Ctrl (Windows and Linux) and click the link or the code element. The file
opens in a new tab and is directly accessible from the Explorer view.

8.1.1.2 Bracket and quote highlighting

By default, the editor highlights the matching brackets or quotes when your cursor is over them.
When you type the left bracket or quote, the editor automatically inserts the matching right
bracket or quote.
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8.1.1.3 Source hover

Additional information about the code elements you are hovering over in your code displays in a
popup.

Figure 8-1: Additional information available when you hover over the code
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8.1.1.4 Go to Declaration and Peek Declaration

To navigate to a declaration, use the Go to Declaration and Peek Declaration options.

Procedure
• Hover over a code element, right-click, and select one of these options:

◦ Go to Declaration: Opens the header file where the declaration is defined in a separate tab.

◦ Peek > Peek Declaration: Takes you to the declaration but the declaration is presented
inline.

Figure 8-2: Declaration presented inline with the Peek Declaration option
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8.1.1.5 Go to Definition and Peek Definition

You can navigate to the definition of a code element with the Go to Definition and Peek Definition
options.

Procedure
• Hover over a code element, right-click, and select one of these options:

◦ Go to Definition: Opens the file where the element is defined in a separate tab.

◦ Peek > Peek Definition: Takes you to the definition of an element but the definition is
presented inline.

Figure 8-3: Definition presented inline with the Peek Definition option

8.1.1.6 Go to References and Peek References

You can find the references to a code element throughout all the files of an active project with the
Go to References and Peek References options.

About this task
The Go to References and Peek References options show the code element references inline (or,
if there is only one reference, the Go to References option takes you directly to the element). To
navigate between references and make edits in the inline editor follow the steps in the Procedure.
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Procedure
1. Double-click a reference to open the file or files where the code element appears.
2. Hover over the code element, right-click, and select one of the options.

Results
Figure 8-4: You can edit directly in the inline editor

8.1.1.7 Go to Symbol

Describes how to use the Go to Symbol… option in Keil Studio to perform a symbol-focused search
of your code.

Procedure
1. Right-click anywhere in the editor and select Go to Symbol….

The search bar displays the available symbols in the file you are currently working on.
2. Select a symbol to go to that symbol.
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Results
Figure 8-5: Go to Symbol… option

8.1.1.8 Open the Outline view

The Outline view gives you a tree view of the classes, variables, and functions in the current file.

Procedure
1.

From the View menu, select Outline or click the Outline button  at the top-right corner
of the screen.

2. To navigate through the file, click the elements in the Outline view.

Results
In the Outline view, orange icons represent classes, white icons represent variables, and purple
icons represent functions.
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Figure 8-6: Intellisense outline view

8.1.2 Editing and refactoring your code

Describes the auto-completion, renaming, format-correcting, and refactoring functionality that is
available in Keil Studio, to help you edit your code.

8.1.2.1 Auto-completion and signature help

When you start typing a keyword, type, function, variable name, or other project element that
Keil Studio recognizes, the editor offers to complete what you are typing. A drop-down list with
possible options opens where you can select what you need. The list also shows an icon that
represents the code entity of each option (for example namespace, function, class or variable), and
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signature help for parameters of functions. Clicking the “i” icon gives you more details on each
option.

Procedure
• You can trigger auto-complete and help for existing code by pressing Ctrl+Space.

Figure 8-7: Auto-completion and i icon
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8.1.2.2 Rename an element

If you want to rename an element in your code such as a class, a function, or a variable, use the
Rename symbol option. This option renames all the occurrences of a symbol in the file you are
currently working on.

Procedure
• To find and replace a string everywhere in the file you are currently working on, use the Change

All Occurrences option.

Figure 8-8: Renaming a symbol

8.1.2.3 Code formatting

This topic describes how to change the indentation to format you code correctly.

About this task
The Format Document and Format Selection options allow you to indent your code correctly.

If you select:

• Format Document: the indentation corrects in the whole file you are currently working on.

• Format Selection: only the line, or lines, of code you selected indent correctly.
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Figure 8-9: Changing the indentation with Format Selection

Procedure
1. To change the indentation, click the Spaces or Tab Size option on the right-hand side of the

status bar.
A drop-down list opens at the top of the editor.

2. Select Indent Using Spaces or Indent Using Tabs in the drop-down list, then select the number
of spaces and tabs to use for the indentation.
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8.1.2.4 Fix-its, Peek Problem, and Quick Fix

Fix-its offer suggestions to correct problems in your code, for example a missing bracket or
semicolon.

Procedure
• Either:

◦ Click an element underlined with a squiggly line to display corrections.

A lightbulb icon appears next to the problematic line. Click the lightbulb and check the
correction suggested. If you are happy with the suggestion, click the popup message.

Figure 8-10: Fix-it example

◦ Use the Peek Problem and Quick Fix… options to correct your code. Hover over a red
squiggly line in your code to display these options. Peek Problem shows the errors inline.
Quick Fix… operates the same way as fix-its, click the popup message to apply a correction.

Figure 8-11: Peek problem example
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8.1.2.5 Problems view

Keil Studio lists detected problems in your code in the Problems view.

Procedure
1. To open the view, go the View menu and select Problems, or click the Problems option in the

status bar.
2.

To collapse the list of problems in the Problems view, click the Collapse All icon .

You can also close the error messages one by one or click the Clear All icon  to clear all
the messages at once.

8.1.2.6 Refactoring

Keil Studio supports refactoring operations such as extract function and extract variable.

About this task
You can either use the steps described below, or alternatively, you can click the lightbulb next to
the code you want to refactor.

Procedure
1. Select the source code you want to extract, right-click the code, and select Refactor….:

• If you are extracting a function, an Extract to function popup message appears. Source code
fragments can be extracted into a new function.

• If you are extracting variable, an Extract subexpression to variable popup message appears.
You can create a new local variable for the currently selected expression.

2. To refactor the code, click the popup message for your function or variable extraction.
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Example 8-1: Extract a function or variable

• Extract a function:

Figure 8-12: Extract to function refactoring example

• Extract a variable:

Figure 8-13: Extract to variable refactoring example
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8.2 Code linting
Linting is the automated checking of your source code for programmatic and stylistic errors. Linting
intends to improve the overall quality of your code and make code reviews and tests more efficient.

Keil Studio uses clang-tidy, a clang-based C/C++ linter tool. Clang-tidy is an extensible framework
for diagnosing typical programming errors, or style issues (generally anything which can be
detected during static analysis of the code). Clang-tidy checks your code as you type and uses
squiggly lines to highlight problems and lightbulbs to suggest fixes in the editor. The clang-tidy
linter checks complement existing IntelliSense capabilities that were already available with Keil
Studio and brought by clangd.

8.2.1 Enable clang-tidy

Clang-tidy is not enabled by default. This topic describes how to enable clang-tidy for the active
project.

About this task
To enable clang-tidy, create a .clang-tidy file in the root folder of the active project.

Procedure
1. From the Explorer view, right-click on the active project and select New File.
2. In the New File dialog box, type .clang-tidy and click OK.

Keil Studio creates a .clang-tidy file in your project folder.
3. To enable all the default clang-tidy checks in the .clang-tidy file, type Checks: '*'.

8.2.2 Configure clang-tidy checks

For each of your projects, you can configure the checks that clang-tidy should carry out using a
.clang-tidy file. You can decide which clang-tidy checks you want to enable or disable and
configure advanced custom checks.

8.2.2.1 Enable or disable checks

If you must enable or disable particular checks, use the clang-tidy command-line format in your
.clang-tidy files. The command-line format specifies a comma-separated list of positive and
negative globs: positive globs add subsets of checks, and negative globs (prefixed with -) remove
subsets of checks.

For example, to enable modernize- checks that advocate usage of modern (currently “modern”
means “C++11”) language constructs, use:

Checks: 'modernize-*'
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See the Clang-Tidy Checks page for a complete list of available checks. A “Yes” in the Offers fixes
column indicates that the check is supported. For more general information, see the Clang-Tidy
page.

8.2.2.2 Configure advanced custom checks

Shows an example of how to configure advanced custom checks.

In the following example, we enable all checks and provide the additional option to modernize-
use-nullptr:

Checks: '*'
CheckOptions:
- key:             modernize-use-nullptr.NullMacros
  value:           NULL,CUSTOM_NULL

For more information, see the official YAML website.
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9 Manage files
Describes how to compare, upload, download, and move files in Keil Studio.

9.1 Compare files
Keil Studio supports a side-by-side view of files, both for comparing local and remote versions in
source control and comparing two local files. You can compare any two files in your workspace,
even if they are not in the same project.

Procedure
1. Right-click a file and select Select for Compare.
2. Right-click a second file and select Compare with Selected.

Keil Studio displays both files in a single tab, with highlighted differences.

Related information
Compare local and remote versions in Git source control on page 60
Compare local and remote versions in Mercurial source control on page 70

9.2 Upload and download files or projects
Describes how to upload or download a file or project in Keil Studio.

Procedure
• Either:

◦ Upload: You can use the File > Upload Files… option to upload files to the root directory of
the project selected in the list of projects available. You can also drag and drop files to add
them to your project.

◦ Download: You can download a project or any file in a project with the File > Download
Current Selection option. You can also download the active project with the File >
Download Active Project option.
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9.3 Change file locations
Keil Studio puts new files and folders in the root directory. If you move these files to other folders
in your project structure, Keil Studio detects the location change and builds your project with the
correct file paths.

Procedure
1. To create a folder, either:

• Right-click the project and select New Folder.

• Go to File > New Folder.
2. If necessary, you can drag and drop files to move files around.

Warning: For Mbed projects only - You cannot move the mbed-os library; the mbed-os library
must remain in the root folder.

9.4 Copy the path of a file or folder
You can copy the full or the relative path of a file or folder to the clipboard.

To copy the full path, right-click a file or folder in the Explorer view and select Copy Path.

To copy the relative path, right-click a file or folder and select Copy Relative Path.
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10 Managing a project
This chapter describes how to manage CMSIS projects and their components, and how to manage
Mbed projects and their libraries.

10.1 Manage a CMSIS project and its components
The Manage components view in Keil Studio allows you to see which software components are
included in a project. In the current version of Keil Studio, the Manage components view is read-
only.

In a future version, you will be able to select the software components to include in your project
and manage the dependencies between components. It will be possible to build a project using
different combinations of pack and component versions, and different versions of a toolchain.

The Project outline is accessible from the Explorer view and gives you an overview of what is
included in your project. The Project outline is read-only. In a future version, you will be able to
easily manage your project files from the Project outline.

10.1.1 Open the Manage components view

The Manage components view shows all the software components in the active CMSIS project.
This topic describes how to open the Manage components view.

Procedure
1. Set the project you want to work on as the active project.
2.

Click the Manage components icon  from the Explorer.

Results
The Manage components view opens.

The Show selected only toggle button is on by default. Only the components included in the active
project display. If you switch off the toggle, you can see all the components that will be available
for use in a future version of Keil Studio.
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Figure 10-1: The 'Manage components' view showing the components included in the active
project

The CMSIS-Pack specification states that each software component should have the following
attributes:

• Component class (Cclass): A top-level component name. For example: CMSIS. For a full list of
component classes, see Software Component Cclasses.

• Component group (Cgroup): A component group name. For example: CORE for the CMSIS
component class.

• Component version (Cversion): The version number of the software component.

Optionally, a software component might have these additional attributes:
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• Component subgroup (Csub): A component subgroup that is used when multiple compatible
implementations of a component are available. For example: RTOS2 (API) > Keil RTX5 for the
CMSIS component class.

• Component variant (Cvariant): A variant of the software component is typically used when the
same implementation has multiple top-level configurations, like Source for RTOS2 > Keil RTX5.

• Component vendor (Cvendor): The supplier of the software component. For example: Keil.

• Bundle (Cbundle): Allows you to combine multiple software components into a software
bundle. Bundles have a different set of components available. All the components in a bundle
are compatible with each other but not with the components of another bundle. For example:
ARM Compiler for the Compiler component class.

The last column in the Manage components view shows how many instances of the component
are deployed in the project. If the component has a selected checkbox, one instance is deployed. If
the checkbox is not selected, it is not deployed in the project. If a number input displays, multiple
instances of this component can be deployed to a project. In a future version of Keil Studio, you
will be able to change the number of instances deployed for your project.

Figure 10-2: Documentation links in the 'Manage components' view

Documentation links are available for most component groups and subgroups when you click their
names.

With the Search field, you can do a search on the component groups and subgroups.

10.2 Manage an Mbed project and its libraries
Describes how to manage Mbed projects and libraries.

When you import a project to Keil Studio from os.mbed.com, a Git hosting service, or one of the
built-in example projects, you also import the libraries on which it is dependent, including Mbed
OS which is delivered as mbed-os. You can import more libraries to your project to use their
functionality.
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• When you create an example Mbed project, including an empty example, Keil Studio adds the
version of Mbed OS that Keil Studio is shipped with .

• When you import an existing project, Keil Studio adds the version of Mbed OS stated in the
mbed-os.lib file of the imported project.

Note that the Mbed OS bare metal profile is not a separate library; the Mbed OS bare metal profile
is the full Mbed OS library, which is stripped down at build time. For more information, see the
Mbed OS bare metal profile page.

Your project might require extra libraries, for example libraries that support hardware you have
added to your development board. If you import a project that already uses these libraries, the
libraries are imported with your project. If you must add extra libraries, see Import an Mbed library.

10.2.1 Open the Mbed Libraries view

The Mbed Libraries view lists all the libraries in an active project (indicated with the cogwheel icon
on the file list). From the Mbed Libraries view, you can see library details, such as the library version
and where it was imported from. You can also import, remove, update a library, or check out a
specific library version.

Procedure
1. Right-click the project name in the Explorer view and select Set Active Project.
2. Select Mbed Libraries from the View menu.

The Mbed Libraries view opens in the bottom panel. When a library depends on another
library, the Mbed Libraries view presents the dependency indented under the dependent
library.

10.2.2 Import an Mbed library

Describes how to import Mbed libraries to an existing project.

Before you begin
The project that you want to add a new Mbed library to must be set to the active project. To make
the project active, right-click the project name in the Explorer view and select Set Active Project.

About this task
You can import Mbed libraries to an existing project from os.mbed.com or from a Git hosting
service. Each library that you add to a project can be identified by a .lib file.

The Keil Studio Explorer view hides .lib files.
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Procedure
1. Either:

• Open the Mbed Libraries view, select View > Mbed libraries. In the Mbed Libraries view,

click the Add new library button .

• In the Explorer view, right-click the project in which you want to add your new Mbed library
and select Add Mbed library….

A dialog pops up with the title 'Add Mbed library'.
2. Choose whether you want to import the library from os.mbed.com or from a Git hosting service

and paste the full remote URL.
3. Modify the library name as required, and click Next.
4. Specify the branch or tag you want to import.

Note: When a branch is checked out, the library checks out to the tip of the selected branch.
When a tag is checked out, the library is put in a detached head state.

5. Click Finish.
You can view the progress of the import on the Background Tasks progress indicator, which
appears at the bottom-right corner of the screen. When the import is complete, the library
appears in the Mbed Libraries view and in the Explorer view.

10.2.3 Remove an Mbed library

Describes how to remove an Mbed library from your active project in Keil Studio.

Before you begin
• Ensure that your project contains one or more Mbed libraries. To see how to import an Mbed

library, see Import an Mbed library.

• The project containing the Mbed library (or libraries) that you want to remove must be set to
the active project. To make the project active, right-click the project name in the Explorer view
and select Set Active Project.

Procedure
1.

Click the Remove library button , which appears on the right when you hover the mouse
pointer over the name of the library in the Mbed Libraries view.
The Remove library dialog box displays.

2. Click Remove.

10.2.4 Update and change Mbed libraries

Describes how to update and change Mbed libraries in Keil Studio.

When you import a library to Keil Studio from os.mbed.com or from a Git hosting service (either
manually, or as a dependency for an imported project), you clone the library to your workspace.

Copyright © 2021 Arm Limited (or its affiliates). All rights reserved.
Non-Confidential

Page 56 of 101

https://os.mbed.com/code
https://os.mbed.com/code


Arm Keil Studio Cloud User Guide Document ID: 102497_1.5_03_en
1.5

Managing a project

Libraries are associated with specific projects in your workspace. If you have multiple projects that
use a particular library, you have multiple copies of the same library; one per project. Each copy of
the library can be at a different commit, if you update a library for one project, it does not update
other copies of that library.

In Keil Studio, you can easily update all Mbed libraries at once, update a single library to the latest
version, or update a single library to a specific version (as described in the following topics).

10.2.4.1 Update all Mbed libraries

Describes how to update all of the top-level Mbed libraries in the active project.

Before you begin
• Ensure that your project already contains one or more Mbed libraries. To see how to import an

Mbed library, see Import an Mbed library.

• The project containing the Mbed libraries that you want to update must be set to the active
project. To make the project active, right-click the project name in the Explorer view and select
Set Active Project.

About this task
When there are updates to libraries in an active project, the Update all button at the top-right
corner of the Mbed Libraries view indicates the number of updates available. Click the Update all
button to view details about the available updates.

Procedure
1. Open the Mbed Libraries view, select View > Mbed libraries.
2.

At the top right corner of the Mbed Libraries view, click the Update all button .
The Update all libraries dialog box opens with details about all the libraries for which updates
are available.

3. Click Update all.
Note: Updating all top-level libraries does not automatically update all library dependencies.

10.2.4.2 Update an Mbed library to the latest version

Describes how to update an Mbed library to the latest version.

Before you begin
• Ensure that your project already contains one or more Mbed libraries. To see how to import an

Mbed library, see Import an Mbed library.

• The project containing the Mbed library that you want to update must be set to the active
project. To make the project active, right-click the project name in the Explorer view and select
Set Active Project.
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Procedure
1. Open the Mbed Libraries view (select View > Mbed Libraries).
2.

To the right of the name of the library, click the Update to latest button .

10.2.4.3 Update an Mbed library to a specific version

Describes how to update to an Mbed library to a specific version.

Before you begin
• Ensure that your project already contains one or more Mbed libraries. To see how to import an

Mbed library, see Import an Mbed library.

• The project containing the Mbed library that you want to update must be set to the active
project. To make the project active, right-click the project name in the Explorer view and select
Set Active Project.

Procedure
1. Either:

• Open the Mbed Libraries view, select View > Mbed Libraries. Next to the library name
is the Update to latest button and a chevron. Click the chevron, and select Change To
Version.

• In the Explorer view, right-click the Mbed OS library that you want to update, and select
Change To Version.

A dialog pops up with the title 'Update <selected-library> to version'.
2. In the dialog, click the drop down menu and select the version of the library to check out. The

list is divided into BRANCHES and TAGS.
Note: When a branch is checked out, the library checks out to the tip of the selected branch.
When a tag is checked out, the library is put in a detached head state.

3. Click Update Library.
The selected version of the library starts to check out. You can monitor the progress of the
checkout in the Mbed Libraries view.

When the checkout is complete the .lib file is updated.

10.2.5 Fix library problems

Describes how to fix library problems in Keil Studio.

About this task
When there are problems with any of the libraries in an active project, the Fix all problems button
at the top-right corner of the Mbed Libraries view indicates the number of fixes required. For
example, if you do not have the source of a library downloaded, or if you check out a new commit
of a project that refers to a library commit you do not have checked out.

Click the Fix all problems button to view details about the required fixes.
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You can fix all the libraries in the active project in one click, or you can fix each library individually.

Procedure
1.

Click the Fix all problems button  at the top-right corner of the Mbed Libraries view.
The Fix all problems dialog box opens with details about all the required fixes.

2. Click Fix all.
To fix a specific library, click the Fix problems button to the right of the library name in the
Mbed Libraries view.

10.2.6 Source-control library updates

.lib files describe the libraries in your project. To share library changes with collaborators, commit

.lib file changes to the source control repository of your project. Do not add the library directory
and its contents to your project repository.

The .lib file only identifies the commit that you are using; the file does not include
branch information. In Keil Studio, you can check out a library to the tip of a specific
branch, but this information is not included if you open your project repository in
another application, or if you push changes to a remote repository.
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11 Source control
Describes how to use Keil Studio with the Git and Mercurial source control technologies, and how
to use the History view to view your commit history.

11.1 Work with Git
Keil Studio supports the most common Git actions for your projects, including branching, stashing
and synching with the remote repository.

The flow of Keil Studio matches the Git flow with the “stage” step:

1. Set a remote repository.

2. Branch.

3. Edit files.

4. Stage changes.

5. Commit.

6. Push.

Before you begin, set your GitHub credentials.

11.1.1 Set credentials for GitHub

Working with Git-based hosting services requires authentication against those services.

You can connect to your Git hosting service directly from Keil Studio and link your Arm account and
your GitHub account from this page: os.mbed.com/account/connected/ . Click the Connect button
on the page to allow Keil Studio to access your GitHub account.

11.1.2 Interface and features reference

Source control in Keil Studio is handled in two views: The Source Control view, for handling the
current work, and the History view to see previous commits. They always show the active project.

The image highlights:
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1. The actions menu. Both:

•

Toggle to List View 

•

Toggle to Tree view 

buttons allow you to display your changes as a list or as a tree view. Note the … button for
more actions.

2. The buttons available on each file when you hover over a file name: Discard Changes, Open
File, Stage Changes (+), and Unstage Changes (-).

3. Five changed files and one staged file.

4. The last (head) commit.

Figure 11-1: The 'Source Control' view for Git.

Group Features Comments

Local
changes

Discard all changes Revert all changed files to their state as of the last time they were pushed (or their starting state if
they have never been pushed).
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Group Features Comments
Local
changes

Stage and Stage all
changes

Use the Stage option for files you want to add to your next commit. Staging files manually breaks
your work into logical units, each in its own commit, rather than having to commit all files together.

Local
changes

Unstage and Unstage
all changes

Return a staged file, or all staged files, to the CHANGES list.

Local
changes

Refresh >Update the list of local changes.

Commits Commit Put all staged files into a single record of local changes. The commit is the record you can push to the
remote repository.

Commits Add signed-off-by Tag your commit and add comments, a signature, the date, and your email. For some projects, this is
a requirement for all contributions submitted as pull requests.

Commits Commit (amend) Change your last commit (head commit) by amending the message and the content of the commit, or
only the content. This option combines your staged changes with the head commit.

Commits Amend (button) Change your last commit (head commit) by amending the message and the content of the commit, or
only the content. This option combines your staged changes with the head commit.

Branch
management

Branch Create a new local branch or checkout an existing branch. The default branch for a newly set
repository is Master.

Branch
management

Fetch Fetch changes from the remote, but do not merge them into the current local branch.

Branch
management

Merge Incorporate changes from another branch into the current branch. For example, add the latest
changes from the remote repository to your local copy.

Branch
management

Pull Apply the latest changes from the default remote repository to your local repository (fetch and
merge). We recommend pulling only with a clean working copy; if you have any uncommitted local
changes, use fetch and merge.

Branch
management

Pull from… Pull from a specific remote, rather than the current one.

Branch
management

Push Send new local commits to the remote.

Branch
management

Push to… Push to a specific remote, rather than the current one.

Stash Stash Set aside your changed files. This allows: a) Switching branches without committing local changes;
apply the stash when you are ready to go back to the branch. b) Applying work from one branch to
another; apply the stash in the new branch.

Stash Apply latest stash dd the latest stashed changes to the branch, without clearing the stash.

Stash Apply stash Add a specified stash to the branch, without clearing the stash.

Stash Drop stash Discard all changes in the stash.

Stash Pop latest stash Apply the latest stash and clear the stash.

Stash Pop stash Apply a specified stash and clear the stash.

Publishing Publish project > Set
Remote URL

Publish your Git project to an existing remote repository.

Publishing Publish project >
Publish to a new
GitHub repository

Publish your Git project to a new GitHub repository.

Publishing Fork on GitHub Fork a Git project and publish it to a new GitHub repository.
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11.1.3 Configure a project for source control and collaboration

If you import a project from Git, the project automatically points to the remote repository you
imported the project from. For projects which are not yet configured for source control, you need
to either point to an existing remote repository (without any commits) or publish a new repository
from within Keil Studio to enable source control.

Before you begin
Your active project must not yet be configured for source control.

Procedure
1. Go to the Source Control view.
2. Click the Publish project button.

The Publish dialog box opens.
3. Use the Publish dialog box to publish your repository:

• To use an existing remote repository (without any commits):

a. Select the Set Remote URL radio button and enter a URL for your remote repository.
The format can be either SSH (if you have set up an SSH key) or HTTPS. The URL must
not contain a branch name. For example, for GitHub:

◦ SSH: git@github.com:user-name/repo-name

◦ HTTPS: https://github.com/user-name/repo-name

b. Click Set Remote Repository.

• To publish a new repository:

a. If you have not already connected your Arm account and your GitHub account, do so
from this page: os.mbed.com/account/connected/ . Then log out of Keil Studio and log
in again using your Arm account credentials.

b. Select the Publish to a new GitHub repository radio button and enter a repository name
and description.

c. By default Keil Studio creates a private repository. If you want to create a public
repository, clear the Private repository checkbox.

d. Click Publish.

Setting a remote repository or publishing a new repository through the UI is only possible once
for each new project. Setting a remote repository is not possible for a project you import from
Git (the remote repository is automatically set to the repository you imported it from).

11.1.4 Fork a Git project

You can fork a project imported from GitHub or another Git hosting service and publish it to your
GitHub account in one go.

Procedure
1. In the Explorer view, set the project you want to fork as the active project.
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2. Move to the Source Control view.
3. Click the … button and select Fork on GitHub.
4. Depending on where the project comes from, Keil Studio forks the project directly or asks you

to set up a destination repository.

• If the project was imported from GitHub, then Keil Studio forks the project directly. Check
your GitHub account.

• If the project was imported from another Git hosting service, the Setup Destination GitHub
Repository dialog box opens:

a. Modify the repository name if needed and add a description.

b. By default Keil Studio will create a private repository. If you want to create a public
repository, clear the Private repository checkbox.

c. Click Next.

Keil Studio forks the project and creates a repository in your personal workspace on GitHub.

11.1.5 Create or switch branches

Describes how to create a branch or switch to a different branch.

About this task
Git uses branches to isolate your work from the work of other people or from code that must
remain stable. Keil Studio allows creating branches, and synching the remote and local branches.
You can see which branch you are working on from the status bar (when first setting a repository,
you are on the master branch by default).

Procedure
1. Click the current branch in the status bar.

The available branches are listed at the top of the window.
2. Create or switch:

• To create a branch: Select Create new branch… and enter a name to create a branch.

The name of the new branch should not contain spaces.

The branch is created locally; the branch publishes to the remote repository the first time
you push from the branch.

• To switch to a different branch, search for and select an existing branch in the list.

Figure 11-2: Create a branch, or select one from the list
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11.1.6 Manage local files

This section describes the different options to manage your local files and explains how to update
the remote.

11.1.6.1 File statuses

Statuses display to the right of each file to indicate changes.

• U: Untracked - a new file in the CHANGES list (not yet staged).

• A: Added - a new file in the STAGED CHANGES list.

• M: Modified - an existing file in either the CHANGES or STAGED CHANGES list.

• D: Deleted - a deleted file.

• C: Merge Conflict - you must resolve the merge conflict before you can push.

11.1.6.2 View changes

Describes how to view the changes you have made to a file in Keil Studio.

Procedure
• To view the changes you have made to a file, double-click its name. The file opens.

The changes open in a new tab, comparing what was available in the file before the changes (in
red) and what has changed (in green).

Figure 11-3: Double-click a file to view its side-by-side comparison
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• To compare the same file or folder across multiple Git branches, right-click a file or folder and
select Compare with. Keil Studio shows a list of available branches.

If you compare a single file, Keil Studio opens a diff view of that file.

If you compare an entire folder, Keil Studio opens a tab listing all the files. To open a diff view
for that file, click a file:

Figure 11-4: List of files changed in the folder

Next steps
You can open the file for editing by clicking the Open File icon at the top-right corner of the
screen.

Go back to the changes by clicking the Open Changes icon.

Note that you can open several files at once for editing: hold Shift or else Cmd (macOS) or Ctrl
(Windows and Linux) and select the files, then right-click and select Open File.

When in the editor, if there are changes to a file, the Open Changes icon is also available when you
open the file.
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11.1.6.3 Stage, commit, and push changes

Describes how to stage, commit, and push changes in Keil Studio.

About this task
Use staging to manually control which of your edited files are added into each commit. This breaks
your work into logical units, each in its own commit, rather than having to commit all files together.
You can always remove a file from the STAGED CHANGES list, and later add it to a different
commit. When you are ready, commit and push your changes.

Procedure
1. In the Source Control view, all new and modified files are listed under CHANGES.
2. Hover your mouse over the file you want to commit and click + to stage your changes. The

file is listed under STAGED CHANGES. To stage several files at once, hold Shift or else Cmd
(macOS) or Ctrl (Windows and Linux) and click the files you want to stage, then click +.

3. In the Commit message box, enter a commit message for the staged changes.
4. Click Commit or Commit (Signed Off).

The committed changes can be seen at the bottom of the Source Control view, and in the
History view.

5. To push the commit to the remote branch, click … > Push.
Note:

• To stage or unstage one or several files, you can also select the file or files, right-click and
select Stage Changes or Unstage Changes.

• If you try to push your changes to a repository on which you do not have permission, you'll
get an error message with a Fork on GitHub button. Click this button to fork the repository
and then try to push your changes again. See also Fork a Git project.

• If you try to push your changes to a repository on which you do not have permission and a
fork already exists, you'll get an error message with a Set Fork as Default button. Click this
button to use your fork and then try to push your changes again.

11.1.6.4 Amend local commits

Before pushing to the remote to share your work with others, you can rewrite local commits.

To rewrite local commits, you can:

• Add, update, or remove files in your last commit and change the commit message.

• Change multiple commits at once.

If you have already pushed your changes to the remote and notice that something is
not quite right, you can still fix your commits and force push the changes. However,
you must be absolutely certain that nobody has pushed commits to the remote
before doing a force push because force pushes overwrite commits.
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11.1.6.4.1 Change the last commit

Describes how to change your last commit in Keil Studio.

About this task
With the Commit (amend) option, you can amend your most recent commit and change the
content of the commit by adding, updating, or removing files. You can also optionally change the
commit message.

Procedure
1. Stage the files that you want to include in your last commit.

Note: To remove a file from your last commit, first delete it from the Explorer view (the file
appears as deleted D in the CHANGES list), then stage the deleted file.

2. Click … > Commit (amend).
3. Add a commit message in the message box that opens. Or, to reuse the last commit message

and only update the content of the commit, press Enter.

11.1.6.4.2 Change multiple commits

Describes how to change multiple commits in Keil Studio.

About this task
With the Amend button, you can roll back several commits to reset your head commit to a prior
state. The changes done between the original head commit and the current head commit are
staged. This way you can add, modify, or remove files and stage new changes.

Procedure
1. Click the Amend button for each commit that you want to amend.

All the changes you had committed are staged. You can decide which changes to stage or
unstage and combine commits.

Use the Unamend button if you change your mind and prefer to keep a commit untouched.
This resets the head commit to the commit you have just “unamended”. If there are several
commits to “unamend”, click Unamend all commits (-).

2. Once you are happy with the changes, in the Commit message box, enter a commit message
for the staged changes.

3. Click Commit or Commit (Signed Off).

Results
The changes commit and the commit can be seen at the bottom of the Source Control view, and in
the History view. In the History view, you can see that the amended commits are replaced by the
new commit.
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You can clear all the commits in the COMMITS BEING AMENDED list at once
with the Clear amending commits (x) button. The files staged while amending the
commits remain in the STAGED CHANGES list.

11.1.6.5 Ignore files

To keep your file list tidy and navigable, you can exclude files from the Source Control view. For
example, by default Keil Studio does not list any Mbed OS files.

Use .gitignore to list the files you want to exclude. The .gitignore file exists by default in all
Mbed projects, and is visible and editable in Keil Studio.

For more information about how .gitignore files work and how to use them, see the Ignoring
Files chapter of the Pro Git book.

11.1.7 Synchronize

If the remote repository has changed since you last pulled, you must synchronize your local copy
before you can push any of your own changes to the remote.

The Synchronize Changes indicators on the left-hand side of the status bar show:

• How many changes have been pushed to the remote repository since your last pull.

• How many commits you have on your local copy.

The Synchronize Changes indicators are also a button that displays the available synchronization
options.

Synchronization options
Keil Studio offers three synchronization options. Each one combines different Git operations to
automatically manage the changes.

Click the Synchronize Changes button to display the available options:

• Pull and push commits from and to 'origin/<branch name>': Apply the latest changes from the
remote repository to your local repository by doing a pull (fetch and merge), then push your
changes to the remote repository. This option might generate merge conflicts.

• Fetch, rebase, and push commits from and to 'origin/<branch name>': Put aside the local
changes, fetch the remote changes to bring the local up to date, reapply your local changes,
and push to the remote. The rebase option compresses all the changes into a single “patch” to
integrate with the remote branch. This option might generate merge conflicts.

• Force push commits to 'origin/<branch name>': Overwrite the remote branch with your local
branch, regardless of the status of that remote branch.
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Resolve merge conflicts
Synchronizing remote and local changes by pulling or rebasing can lead to merge conflicts when a
single file has been edited in both locations. Merge conflicts can also happen when you apply or
pop a stash, if the stash contains changes that contradict further work on the branch.

By default, when Git sees a conflict between two branches being merged, Git:

1. Adds merge conflict markers, <<<<<<< ======= >>>>>>>, into your code.

2. Marks the file as conflicted.

3. Lets you resolve the merge conflicts.

The top half of a conflict is the branch you are merging into, and the bottom half is from the
commit that you are trying to merge in.

So, for example, if you pull (fetch and merge):

• The top half shows your local changes.

• The bottom half shows the remote changes which you were trying to merge in.

To resolve a conflict, you have to decide which part you want to keep or merge the contents
yourself, and then remove all the merge conflict markers. Once you are happy with the corrections
on a given file, click + to stage your changes.

For more information about merge conflicts, see the About merge conflicts page of the GitHub
Help.

11.2 Work with Mercurial
Keil Studio supports the most common Mercurial actions for Mbed projects hosted on
os.mbed.com, including branching and synching with the remote repository.

The Mercurial flow in Keil Studio:

1. Set a remote repository.

2. Branch.

3. Track files.

4. Edit files.

5. Commit.

6. Push.

Keil Studio includes its own version of Mercurial; you do not need to manually install
it.
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Before you begin, check the Credentials section.

11.2.1 Credentials

For Mercurial, on any operating system, your credentials are taken from the Arm account with
which you logged into Keil Studio. You can work with all public repositories, and any private
repository to which you have access through os.mbed.com.

Keil Studio supports Mercurial repositories from os.mbed.com only.

11.2.2 Interface and features reference

Source control in Keil Studio is handled in two views: The Source Control view, for handling the
current work, and the History view to see previous commits. Both views always show the active
project.

The image highlights:

1. The actions menu. Both the Toggle to List View and the Toggle to Tree view buttons allow you
to display your changes as a list or as a tree view:

•

Toggle to List View: 

•

Toggle to Tree view: 

Note the … button for more actions.

2. The buttons available on each file when you hover over a file name: Track (+), Untrack (-),
Discard Changes, and Open File.

3. One tracked file - a Modified (M) file, which had already been committed to Mercurial once and
has changed since. One untracked file - an Added (A) file, which has not been committed yet.
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Figure 11-5: The 'Source Control' view for Mercurial

Group Features Comments

Local
changes

Track and Track
all files

Use the Track option to monitor the files for changes. A tracked file with changes is automatically added
to a commit. You can move files back to the UNTRACKED list only if you have never committed them
(these files are marked with “A”, for “Added”). Once you commit files, they remain tracked.

Local
changes

Discard all
changes

Revert all changed files to their state as of the last time they were pushed (or their starting state if they
have never been pushed).<

Local
changes

Refresh Update the list of local changes.

Commits Commit Put all tracked files into a single record of local changes. The commit is the record you can push to the
remote repository.

Commits Add signed-off-
by

Tag your commit and add comments, a signature, the date, and your email. For some projects, this is a
requirement for all contributions submitted as pull requests.

Branch
management

Branch Create a new local branch or checkout an existing branch. The default branch for a newly set repository is
“default”.

Branch
management

Pull Apply the latest changes from the default remote repository to your local repository (pull and merge).

Branch
management

Push Send new local commits to the remote.

Branch
management

Push to… Push all branches to a specific remote, rather than the default remote.
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Group Features Comments
Branch
management

Merge heads Merge two or more heads of a branch into a single head.

Publishing Set Remote
URL

Publish your Mercurial project to an existing remote repository.

Publishing Convert to a Git
Repository and
Fork on GitHub

Convert your Mercurial project to a Git project and publish it to a new GitHub repository.

11.2.3 Configure a project for source control and collaboration

If you import a project from Mercurial, the project automatically points to the remote you imported
it from. If you create a new project, however, you must manually set the repository. For both new
and imported projects, you can work with new or existing remote repositories, but you cannot
create a new remote repository from within Keil Studio. Instead, you must create the repository
directly through os.mbed.com. When the active project is not yet configured for source control, you
can initialize the project and set a remote repository.

Before you begin
Your active project must not yet be configured for source control.

Procedure
1. Initialize the project for source control:

a. Go to the Source Control view.

b. Click the Set Remote URL button.

The Set Remote URL dialog box opens.

c. Enter a URL for your remote repository.

Note: The URL must not contain a branch name.
2. Set a remote repository. Click Set Remote Repository.

Setting a remote repository through the UI is only possible once for each new project.

11.2.4 Convert a Mercurial project to Git

You can convert a project imported from Mercurial to Git and publish the converted project to your
GitHub account in one go.

Procedure
1. In the Explorer view, set the project you want to convert as the active project.
2. Move to the Source Control view.
3. Click the … button and select Convert to a Git Repository and Fork on GitHub.

The Setup Destination GitHub Repository dialog box opens.
4. Modify the repository name if needed and add a description.
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5. By default Keil Studio creates a private repository. If you want to create a public repository,
clear the Private repository checkbox.

6. Click Next.
The Match authors to GitHub users dialog box opens.

7. This step is not mandatory, but Arm recommends including the GitHub username of each
contributor to the project (or alternatively providing their GitHub email address). Including the
GitHub username of each contributor preserves the commit history of the project you are
converting.

Figure 11-6: Matching authors to users

8. Click Migrate now.
Keil Studio converts the project to Git and creates a repository on GitHub.

11.2.5 Create or switch branches

Describes how to create a branch or switch to a different branch in Keil Studio.

About this task
Mercurial uses branches to isolate your work from other people's work or from code that must
remain stable. Keil Studio allows creating branches, and synching the remote and local branches.
You can see which branch you are working on from the status bar (when first setting a repository,
you are on the “default” branch by default).

Procedure
1. Click the current branch in the status bar.

The available branches are listed at the top of the window.
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2. Create or switch:

• To create a branch: Select Create new branch… and enter a name to create a branch.

The name of the new branch must not contain spaces.

The branch is created locally; the branch publishes to the remote repository the first time
you push from it.

• To switch to a different branch, search for and select an existing branch in the list.

Figure 11-7: Create a branch, or select one from the list

11.2.6 Manage local files

This section describes the different options to manage your local files and explains how to update
the remote.

11.2.6.1 File statuses

Statuses display to the right of each file to indicate changes.

• A: Added - a new file in either the TRACKED or UNTRACKED list.

• M: Modified - an existing file in the TRACKED list.

• D: Deleted - a deleted file.

• C: Merge Conflict - you must resolve it before you can push.

Copyright © 2021 Arm Limited (or its affiliates). All rights reserved.
Non-Confidential

Page 75 of 101



Arm Keil Studio Cloud User Guide Document ID: 102497_1.5_03_en
1.5

Source control

11.2.6.2 View changes

Describes how to view the changes previously made to a file.

Procedure
• Either:

◦ Double-click its name to open the file.

The changes open in a new tab, comparing what was available in the file before the
changes (in red) and what has changed (in green).

Figure 11-8: Double-click a file to view its side-by-side comparison

◦ Open the file for editing by clicking the Open File icon at the top-right corner of the screen.
Go back to the changes by clicking the Open Changes icon.

When in the editor, if there are changes to a file, the Open Changes icon is also available
when you open the file.

11.2.6.3 Track, commit, and push changes

Describes how to track, commit and push changes in Keil Studio.

Procedure
1. In the Source Control view, all new files are listed under UNTRACKED.

Files that have already been committed once are automatically shown in the TRACKED list
when you modify them.

2. Hover your mouse over the file you want to commit and click + to track your changes. The file
is listed under TRACKED.

3. In the Commit message box, enter a commit message for the tracked changes.
4. Click Commit or Commit (Signed Off).

The committed changes can be seen in the History view.
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5. To push the commit to the remote branch, click … > Push.
Note: To track or untrack one or several files, you can also select the file or files, right-click, and
select Track or Untrack.

11.2.6.4 Ignore files

You can exclude files from the Source Control view to keep your file list tidy and navigable. For
example, by default Keil Studio does not list any Mbed OS files.

Use .hgignore to list the files you want to exclude. The .hgignore file exists by default in all
Mbed projects, and is visible and editable in Keil Studio.

For more information about how .hgignore files work and how to use them, see the Mercurial
documentation.

11.2.7 Synchronize

If the remote repository has changed since you last pulled, you must synchronize your local copy
before you can push any of your own changes to the remote.

Resolve merge conflicts
Synchronizing remote and local changes can lead to merge conflicts when a single file has been
edited in both locations.

By default, when Mercurial sees a conflict between two branches being merged, Mercurial:

1. Adds merge conflict markers, <<<<<<< ======= ||||||| >>>>>>>, into your code.

2. Marks the file as conflicted.

3. Lets you resolve the merge conflicts.

The top half of a conflict is the branch you are merging into, and the bottom half is from the
commit that you are trying to merge in.

So, for example, if you pull (pull and merge):

• The top half shows your local changes and your base version (after the ||||||| markers).

• The bottom half (after the ======= markers) shows the remote changes which you were trying
to merge in.

To resolve a conflict, you have to decide which part you want to keep or merge the contents
yourself, and then remove all the merge conflict markers. Once you are happy with the corrections
on a given file, click + on the file entry in the MERGE CHANGES list to resolve the conflict and
move the file to the TRACKED list.

For more information about merge conflicts with Mercurial, see the Tutorial - Merging conflicting
Changes.
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11.3 History view
The History view shows your commit history.

To view the changes that have been made for a given commit, click the eye icon . The
commit info includes the commit message, date, and a list of changed files.

To see the details of the changes on a given file, double-click the file. The changes open in a new
tab.
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12 Monitor and debug
This section describes the Keil Studio Serial Monitor view, and how to debug detected and
unsupported development boards in Keil Studio.

12.1 Use the Keil Studio Serial Monitor view
The Serial Monitor view displays the output of the board. By default, Keil Studio automatically
detects any board with a WebUSB-enabled CMSIS-DAP interface that you connect to your
computer and opens a Serial Monitor view. If you connect multiple boards, Keil Studio opens a view
for each board.

The first time you connect your board, you must click the Find target button to the
right of the Target hardware drop-down list. After the first successful connection,
Keil Studio detects the board and suggests a matching target.

You can have only one Serial Monitor view open for each connected board. Before you open an
external serial monitoring program, close the Serial Monitor view for your board in Keil Studio.

To reopen the Serial Monitor view, either:

• Select View > Serial Monitor.

•

In the Explorer view, click the Open serial monitor button .

You can disable the automatic opening of the Serial Monitor view from the preferences. Select
File > Settings > Open Preferences and search for the Serial Monitor preference. Clear the
Automatically Open checkbox if you do not want the Serial Monitor view to open automatically
when you connect your board.

To view the output of a board correctly, select the appropriate value from the Baud rate drop-down
list. The baud rate you select must be the same as the baud rate of your active project.

To download the output, click the Save Output icon .

To clear the Serial Monitor view, click the Clear Output icon .
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12.2 Debug a CMSIS project with Keil Studio
This section describes the debugger mode and debugging tools available in Keil Studio.

You can step debug a project on any connected board that supports a WebUSB-enabled CMSIS-
DAP interface. The debugger mode provides different ways of checking what your code is doing
while it runs. You can step through your code, examine the execution path of your code, or look at
the values stored in variables, and more.

The section explains how to debug with development boards that are automatically detected and
configured. For more information about supported hardware, see Supported hardware. If you are
using an external debug probe, or want to use configuration from a CMSIS-Pack, you must first set
up a custom target.

In the first version of Keil Studio, debugging features are only available for CMSIS
projects.

Debug first steps
To debug:

1. Set the project you want to debug as the active project.

2. Connect your board over USB and ensure the correct target hardware is selected for your

project. The first time you connect your board, you must click the Find target button 
to the right of the Target hardware drop-down list. After the first successful connection, Keil
Studio detects the board and suggests a matching target.

3.

Click the debug button, .

Keil Studio automatically builds and flashes your project to the connected board. The Debug
view displays and the debug session starts. The debugger stops at the function “main” of your
application.

Restart or stop the debugger

If you click the Restart button  when:

• The debugger was running, the debugger continues to run until a breakpoint is hit or until you
click Pause.

• The debugger was paused, the debugger starts to debug the code from the start. Restarting
from a paused state is faster than stopping the debugger and initiating a new debug session
from the Explorer view.
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To stop the debugger and return to the editor, click the Stop button .

Navigate your code using the step buttons
There are several options available to help you navigate your code quickly:

•

Step Over : Advance the debugger to the next source line that follows in the program
execution to go straight to the parts of code you are more interested in.

•

Step Into : Advance the debugger into each function. The debugger then breaks on the
first line that gets executed in the function.

•

Step Out : Advance the debugger until the current function returns (in other words,
advance all the way through the current function).

Note that Step Over and Step Out operations halt on breakpoints.

Set breakpoints
Breakpoints are useful when you know which part of your code must be examined. To look at
values of variables, or to check if a block of code is getting executed, you can set one or more
breakpoints to suspend your running code.

By default, Keil Studio stops on the first line of main(). To change this default
behavior, select File > Settings > Open Preferences > Debug > Run To Main. To
keep the program running until the first user breakpoint, clear the checkbox.

To set a breakpoint:

1. Click the margin to the left of a line of code in the editor. A red dot displays. You can also right-
click the margin and select Add Breakpoint.

2.

To start debugging, click the Continue button .

The debugger runs to the first breakpoint it encounters and stops. A yellow arrow displays next
to the statement on which the debugger paused. The statement highlights in yellow.

Once you have set a breakpoint, you can remove the breakpoint, or disable and enable the
breakpoint again. Right-click the breakpoint and select Remove Breakpoint or Disable Breakpoint
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(or Enable Breakpoint if the breakpoint is disabled). You can also remove a breakpoint by clicking
that breakpoint in the margin.

To remove, or disable, and enable breakpoints, more options are available from the Breakpoints list:

•

Activate/Deactivate Breakpoints : Activate or deactivate all breakpoints at once.
Activating or deactivating breakpoints does not change the enable or disable state of each
breakpoint.

•

Remove All Breakpoints : Remove all breakpoints at once.

• When you right-click a breakpoint from the list, the following options are available: Remove
Breakpoint, Remove All Breakpoints, Enable All Breakpoints, Disable All Breakpoints.

• To disable or enable a breakpoint, select the checkbox next to the breakpoint in the list.

Set function breakpoints
With function breakpoints, you can break execution when a function is called. Breaking execution is
useful, for example, when you know the function name but not the functions location.

To set a function breakpoint:

1.

Click the Add Function Breakpoint button  in the Breakpoints list.

The Add Function Breakpoint dialog box opens.

2. Type the name of the function you are looking for (function names are case-sensitive) and click
OK.

Examine threads and call stacks
You can examine and work with threads in the code that you are debugging. Working with threads
is useful for debugging multithreaded applications. Each thread appears on a separate row in the
Threads list and has a call stack.

In the current version of Keil Studio, only one thread displays in the Threads list
(Main).

When you select the Main thread, the call stack displays in the Call Stack list. The call stack shows
the order in which methods and functions are called. The call stack list is a good way to examine
and understand the execution flow of your code.

When you right-click the Main thread, the following options are available:

• When the debugger is paused, click Continue, Step Over, Step Into or Step Out to navigate the
code.
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• When the debugger is running, click Pause to pause the debugger.

When you right-click a call stack from the Call Stack list, the Copy Call Stack option becomes
available. The Copy Call Stack option allows you to copy a call stack to the clipboard to further
investigate a problem.

Inspect variables
You can inspect variables and check if they are storing the values you expect. If you find an
incorrect value, find out where it was set (you might need to restart the debugger, look at the call
stack, or both).

Local variables, global variables, function arguments, and register contents are shown in the
Variables list.

When the debugger is paused, to see a properties current value, hover over the object with your
cursor. You can also view variable values in the Variables list.

The value <not in scope> means that a variable is known but is not visible at the current location of
the program.

Global variables are grouped by modules (compilation units) in the Variables list under the Global
entry. Modules display as <file_name>: <{alias}/file_path>. Where alias is either
{cmsisPacks} or {workspace}. Click a module, to see the global variables defined for that
module.

Only modules with global variables are visible.

The following table provides register details:

Register
category

Description

Core Shows the CPU core registers (R0 to R15) and the processor status register (xPSR). Note that R13 (SP) means current Stack
Pointer, R14 (LR) means Link Register, R15 (PC) means Program Counter.

Banked Shows the Main Stack Pointer (MSP) and Process Stack Pointer (PSP). Depending on the currently active stack pointer of the
CPU, R13 (SP) either shows the value of MSP or PSP. See the Status category below.

System Shows more CPU register values (BASEPRI, PRIMASK, FAULTMASK, CONTROL).

Status Shows CPU state details. Mode can be “Thread” or “Handler”. Privilege shows the CPU code execution and can be “Privileged”
or “Unprivileged”. Stack shows the currently selected stack pointer (MSP or PSP).

You can display variable values inline in the editor with the Inline Values setting. Go to File >
Settings > Open Preferences > Debug and select the Inline Values checkbox.

When the debugger is paused, you can copy the value of a variable. From the Variables list, right-
click a variable and select Copy Value.
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Double-click an entry in the Call Stack list to see the Local Variable values for that
entry.

Advanced debugger settings
The following tables describe advanced settings for the debugger. The settings are available in the
Debug or Run categories in File > Settings > Open Preferences.

Most of the settings in the Debug and Run categories are related to how Keil Studio connects to
and resets a board, and how the flash download of code works.

For flash download, you can either:

• Use DAPLink (Use Daplink option in the Run category). In this case, the DAPLink firmware takes
care of the flash download.

• Use a WebUSB-enabled CMSIS-DAP firmware. In this case, flash algorithms contained in
the CMSIS-Pack that is used in your project are deployed in the background to do the flash
download. You can refine how the debugger behaves by selecting your preferred options.

See the CMSIS-Pack documentation for more information on flash programming algorithms.

There are also options to change how panels are displayed in the user interface in
the Debug category.

Connection and flash download options in the Debug category:

Setting Description

Connect
Mode

Controls the operations that are executed when the debugger connects to the board. The options are:

• haltOnConnect (default): Stops the CPU of the board for a reset before the flash download or the debug session.

• underReset: Asserts the hardware reset during the connection.

• preReset: Triggers a hardware reset pulse before the connection.

• running: Connects to the CPU without stopping the program execution during the connection.

Reset
Mode

Controls the reset operations performed by the debugger. The options are:

• auto (default): The debugger decides which reset to use based on information from the CMSIS-Pack.

• system: This mode uses the ResetSystem sequence from the CMSIS-Pack.

• hardware: This mode uses the ResetHardware sequence from the CMSIS-Pack.

• processor: This mode uses the ResetProcessor sequence from the CMSIS-Pack.

Reset
After
Connect

Performs a reset operation as defined in Reset Mode after connecting to the board.

Verify
Application

Compares the content of the target memory with the program loaded in the debugger. Enable this option to ensure that the
image loaded in the target system matches the image loaded in the debugger. This prevents debugging the wrong code when
working with various targets or more instances of Keil Studio.
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Setting Description
Deploy
First

If selected, a flash download is triggered when you start a debug session. To save connection time, the flash download only
happens if the code has changed, the active project has changed, or the board has been disconnected and reconnected.

Flash download options in the Run category:

Setting Description

Use Daplink If selected, the DAPLink firmware does the flash download of programs to your board.

Erase Mode The erase modes available if you are not using DAPLink. The options are:

• sectors (default): Erase only sectors to be programmed.

• full: Erase full chip.

• none: Skip flash erase step.

Program
Flash

Flash program option if you are not using DAPLink. Writes code into the flash memory.

Verify Flash Flash verify option if you are not using DAPLink. Verifies the content downloaded to the flash memory during the flash
download.

Reset Run Reset option if you are not using DAPLink. Triggers a hardware reset after the flash download.

Options to change how panels display in the user interface in the Debug category:

Setting Description

Debug View Location Controls where the Debug view displays in the user interface. The options are:

• left (default): The Debug view displays on the left-hand side.

• right: The Debug view displays on the right-hand side.

• bottom: The Debug view displays at the bottom of the screen.

Internal Console Options Controls when the Debug Console view displays. The options are:

• neverOpen: The Debug Console view never displays.

• openOnSessionStart (default): The Debug Console view displays whenever a debug session starts.

• openOnFirstSessionStart: The Debug Console view displays the first time a debug session is
started only.

Open Debug Controls when the Debug view displays. The options are:

• neverOpen: The Debug view never displays.

• openOnSessionStart (default): The Debug view displays whenever a debug session starts.

• openOnFirstSessionStart: The Debug view displays the first time a debug session is started only.
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13 Exporters
To download any CMSIS or Mbed project, select File > Download Active Project in Keil Studio.
Projects are exported as .tar files and can be used with the Keil µVision IDE. To import your
project, follow the Keil µVision import process.
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14 Supported and custom targets
Describes where to find a list of development boards that Keil Studio supports.

14.1 Supported hardware
Describes the supported hardware that Keil studio supports.

For CMSIS projects, Keil Studio supports the following development boards:

• NXP LPCXpresso55S69

• NXP FRDM-K32L3A6

• NXP EVK-MIMXRT1064

For Mbed projects, Keil Studio supports the following development boards.

14.2 Custom targets
A build target (or target hardware) is a destination for a software build, for example an MCU,
development board or custom board. A build is always done for a specific target hardware.

Keil Studio has a list of build targets for all compatible boards. Sometimes, you might want to create
a custom target. For example, you might have a debug probe connected to a board that does not
have an integrated interface chip. When you plug in a debug probe, Keil Studio needs to know the
target to build and debug for, so you must specify it.

A custom target is tied to an individual board or debug probe (based on its USB Serial Number).
Every time you plug a custom target in, Keil Studio automatically chooses the custom target you set
up for it.

Flashing and debugging in an incompatible way (for example, if you select an
incorrect build target) can damage your board and make it unusable.
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14.2.1 Set up a custom target

Describes how to set up a custom target in Keil Studio.

Procedure
1. Connect your hardware over USB. The first time you connect your board, you have to click the

Find target button to the right of the Target hardware drop-down list. After the first successful
connection, Keil Studio detects the board and suggests a matching target.
If your device is a debug probe, or for Mbed projects, if your board is not supported by the
Mbed OS version for your project, the Manage Custom Targets dialog box opens automatically.

If your device is a development board, open the Target hardware drop-down list and click the

Manage custom targets button .
2. The Manage Custom Targets dialog box shows all USB-connected devices in the USB device

drop-down list. Select the one you want to create a custom target for.
3. In the Build target drop-down list, select a build target. A build target is the target hardware

(device) you build the project for.
Selecting a build target populates the Target name field with a matching value, unless you have
already manually edited this field.

4. Click the Save All button.

14.2.2 Reset a target

Describes how to reset a target in Keil Studio.

Procedure
1. Open the Manage Custom Targets dialog box.
2.

Click the Reset custom target button .
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15 Preferences
This section discusses the preferences and shortcuts that you can update to tailor Keil Studio to
your preferred setup.

15.1 Change preferences
You can customize how Keil Studio operates to suit the way that you are used to working.

Procedure
1. Go to File > Settings > Open Preferences.

There are two tabs: a User tab and a Workspace tab.

In the User tab, you can define preferences that apply to all workspaces. In the Workspace
tab, you can define preferences for the workspace currently open only. Preferences set in the
Workspace tab take precedence over preferences set in the User tab.

The Open Preferences in JSON icon  { height=30 width=30 } opens a JSON file storing
all the preferences you changed from their default values.

2. Select the User or the Workspace tab. If you have several workspaces and want to define
preferences by workspace, select the correct workspace. To switch between workspaces, use
File > Open Recent Workspace….

3. Click the preference that you want to change and modify the predefined values as needed.
Note: For some preferences, you can add a manual value in the JSON file.

4. For preferences that require a manual value, when you click the Edit in settings.json link, a
preference ID is added in the JSON file. You must add the correct value for that preference ID.
For example, if you click Edit in settings.json for the Files preference, the JSON file opens
in a separate tab and shows the files.associations ID without a value. You can now
associate new file extensions to a language:

{
    "files.associations": {"*.myextension": "cpp"}
}

In this example, your files with a *.myextension extension are recognized as C++ files.

Results
Once you have changed a preference, a blue line and a cogwheel icon appear to the left of the
preference. You can click the cogwheel icon and select Reset Setting to reset the preference. You
can also copy the preference ID and the value set for the preference in JSON format (Copy Setting
as JSON option), or copy the preference ID only (Copy Setting ID option).
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To look for a specific preference, type the preference name or ID in the Search
Settings field.

Example 15-1: Common preferences example

In the following example, Keil Studio will:

• Only open files on double-click (instead of single-click).

• Use \r\n for the end of line character (instead of matching the operating system).

• Not auto indent.

• Not ignore white-space changes when comparing files.

• Auto close brackets only before a white space.

You can change the most common preferences without going to the Preferences list. For example,
to switch from the default dark theme to a light theme, select File > Settings > Color Theme, or to
indent with tabs, click the Spaces option on the information bar.

15.2 Set word wrap preferences for the editor
You can control word wrap in the editor through the Word Wrap preference. By default, this
preference is off but if you set it on, text wraps at the width of the editor window.

Two other options are available for Word Wrap and work in combination with the value set for the
Word Wrap Column preference. Word Wrap Column is the maximum number of characters that
can be displayed on a single line.

• wordWrapColumn: When this option is selected, text wraps at the value set for Word Wrap
Column.

• bounded: When this option is selected, text wraps at the width of the editor window or at the
value set for Word Wrap Column, whichever is the smaller value of the two widths.

Once you have set these preferences, select View > Toggle Word Wrap to toggle between the
different options for the Word Wrap preference.

15.3 Customize keyboard shortcuts
Keil Studio lets you perform most tasks from the keyboard with keyboard shortcuts (also called
keybindings). You can modify existing keyboard shortcuts or add new ones to commands that do
not yet have shortcuts associated with them.
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15.3.1 Change keyboard shortcuts

Describes how to change keyboard shortcuts in Keil Studio.

Procedure
1. Select File > Settings > Open Keyboard Shortcuts.
2. In the Search keybindings field, type the name of a command or keybinding. You can also do

a search on the context and "when" clauses. Note that you can click the Clear Keybindings

Search Input icon  to clear the field, if needed.
3.

Hover over the shortcut you want to modify and click the Edit Keybinding pen icon  to
the left of the command. You can also double-click the shortcut to edit it.
The Edit Keybinding For <command> dialog box opens.

4. Update the shortcut and click OK. To find out what keys you can use, see the Supported Keys
section in Using the JSON file.

To make further changes, you can click the Open Keyboard Shortcuts in JSON icon . The
Open Keyboard Shortcuts in JSON icon opens the keymaps.json file which stores all the
shortcuts that have been changed from their default values. Change the lines corresponding to
the shortcut or shortcuts you want to modify. For more information, see Use the JSON file.

15.3.2 Reset keyboard shortcuts

Describes how to reset keyboard shortcuts in Keil Studio.

Procedure
1. Search for the keyboard shortcut you want to reset.
2.

Hover over the shortcut and click the Reset Keybinding icon  to the left of the command.
The Reset keybinding for <command> dialog box opens.

3. Click OK.
Alternatively, you can reset a shortcut from the Edit Keybinding For <command> dialog box
with the Reset button. You can also delete the lines corresponding to the shortcut you want to
reset in the keymaps.json file. For more information, see Use the JSON file.
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15.3.3 Use the JSON file

All the changes that you make to keyboard shortcuts are stored in a keymaps.json file. Once you
have made changes to shortcuts, you can update or delete your changes directly from the JSON
file.

Keyboard rules
When you open the keymaps.json file, you can see that two blocks are present for each
shortcut that is modified. The current value of a shortcut is presented first, followed by the
previous values for that shortcut. The blocks contain what are called keyboard rules.

Each rule consists of:

• A "command" containing the identifier of the command to execute.

• A "keybinding" that describes the pressed keys.

• An optional "when" clause that contains a boolean expression which evaluates depending on
the current context. If there is no "when" clause, the keyboard shortcut is globally available at
all times.

For example, if the keyboard shortcut for the Copy Line Down command was modified to use
shift+down, instead of shift+alt+down, to trigger the command when using the editor, you
would see:

  {
     "command": "editor.action.copyLinesDownAction",
     "keybinding": "shift+down",
     "when": "editorTextFocus && !editorReadonly"
  },
  {
     "command": "-editor.action.copyLinesDownAction",
     "keybinding": "shift+alt+down",
     "when": "editorTextFocus && !editorReadonly"
  }

To reset the keyboard shortcut, you can modify the "keybinding" element in the first block or
delete both blocks.

It is not currently possible to change the "command" identifiers or "when" clauses.

Supported keys
The following keys are supported:

To use ctrl on Windows or Linux and cmd on macOS, use ctrlcmd.

You can use shift, ctrl, alt, meta, option (alt), command (meta), cmd (meta) as
modifiers.
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If you define a custom shortcut with cmd, command, or meta in your
keymaps.json file, the same keymaps.json file will not work on a Windows or
Linux machine because Windows and Linux machines do not have equivalent keys.

You can also use the following strings for special keys: backspace, tab, enter, return,
capslock, esc, escape, space, pageup, pagedown, end, home, left, up, right, down, ins,
del, and plus.

Chords (two separate keypress actions) are supported and must be separated with a space.
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16 Integration with Pelion Device
Management

For Mbed projects only: The Arm Pelion IoT platform connects devices to the cloud for easy
management.

The Pelion Device Management (PDM) services manage the connection of the device and resource
management, and remote firmware updates.

The PDM integration in Keil Studio configures your project with the certificates, IDs, and other
credentials it requires to connect to PDM. Keil Studio can also perform a firmware update with a
single click, making it simple to test the PDM functionality of your project: verify your project can
connect to your PDM account, send the correct resources, and correctly apply a new firmware
update.

You need a Pelion Device Management account to use the PDM services. If you do
not have an account, request access from the Pelion website.

16.1 Overview
Describes what a project requires to connect to PDM and receive updates.

To be able to connect to PDM and receive updates, a project (the first image installed on a device)
must have:

• A connect certificate to access a Pelion Device Management account. When you run the
project on a device, the bootstrap server uses this connect certificate to authenticate your
project with your Pelion Device Management account.

• An API key to access Pelion Device Management services.

• An update certificate to verify that incoming updates come from a trusted source.

• A bootloader to verify and install update images.

• The Pelion Device Management Client library (mbed-cloud-client.lib), normally
imported as part of the example project mbed-os-example-pelion.

For development use cases only, you can use Keil Studio to generate the certificates
(“developer” connect and update certificates) and the manifest file. For production
use cases, use offline tools to generate and store these certificates securely.

Once the initial, updatable project is on the device, the device itself is considered updatable; the
device can receive over-the-air updates. These updates can be sent to the device (or multiple
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devices) using Pelion Device Management (all your devices must be connected to Pelion Device
Management before rolling out the campaign).

To update a device, you need:

• A new firmware image. This image does not include the certificates, keys and bootloader of the
original project; the image contains only the project code.

A manifest file, which defines the update, including the location of the new firmware image and
the type of device the update applies to. The manifest file is signed with a private key to assure
the device that the image is from a trusted source and has not been tampered with.

• A private key so you can sign the firmware update manifest file.

From Keil Studio, you can then roll out an update campaign for your image, using the manifest, to
your selected devices. Keil Studio monitors the devices and shows applied updates.

16.2 Connect your device to Pelion Device Management
Describes how to create a connect certificate and give your project access to your Pelion Device
Management (PDM) account.

Procedure
1. Create a project from the mbed-os-example-pelion example.

Make sure the project is set as active.
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2. If you do not have a Pelion Device Management API key, create one:

a. Go to the Pelion Device Management view.

b. Click Open Pelion Device Management. Your web browser opens the Pelion Device
Management (PDM) portal.

c. Log in to your Pelion Device Management account.

d. Select Access management > API keys.

e. Click + New API key and follow the instruction on the screen.

Figure 16-1: Creating an API key

Copy the API key to the clipboard.
3. Add your API key to Keil Studio:

a. In the Pelion Device Management view, click the cogwheel icon. The Pelion DM Account
Settings dialog box opens.

b. Paste your API key in the API key field and click Save.
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4. If you do not have a connect certificate, create one:

a. In the Pelion Device Management (PDM) portal, select Device identity > Certificates.

b. Select + New Certificate > Create a developer certificate and follow the instructions to
create a developer certificate.

Figure 16-2: Pelion creating a developer certificate

Warning: The developer connect certificate file contains multiple certificates and a private key.
The certificate is not suitable for production and you must keep it safe so as not to expose
the private key. Arm recommends adding it to your .gitignore (for Git repositories) or
.hgignore (for Mercurial repositories) file, so that it is not pushed to your source control
repositories.

5. To add your certificate to your project, in the Keil Studio Pelion Device Management view, click
Configure.
Keil Studio uses your API key to display your available certificates. Select the one you want to
add to the project.

6. To be able to update your project, leave the Enable remote firmware update checkbox selected.
Leaving the checkbox unticked adds an update certificate and key to the project.
Warning: The update certificate and key are not suitable for production use cases.

7. Click Done.
Keil Studio updates the file mbed_cloud_dev_credentials.c in your project with your
developer certificate information.

The project can now connect to your Pelion Device Management account.
8. Set up your project to connect the internet, Wi-Fi or Ethernet:

• For Wi-Fi: In the mbed_app.json file for your project, set up your Wi-Fi credentials: enter
a value for nsapi.default-wifi-ssid (replace SSID) and nsapi.default-wifi-
password (replace PASSWORD). Ensure you leave the quote marks and escape characters,
for example "\"<newname>\"", and "\"<password>\"".

• For Ethernet: Connect your board with a cable; no project setup is required.
9. Build and run the project to connect your device. When your device goes online, you can see it

in the Pelion Device Management (PDM) portal.
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16.3 Update workflow
Once you have flashed the initial project to your device (over USB), you can start using Pelion
Device Management (PDM) to remotely update new versions of the project. This topic describes
how to update your device.

Procedure
1. Make changes to your project.
2. In the Pelion Device Management view, click Push to devices. Keil Studio:

a. Builds the project as a new image, which does not include the bootloader (that was only
needed for the initial project).

b. Creates a manifest for the update, signed with your private key.

c. Uploads the image and manifest to Pelion Device Management and updates all connected
devices that match the class ID and vendor ID listed in the manifest.

Results
Keil Studio reports the number of successfully updated devices.

The vendor and class IDs are randomly generated on your machine as part of the
PDM configuration process, so it is highly unlikely that the update will target anyone
else's device. You can also set the vendor and class IDs manually.

You can see your update image, manifest, and campaign in the Firmware update menu of the Pelion
Device Management (PDM) portal.

16.4 Pelion troubleshooting
Describes solutions to some issues you might experience when using the Pelion Device
Management (PDM) portal.

Using a new update certificate fails
If you must change the update certificate for your project, or if you are using the same
development board to test more than one application (each application must have a unique update
certificate), you must erase the storage of your board; the certificate is not erased in the normal
process of reflashing a board.

Solution
You can erase the storage of your board by:

• Sending r: Focus on the Serial Monitor view and press R.

• For an external SD card, connect the card to your computer and format the card as instructed
by the manufacturer.

Copyright © 2021 Arm Limited (or its affiliates). All rights reserved.
Non-Confidential

Page 98 of 101

https://www.pelion.com/docs/device-management/current/updating-firmware/device-identifiers.html


Arm Keil Studio Cloud User Guide Document ID: 102497_1.5_03_en
1.5

Known issues and troubleshooting

17 Known issues and troubleshooting
Describes Keil Studio known issues, how to troubleshoot some common issues, and how to contact
Arm to report issues and make development suggestions.

17.1 Known issues
Describes the known issues in Keil Studio.

Keil Studio has the following known issues:

• Projects that you download from the Online Compiler as ZIP files contain a cut-down version of
Mbed OS specific to the selected target. To select a different target, delete the Mbed OS library
and replace it with a full copy of the library.

• Some users have reported licensing issues for Arm Compiler 6. These issues might be related to
the system clock and region format.

• On Linux, there is a limit on the number of files that can be watched in the workspace. Follow
the instructions on the Visual Studio documentation site to increase the limit.

• On Linux, source control management requires the libcurl4 package to work correctly.

17.2 Troubleshooting
Provides solutions to some common issues you might experience when you use Keil Studio.

Can't log into Keil Studio
You are unable to log into Keil Studio.

Solution
Ensure that your Arm account or Mbed account credentials are correct.

Cannot make an Mbed project the Active Project
If a project requires an Mbed OS library, but there is no Mbed OS library imported into that project,
you cannot set that project as the Active Project. Instead, you see a warning such as “Cannot
set”<project-name >" as Active Project as it is not recognised as a valid project.".

Solution
In the Explorer view, check if you have an Mbed OS library imported to the project, but with a
directory name that is not mbed-os.

• If you find an Mbed OS library directory with a directory name that is not mbed-os (in other
words, a custom name), rename the directory to be called mbed-os.
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• If you do not find an Mbed OS library directory with a custom name, you must add an Mbed
library to that project:

1. Right-click on the project name and select Add Mbed library.

2. Provide the URL to import the Mbed OS library from.

If you import your Mbed OS library from https://github.com/ARMmbed/mbed-os/, the
Library Name pre-populates as mbed-os. Do not change the pre-populated mbed-os
name.

If you import your Mbed OS library from another URL, ensure the Library Name given
becomes mbed-os.

3. Click Next.

4. Select the branch or tag to import for your Mbed OS library.

5. Click Finish.

Your library starts to import. When the import completes, you can set the project as the
Active Project.

Code editor shows many red squiggly lines in an Mbed project
Your project must contain an mbed-os directory. Without an mbed-os directory, Keil Studio
shows many red squiggly lines where something in your code (header files, types, and similar)
requires an Mbed OS library component.

Solution
1. Open the Mbed Libraries view, select View > Mbed Libraries.

2. Check that the Mbed OS library for your project is there. To the left of each library that is listed,
there is a drop-down button which you can select to see where the library was imported from.

a. If there is not an imported Mbed OS library listed, you must add an Mbed OS library to your
project. To learn how to add and manage Mbed libraries, see Manage an Mbed project and
its libraries.

b. If there is an imported Mbed OS library listed, but it does not have the name mbed-os, you
must rename the library directory to be mbed-os. Go to the Explorer view, find the library
to rename, right-click on that library directory, and select Rename.

Connected development board not found
You have connected your development board, but the board is not being detected by Keil Studio.

Solution
• Run Device Manager (Windows), System Information (Mac), or a Linux system utility tool like

hardinfo (Linux) and check for warnings beside your devices. Warnings can indicate that device
drivers are not installed. If necessary, obtain and install the appropriate drivers for your device.
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• Update the firmware of the board to the latest version:

◦ DAPLink

◦ ST-LINK

Note: ST development boards on Windows require extra drivers. You can download them
from the ST site.

Development board not showing serial data
Serial data for a development board is not being shown in Keil studio.

Solution
• Disconnect and reconnect the board.

• Check that no other project is accessing the serial data on the board; the device can only
connect to one serial monitor at a time.

• On Linux, ensure that the current user belongs to the dialout group. To check that the
current user belongs to the dialout group, run the command: sudo adduser "$USER"
dialout.

Linker failing with “file not found” for Mbed OS 15.4.0 and older
Mbed OS 15.4.0 and older do not support spaces in project names. The linker fails and states
"file not found".

Solution
Change your project name and try to compile again.

17.3 Report an issue or make a development suggestion
Help us develop Keil Studio.

Report any issues you experience, or make development suggestions on the forums:

1. From the Help menu, select Report an Issue. The Report an issue or provide feedback dialog
box opens.

2. Click Report Issue, which takes you to the Keil forum.

You can also access the Keil forum and Mbed forum, through the Help > Forums menu selection.
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