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Application Note 168

Trace is a powerful debug tool supported by ARM cores that have an Embedded Trace
Macrocell (ETM). Trace provides a capture of program instruction flow and data accesses,
without impacting the real-time performance of an application. For this reason, trace is an
invaluable tool when traditional halted debug methods can not be used for resolving real-time
application issues.

This Application Note provides an introduction to tracing with ARM's RealView Debugger
(RVD). RVD provides a powerful front end for configuring trace and displaying the results of
a trace capture. Since only a limited amount of information can be collected from trace, it is
important that your trace capture is properly set to isolate the area of interest for debugging or
profiling. This Application Note will focus on the mechanics of performing trace capture using
auto trace, trace points, trace ranges and triggers.

A sample application is used as an example throughout the Application Note. This example
provides a framework for a series of trace scenarios which can be followed along as a tutorial or
used as a reference to make a similar trace capture in your own application.

This Application Note is written for ETM-enabled targets interfaced to RVD through Real View
ICE using an Embedded Trace Buffer or RealView Trace (RVT). Some of the trace scenarios
will work on the RealView Instruction Set Simulator (RVISS), but tracing RVISS targets is
notably different as defined in the RVD Trace User Guide. A working knowledge of RVD and
RVT is assumed.

You may find the following references useful when reading the Application Note:
. Embedded Trace Macrocell Architecture Specification - ARM IHI 0014

. RVDS 2.2 RVD / RVT Tutorial

. RealView Debugger Command Line Reference Guide - ARM DUI 0175

. RealView Debugger Essentials Guide - ARM DUI 0181

. RealView Debugger Trace User Guide - ARM DUI 0322

. RealView Debugger User Guide - ARM DUI 0153

. RealView ICE and RealView Trace User Guide - ARM DUI 0155.
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2 Sample Application

The sample application is supplied in the file TRACE.C. It simulates a small system that reads
a set of input data samples, computes the sample average and then outputs the average followed
by a variable number of input data samples. It yields code that is easy to follow and provides a
framework for common instruction and data trace scenarios.

The application is designed to run on any hardware platform because it simulates data input and
output rather than relying on specific peripherals. Data sampling and processing is initiated on
a random time basis using the rand() function. Instead of reading data from an input device
(such as an analog-to-digital converter), new input data is generated from previous input data.
The sample average and input samples are output by writing to a fixed address in memory
(intended to simulate the write buffer of a serial port).

The batch file BUILD.BAT is supplied to build the application using RealView Development
Suite. The batch file compiles TRACE.C and links the application using the scatterloading file
TRACE.SCAT. The scatterloading file places the executable image at 0x8000, followed by the
RW and ZI data sections. The application uses a one-region memory model, with the heap and
stack placed 256 bytes after the ZI section. The simulated write buffer is located in a separate
section at address 0x20000. To run the application from a different address or relocate any of
the memory sections, you must modify the TRACE.SCAT file accordingly.

Note

1) The sample application was built using Real View Development Suite v3.0 SP1. If you build
the application using a different version of the tools, you may collect slightly different trace
captures from those presented in Sections 4 - 8. Any difference in trace captures can be
attributed to the difference in assembly code generated by the compiler.

2) The application must be run on RVD with semihosting enabled because it contains calls to
printf().

3) The application control loop contains a call to printf() which provides feedback on program
execution. Standard semihosting places the target in a debug state which slows program
execution and impacts trace profiling results. You can comment out the call to printf() and
rebuild the progam to make the program execute faster. If you comment out the call to printf(),
your trace captures may no longer match those in Sections 4 - 8.

Copyright © 2006. All rights reserved. DAIO168B
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3 Configuring Trace

3.1 Trace Interfaces

Trace can be collected only from ARM cores that feature an Embedded Trace Macrocell (ETM).
The ETM generates trace information based on your trace settings. Trace information output by
the ETM must first be stored so that it may be sent to RVD for analysis. The ETM allows two
different interfaces for collecting trace data - a dedicated trace port and external buffer or an
on-chip Embedded Trace Buffer.

Collecting Trace from an External Trace Port using RVI/RVT

If your target utilizes a trace port, trace data is collected by RealView Trace (RVT). RVT sits
on top of RealView ICE (RVI) and the two are connected through a 60-pin and 80-pin connector.
RVT interfaces to the trace port through a 38-pin Mictor connector. When a trace capture is
made, the ETM fills the contents of RVT memory with trace data through the trace port. The
trace data is then uploaded to RVD for analysis via RVI:

RealView
Debugger
| AR Target
RealView Trace
T Port
race
I
EealView ARM CPTT
I°E JTAG ETHA
macrocell
Port
|
Figure 1

Note
This is the default configuration expected by RVD.

Collecting Trace from an ETB using RVI

If your ETM features an Embedded Trace Buffer (ETB), then you don't need a trace port or
RealView Trace to make a trace capture. Instead, the ETB collects trace information and sends
it to RVD through the JTAG port via RVI:
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EealView
Debugger
AR Target
[ zm |
ETB

AFM CPU
EealView JTAG ETHA
ICE Port macrocell

Figure 2

Note

The trace interface is implementation defined. It will either be a 38-pin Mictor connector or
JTAG interface. Some designs may provide both interfaces. You must configure the tools to use
an ETB since they default to using an external trace port.

If your target does feature an ETB, you will see it when you configure the RVI scan chain from
the Connection Control window in RVD. The ETB will be identified as "ETMBUF" by the RVI

configuration utility:

' RVConfig - C:\Program Files\ARM\RVD\Core\3.0.1\309\win_32-pentium\... - |[0/E3

Eile Wiew Help
= Realiew ICE: [TCPAP Junior)
= Devices
ETHMBUF
ARM1T136JF-5
Advanced

Scan Chain Configuration

DO 1—‘

TARPID | Device |0 Code IR Length | Options | Template Yersion

1

TDIQ

[Auto Configure Scan Ehain] [Device Properties...] [ Move Up ]
[Add Device... ] [Hemove Device]

JTAG Clock Speed
(&) Adaptive () BMHz () BOMHz
) 20kHz (O 10MHz (O Other 10,000 MHz Set
O 1MHz (O 20 MHz

Figure 3

If you want to trace using ETB, you must enable this option by selecting your ARM core in the
scan chain and clicking "Device Properties":
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:'RVConfig - C:\Program Files\ARM\RVD\Core\3.0.1\309\win_32-pentium\etc\rvi.rve |- |[0/24

Eile Wiew Help
= Realiew ICE: [TCPAP Junior)

= Devices Scan Chain Configuration
ETHELF
ARMT136JF-5 70D ‘—‘
Advanced

TARPID | Device |0 Code IR Length
B Ox2B:900F0F
0 0F

TDIQ

f_'_‘-‘-"""h..
[Auto Configure Scan EhairﬂDevice Properties...u Move Up ]

JTAG Clock Speed

(&) Adaptive () BMHz () BOMHz

O 1MHz O 20 MHz

e N
[ Add Device... ] [Hemove Device] Move Down

O 20kHz O 10MHz O Other 10.000 MHz

Template Yersion
1:0:0

Click the checkbox for the Embedded Trace Buffer and select OK:

Figure 4

The RV Configuration utility will now show that the ETB will be used for tracing:

+'Device Properties 23
Device Name : ARM1136IF-S
Template YWersion: | 1:0:0 -
Options :

Embedded Trace Macrocel [ETH)

Embedded Trace Buffer [ETE) ]

O “ector Floating Paint [VFP)
[ Ok ] ’ Lancel ] ’ Help ]

Figure 5
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:'RVConfig - C:\Program Files\ARM\RVD\Core\3.0.1\309\win_32-pentium\etc\rvi.rv... - |[0/E4

Eile Wiew Help
=-Real

ARM1T136JF-5
Advanced

Scan Chain Configuration

DO 1—‘

TARPID | Device |0 Code IR Length | Options Template Yersion
1] ETMBUF  0x2BS00FOF 4 — 1:0:0
ARM1136IF-S  0=07B36FOF 5 ETM.ETB
o

TOI Q
[Auto Configure Scan Ehain] [Device Properties...] [ Move Up ]

[Add Device... ] [Hemove Device]

JTAG Clock Speed

(&) Adaptive () BMHz () BOMHz
) 20kHz (O 10MHz (O Other 10,000 MHz Set
O 1MHz O 20 MHz

3.2 Enabling and Configuring Trace

Figure 6

Trace is enabled and configured through RVD. Before you can configure trace, trace must first
be enabled from the "Tools - Analyzer/Trace Control - Connect Analyzer/Analysis" menu.

Copyright © 2006. All rights reserved.
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FARVDEBUG = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =JoEd
[ Eile Edit Yiew Target Debug | Toaols Help
'
O el &% & [ snalyzer/Trace Contral 4 Connect Analyzer/analysis...
FileJsce.c hid Sirnulation Control Configure Analyzer Proparties. ..
Logs and Journal 3 ”~
*
*  Function: main Include Commands from File...
*
*  Areuments: None Add/Edit Debugger Macros. ..
* Returns: Hewver ;
- Options...
* Purpose: Program executive which simulates a simple I/0
* system. It waits a random time to perform data
* processing. Processing consists of:
* Generating input data (to simulate an ADC)
* Computing the awverage of the input
* Outputing the average and some input samples
*

L
int main (wvoid)
int sample_num=0; /% local to track nuwher of samples */

/% initialize board and data %/
Init():

A% enter program executive, loop contimually in main control loop */
printf ("Entering main control loopin™):
while(l)

i
A |k [\ Dam £ Src g tracec 4 LR
|+ |1» [\Dsm st jrace s / D

ﬁ load/pds/r 'C:YAN168%code) trace. axt!’
g Loading file C:%AN168%code)\trace.axf...

=

Stop>
< | » \cma fstao JFieFind fLog / J J

Select/connect logic analyzer or other analysis mechanism Stopped Ln 65, Col 1

Figure 7

After you enable trace, a message will be displayed indicating which ARM core and ETM you
have connected to:

ﬁ analyzer,connect s
g Initialising Trace Support

ﬂ Cornmecting Analyzer to ARM1136JF-3_1 -- ETHM Architecture: 3.1.0

For demonstration and ewvaluation purposes only

Goftware supplied by: ARM Limited

Stop> |
< | » \cmd fstao JFieFind fLog / J J "

Stopped Lh 1, Col 1

Figure 8

If you receive an error when enabling trace, verify that your target does have an ETM and that
it is supported by your version of RVI firmware. If you are tracing with RVT, check that
RealView ICE (RVI) and RVT are properly connected and RVT is connected to your target
through the 38-pin Mictor connector. If you are tracing with an Embedded Trace Buffer (ETB),
check that you have properly enabled ETB trace from the RVI Configuration Utility as described
in Section 3.1.

Once trace is enabled, you can configure it from the "Tools - Analyzer/Trace Control - Configure
Analyzer Properties" menu. The options available in the ETM Configuration dialogue depend
upon your ETM architecture version and the features it has enabled. You can expect some
dialogue options to be unavailable for selection (i.e., grayed out). A sample configuration
dialogue for the ETM v3.1 architecture is shown below.

DAI0O168B
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3.3

A Configure ETM X
Architecture: 3.1

Trace data wicth ;— Trace port mode Trace huffer packing
i 4 bit Part speed:ETM clock speed &+ A tomatic
i & hit 2 ™ Mormal packing

: -

+ 16 hit " Double packing
i ~ i
I | Dizable traceport

FIFC overflow protection Trace coproc register transfer
% Mo protection * Mone
i |
" Data suppression ™ Only when tracing data

FIFC highweater |0

Extended external input selection
nput 1 [ Input 2 [ [

[~ Memory map decode 0000
Synchronization frequency | 1024

[~ Enable timestamping

[ Cycle accurate tracing
[ Data only trace (Do not trace instructions)
-

| =
Ok | Cancel | Help |

Figure 9

The remainder of this Application Note assumes that trace is properly enabled and the ETM is
properly configured. Consult the Technical Reference Manual for your specific ETM and the
RVD Trace User Guide for guidelines on configuring the ETM.

Reducing the Trace Buffer Size

RVD sets the default trace buffer size for RVT to the maximum (4,194,304). This results in a
tremendous amount of trace information that can take RVD several seconds to process and
display. If you prefer to capture less data and have it displayed more quickly, you can adjust the
trace buffer size using the "Edit - Set Trace Buffer Size" menu from the Analysis window:

10

Copyright © 2006. All rights reserved. DAIO168B



Application Note 168

£ Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =Jokd
[ Eile | Edit “iew Find Filter Sort Trace Data Profiling Data Help
= bl Bz Copy Ciric
%ﬁ Connect/Disconnect Analyzer | Address | opcode Other -
<No H

Tracing Enabled
Configure Analyzer Properties...
Set Trace Buffer Size...
Store Confrol-Elow Changes Only
Buffer Full Mode

Trigger Mode »
Data Tracing Mode »
Automatic Tracing Mode 2
Set/Edit Event Triggers...

Clear &l Event Triggers

Physical to Logical Address Mapping. ..

4| ¥\ Trace fSource AProfiIe / J J 4
Adjusts size of actual race buffer Tracing enabled
Figure 10

Valid trace buffer sizes are 16,384 to 4,194,304. If you are using an ETB, the trace buffer size
is based on the design of your target's ETM and it can not be modified.

&¥ Enter Value X

\11) Enter buffer size to set:

|4134304

Set Cancel |
Figure 11
Note
A trace buffer size of 1,000,000 should be sufficient to replicate the trace captures in Sections 4
- 8.
3.4 Target Specific Information

The trace captures presented in this Application Note were made using an ARM1136JF-S Core
Module with RVD v3.0. This target features an ETM11RV which is based on ETM Architecture
v3.1. Trace captures made from ETM v1.x architectures will appear different in RVD v3.0:

. For v1.x ETMs, the Elem (element) column starts with "-N" and decrements to the last
element "0". The element number may not always decrement by one. The decrement
factor depends on the contents of each trace packet and the trace buffer packing setting.
For v3.x ETMs, the element column starts with 0 and increments sequentially to "N".

DAIO168B Copyright © 2006. All rights reserved. 11
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. For v1.x ETMs, the Time/cycle column of the Analysis window is unpopulated if Cycle
Accurate trace or Timestamping is not enabled. For v3.x ETMs, the Time/cycle column
provides an instruction count if Cycle Accurate trace or Timestamping is not enabled.

The following captures, from an ARM926 (ETM v1.3) and ARM1136 (ETM v3.1) respectively,
demonstrate these differences:

Trace from ARM926EJ-S:

£ Analysis = @ ARM926E J-S_0:ARM-ARM-NW [Unattached] =Jokd
[ File Edit wiew Find Filter Sort Trace Data Profiling Data Help

= [

Elem | Time/pico | Type | Symbolic | Address | Opcode 0ther A
%, Warning: Trace pause
Exec _ main O0x00005000 OxEADQ0000 B _ scatterload rti <0xS008>
Exec _ scatterload rta 0x00003005 0xEZ5F0025 ADR r0, {pct+0x30 ; O0x3038
Exec _ scatterload rta 0x0000300C 0xES900C00 LDM r0,{rl0,rll}
Exec _ scatterload rta 0x00005010 OxEQSAA000 ADD rlo,rl0,x0
Exec _ scatterload rta 0x00005014  OxEOSEEQOO ADD rll,rll,x0
Exec _ scatterload rt2 0x000080158  0xEZ447001 SUB r7,rl0,#1
Exec _ scatterload null O0x0000501C OxELSAQO0E CHMP rlo,rll
Source KProfiIe / 4 j 4

Tracing enabled

Figure 12
Trace from ARM1136JF-S:
o .
£ Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =Jokd
[ File Edit view Find Filter Sort Trace Data Profiling Data Help
= BHE-
Elem | Time/inst| Type | Symbolic | address | opcode Other -
0 Warning: Debug state
Exec _ main O0x00005000 OxEADO0O0D B _ scatterload rti <0xS008>
Exec _ scatterload rta 0x00003005 0xEZ8F0025 ADR r0, {pct+0x30 ; O0x3038
Exec _ scatterload rta 0x0000300C 0xES900C00 LDM r0,{rl0,rll}
Exec _ scatterload rta 0x00005010 OxEQSAAO000 ADD rlo,rl0,x0
Exec _ scatterload rta O0x00005014  OxEOQSEEOOO  ADD rll,rll,x0
Exec _ scatterload rtz 0x00008018  OxEZ447001 SUB r7,rl0,#1
Exec _ scatterload null O0x0000501C OxELSAQ00E CHP rlo,rll

Source KProfiIe / J J 4

Tracing enabled

Figure 13
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4 Auto Tracing

After trace is enabled and configured as described in Section 3, RVD places your target in an
Auto Tracing mode by default. This means that if you run and halt your program, instruction
trace will automatically be captured.

4.1 Tracing from Program Entry

To observe how Auto Tracing works, load TRACE.AXF to your target. Place a breakpoint at the
call to Init() from main(), as shown below.

FARVDEBUG = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =JoEd
[ File Edit Yiew Target Debug Tools Help
DEH & ) 2a Gl aeRPes tIXSsl RN F-&-
Fileltrace.c Find | j Line
S
" 1=
* Function: main
*
* Arquments: None
* Returns: Hewver
*
* Purpose: Program executive which simulates a simple I/0
* system. It waits a random time to perform data |
* processing. Processing consists of: 3
* Generating input data (to simulate an ADC)
* Computing the awverage of the input
* Outputing the average and some input samples
*
L
int main (wvoid)
int sample_num=0; /% local to track nuwher of samples */
= /% initialize board and data */
Init():
/% enter program executive, loop continually in main control loop */
printf ("Entering main control loopin™):
while(l}
{
A% bunp global execution counter */
num_runs+=1;
/% use rand() to simulate polling and determine if ADC has new data */
A% ADC data iz awailable if sample_ready is =zero */
sample_ready = (rand():N):
if (sample_ready==0)
‘ .
LR \DsmKSrc i trace.c / 4 j 4
]
g load/pds/r 'C:YAN168%code) trace. axt!’
ﬂ Loading file C:%AN168%code)\trace.axf...
binstr “TRACE‘\#659:1
Stop>
< | » \cma fstao JFieFind fLog / J J
Stopped Ln 65, Caol 1
Figure 14

Run to the breakpoint. When the breakpoint is reached, program execution is stopped and the
contents of the trace buffer are sent to RVD for display.

A trace capture is viewed in the Trace Analysis window. The Trace Analysis window can be
opened from the "View - Analysis Window" menu. This option is only available when trace is
enabled.

Open the Trace Analysis and observe your Auto Tracing capture. You should see that tracing
begins from your program entry point, 0x8000 if built with the supplied files.

DAIO168B Copyright © 2006. All rights reserved. 13
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&F Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached]

M= X

=& [

[ File Edit wiew Find Filter Sort Trace Data Profiling Data Help

Elem | Time/inst | Type | Symbolic | address | opcode Other -
u] Warning: Debug state

o -13z8 Exec _ main O0x00005000 OxEADQ0000 B _ scatterload rti <0xS008>
1 -1325 Exec _ scatterload rta 0x00003005 0xEZ5F0025 ADR r0, {pct+0x30 ; O0x3038

2 -1327 Exec _ scatterload rta 0x0000300C 0xES900C00 LDM r0,{rl0,rll}

3 -13z26 Exec _ scatterload rta 0x00005010 OxEQSAA000 ADD rlo,rl0,x0

4 -1325 Exec _ scatterload rta 0x00005014  OxEOSEEQOO ADD rll,rll,x0

5 -1324 Exec _ scatterload rta 0x00005018 OxEZ447001 5UEB r7,rl0,#1

] -1323 Exec _ scatterload null O0x0000501C OxELSAQO0E CHMP rlo,rll

7 -l3zz NoExec _ scatterload null 0x00005020 0x0A0O0LSE BEQ __rt entry <0x5654

g -1321 Exec _ scatterload null 0x00005024 0xESEA000F LDM rlo! , fr0-r3}

9 -1320 Exec _ scatterload null 0x00003025 0xEZ4FE014 ADE lr,{pc}-0Oxc ; Ox80lc

10 -1318 Exec _ scatterload null Ox0000802C 0XE3130001 TST r3, #l

11 -1315 NoExec _ scatterload null 0x00003030 0x1047F003 SUBNE pc,r7,r3

1z -1317 Exec _ scatterload null 0x00005034  OxXELAQFO03 MOV pc,r3

13 -1318 Exec _ scatterload copy 0x00003040 0xEZ522010 3UBS rz,rz,#0x10

14 -1315 NoExec _ scatterload copy 0x00005044 0x25B000753 LDMCS r0! , {r3-r6}

15 -1314 NoExec _ scatterload copy 0x00003045 0x25410075 STHMCS rl!, {r3-re}

16 -1313 NoExec _ scatterload copy O0x0000504C OxSAFFFFFE EHI _ scatterload copy <0x8040-
17 -1312 Exec _ scatterload copy 0x00003050 0xE1BOZESZ L3LS ri,rz, #29

15 -1311 NoExec _ scatterload copy 0x00005054 0x25B00030 LDMCS r0!, frd,r5}

19 -1310 NoExec _ scatterload copy 0x00003055 0x25410030 STHMCS rl!, {rd,r5}

20 -1309 Exec _ scatterload copy 0x0000305C 0x45904000 LDEMI rd,[r0,#0]

4| k| Trace ,(Sourc:e KProfiIe /

<

| oy

Tracing enabled

Figure 15

The trace capture contains the application initialization performed by the C library. If you
examine the program's assembly code from the "Dsm" source tab in RVD and scroll to the end
of the trace buffer, you will see that tracing ends with the instruction immediately preceding the
call to Init() in main(). This instruction is highlighted in red below.

£ Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =Jokd
[ File Edit wiew Find Filter Sort Trace Data Profiling Data Help

== U2

Elem | Time/inst | Type | Symbolic | Address Opcode 0ther A

1308 -2l Exec _initio 0x00008EED OxESEDE070 POP {rd-ré,pc}

1309 -&0 Exec _ rt_lib_init 0x0000404C OxELA00000 MOV 0, x0

1310 -19 Exec _ rt_lib_init 0x00004050 OxELA00000 MOV 0, x0

1311 -15 Exec _ rt_lib_init O0x00004054 OxELA00000 MOV 0, x0

1312 -17 Exec _ rt_lib_init 0x00004058 OxELl&00004 MOV 0, rd

1313 -lg Exec _ rt_lib_init 0x0000A05C OxELA01005 MOV rl,r5

1314 -15 Exec _ rt_lib_init 0x00004060 OxELA0Z007 MOV ra,r?

1315 -14 Exec _ rt_lib_init O0x00004064 OxELA03008 MOV 3, r6

1316 -13 Exec _ rt_lib_init 0x0000A065 OxEZEDDOOC ADD ap,sp, #0xc

1317 -1z Exec _ rt_lib_init O0x0000A06C OxESEDOLFD POP {rd-r§}

1318 -11 Exec _ rt_lib_init 0x00004070 OxESEDEZ00 POP {r8,pc}

1319 -10 Exec __ rt_entry Ox00008660 OxESEZDO0O0F PUSH {r0-r3}

1320 -4 Exec __ rt_entry 0x00008670 OxEEOO0GES EBL _platform post_lib_init <0xalfc:

1321 -5 Exec _platform post_lib_init Ox0000&A05C OxESED4010 PUSH {rd,lr}

1322 -7 Exec _platform post_lib_init Ox0000A0A0 OxELA00000 MOV 0, x0

1323 -6 Exec _platform post_lib_init Ox0000&044  OxESEDS010 POF {rd,pc}

1324 -5 Exec __ rt_entry 0x00008674 OxESEDOOOF POP {r0-r3}

1325 -4 Exec __ rt_entry 0x00008678 OxEEFFFEEC EL main <0xE230-

1326 -3 Exec main 0x00005230 OxESED4070 PUSH {rd-ré,lr}

1327 -a Exec nain' #66 O0x00005234 OxE3404000 MOV rd, #0

1328 -1 Exec nain' #67. . #69 O0x00005238 OxEEFFFFDA EL Init <0x&laf>

4| » [ Trace ,(Sourc:e KProfiIe / 4 j v

Tracing enabled

Figure 16
4.2 Tracing to Another Breakpoint
As a follow on to the capture made in Section 4.1, remove the breakpoint at the call to Init() and
place another breakpoint in the while(1) loop at the instruction if (sample_ready == 0), as shown
below.
14 Copyright © 2006. All rights reserved. DAIO168B
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FIRVDEBUG = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached]

M= X

[ File Edit Yiew Target Debug Tools Help

D EE & malaE senres +3X(EEl 885

J_lFiIeItrac:e.c: [Find I LI [Line I |

i

int main (wvoid)
i

int sample_num=0; /% local to track nuwher of samples */

4% initialize board and data %/

A% enter program executive, loop contimually in main control loop */
printf ("Entering main control loopin™):

while(l)

i

A% bunp global execution counter */
num_runs+=1;

/% use rand() to simulate polling and determine if ADC has new data */
A% ADC data iz awailable if sample_ready is =zero */
sample_ready = (rand():N):

if (sample_ready==0)
i
/% start data processing secquence ¥/
printf ("Processing Sample: %dvn", sample num+) 2
GetDatal);
Getdverage(]:
SendDatal);
vo4% end if () *S

voo4% end while(l) */

Yoo/* end maini) *S

A |k [\ Dam £ Src g tracec

< | v

llolx

4 | 3 |‘ st fFileFind fLog £

[ [

|St3pped

negcorzt| [ [ [ A

Figure 17

Run to the new breakpoint from the current PC location and inspect the Trace Analysis window.
First notice that the old trace has been discarded. The new trace begins with the instruction BL
Init, which corresponds to the function call to Init(). This instruction is highlighted by the red

box below.

DAI0O168B
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£ Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =Jokd

[ File Edit wiew Find Filter Sort Trace Data Profiling Data Help

=& [

Elem | Time/inst | Type | Symbolic | address | opcode Other -
o] Warning: Debug state

1] -3362 Exec nain' #67. . #69 O0x00005238 OxEEFFFFDA EL Tnit <0x8lad> |
1 -3361 Exec Init 0x00005145 OxE3A00FFA MOV rl, #0x3ed

Z -3360 Exec Inith#113 Ox000051AC OxESSF11258 LDR rl,0x8z2dc

3 -3358 Exec Inith#113 0x000051ED 0xES510000 3TER 0, [rl,#0]

4 -3358 Exec Inith#lld 0x000051E4 0xE3A00E7D MOV rl, #0x7d0

5 -3357 Exec Inith#lld 0x000051ES 0xES510004 3T 0, [rl,#4]

] -3356 Exec Inith#l15 0x000081EC OxESSFOL1LC LDR r0,0x8zZe0

7 -3355 Exec Inith#l15 0x000081C0 0xES510005 3TR 0, [rl,#58]

g -3354 Exec Inith#ll6 O0x000051C4 0xE2400FF4 3UE 0, r0, #0x3ed

9 -3353 Exec Inith#ll6 0x000081CE 0xES51000C 3T 0, [rl,#0xc]
10 -3352 Exec Inith#117 O0x000081CC OxESSFO110 LDR r0,0x52Zed

11 -3351 Exec Inith#117 0x000051D00 0xES510010 3TER 0, [rl, #0x10]
1z -3350 Exec Inith #1158 0x000051D4 0xE2500FF4 ADD 0, r0, #0x3ed
13 -3349 Exec Inith #1158 0x000051D8 0xES510014 3T 0, [rl,#0x14]
14 -3348 Exec Inith#119 0x000051DC OxESSF0104 LDE r0,0x82ed

15 -3347 Exec Inith#119 0x000051ED 0xES510015 3TR 0, [rl, #0x18]
16 -3346 Exec Inith#120 O0x000051E4 0xE1400050 L3L r0,x0,#1

17 -3345 Exec Inith#120 0x000051ES 0xES51001C 3TER 0, [rl, #0xlc]
15 -3344 Exec Inith#l21 0x000081EC 0xE3A00E7D MOV rl, #0x7d0

19 -3343 Exec Inith#l21 0x000051F0 0xES510020 3TR 0, [rl,#0xz20]
z0 -3342 Exec Inith#l22 O0x000051Fd 0xE3A00FFa MOV rl, #0x3ed

4| k| Trace ,(Sourc:e KProfiIe / 4 j 4

Tracing enabled

Figure 18

The Analysis window supports source code tracking to help you follow the execution of your
program. Highlight a sample from Init(), such as trace Element 10 shown below.

£ Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =Jokd
[ Eile Edit Yiew Find Filter Sort Trace Data Profiling Data Help

& H BE -

Elem | Time/inst | Type | Symbolic | address | opcode Other -

u] Warning: Debug state

o -3362 Exec main' #67. . #69 0x00008235 0xEEFFFFD& EL Init <0x&laf>

1 -3361 Exec Init 0x00005 145 0xE3A00FF& MOV rl, #0x3ed

Z -3360 Exec Inith#113 O0x000051AC 0xESSFL1E5 LDE rl,0x8z2dc

3 -3359 Exec Inith#113 0x000081E0 0xES510000 3TER 0, [rl,#0]

4 -3358 Exec Inity#114 O0x000051E4 0xE3A00E7D MOV rl, #0x7d0

5 -3357 Exec Inity#114 0x000081E5 0xES510004 3T 0, [rl,#4]

& -3356 Exec Inith#115 0x000081EC 0xESSFO0L1C LDE r0,0x8zZe0

7 -3355 Exec Inith#115 Ox000081C0 0xES510005 3TR 0, [rl,#58]

g -3354 Exec Inith#lle Ox000081C4 0xE2400FF4 3UE 0, r0, #0x3ed

£l -3353 Exec Inith#lle O0x000081C5 0xES51000C 3TR r0,[rl,#0xc]

10 -3352 Exec Inith#117 Ox000081CC 0xESSF0110 LDE r0,0x52ed

11 -3351 Exec Inith#117 000008100 0xES510010 3TER 0, [rl, #0x10]

1z -3350 Exec Inith#lla 0x00005104 0xE2500FF4 ADD 0, r0, #0x3ed

13 -3349 Exec Inith#lla 0x00008105 0xES510014 3T 0, [rl,#0x14]

14 -3345 Exec Inith#119 0x0000810C 0xESSF0104 LDE r0,0x82ed

15 -3347 Exec Inith#119 0x000051ED 0xES510015 3TR 0, [rl, #0x18]

16 -3346 Exec Inith#lz0 O0x000051E4 0xE1400050 L3L r0,x0,#1

17 -3345 Exec Inith#lz0 0x000051ES 0xES51001C 3TER 0, [rl, #0xlc]

15 -3344 Exec Inith#l2l 0x000081EC 0xE3A00E7D MOV rl, #0x7d0

19 -3343 Exec Inith#l2l 0x000081F0 0xES510020 3TR 0, [rl,#0xz20]

20 -3342 Exec Inith #1222 O0x000051F4 0xE3A00FFa MOV rl, #0x3ed

4| k| Trace ,(Sourc:e KProfiIe / 4 j 4

Tracing enabled

Figure 19

Now click on the Source tab in the Analysis window and observe the effects of source code
tracking. Namely, line 117 in the source file TRACE.C is now highlighted. This line of C code
corresponds to the highlighted element from the Trace tab. Now highlight another line from the
Source tab and toggle back to the Trace tab. Observe that source code tracking can be used from
both tabs.

16
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£ Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =Jokd
[ Eile Edit Yiew Find Filter Sort Trace Data Profiling Data Help
=" i U g
Func/Line | Source ~
97
95
99 *
100 * Function: Init
101 *
102 * Arcuments: None
103 * Returns: Void
104 *
105 * Purpose: Initialize the input wector.
106 *
107 *
105
109 void Init (woid)
110 i
111
112 /% initialize the input wvector */
113 input[0] = 1000
114 input[1] = 000
115 input[2] = -3000
116 input[3] = -4000
17 input[4] = 5000
115 input[5] = 6000
119 input[6] = -1000
120 input[7] = -2000
121 input[8] = 2000;
122 input[9] = 1000;
123 input[10] = -2000
124 input[11] = -3000
125 input[12] = 5000
126 input[13] = 2000
127 input[14] = -1000
128 input[15] = -3000
129
130
131 voo/% end Init() %/
kil
< | » [ Trace J Source ,(Profile / 4 j w
Tracing enabled
Figure 20
Note

Source code tracking from the Analysis window also causes source code tracking to occur in the
RVD code window. You can bring the PC back into focus by right-clicking in the RVD code
window and selecting "Scope to PC". This has no effect on the Analysis window.

If you scroll through the entire trace buffer, you will see that over 3000 samples are captured.
Most of these are attributed to the printf() for printing the message "Entering main control loop".
The ARM libraries are supplied only in object form. If you try and view the source code of
traced library code, you will see the message "no source available" in the Analysis window.

DAI0O168B
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5 Trace Start and Stop Points

Trace Start and Stop points are used to define points in your code where tracing will start and
stop. They are most useful for reducing the amount of trace which can be generated from Auto
Tracing and they allow one to focus on specific areas of program execution.

5.1 Using a Trace Start Point

Trace Start points are used to initiate trace capture and do not require a matching Trace Stop
point. For instance, to bypass the capture of the application startup code, you could place a
Trace Start point at the call to Init() and use a breakpoint to end the trace capture.

Place the cursor in the left gutter of the Init() line in the source window, click the left or right
mouse button and select Set/Toggle Tracepoint as shown below.

FARVDEBUG = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =JoEd

[ File Edit Yiew Target Debug Tools Help
D@ & s EE ardares +3 X EE0|BBE-5-

Fileltrace.c Find | j Line l—
*j’ .A.
int main (wvoid)
int sample_num=0; /% local to track nuwher of samples */
/% initialize board and data %/
— Set Break
G0 To Here tinually in main control loop %7

n");
Scope to Here
Show Disassermbly/Source at this Location

*
Set Break...

Set BreakIf...
. g and determine if ADC has new data */
Set/Toggle Tracepoint... le ready is zero */

Set Detailed Tracepoint...
Set Trace Fange

Break Infa... ence */

dvn", sample num+) ;

Patch Asrm Interactive. ..
Set PC 1o Here

Vo4 oend if () S

voo4% end while(l) */

Yoo/* end maini) *S

4 | » |\DsmKSrc }\trace.c/ 4 | jv
=
j=|
=l
4| » [\ omd ) Staio fFieFind Alog / J J
Stopped Lh 65, Caol 2
Figure 21

From the List Selection dialogue, select "Trace Start Point" and click "OK" as shown below.
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£lList Selection X

Select tracepoint to set:

Set Trigger

Trace Start Point

Trace End Point

Start of Trace Range (Instruction Only)

Start of Trace Range (Instruction and Data)

Start of Excluded Trace Range [Instruction and D ata)
Start of Excluded Trace Range [Data Only)

Set Externaldut] Point

Set Externaldut2 Point

QK I Cancel | Help |

Figure 22

This operation will place a Trace Start point on the call to Init(). The Trace Start point appears
in the gutter as a green downward arrow as shown below.

FARVDEBUG = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =JoEd
[ File Edit Yiew Target Debug Tools Help

D EE & s manE srnres +3X(EEl 885
J_lFiIeItrac:e.c: [Find I LI [Line I |

wg w

int main (wvoid)
int sample_num=0; /% local to track nuwher of samples */

/% initialize board and data %/
w Init():

A% enter program executive, loop contimually in main control loop */
printf ("Entering main control loopin™):

while(l)

i

A% bunp global execution counter */
num_runs+=1;

/% use rand() to simulate polling and determine if ADC has new data */
A% ADC data iz awailable if sample_ready is =zero */
sample_ready = (rand():N):

. if (sample_ready==0)
i
/% start data processing secquence ¥/
printf ("Processing Sample: %dvn", sample num+) 2
GetDatal);
Getdverage(]:
SendDatal);
vo4% end if () *S

voo4% end while(l) */

voo/% end main() ¥/

A |k [\ Dam £ Src g tracec <| | _bIM

llolx

] | b |‘ St fFileFind {Lag / ;| _>|
Stopped [tn 65, col 1 [ A

Figure 23
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Reload the image using the "Target - Reload Image to Target" menu. Observe that reloading the
image from this menu retains your breakpoint and tracepoint. This reload operation will be used
throughout the Application Note.

Run to the breakpoint. Notice that the trace capture is the same trace as that from Section 4.2.
Namely, the application startup code is not traced, and tracing begins with the BL Init instruction
at address 0x8238.

There is one minor difference in the captures. This capture begins with "Warning: Trace pause"
to indicate that the target was running when trace became activated from executing the Trace
Start point. The capture made with Auto Tracing in Section 4.2 starts with "Warning: Debug
state" to indicate that the target was in debug mode (halted) just before tracing began.

£ Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =Jokd

[ File Edit wiew Find Filter Sort Trace Data Profiling Data Help

=& [

Elem | Time/inst | Type | Symbolic | address | opcode Other -
o] Warning: Trace pause

1] -3362 Exec nain' #67. . #69 | O0x00005238 OxEEFFFFDA  EL Init <0x8lad> |
1 -3361 Exec Init 0x00005145 OxEZA00FFA MOV rl, #0x3ed

Z -3360 Exec Inith#113 Ox000051AC OxESSF1128 LDE rl,0x8z2dc

3 -3358 Exec Inith#113 0x000051ED 0xES510000 STR. 0, [rl,#0]

4 -3358 Exec Inith#lld 0x000051E4 0xE3A00E7D MoV rl, #0x7d0

5 -3357 Exec Inith#lld 0x000051ES OxES510004 STR. 0, [rl,#4]

] -3356 Exec Inith#l15 0x000081EC OxESSFOLLC LDE r0,0x8zZe0

7 -3355 Exec Inith#l15 0x000081C0 0xES510005 STR. 0, [rl,#58]

g -3354 Exec Inith#ll6 O0x000051C4 0xE2400FF4 SUB 0, r0, #0x3ed

9 -3353 Exec Inith#ll6 0x000081CE OxES51000C STR. 0, [rl,#0xc]
10 -3352 Exec Inith#117 O0x000081CC OxESSFO110 LDE r0,0x52Zed

11 -3351 Exec Inith#117 0x000051D00 0xES510010 STR. 0, [rl, #0x10]
1z -3350 Exec Inith #1158 0x000051D4 0xEZ500FF4  ADD 0, r0, #0x3ed
13 -3349 Exec Inith #1158 0x000051D8 O0xES510014 STR. 0, [rl,#0x14]
14 -3348 Exec Inith#119 0x000051DC OxESSF0104 LDE r0,0x82ed

15 -3347 Exec Inith#119 0x000051ED 0xES510015 STR. 0, [rl, #0x18]
16 -3346 Exec Inith#120 O0x000051E4 0xE1&00050 L3L r0,x0,#1

17 -3345 Exec Inith#120 0x000051ES 0xES51001C STR. 0, [rl, #0xlc]
15 -3344 Exec Inith#l21 0x000081EC 0xE3A00E7D MoV rl, #0x7d0

19 -3343 Exec Inith#l21 0x000051F0 0xES510020 STR. 0, [rl,#0xz20]
z0 -334z Exec Inith#l22 0x000051F4 0xE3A00FFa2 MOV rl, #0x3ed

4| k| Trace ,(Sourc:e KProfiIe / J J 4

Tracing enabled

Figure 24

5.2 Using Trace Start/Stop Points to Time Function Execution

A Trace Start and Trace Stop point pair can be used to determine the execution time of a
function. To obtain timing information from trace, either Cycle Accurate trace or Timestamping
must be enabled. These selections are made from the ETM Configuration dialogue. By default
both options are disabled.

20
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A Configure ETM X
Architecture: 3.1

Trace data wicth ;— Trace port mode Trace huffer packing
i 4 bit Part speed:ETM clock speed " Automatic
i & hit 2 % Mormal packing

: -

% 16 hit " Double packing
i ~ i
I [ Disable traceport

FIFC overflow protection Trace coproc register transfer
% Mo protection * Mone
i |
" Data suppression ™ Only when tracing data

FIFC highweater |0

Extended external input selection
nput 1 [ Input 2 [ [

[~ Memary map decode | gxoo00
Synchronization frequency | 1024

Enable timestamping

Cyele accurate tracing

[ Dsta onlytrace (Do not trace instructions)

| =
Ok | Cancel | Help |

Figure 25

Note

Time stamps are applied by RealView Trace as the trace capture is made, so this option is not
available if tracing with an Embedded Trace Buffer.

In this scenario, Cycle Accurate trace is used in conjunction with Trace Start and Stop points to
determine the execution time of GetData(). Remove the previous setup and replace it with the
following setup:

. Trace Start is placed in GetData() at the line which sets input[0].
. Trace Stop is placed at the closing brace of GetData().
d Enable Cycle Accurate tracing from the ETM Configuration dialogue.

DAI0O168B
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FARVDEBUG = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =JoEd

[ File Edit Yiew Target Debug Tools Help

D EE & 2Rl BE srnret +dX | EEl 885

J_lFiIeItrac:e.c: [Find I LI [Line I |
]
*
* Function: GetData
*
* Arruments: None
* Returns: Void
* Globals: Modifies input[].
*
* Purpose: Simulates reading a buffer of data from an ADC
* input chamnel. This function just generates
* "randon” data for the program starting from an
* initialized wvector.
*

i

woid GetData(woid)
i

int i;
mw input[0] = input[0] * { (input[NUM_SAMPLES-1] »> 1) + 1)
for (i=1; i<NUM SAMPLES: i++)

i
input[i] = input[i] *~ [ (input[i-1] => 1] + 1]:

voo/% end GetDatal) /7
A |k [\ Dam £ Src g tracec <| | _bIM

il clear,h 1

clear,h 2

:l trace,prompt “YTRACE#153:1
trace,prompt “YTRACE\#16Z:2
etn config, half,packauto,cycle

Stop> |
O | v I omd S0 JFieFind fLog ;| _>|

Stopped [tn 75, col 1 [ A

Figure 26

The Disassembly source view (from the Dsm tab) of GetData() and the trace points are shown

22
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FARVDEBUG = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =JoEd
[ File Edit Yiew Target Debug Tools Help
Dwd & 2alEE s e0 23N S&FHIBEE-F
File: [Dsm x| |Lire
GetData: -
[ 00008144 E59F1190 LDE rl,0x8z2dc
00005148 ES911000 LDR rl,[xl,#0]
0000514C ES9F21858 LDR rz,0xgz2de
00005150 ES92203C LDR r2,[r2,#0x3c]
00005154 E3AQ03001 MOV r3, #l
00005155 EO8320C2  ADD rZ,r3,ri,A5R #1
0000515C E0Z11002 EOR rl,rl,ra
00005160 ES9F2174  LDR rz,0xgz2de
00005164 ES821000 ST rl,[r2,40]
00005165 E3AQ000L MOV 0, #1
0000516C EA000004 B 0x519c <TRACE' #155>
00005170 ES9F1164  LDR rl,0x8z2dc
00005174 E7911100 LDR rl,[rl,r0,L8L #2]
00005175 EzZ402001  SUB ra,r0,#1
0000517C ES9F3158  LDR r3,0x82de
00005180 E7932102  LDR r2,[r3,r2,L8L #2]
000051584 E3AQ3001 MOV r3, #l
00005185 EO8320C2  ADD rZ,r3,ri,A5R #1
0000518C E0Z11002 EOR rl,rl,ra
00005190 ES9F2144  LDR rz,0xgz2de
00005194 E7821100 STR rl,[r2,r0,L8L #2]
00005195 EZ500001  ADD r0,x0,#1
000o0519c E3500010 CHP rl, #0x10
00005140 BAFFFFFZ  EBLT 0x5170 <TRACE\#157>
4k 00008144 E1ZFFFIE EX 1r
Init:
4 |k [\ D=m ,(Src: Atrace.c/ 4 j w
ﬁ clear,h 1
g clear,h 2
ﬂ trace,prompt “YTRACE#153:1
trace,prompt “YTRACE\#16Z:2
etn config, half,packauto,cycle
Stop>
< | » \cma fstao JFieFind fLog / J J
Stopped Lh 1, Col 1

Figure 27

Reload the program using the "Target - Reload Image to Target" menu such that your trace
points are retained. Run the program for a few seconds and then stop it. Observe the program

output in the RVD StdIO output window:

ﬁ Entering main control loop
g Processing Sample: 0

ﬂ Procezsing Sample:
Processing Sample:
Processing Sample:
Processing Sample:
Processing Sample:

s W

Processing Sample: &
« | » [ cmd y stdio £ FileFind K‘Log /

[ [

Stopped

Ln 45, Cal 13

Figure 28

Open the Trace Analysis window, scroll through the trace capture and observe the following:

. Only instructions from GetData() are traced.

. A continuous trace segment begins with the LDR instruction at 0x8144 and ends with the

BLT instruction at 0x81A0.

d Just before trace is paused, the final BLT instruction is not executed and is marked

"NoExec" in the Type column.

. The BX LR instruction which returns from GetData() is not traced due to the placement

of the Trace Stop point (see the previous Dsm source view).

DAI0O168B
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Trace discontinuities are marked by "Warning: Trace Pause". This message represents the
execution between the exit of GetData() and the entry of GetData() when trace is not
captured.

After the trace pause, tracing always starts again from the Trace Start point.

s .
£ Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =Jokd
[ File Edit view Find Filter Sort Trace Data Profiling Data Help
=E U2
Elem | Time/cycl | Type | Symbolic | Address | Opcode 0ther A
410 26,971,513 Exec GetData' #157 O0x0000518C 0xE0Z211002 EOR rl,rl,ra
411 26,971,514 Exec GetData' #157 0x00005190 OxES9FzZ144 LDE rz,0xgz2de
41z 26,971,712 Exec  GetData‘#157 0x00008194  OxE7821100 STR rl,[r2,r0,L8L #2]
413 26,971,750 Exec GetData\ #155 0x00005198 0xE2500001 ADD r0,x0,#1
414 26,971,751 Exec GetData\ #155 O0x0000519C 0xE3500010 CHMP rl, #0x10
415 26,971,752 NoExec GetDatah#155 Ox00005140 0xBAFFFFF2 ELT O0x5170 <TRACEY#157>
415 Warning: Trace pause
416 50,480,377 Exec GetData Ox00005144 0xESSFL190 LDE rl,0x8z2dc
417 50,450,520 Exec GetData\#153 0x00005148 0xES911000 LDE rl,[rl,#0]
415 50,450,549 Exec GetData\#153 0x0000514C 0xES9FZ185 LDE rz,0xgz2de
419 50,450,736 Exec GetData\#153 0x00005150 0xES92203C LDE ra, [rZ,#0x3c]
4z0 50,450,765 Exec GetData\#153 0x00005154 0xE3403001 Moy r3, #l
421 50,450,765 Exec GetData\#153 0x00005158 0xE0S320C2 ADD rZ,r3,r, ASE #1
422 50,450,769 Exec GetData\#153 0x0000815C 0xE0Z211002 EOR rl,rl,ra
4| k| Trace ,(Sourc:e KProfiIe / J J 4
Tracing enabled

Figure 29

Note

The effects of Cycle Accurate trace can be observed in the second trace column, "Time/cycle".
By default RVD will display the time in cycles. This column only contains valid timing
information if Cycle Accurate trace or Timestamping is enabled.

To determine the execution time of GetData(), highlight the instruction after a trace pause
message (this will be the instruction at the Trace Start point):

£ Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =Jokd

[ File Edit wiew Find Filter Sort Trace Data Profiling Data Help

=& [

4| k| Trace ,(Sourc:e KProfiIe / 4

Elem | Time/cycl | Type | Symbolic | Address | Opcode 0ther A
415 27,920,160 NoExec GetData\#l55 000005140 0xBAFFFFFZ ELT 0x5170 <TRACE\#157>
415 Warning: Trace pause

416 51,935,185 Exec GetData 0x000051 44 0xESSF11590 LDE rl,0x82dc |

417 51,935,325 Exec GetData\#153 0x00005145 0xES911000 LDE rl,[rl,#0]

415 51,935,357 Exec GetData\#153 Ox0000514C 0xES9FZ1585 LDE rz,0xgz2de

419 51,935,544 Exec GetData\#153 000008150 0xES92203C LDE ra, [rZ,#0x3c]

4z0 51,935,573 Exec GetData\#153 Ox00005154 0xE3403001 MOV r3, #l

421 51,935,576 Exec GetData\#153 0x00008155 0xE0S32Z0C2 ADD rZ,r3,ri,A5R #1

422 51,935,577 Exec GetData\#153 O0x0000815C 0xE0Z211002 EOR rl,rl,ra

423 51,935,575 Exec GetData\#153 O0x00008160 0xES9FZ174 LDE rz,0xgz2de

424 51,935,616 Exec GetData\#153 Ox00005164 0xESSZ1000 3TR rl,[rZ,#0]

425 51,935,654 Exec GetData\#154. . #155 0x00008165 0xE3400001 MOV 0, #1

426 51,935,655 Exec GetData\ #155 Ox0000816C 0xEA000004 B 0x519c <TRACE'\#155>
427 51,935,705 Exec GetData\ #155 Ox0000819C 0xE3500010 CHP r0,#0x10

425 51,935,753 Exec GetData\ #155 000005140 0xBAFFFFFZ ELT 0x5170 <TRACE\#157>
429 51,935,913 Exec GetData\#156. . 4157 O0x00008170 0xES9F1164 LDE rl,0x8z2dc

430 51,935,976 Exec  GetData\#157 0x00008174  0xE7911100 LDR rl,[rl,r0,L8L #2]

ME

Tracing enabled

Figure 30

Without clicking in the Analysis window, scroll down to the next Trace Pause message.
Right-click the BLT instruction just above the Trace Pause message and select "Time Measured
from Selected...":

24
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£ Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =Jokd
[ File Edit view Find Filter Sort Trace Data Profiling Data Help
= & [
Elem | Time/cycl | Type | Symbolic | Address | Opcode 0ther A
620 51,944,936 Exec  GetData\#157 0x000081594  OxET821100 STR rl,[r2,r0,L3L $2]
621 51,944,974 Exec  GetData\#155 0x00008198  OxE2800001 ADD r0,r0,#1
622 51,944,975 Exec  GetData\#155 0x0000819C  OxE3500010 CHMP 0, #0x10
623 51,944,976 NoExec Getl = * """ o ocecnstis S RAFFFFFZ BLT 0x%8170 <TRACE\#157>
623 Warning: Trace pause Copy
624 77,419,993  Exec  Getl ) ) ESSFL190 LDR rl,0x82dc
625 77,420,136 Exec Gerl  Track in Codeitfincow E5911000 LDR rl,[tl,#0]
626 77,420,165 Exec  Getl  Time Messure from Selected,,.  [E59F2188 LDR rz,0x82dc
627 77,420,352 Exec  Getl ES92203C LDR rz,[r2,#0x3c]
G628 77,420,381 Exec Getl Tirne Measure from Trigger E3403001 MOV r3,#1
629 77,420,384 Exec  Getl _ E08320C2 ADD r2,r3,r2,A45R #1
&30 77,420,385 Exec Gerl  Tind Mext F0211002 EOR rl,rl,r2
631 77,420,386 Exec  Getl  Find Previous ES9F2174 LDR rz,0x82de
632 77,420,424 Exec  Getl ES821000 STR rl,[r2,#0]
633 77,420,462 Exec  GetData\#154..#155  0x00008165  OxE3A00001 MOV r0,#1
634 77,420,463 Exec  GetData\#155 0x0000816C  OxEADDOOOA B 0x819c <TRACEY#155>
635 77,420,513 Exec  GetData\#155 0x0000819C  OxE3500010 CHMP 0, #0x10
4|k [} Trace ,(Sourc:e KProfiIe / 4 | |j w
Tracing enabled

Figure 31

RVD will return the time difference between the two trace samples. In this instance, the time
difference is the execution time of GetData(). The same measurement can be obtained by
manually subtracting the time of element 416 (51,935,185) from the time of element 623

(51,944,976):

Note

£l Prompt X

Time difference between Element
E23 and 416 iz 9791 cycles

Figure 32

Execution time is hardware dependent. Your measured execution time for GetData() may be

different.

The time unit of the trace elements and the computed time difference can also be displayed in
absolute time (i.e., uS). This selection is made from the "View - Scale Time Units" menu from

the Analysis Window:

DAI0O168B
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&F Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached]

M= X

[ Eile Edit | view Find Filter Sort Trace Data Profiling Data Help

== Update

Elem T Clear Trace Buffer | Address | Opcode 0ther A
612 51 - - 0x00008174  OxE7911100 LDR rl,[rl,r0,L5L #2]

613 51E Code Window Tracking 0x00008178  OxE2402001 SUB £2,0,#1

614 51 Ghow Position Relative to Trigger 0x0000817C  OxES9F3158 LDR r3,0x82dc

615 1 0x00008180  OxE7932102 LDR r2,[r3,r2,L8L #2]

616 51 Seale Time Units... 0x00008184  OxE3A03001 MOV 3,41

617 5] 0x00008188  OxE0S320C2 ADD r2,r3,r2,A5R #1

618 51 Define Processor Speed for Scaling. . 0x0000818C  OxE0211002 EOR rl,rl,rz

619 51 ) 0x00008190  OxE59F2144 LDR rz,0x82de

620 51| ¥ Automatic Undate on New Buffer 0x00008194  OxE7821100 STR rl,[r2,r0,L5L $2]

621 51,044,574  Exec  GetDatay#155 0x00008198  OxE2800001 ADD 0,0, #1

622 51,944,975 Exec  GetData\#155 0x0000819C  OxE3500010 CHMP 0, #0x10

623 51,944,976 NoExec GetData\#155 0x00008140  OxBAFFFFFZ BLT 0x%8170 <TRACE\#157>

523 Warning: Trace pause

624 77,419,993  Exec  GetData 0x00008144  OxES9FL190 LDR rl,0x82dc

625 77,420,136 Exec  GetData\#153 0x00008148  OxE5911000 LDR rl,[rl,#0]

626 77,420,165 Exec  GetData\#153 0x0000814C  OxE59F2188 LDR rz,0x82dc

627 77,420,352 Exec  GetData\#153 0x00008150  OxE592203C LDR r2,[r2,#0x3c]

4|k [} Trace ,(Sourc:e KProfiIe / 4 | |j w

Changes Time scale to units selected,

Tracing enabled

Figure 33

In order to convert cycles to absolute time units you must enter a processor speed from the "View
- Define Processor Speed for Scaling..." menu. The default processor speed is 20 MHz. Any
changes made to the time units and processor speed take immediate effect on the trace capture.

&F Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached]

M= X

[ Eile Edit | view Find Filter Sort Trace Data Profiling Data Help

== Update

Elem T Clear Trace Buffer | Address Opcode 0ther A
612 25 - - 0x00008174  OxE7911100 LDR rl,[rl,r0,L8L $27] |

613 25 B Code Window Tracking 0x00008178  OxE2402001 SUB rz,r0,$1

614 25 ghow Position Relative to Trigger 0x0000817C  OxES9F3158 LDR r3,0x82dc

615 5 0x00008180  OxE7932102 LDR r2,[r3,r2,L8L #2]

616 25  Seale Time Units... 0x00008184  OxE3A03001 MOV 3,41

617 25 0x00008188  OxE0S320C2 ADD r2,r3,r2,A5R #1

618 25 Define Processor Speed for Scaling. . 0x0000818C  OxE0211002 EOR rl,rl,rz

619 25 ) 0x00008190  OxE59F2144 LDR rz,0x82de

620 25 ¥ Automatic Undate on New Buffer 0x00008194  OxE7821100 STR rl,[r2,r0,L5L $2]

621 2597248.7  Exec  GetDatat#155 0x00008198  OxE2800001 ADD 0,0, #1

622 2597248.7 Exec  GetData‘#155 0x0000819C  OxE3500010 CHMP 0, #0x10

623 2597248.8 NoExec GetData)#155 0x00008140  OxBAFFFFFZ BLT 0x%8170 <TRACE\#157>

523 Warning: Trace pause

624 3870999.6 Exec  GetData 0x00008144  OxES9FL190 LDR rl,0x82dc

625 3871006.8 Exec  GetData‘#153 0x00008148  OxE5911000 LDR rl,[rl,#0]

626 3871008.2 Exec  GetData‘#153 0x0000814C  OxE59F2188 LDR rz,0x82dc

627 3871017.6 Exec  GetData‘#153 0x00008150  OxE592203C LDR r2,[r2,#0x3c]

4|k [} Trace ,(Sourc:e KProfiIe / J J w

Defines time of & cycle in processar,

Tracing enabled

Figure 34

Set the processor speed to your core speed and perform another time measurement using
absolute time. If you are using a 180 MHz clock, the 9791 cycles equate to 54.39 ps.

X]

Time difference between Element
£23 and 416 is 54.394444

- °
\1]) microseconds

#Prompt

Figure 35
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In your real application, Trace Start and Stop points may be particularly useful if you are
interested in timing a function that is interrupted by an interrupt service routine (ISR), because
the ISR will also be traced. This allows you to see the occurrence of ISR disruptions and
determine the absolute maximum execution time for a function.

DAI0O168B
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6 Trace Ranges

Trace Ranges provide an alternate method to Trace Start / Stop points for controlling the region
of your program that is traced. Trace Ranges allow you to define a continuous address range for
tracing. If the program counter (PC) resides within the defined address range, trace is captured.
If the PC is outside the address range, trace is not captured.

6.1 Comparing a Trace Range with Trace Start / Stop Points

To observe the difference between tracing with Trace Ranges and Start / Stop Points, the
while(1) loop of the sample program will be traced using each method.

Tracing while(1) with Trace Ranges

Reload TRACE.AXF and remove all trace points and breakpoints. Using the Disassembly
source view, place the trace range:

. Start of Trace Range (Instruction Only) at 0x8244 (on B 0x829C)

. End of Trace Range (Instruction Only) at 0x82A0 (just after B 0x8248)

FIRVDEBUG = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached]

M= X

[ File Edit Yiew Target Debug Tools Help

O Ed &% 2aEE sraiet +32 8 @&

0 B~ K | |Fie|Dsm Find | x| |Lire
main: S
00005230 ESZD4070  PUSH {rd-r6,lr}
00005234 E3A04000 MOV rd, #0
00005235 EEFFFFDA  EBL Init <0x5lad>
0000523C EZSFO0AC  ADR 0, {pci+ixbd ; OxGZf0
00005240 EEOOOOGSA  EBL _ Oprintf <0xG3E0-
[ 00008244 EA000O014 B Ox529c <TRACE #7353
00005245 ESSFOOEC  LDR r0,0x830c
00005240 ES900000 LDR r0,[x0,#0]
00005250 EZ500001  ADD r0,x0,#1
00005254 ESSF10ED LDR rl,0x830c
00005258 ES810000  STR r0,[xl,#0]
0000525C EEOOOOSS  BL rand <0x5454-
00005260 E1AQNSOOO0 MOV r5,x0
00005264 E3AQLO0LF MOV rl,#0x1f
00005265 EEOOOOSE  BL _ aeabi_idivmod <0x54ed>
00005260 ESSFO0SC  LDR r0,0x8310
00005270 ES80L000  STR rl,[x0,#0]
00005274 ES900000 LDR r0,[x0,#0]
00005275 E3500000 CMP rl, #0
0000527C 1A000006 ENE Ox529c <TRACE #7353
00005280 E1A0lood MOV rl,rd
00005254 E2544001  ADD rd, rd, #1
000052585 EZ8F00584  ADR 0, {pci+0xdc ; Ox8314
0000528C EEOOOOST  BL _ Oprintf <0xG3E0-
00005290 EEFFFFAE  EL GetData <0x5144-
00005294 EEFFFFS4  EBL Getidverage <0x5104
00005295 EEFFFFSL  EBL SendData <0x50ad-
0000529C EAFFFFES B Ox5248 <TRACE\ #77>
__user_initial_stackheap:
4 00008240 E9ZD403F PUSH {r0-r5,1r}
00005244 E1AQCOOO MOV rlz,r0
A4 | ¥ [\Dam ,(Src: Atrace.c/ J J 4
ﬁ trace,prompt 0x00005244 s
g trace,prompt Ox00005Z40
hd
Stop>
< | » \cma fstao JFieFind fLog / J J "
Stopped Ln 157, Cal 4
Figure 36
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Run the program for several seconds and stop it. Inspect the Analysis window and note the
following:

d Only instructions residing within the address range are traced.

. A "Warning: Trace pause" message is generated every time a function is called from the
while(1) loop.

. Most of the trace capture consists of the same four C lines, which call rand() and check
the value of sample_ready.

£ Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =Jokd

[ File Edit Yiew Find Filtler Saort Trace Data Profiling Data Help

= H -

Elem | Time/pico | Type | Symbolic | Address | Opcode 0ther A
35 10,720 Exec main' #77 0x00005254 0xESSFLOED LDE rl,0x830c

36 10,752 Exec main' #77 O0x00005258 0xES510000 STR. 0, [rl,#0]

37 10,950 Exec main' #78. . #51 Ox0000825C 0xEE0O00SS EL rand <0x5454-

37 Warning: Trace pause

38 11,865 Exec main' #51 0x00005260 0xE1a05000 Moy r5,x0

39 11,866 Exec main' #51 0x00005264 0xE340101F Moy rl,#0x1f

40 11,905 Exec main' #51 0x00005268 0xEE0OO0SE EL _ aeabi_idivmod <0x84ed>
40 Warning: Trace pause

41 15,113 Exec main' #51 Ox00005260 0xESSF00SC LDE r0,0x8310

42 15,216 Exec main' #51 0x00008270 OxESS01000 STR. rl,[x0,#0]

43 15,398 Exec main' #52. . #53 Ox00008274 OxES900000 LDE 0, [x0,#0]

44 15,439 Exec main' #53 0x00008278 0xE3500000 CHP rl, #0

45 15,440 Exec main' #53 0x0000827C 014000006 ENE Ox5259c <TRACEY#73>

46 15,497 Exec main' #73 Ox0000529C 0xEAFFFFES E Ox5248 <TRACEY#77>

47 15,545 Exec nain' #74. . #77 0x00005245 0xESSFO0EC LDE r0,0x830c

45 15,648 Exec main' #77 O0x0000524C OxES900000 LDE 0, [x0,#0]

49 15,831 Exec main' #77 0x00005250 0xE2500001 ADD r0,x0,#1

50 15,832 Exec main' #77 0x00005254 0xESSFLOED LDE rl,0x830c

51 15,5864 Exec main' #77 O0x00005258 0xES510000 STR. 0, [rl,#0]

5z 16,062 Exec main' #78. . #51 Ox0000825C 0xEE0O00SS EL rand <0x5454-

52 Warning: Trace pause

53 16,977 Exec main' #51 0x00005260 0xE1a05000 Moy r5,x0

54 16,978 Exec main' #51 0x00005264 0xE340101F Moy rl,#0x1f

55 17,017 Exec main' #51 0x00005268 0xEE0OO0SE EL _ aeabi_idivmod <0x84ed>
55 Warning: Trace pause

56 Z0,80%9 Exec main' #51 Ox00005260 0xESSF00SC LDE r0,0x8310

57 20,912 Exec main' #51 0x00008270 OxESS01000 STR. rl,[x0,#0]

4| | Trace ,(Sourc:e KProfiIe / 4 | |j 4

Tracing enabled

Figure 37

Search through the trace capture using the "Find - Find Address Expression" menu from the
Analysis Window. Search for 0x828C, the address of the BL __ Oprintf instruction for printing
the "Processing Sample" message:

&¥ Enter Value X

-
\11) Enter Address Expreszion for Address or auto-range to search with:

|Dxs2a0]

Find | Cancel |

Figure 38

You will be brought to the next occurrence in the trace buffer where sample_ready equals 0 and
processing occurs. Note that the functions __Oprintf(), GetData(), GetAverage() and
SendData() are not actually traced because they lie outside the active trace range.
Discontinuities in the trace capture are marked with "Warning: Trace pause".

DAI0O168B
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£ Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =Jokd
[ Eile Edit Yiew Find Filter Sort Trace Data Profiling Data Help
=" [
Elem | Time/cycl | Type | Symbolic | Address | Opcode 0ther A
192 66,920 Exec main' #51 0x00008270 OxESS01000 STR. rl,[x0,#0]
193 67,102 Exec main' #52. . #53 Ox00008274 OxES900000 LDE 0, [x0,#0]
194 67,143 Exec main' #53 0x00008278 0xE3500000 CHP rl, #0
195 67,144 NoExec main'\#53 0x0000827C 014000006 ENE Ox5259c <TRACEY#73>
196 67,146 Exec main' #54. . #56 O0x00008250 OxEla0l004 Moy rl,rd
197 67,147 Exec main' #56 Ox00005254 OxE2544001 ADD rd, rd, #1
195 67,145 Exec main' #56 Ox000052588 OxE25F0054 ADE 0, {pcl+0xdc ; Ox5314
199 67,149 Exec main' #56 Ox0000528C O0xEE0OO0ST EL Oprintf <0x&3£0- |
199 Warning: Trace pause
200 24,594,145 Exec main' #57 0x00005290 0xEEFFFFAE EL GetData <0x5ld4-
200 Warning: Trace pause
201 24,604,073 Exec main' #58 O0x00005294 0xEEFFFFo4 EL Getdverage <0x5104-
201 Warning: Trace pause
Z02 24,609,559 Exec main' #59 0x00005298 0xEEFFFFS1 EL SendData <0x50ad-
202 Warning: Trace pause
203 24,614,065 Exec main' #73 Ox0000529C 0xEAFFFFES E Ox5248 <TRACEY#77>
Z04 24,614,113 Exec nain' #74. . #77 0x00005245 0xESSFO0EC LDE r0,0x830c
205 24,614,216 Exec  main\#77 0x0000824C  0xES900000  LDR r0,[x0,#0]
Z06 24,614,399 Exec main' #77 0x00005250 0xE2500001 ADD r0,x0,#1
207 24,614,400 Exec main' #77 0x00005254 0xESSFLOED LDE rl,0x830c
208 24,614,432 Exec  main\#77 000008256  OxESS10000 STR r0,[xl,#0]
Z09 24,614,630 Exec main' #78. . #51 Ox0000825C 0xEE0O00SS EL rand <0x5454-
209 Warning: Trace pause
Z10 24,615,545 Exec main' #51 0x00005260 0xE1a05000 Moy r5,x0
211 24,615,546 Exec main' #51 0x00005264 0xE340101F Moy rl,#0x1f
Z12 24,615,585 Exec main' #51 0x00005268 0xEE0OO0SE EL __aeabi_idivmod <0x&de
4| k| Trace ,(Sourc:e KProfiIe / 4 j 4
Tracing enabled

Figure 39

Tracing while(1) with Trace Start / Stop Points

Reload TRACE.AXF and remove the Trace Range that you set in Section 6.1.1. Using the
Disassembly source view, place the Trace Start and Stop points:

. Trace Start at 0x8248 (on LDR r0, 0x830C)
. Trace Stop at 0x829C (on B 0x8248)
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FARVDEBUG = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] |- [0/
[ File Edit Yiew Target Debug Tools Help
D Ed & fmaEEE @Braie0 +3 08 &R
0 B~ K | |Fie|Dsm Find | x| |Lire
main: ~
000058230 E92ZD4070 PUSH {rd-r6,1r}
00005234 E3a04000 MOV rd, #0
000053235 EEFFFFDA  EL Init <0x51lad>
00005823C EZ5F00AC  ADR r0, {pci+0xbd ; O0x52£0
000053240 EEOOOOSA EBL _ Oprintf <0xG3E£0-
000053244 EA000014 B 0x529¢c <TRACE\ #73>
ﬁ 00005245 ES9FO0EC LDRE r0,0x530c
00005240 ES900000 LDR v, [r0,#0]
000053250 EZ2500001  ADD r0,r0,#1
00005254 ES9F10E0  LDRE rl,0x530c
00005258 ES810000  STR v, [rl,#0]
00005325C EEOOOOSS EBL rand <0x545L
00005260 Ela05000 MOV r5,x0
00005264 E3A0101F MOV rl,#0x1f
000053265 EEOOOOSE EBL _ aeabi_idivmod <0x54ed>
0000526C ESSF00SC  LDR r0,0x53310
00005270 ES80L000  STR rl,[r0,#0]
00005274 ES900000 LDR v, [r0,#0]
000053275 E3500000 CHMP r0,#0
00005327C 14000005 EBNE 0x529¢c <TRACE\ #73>
00005250 Ela0lood MOV rl,rd
000053254 E2544001  ADD rd,rd, #1
00005255 E25F0054 ADR r0, {pci+0x8c ; 0xE8314
00005325C EEOOOOST  EBL _ Oprintf <0xG3E£0-
000053290 EEFFFFAE EL GetData <0x514L-
000053294 EEFFFF94 EL Getdverage <0x5104-
000053295 EEFFFF31 EL SendData <0x50ads
Q 0000329C EAFFFFES B 0x5245 <TRACE\#77>
__user_initial_stackheap:
00005240 E9ZD403F PUSH {r0-r5,1r}
00005244 Ela0C000 MOV rlz,r0
00005245 E1A0E001 MOV 1lr,rl
4 _>_ \_Ijs_rﬁ k Src Ktrac:e.c: / J J ¥
ﬁ trace,proumpt 0x00003245
g trace,prompt Ox0000329C
~
Stop>
< | » \cma fstao JFieFind fLog / J J
Stopped Ln 169, Col 42
Figure 40
Run the program for several seconds and stop it. Inspect the Analysis window and note the
following:
. The while(1) loop and all function calls made from while(1) are traced
. The only instruction not traced is the Trace Stop point. This instruction (B 0x8248 located

at address 0x829C) is used to return to the top of the while(1) loop
. A "Warning: Trace pause" message is generated when the Trace Stop point is reached.

. After the trace pause message, the first traced instruction is the Trace Start point (LDR 10,
0x830C located at 0x8248).
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£ Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =Jokd
[ File Edit view Find Filter Sort Trace Data Profiling Data Help

=" i U g

Elem | Time/cycl | Type | Symbolic | Address | Opcode 0ther A

619 Z0,601 Exec main' #51 Ox00008260 0xESSF00SC LDE r0,0x8310

G20 Z0,704 Exec main' #51 Ox00008270 OxESS01000 STR. rl,[x0,#0]

G621 Z0,8586 Exec main' #52. . #53 Ox00008274 OxES900000 LDE 0, [x0,#0]

BZE 20,927 Exec main' #53 0x00008275 0xE3500000 CHP rl, #0

G223 20,928 Exec main' #53 Ox0000827C 014000006 ENE Ox5259c <TRACEY#73>

623 Warning: Trace pause

624 21,033 Exec main' #74. . #77 O0x00005245 0xESSFO0EC LDE. r0,0x830c |

GZ5 21,136 Exec main' #77 Ox0000524C OxES900000 LDE 0, [x0,#0]

GZ6 21,319 Exec main' #77 O0x00008250 0xE2500001 ADD r0,x0,#1

627 21,320 Exec main' #77 Ox00008254 0xESSFLOED LDE rl,0x830c

G258 21,352 Exec main' #77 0x00008255 0xES510000 STR. 0, [rl,#0]

629 21,550 Exec main' #78. . #51 Ox0000825C 0xEE0O00SS EL rand <0x5454-

&30 21,552 Exec rand Ox00005454 0xES9F304C LDE r3,0x584d58 <rand+0xSd-

G631 21,559 Exec rand 0x00005455 OxESZDEOO4 PUSH {1r}

G632 Z1,766 Exec rand O0x0000545C 0xESSFCO45 LDE rli,0x84dc <rand+0x58>

633 Z1,805 Exec rand 000005490 0xES932000 LDE ra, [r3,#0]

634 21,837 Exec rand Ox000054594 OxES930004 LDE 0, [r3,#4]

635 Z1,869 Exec rand 0x00005495 0xE79CELOZ LDE 1r,[rl&,r2,L5L #2]

636 Z1,501 Exec rand Ox0000549C 0xE79CL100 LDE rl,[rl&,x0,L5L #2]

637 21,933 Exec rand 000005440 O0xE2522001 SUBS ri,re, #1

635 21,935 Exec rand 000005444 0xE0S1100E ADD rl,rl,lr

4| k| Trace ,(Sourc:e KProfiIe / j 4

Tracing enabled

Note

Figure 41

On some ETM v1.x targets, the "Warning: Trace pause" message may not be generated because
the instruction located at the trace stop point (at address 0x8274) may also be traced.

Search through the trace capture using the "Find - Find Address Expression" menu from the
Analysis Window. Search for 0x828C, the address of the BL __Oprintf instruction for printing
the "Processing Sample" message:

& Enter Value

X]

-
\11) Enter Address Expreszion for Address or auto-range to search with:

|Dxs2a0]

Find |

Cancel |

Figure 42

You are brought to the next point in the buffer where sample_ready equals 0 and processing
occurs. Note that now the entire __Oprintf function is traced, unlike the Trace Range capture

made in Section 6.1.1:

32
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&¥ Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached]

M= X

[ Eile Edit Yiew Find Filter Sort Trace Data Profiling Data Help

=& [

Elem | Time/cycl | Type | Symbolic | Address | Opcode 0ther

1954 66,939 Exec nain' #8586 Ox00005254 OxEZ544001 ADD rd, rd, #1

1955 66,940 Exec nain' #8586 Ox000052588 OxEZEF0054 ADE 0, {pcl+0xdc ; Ox5314

1986 66,941 Exec nain' #86 Ox0000528C OxEEOO0OST EL Oprintf <0x&3£0%-

1987 66,993 Exec _ Oprintf 0x000083F0 OxESZDO00F PUSH {r0-r3}

1958 67,262 Exec _ Oprintf O0x000053F4 OxESSF2034 LDE ra, 08430 <_ Oprintf+0x40s-
1959 67,301 Exec _ Oprintf O0x000083FS OxESSF1034 LDE rl,0x8434 <_ Oprintf+0xdds
1990 67,333 Exec _ Oprintf O0x000083FC OxESZD4010 PUSH {rd,lr}

1991 67,3590 Exec _ Oprintf 0x00005400 OxEZED300C ADD r3,3p,#0xc

1992 67,391 Exec _ Oprintf Ox00005404 OxEQSFlO01 ADD rl,pc,rl

1993 67,392 Exec  _ Oprintf 0x000084058  OxESSDO00S LDR r0,[2p,#8]

1994 67,589 Exec _ Oprintf Ox0000540C 0xEEOO0OEE EL _printf char common <0x&7c0>
1995 67,591 Exec _printf_char common 0x000037C0 0xESZD400F PUSH {r0-r3,1r}

1996 67,862 Exec _printf char common  0Ox000057C4  OxELlA00001 MoV 0, rl

1997 67,863 Exec _printf char common  Ox000087CS OxELA01003 MoV rl,r3

1995 67,864 Exec _printf_char common 0x000037CC 0xEZ4DD044 SUB sp,sp, #0xdd

1999 67,866 Exec _printf char commorn 0x00008700 0xESED00LC STR. r0,[sp,#0xlc]

z00o0 67,902 Exec _printf char common  Ox000057D4  OxESSFO034 LDE 0, 08510 <_printf_ char common+0x50-
2001 67,943 Exec _printf_char common 0x000037D5 0xE0SFO000 ADD r0,pc,x0

2002 67,944 Exec _printf_char common 0x0000537DC 0xEZ58D3020 ADD r3,sp,#0x20

2003 57,945 Exec _printf_char common 0x000037E0D 0xES530005 STH r3,{r0,r2}

z004 68,158 Exec _printf char common  Ox000057E4  OxE3A00000 How r0,#0

2005 68,159 Exec _printf char commorn 0x000037ES 0xESE8D0030 STR. r0,[sp,#0x30]

z006 65,198 Exec _printf char common  Ox000087EC OxESSFO0Z0 LDE r0,0x8514 <_printf_ char common+0x5ds
2007 65,239 Exec _printf_char common 0x0000537F0 0xE0SFO000 ADD r0,pc,x0

2008 68,240 Exec _printf char commorn 0x000087F4 0xESED00ZSE STR. r0,[sp,#0x25]

2009 65,275 Exec _printf_char common 0x000037F3 0xEZ5D0044 ADD r0,sp, #0xdd

Z010 68,279 Exec _printf char commorn 0x000087FC 0xESE8D0O0ZC STR. r0,[sp,#0x2Zc]

2011 65,318 Exec _printf char common  Ox00008500 OxELla0000D MoV rl,ap

201z 65,319 Exec _printf char common  Ox00005804  OxEBOOOZG6F EL _ bprintf <0x9lcd>

2013 65,369 Exec _ printf 0x000091CE OxESEZD47E0 PUSH {x7-rlo, 1}

4| k| Trace ,(Sourc:e KProfiIe / 4

e

Tracing enabled

Figure 43

To confirm that other function calls from the while(1) loop have been traced, search for them by
name using the "Find - Find Symbol Name" menu from the Analysis Window. No parenthesis

should be used when entering the function name:

& Enter Value

X]

J)

Enter Symbol Mame to search with
[Mate: wildeard matches are not available on this view]:

|GaDma

Find |

Cancel |

Figure 44

The Symbol Name search for GetData will bring you to the next occurrence in the trace buffer
of a trace element from GetData():
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£ Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =Jokd
[ File Edit view Find Filter Sort Trace Data Profiling Data Help

=1" U2

Elem |Time!cucl| Type |Sumholic |nddress |Dpcode 0ther A

4505 24,462,279 Exec  _ Oprinte 0x00005424  OxE49D4004 POP ird}

4506 24,462,309 MNoExec _ Oprinte 0x00008428  0x13E00000 MVNHE i, #0

4507 24,462,310 Exec Oprintf 0x0000542C  OxE49DFO14 LDE. pc,[=p], #0x14

4605 24,462,393 Exec  main'#87 0x00008290  OxEBFFFFAR BL GetData <0x§ld4ds

4509 24,462,473 Exec  GetData 0x00005144  OxES9FL1190 LDE. rl,0x5zdc

4510 24,462,616 Exec  GetData‘#l53 0x00008148  0xE5911000 LDE. rl,[rl,#0]

4511 24,462,545 Exec  GetData‘#l53 0x0000814C  OxE59F2188 LDE. rz,x5zdc

451z 24,462,832 Exec  GetData‘#l53 0x00008150  0xE592203C LDE. vz, [r2, #0xic]

4513 24,462,861 Exec  GetData‘#l53 0x00008154  OxE3A03001 MoV ri, #1

4514 24,462,864 Exec  GetData‘#l53 0x00008158  0xE0&320C2 ADD rE,r3,re, A50 #1

4515 24,462,865 Exec  GetData‘#l53 0x0000815C  0xE0211002 ECOR rl,rl,rz2

4sl6 24,462,868 Exec  GetData‘#l53 0x00008160  OxE59F2174 LDE. rz,x5zdc

4517 24,462,904 Exec  GetData‘#l53 0x00008164  0xE5821000 STR. rl,[rz,#0]

4515 24,462,942 Exec  GetData‘#l54..#155 0x00008168  OxE3A00001 MoV ro, #1

4519 24,462,943 Exec  GetData‘#l55 0x0000816C  OxEAOOOODA B OxE19c <TRACEL#155>

4820 24,462,993 Exec  GetData‘#l55 0x0000819C  0xE3500010 CHP v, #0x10

4521 24,463,041 Exec  GetData‘#l55 0x00008140  OxBAFFFFF2 ELT 0xE170 <TRACEL#157>

4522 24,463,201 Exec  GetData‘\#l56..#157 0x00008170  OxE59F1164 LDE. rl,0x5zdc

4823 24,463,264 Exec  GetData‘#l57 0x00008174  OxE7911100 LDE. rl,[rl,r0,L3L #2]

4524 24,463,445 Exec  GetData‘#l57 0x00008178  0xE2402001 3UB rz,ro, #1

4825 24,463,448 Exec  GetData‘#l57 0x0000817C  OxE59F3158 LDE. r3,0x52dc

4826 24,463,480 Exec  GetData‘#l57 0x00008180  OxE7932102 LDE. vz, [r3,r2,L3L #2]

4827 24,463,509 Exec  GetData‘#l57 0x00008184  OxE3A03001 MoV ri, #1

4825 24,463,512 Exec  GetData‘#l57 0x00008188  0xE0&320C2 ADD rE,r3,re, A50 #1

4829 24,463,513 Exec  GetData‘#l57 0x0000818C  0xE0211002 ECOR rl,rl,rz2

4830 24,463,514 Exec  GetData‘#l57 0x00008190  OxE59F2144 LDE. rz,x5zdc

4531 24,463,712 Exec  GetData‘#l57 0x00008194  0xE7821100 STR. rl,[rZ,r0,L3L #2]

4832 24,463,750 Exec  GetData‘#l5s 0x00008198  0xE2E00001 ADD rd, 0, #1

4833 24,463,751 Exec  GetData‘#l55s 0x0000819C  0xE3500010 CHP v, #0x10

4534 24,463,752 Exec  GetData‘\#l5s 0x00003140  OxBAFFFFF2 ELT 0xE170 <TRACEL#157>

4| k| Trace ,(Sourc:e KProfiIe / 4 j 4

Tracing enabled

Figure 45
Now search for the symbols rand, GetAverage and SendData to show that all functions from the
while(1) loop are traced.
6.2 Trace Range Exclusions

Trace Range Exclusions are used to prevent trace from being captured over a specified address
range. Trace exclusions are particularly useful if you have a function that is frequently called,
but you don't want it traced. You may decide to exclude code portions from your trace capture
so you can save the limited trace memory for areas that are of greater interest. For instance,
trusted library functions may be good candidates for trace exclusion if you require more trace
visibility of your own written code.

In this scenario a Trace Start Point is used to enable trace capture, and an Excluded Trace Range
is used to prevent the function GetData() from being traced. Remove the previous trace setup.
Using the C source view, place the following trace points:

. Trace Start Point in main() at while(1)
. Start Excluded Trace Range (Inst + Data) at start of GetData()
. End Excluded Trace Range (Inst + Data) at end of GetData()

The location of the Trace Start Point is shown here:
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FARVDEBUG = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] |- [0/
[ File Edit Yiew Target Debug Tools Help

BRI OET IR R R AT 13

JJ@ §§ @ - ‘ v|J_|Fi|e|trac:e.c: [Find I L”Line I |

int main (wvoid)
int sample_num=0; /% local to track nuwher of samples */

/% initialize board and data %/
Init():

m

A% enter program executive, loop contimually in main control loop */
printf ("Entering main control loopin™):

mw while (1)

i

A% bunp global execution counter */
num_runs+=1;

/% use rand() to simulate polling and determine if ADC has new data */

A% ADC data iz awailable if sample_ready is =zero */
sample_ready = (rand():N):

A |k [\ Dam £ Src g tracec <| | _bIM

trace,prompt YTRACEL#73:2

llolx

Stop>
4| v b omd FStao fFieFind fLog ;| _>|

Stopped Ln 69, Col 12 [ A

Figure 46

The location of the Excluded Trace Range is shown here:

FARVDEBUG = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] |- [0/
[ File Edit Yiew Target Debug Tools Help

BRI OET IR R R AT 13

JJ@ §§ @ - ‘ v|J_|Fi|e|trac:e.c: [Find I L”Line I |

wg b]

woid GetData(woid)
i

int i;
mw input[0] = input[0] * { (input[NUM_SAMPLES-1] »> 1) + 1)
for (i=1; i<NUM SAMPLES: i++)

i
input[i] = input[i] *~ [ (input[i-1] => 1] + 1]:

m

W 1 /% end GetDatai) %/

*

A |k [\ Dam £ Src g tracec <| | _bIM

trace,prompt YTRACEL#73:2
trace,prompt “YTRACE#153:1
trace,prompt “YTRACE\#16Z:2

llolx

Stop>
4| v b omd FStao fFieFind fLog ;| _>|

Stopped [tn 73, Col 4 [ A

Figure 47
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Reload TRACE.AXEF, run the program for a few seconds and stop it. Open the Trace Analysis
window, scroll through it and observe that the while(1) loop is traced. Perform a search for
GetData using the "Find - Find Symbol Name" menu from the Analysis Window:

&¥ Enter Value X

i Enter Symbol Mame to search with
[Mate: wildeard matches are not available on this view]:

Find |

|GetD ata

Cancel |

Figure 48

Observe that there is only one instruction traced from GetData(), while all the other functions

called from the while(1) loop are completely traced. The BX LR instruction from GetData() is
used to return from the function. Itis presentin the trace capture because the end of the excluded
trace range fell at this address (0x81A4) when the trace range was set from the C source view.

£ Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =Jokd
[ Eile Edit Yiew Find Filter Sort Trace Data Profiling Data Help
=" i U g
Elem | Time/cycl | Type | Symbolic | Address Opcode 0ther
4617 25,882,413 Exec _ Oprintf Ox0000541C 0xE3500000 CHP r0,#0
4615 25,882,414 Exec _ Oprintf Ox00005420 Ox01400004 MOVEQ ri,rd
4619 25,882,415 Exec _ Oprintf Ox00005424 0xE45D4004 POP {rd}
4620 25,282,445 NoExec _ Oprintf 0x00005425 0x13E00000 MYNNE r0,#0
4621 25,282,446 Exec  _ Oprintf 0x0000842C  O0xE49DF014 LDR pc,[sp], #0x14
4622 25,882,529 Exec main' #57 Ox00008290 0xEEFFFFAE EL GetData <0x5ld4-
4622 Warning: Trace pause
4623 25,292,401 Exec GetData\ #1558, . #162 Ox00005144 0xE1ZFFF1E EX 1ir
4624 25,892,457 Exec main' #58 Ox000082594 0xEEFFFF94 EL Getdverage <0x5104-
4625 25,892,537 Exec Getidverage Ox00005104 0xE3400000 MOV r0,#0
4626 25,892,577 Exec Getdverage'\ #151..#152 0x00008105 0xE3402000 MOV ra, #0
4627 25,892,575 Exec Getdverage' #1582 Ox0000810C 0xEA000003 B 0x5120 <TRACE\#152>
4625 25,892,697 Exec Getdverage' #1582 Ox00008120 0xE3520010 CHP rZ,#0x10
4629 25,892,695 Exec Getdverage' #1582 Ox00008124 0xBAFFFFFS ELT 0x5110 <TRACE'\#154-
4630 25,892,857 Exec Getdverage' #1583, . #1564 O0x00008110 0xESSFL1C4 LDE rl,0x8z2dc
4631 25,292,920 Exec Gethverage'#184 0x00005114  OxE7911102 LDE rl,[rl,r2,L8L #2]
4632 25,893,103 Exec Getdverage' #154 0x00008115 0xE0S00001 ADD r0,r0,rl
4633 25,293,104 Exec Getdverage' #1582 Ox0000811C 0xE2522001 ADD rZ,rZ,#1
4634 25,293,106 Exec Getdverage' #1582 Ox00008120 0xE3520010 CHP rZ,#0x10
4635 25,893,107 Exec Getdverage' #1582 Ox00008124 0xBAFFFFFS ELT 0x5110 <TRACE'\#154-
4636 25,293,161 Exec Getdverage' #1583, . #1564 O0x00008110 0xESSFL1C4 LDE rl,0x8z2dc
4637 25,293,224 Exec Gethverage'#184 0x00005114  OxE7911102 LDE rl,[rl,r2,L8L #2]
4635 25,293,407 Exec Getdverage' #154 0x00008115 0xE0S00001 ADD r0,r0,rl
4639 25,293,405 Exec Getdverage' #1582 Ox0000811C 0xE2522001 ADD rZ,rZ,#1
4640 25,293,410 Exec Getdverage' #1582 Ox00008120 0xE3520010 CHP rZ,#0x10
4641 25,293,411 Exec Getdverage' #1582 Ox00008124 0xBAFFFFFS ELT 0x5110 <TRACE'\#154-
4642 25,293,465 Exec Getdverage' #1583, . #1564 O0x00008110 0xESSFL1C4 LDE rl,0x8z2dc
4643 25,293,528 Exec Gethverage'#184 0x00005114  OxE7911102 LDE rl,[rl,r2,L8L #2]
4644 25,893,711 Exec Getdverage' #154 0x00008115 0xE0S00001 ADD r0,r0,rl
4645 25,893,712 Exec Getdverage' #1582 Ox0000811C 0xE2522001 ADD rZ,rZ,#1
4646 25,293,714 Exec Getdverage' #1582 Ox00008120 0xE3520010 CHP rZ,#0x10
4647 25,293,715 Exec Getdverage' #1582 Ox00008124 0xBAFFFFFS ELT 0x5110 <TRACE'\#154-
4645 25,893,769 Exec Getdverage' #1583, . #1564 O0x00008110 0xESSFL1C4 LDE rl,0x8z2dc
4649 25,293,832 Exec Gethverage'#184 0x00005114  OxE7911102 LDE rl,[rl,r2,L8L #2]
4|k [} Trace ,(Sourc:e KProfiIe /
Tracing enabled

Figure 49

You must be aware that this is a common occurrence when placing trace points from the C
source window (from the Src tab). The effects of this phenomenon can be even greater if you
build your application with a high level of compiler optimization. Precise control of trace point
placement can be achieved using the Disassembly source view.

To exclude all instructions of GetData() from the trace (including the BX LR which was
previously traced), the Trace Range Exclusion must be set using the Disassembly source view.
Click on the Dsm tab and remove the previous trace range by clicking on either trace range point
and selecting "Clear Break":

36
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FARVDEBUG = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] |- [0/

[ File Edit Yiew Target Debug Tools Help

EHEZ mEEBRE PRt A E B

O
0 B~ K | |Fie|Dsm

Find | x| |Lire
GetData: -
T Clear Break

Scope to Here

Show Disassermbly/Source at this Location

Disable Break #1

Set/Toggle Tracepoint...

Set Detailed Tracepoint...

<TRACE' #155>

Set Trace Fange

Details... #2]

Break Infa...

#2]

Set PC 1o Here
OOOOEIEE BT SE0r LTTr TZTESTTEESE #1
0000518C E0Z11002 EOR rl,rl,ra
00005190 ES9F2144  LDR rz,0xgz2de
00008194 E7821100  STR rl,[r2,r0,L8L #2]
00005195 EZ500001  ADD r0,x0,#1
000o0519c E3500010 CHP rl, #0x10
00005140 BAFFFFFZ  EBLT 0x5170 <TRACE\#157>

1r

00005144 E1ZFFFIE  EBX
Init:
A4 | ¥ [\Dam Srcﬂtrace.c/

[ [l

ﬁ Processing Sample: 17
g Processing Jample: 18
ﬂ Processing Sawple: 19
Processing Sample: 20
Processing Sample: 21
Processing Sample: 22
Processing Sample: 23

« | » [ cmd y stao £ FileFind K‘Log /

o N

Stopped

Ln 24, Cal 13

Note
Do not remove the Trace Start Point.

Figure 50

Place the new Excluded Trace Range at address locations 0x8144 (the first instruction in
GetData()) and 0x81A8 (the first instruction in Init()):

DAI0O168B
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FIRVDEBUG = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached]

M= X

O
RESF

[ File Edit Yiew Target Debug Tools Help

EHEZ] mEalEE artare 23 A2 EE

File: [Dsm Find | x| |Lire

GetDhata: s
[ 00008144 E59F1190 LDE rl,0x8ade

00003148 ES911000 LDR rl,[rl,#0]

0000514C ES9FZ185 LDR ra,0xdade

00003150 ES92203C LDR rZ,[rz,#0x3c]

00005154 E3AD3001 MOV r3, #l

00005158 EOS3Z0CE  ADD rZ,r3,r, ASE #1

0000515C EOZ11002 EOR rl,rl,xrz

00005160 ESS9FZ174  LDR ra,0xdade

00003164 ES321000 STR rl,[rz,#0]

00005165 E3AOQ0O00L MOV r0,#1

0000516C EAQDOQOOA E Ox&l9c <TRACE, #155>

00008170 ES9FLlled  LDR rl,0x8ade

00008174 E7911100 LDR rl,[rl,r0,L3L #2]

00008178 EzZ402001  SUB ra,r0,#1

0000817C ES9F3158 LDR r3,0xdade

00003180 E7932102 LDR r2,[r3,r2,L3L #2]

00005154 E3AD3001 MOV r3, #l

000051658 EOB320CE  ADD rZ,r3,r, ASE #1

0000515C EOZ11002 EOR rl,rl,xrz

00005190 ES9FZ144  LDR ra,0xdade

00003194 E7321100 TR rl,[r2,r0,L3L #2]

000058198 EZ500001  ADD r0,x0,#1

00o0g819C EZ500010 CHP rl, #0x10

00005140 BEAFFFFFZ ELT Ox5170 <TRACE, #157>

00005144 E1ZFFFIE EX 1r

Init:
dk 00005148 E3A00FFA MOV rl, #0x3ed

000051AC ES9FL1Z5 LDR rl,0xdade

A4 | ¥ [\Dam ,(Src: Ktrac:e.c: /

[

lﬂ clear,h 2
d ftrace,prompt
hd

trace,prompt

St0p>|

O0x00005144
0x00005145

| » [\ cmd fstao KFiIeFind K‘Log /

i

[

Stopped

Ln 24, Cal 13

Figure 51

Reload the program, run it for a few seconds and stop it. Observe that the new trace condition
results in a trace capture with all instructions of GetData() removed:

&F Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached]

M= X

[ Eile Edit Yiew Find Filter Sort Trace Data Profiling Data Help

=& [

Elem | Time/cycl | Type | Symbolic | Address | Opcode 0ther

7750 5Z,660,959 Exec _ Oprintf Ox00005424 0xE45D4004 POP {rd}

7751 52,660,959 NoExec _ Oprintf 0x00005425 0x13E00000 MYNNE rl, #0

7752 52,660,990 Exec Oprintf 0x00006842C  0xE49DF014 LDR pc,[sp], #0x14

7753 52,661,073 Exec main' #57 000008290 0xEEFFFFAE EL GetData <Dx8144>|
7753 Warning: Trace pause

7754 52,671,001 Exec main' #58 Ox000082594 0xEEFFFF94 EL Getdverage <0x5104-
7755 52,671,081 Exec Getidverage Ox00005104 0xE3400000 MOV rl, #0

7756 52,671,121 Exec Getdverage\#151..#152 Ox00005108 0xE3402000 MOV ra, #0

7757 52,671,122 Exec Gethverage' #1582 Ox0000810C 0xEA000003 B Ox5120 <TRACEY#152>
7758 52,671,241 Exec Gethverage' #1582 Ox00008120 0xE3520010 CHP ra, #0x10

7759 5Z,671,242 Exec Gethverage' #1582 Ox00008124 0xBAFFFFFS ELT Ox5110 <TRACEY#15d-
7760 52,671,401 Exec Getdverage'\ #183..#164 Ox00005110 0xESSFL1C4 LDE rl,0x8z2dc

7761 52,671,464 Exec Gethverage'#184 0x00008114  0xE7911102 LDE rl,[rl,r2,L3L #2]

4| k| Trace ,(Sourc:e KProfiIe /

e

Tracing enabled

Figure 52

Interestingly, if you run and stop the program again after it is halted, the Trace Analysis window
will be empty and report "<No Data in Buffer>" :
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£ Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =Jokd
[ Eile Edit Yiew Find Filter Sort Trace Data Profiling Data Help
= nEE-

Elem | Time/cycl | Type | Symbolic | Address | Opcode 0ther A
<No Data in Buffer:> W

4| v [\ Trace fsource KProfiIe / b jv

Tracing enabled

Figure 53

Trace data is not captured because the trace conditions have not been met. The Trace Start Point
(at the while(1) statement) is only executed once in the program (not every time through the
loop). For trace to be collected again, you will have to reload TRACE.AXF so that the Trace
Start Point instruction is executed.
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7 Tracing Data

Trace is customarily used to determine program execution flow and Sections 4 - 6 of this
Application Note have described methods of capturing Instruction Trace. However, there are
times when you require visibility of the data accesses made by your program. The Embedded
Trace Macrocell (ETM) provides the ability to trace data and this section describes how data
trace can be performed from RVD.

Tracing data is a very data intensive operation and may result in trace overflows if you are not
tracing with an ETB. Trace overflows occur when the internal FIFO of the ETM is full and new
trace data is prevented from being stored. To minimize the possibility of trace overflow,
configure your ETM to use the maximum possible trace data width (typically 16 bits) and
disable Cycle Accurate trace:

A Configure ETM X
Architecture: 3.1
Trace data wicth ;— Trace port mode Trace huffer packing
i 4 bit Part speed:ETM clock speed &+ A tomatic
™ & hit ™ Mormal packing
1:2 -
" Double packing
i ~ i
I [ Disable traceport
FIFC overflow protection Trace coproc register transfer
% Mo protection * Mone
i |
" Data suppression ™ Only when tracing data
FIFC highweater |0
Extended external input selection
Input 1 |0 Input 2 |0 |
I~ Memary map decode | geo000
Synchronization frequency | 1024
Enable timestamping
o not trace instructions)
-
-
Ok | Cancel | Help |

Figure 54

71 Tracing Data With Auto Trace

After trace is first enabled and configured as described in Section 3, RVD places your target in
Auto Tracing mode. By default, only instructions are traced. To enable Auto Tracing for
instructions and data, use the "Edit - Automatic Tracing Mode" menu from the Analysis window
and select "Instructions and Data" as shown below:
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£ Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] |- [O/03
[ Eile | Edit “iew Find Filter Sort Trace Data Profiling Data Help
& bd By Copy Ctri+C
| Elem 8 Connect/Disconnect Analyzer | Address | Opcode Other »
<No D:
Tracing Enabled

Configure Analyzer Properties...

Set Trace Buffer Size...
Store Confrol-Elow Changes Only
Buffer Full Mode

Trigger Mode L4

Data Tracing Mode »

Automatic Tracing Mode L4 Off (Use Tracepaints)

Set/Edit Event Triggers... v Instructions Only
M Clear &l Event Triggers Data Orly j hd
Trace b Physical to Logical Address Mapping. .. Instructions and Data  &cing enzbled

Figure 55

Note

Auto Tracing is also enabled if trace was used with trace points and all the trace points are
removed.

Reload TRACE.AXF and remove any previous trace points. Add a Watch window in RVD. In
the Watch window add "&average", "average" and "output_port":

Watch
Og ~| E
Hame Ualue
+ saverage *0x00004470
average 0x00000&F7
=l output_port *0x0000446C

Oxz0000

4| > \watcht fiatchz fiwisteh3 Jwstch 4 | |

Figure 56

Run the program for a few seconds and stop it. Search for the symbol "SendData" using the
"Find - Find Symbol Name" menu from the Analysis Window:

&¥ Enter Value X

i Enter Symbol Mame to search with
[Mate: wildeard matches are not available on this view]:

Find | Cancel |

|SendD ata

Figure 57

To make the Analysis display more legible, use the "Trace Data" menu to select only the
Position, Access Type, Address as Symbol/Line, Address as Value, Data Value in Hex, Opcode,
Interpretation of Data/Opcode, Instructions and Data columns:

DAI0O168B
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£ Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =Jokd

[ Eile Edit Yiew Find Filter Sort| Trace Data Profiling Data Help
== B K~ v Position
Elem | Type | Symbolic Absolute Time | Opcode 0ther A
382 Exec main' #59 X . 0xEEFFFFS1 EL SendData <0x80ad-
353 Exec  SendData Relative Tirne 0xES9F2224 LDR r2,0x52d0
383 R Data v Access Type <Data> 'p' Oxhd 40 'AW0' |
384 Exec  SendData\#228 0xES5922000 LDR rz,[r2,#0]
384 R Data average v Address as SymbolLine <Data> OxE3 0x05 '\v0' 'y0!
3858 Exec SendData'\ #2235 OxE20ZZ00F AND rZ,r2,#0xE
386 Exec SendData\gzze | ¥ Address asvalue OxE2821001 ADD rl,rz,$l
387 Exec GendDatat#229. . , Data Value in Hex 0xES9FZ215 LDE rz,0x82d44
387 R Data <Data> Oxbd Oxbdd Oxbdd Oxdd
388 Exec  SendData’\#230 Data Yalue in Decimal OxE59F3218 LDR r3,0x52d8
388 R Data <Datax 'l Oxdd 'y 0!
389 Exec  SendDataygzso | ¥ 2pcode 0xE5933000 LDR r3,[r3,#0]
359 R Data output_port v Interpretation of Data/Opcode <Data> 'y0' '\0' Ox02 'AO!
390 Exec SendData’\#230 0xESS32000 3TR rz,[r3,#0]
390 W Data output_fifo Count of Hits «<Datar OxAd Oxdd Oxidd Oxid
391 Exec  SendData\#231 0xE59F2204 LDR rz,0x52d0
391 R Data Al Trace <Data> 'p' OxAd 'A0' 140
392 Exec  SendData\#231 Instruction Boundaries 0xES5922000 LDR rz,[r2,#0]
392 R Data average <Data> OxE3 Ox05 'y0' 'yv0!
393 Exec  HendData\#231 | v Instructions 0xE59F3204 LDR r3,0x52d8
393 R Data <Datax 'l Oxdd 'y 0!
394 Exec  SendDataygz3l | ¥ Data 0xE5933000 LDR r3,[r3,#0]
394 R Data output_port Function Boundaries <Data> 'y0' '\0' Ox02 'AO!
395 Exec SendData’\#231 - 0xESS32000 3TR rz,[r3,#0]
395 W Data output_fife Interleaved Source <Data> OxE3 0x05 'y0' '\0!
398 Exec  SendData\$232.. ) 0xE3A00000 Mav i, #0
397 Exec  SendData\#234 Inferred Registers OxEA00000S B O0xB0£8 <TRACEY#234>
398 Exec SendData’ #234 only K Bsiisia 0xE1500001 CMP r0,rl
399 Exec  SendData\#234 ity e e FEgisiss OxBAFFFFF7 ELT %500 <TRACEY#237>
400 Exec  SendData’#235.. Only Changing Registers OXES9FZ1F4 LDR rz,0xg2de
400 R Data <Data> 0x90 Oxd4 '30' 'O
401 Exec  SendData’,#237 Marrow Register Yiew 0xE7922100 LDR rz,[r2,r0,L8L #2]
401 R Data input oL eT UEFFFFrE <Data> '.' O0xF3 OxFF OxFF
402 Exec  SendData\#237 0x000080ES OxES9F31ES LDR r3,0x52d8
402 R Data 0x000082D8 0x0000446C <Datax 'l Oxdd 'y 0!
403 Exec  SendData\#237 0x000080EC 0xES5933000 LDR r3,[r3,#0]
403 R Data output_port 0x00004460 0x000zZ0000 <Data> 'y0' '\0' Ox02 'AO!
404 Exec  SendData\#237 0x000080F0 0xES5532000 3TR rz,[r3,#0]
404 W Data output fifo 0x00020000 OxFFFFFa2E «Data> '.' 0xF§ OxFF OxFF
405 Exec  SendData'\#234 0x000080F4 0xE2500001 LDD rl,r0,#1
4|k [} Trace ,(Sourc:e KProfiIe / 4 j w

Tracing enabled

Figure 58

Note

The traces in Section 7 are made with Cycle Accurate trace disabled and Timestamping
disabled. If you require timing information from your data trace, enable either Cycle Accurate
trace or Timestamping as shown in Section 5.2. To view timing information in the Analysis
window, select "Absolute Time" or "Relative Time" from the "Trace Data" menu.

Your trace capture should now have the following columns of data:
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Application Note 168

£ Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =Jokd
[ File Edit view Find Filter Sort Trace Data Profiling Data Help
== U2
Elem | Type | Symbolic | Address | Data/Hex | Opcode Other S
361 Exec Getdwerage’ #1589, . 4191 0x00005140 OxELZFFFLE BX 1r
362 Exec nain' #8589 O0x00005295 OxEEFFFFSl EL SendData <0x&0ad-
363 Exec Sendhata O0x00005044 OxESSF2zZ24 LDE r2,0xg2d40 |
3683 E Data 0x000052D0 0x00004470 <Data> 'p' Oxad 'y0' 0!
38 Exec JendData’ #2258 0x00005045 OxES522000 LDE r,[rz, #0]
38 R Data average 0x00004470 0x000005E3 <Data> OxE3 Ox05 'y0' 'yv0!
365 Exec JendData’ #2258 O0x0000504AC OxEZ0Z200F AND ri,ra, #0xf
366 Exec JendData’ #2258 0x000050ED OxEZEz1001 ADD rl,ra, #1
387 Exec HGendDatal #229. . #230 0x000050E4 OxESSFZZ18 LDE ra,0xgadd
387 E Data 0x000052D4 OxAABAADLAL <Data> Oxhd Oxdd Oxdd Oxdid
3688 Exec GJendData’ #230 0x000050ES OxESSF3218 LDE 3, 0x8ads
3688 E Data 0x000052D8 O0x00004460 <Data> 'l' Oxad '\O' "»wO!
389 Exec GJendData’ #230 0x000050EC OxES533000 LDE r3,[r3,#0]
389 R Data output_port 0x0000446C  0x00020000 <Data> 'y0' '\0' Ox02 'AO!
390 Exec GJendData’ #230 0x000050C0 OxESE32000 STR r,[r3,#0]
390 W Data output_fifo Ox00020000 OxAABAADLAL <Data> Oxhd Oxdd Oxdd Oxdid
391 Exec JendData’ #231 O0x000050Cd OxESSF2z04 LDE ra, 0xgado
391 E Data 0x000052D0 0x00004470 <Data> 'p' Oxad 'y0' 0!
39z Exec JendData’ #231 0x000050CE OxES522000 LDE r,[rz, #0]
392 R Data average 0x00004470 0x000005E3 <Data> OxE3 Ox05 'y0' 'yv0!
393 Exec JendData’ #231 Ox000080CC OxESSF3204 LDE 3, 0x8ads
393 E Data 0x000052D8 O0x00004460 <Data> 'l' Oxad '\O' "»wO!
394 Exec JendData’ #231 0x000050D0 OxES533000 LDE r3,[r3,#0]
394 R Data output_port 0x0000446C  0x00020000 <Data> 'y0' '\0' Ox02 'AO!
385 Exec JendData’ #231 0x000050D4 OxESE32000 STR r,[r3,#0]
395 W Data output_fifo Ox00020000 0x000005E3 «<Data> OxE3 Ox05 '‘\O' '"\O!
Exec JendData’\ #232. . #234 0x000050D8 OxE3A00000 MoV r0,#0
397 Exec GendData’ #234 0x000050DC OxEADO000S B 0x30£8 <TRACE'\#234-
398 Exec GendData’ #234 0x000050FS OxELS00001 CHFP 0, rl
399 Exec GendData’ #234 0x000080FC OxBAFFFFF? ELT 0x80e0 <TRACE\#237>
400 Exec HGendDatal#235. . #237 0x000050ED OxESSF21F4 LDE ra,0xdade
4| » [ Trace ,(Sourc:e KProfiIe / 4 j v
Tracing enabled

Figure 59

Note

Your capture may have different element numbers and different values in the Data/Hex and
Other columns.

In the trace capture observe that the first data access in SendData is at trace element 383. This
access is a read from address 0x82DO0 of data 0xA470. This read is generated from the execution
of the LDR 12, 0x82DO instruction (boxed in red). This read is for the computation of the local
variable "num_xmit", which resides on the stack:

int i, num_xmit;
num_xmit = (average & OxF) + 1;

Trace element 384 contains the next data access and this is a read of the global variable
"average". The Watch window shows that "average" is stored at 0xA470. Note how "average"
also appears in the Symbolic column. In this particular run, average has a value of 0x5E3.

This segment of the trace capture contains two data write operations at trace elements 390 and
395. These are the respective writes of the packet header (0OXAAAAAAAA) and computed
average (0x5E3) to address 0x20000 (the address of output_fifo, pointed to by *output_port):

*output_port
*output_port

HEADER;  /« output header packet =/
average; /+ output average value x/

To further improve the trace display, enable "Instruction Boundaries" from the "Trace Data"
menu in the Analysis window. This provides a slightly clearer view for interpreting which
instruction performed the data access. This view still includes entries which don't make data
accesses, such as elements 385 and 386:
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Application Note 168

&F Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached]

M= X

O File Edit Yiew

Find Filter Sort Trace Data Profiling Data Help

= EHE-

Elem | Type | Symbolic Address | Data/Hex | Opcode Other ~
362 Exec nain' #589 0x00005298 OxEEFFFFS1 EL SendData <0x80ad-
363 Exec Sendhata O0x00005044 OxESSF2zZ24 LDE r2,0xg2d40 |

383 E Data 0x000052D0 0x00004470 <Data> 'p' Oxad '"\0O' "wO!
364 Exec SendDatab #2285 0x00005045 OxES522000 LDE ra,[rz,#0]

384 R Data average 0x00004470 0x000005E3 <Data> OxE3 Ox05 'y0' 'yv0!
365 Exec SendDatab #2285 O0x0000504AC OxEZ0Z200F AND ra,re, #0xf

366 Exec SendDatab #2285 0x000050ED OxEZEz1001 ADD rl,r2,#1

387 Exec JendData’ #229. . 230 0x000050E4 OxESSFZZ18 LDE ra,0xgadd

387 E Data 0x000052D4 OxAABAADLAL <Data> Oxhd Oxdd Oxdd Oxdid
3688 Exec SendDatah #2350 0x000050ES OxESSF3218 LDE 3, 0x8ads

3688 E Data 0x000052D8 O0x00004460 <Data> 'l' Oxad '\O' "»wO!
389 Exec SendDatah #2350 0x000050EC OxES533000 LDE 3, [r3,#0]

359 R Data output_port 0x00004460 0x000zZ0000 <Data> 'y0' '\0' Ox02 'AO!
390 Exec SendDatah #2350 0x000050C0 OxESE32000 STR ra, [r3,#0]

390 W Data output_fifo Ox00020000 OxAABAADLAL <Data> Oxhd Oxdd Oxdd Oxdid
391 Exec SendDatah #2351 O0x000050Cd OxESSF2z04 LDE ra, 0xgado

391 E Data 0x000052D0 0x00004470 <Data> 'p' Oxad '"\0O' "wO!
39z Exec SendDatah #2351 0x000050CE OxES522000 LDE ra,[rz,#0]

392 R Data average 0x00004470 0x000005E3 <Data> OxE3 Ox05 'y0' 'yv0!
393 Exec SendDatah #2351 Ox000080CC OxESSF3204 LDE 3, 0x8ads

393 E Data 0x000052D8 O0x00004460 <Data> 'l' Oxad '\O' "»wO!
394 Exec SendDatah #2351 0x000050D0 OxES533000 LDE 3, [r3,#0]

394 R Data output_port 0x00004460 0x000zZ0000 <Data> 'y0' '\0' Ox02 'AO!
385 Exec SendDatah #2351 0x000050D4 OxESE32000 STR ra, [r3,#0]

385 W Data output_fifo Ox00020000 0x000005E3 «<Data> OxE3 Ox05 '‘\O' '"\O!
4| k| Trace ,(Sourc:e KProfiIe / 4 j 4

Tracing enabled

Figure 60

If you want to focus solely on data accesses, you can enable "Function Boundaries", disable
"Instruction Boundaries" and disable "Instructions" from the "Trace Data" menu:
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Trace Data Profiling Data Help

Position

Absolute Time

Relative Time

Access Type

Address as SymbolLine
Address as Yalue

Data Yalue in Hex

Data Yalue in Decimal
Opcode

Interpretation of Data/Opcode
Count of Hits

All Trace

Instruction Boundaries
Instructions

Data

Function Boundaries
Interleaved Source
Inferred Registers

Only Known Registers
Only Changing Registers

Marrow Register Wiew

Figure 61

This setting provides a clean view of data accesses and still provides some visibility to general

program location:

DAI0O168B
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Application Note 168

£ Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =Jokd
[ Eile Edit Yiew Find Filter Sort Trace Data Profiling Data Help

=1" U2

Elem | Type | Symbolic Address | Data/Hex | Opcode Other ~

362 Return main 0x00005298 OxEEFFFFS1 EL SendData <0x80ad-

363 Call Sendhata O0x00005044 OxESSF2zZ24 LDE r2,0xg2d40 |

383 E Data 0x000052D0 0x00004470 <Data> 'p' Oxad '"\0O' "wO!

384 R Data average 0x00004470 0x000005E3 <Data> OxE3 Ox05 'y0' 'yv0!

387 E Data 0x000052D4 OxAABAADLAL <Data> Oxhd Oxdd Oxdd Oxdid

3688 E Data 0x000052D8 O0x00004460 <Data> 'l' Oxad '\O' "»wO!

359 R Data output_port 0x00004460 0x000zZ0000 <Data> 'y0' '\0' Ox02 'AO!

390 W Data output_fifo Ox00020000 OxAABAADLAL <Data> Oxhd Oxdd Oxdd Oxdid

391 E Data 0x000052D0 0x00004470 <Data> 'p' Oxad '"\0O' "wO!

392 R Data average 0x00004470 0x000005E3 <Data> OxE3 Ox05 'y0' 'yv0!

393 E Data 0x000052D8 O0x00004460 <Data> 'l' Oxad '\O' "»wO!

394 R Data output_port 0x00004460 0x000zZ0000 <Data> 'y0' '\0' Ox02 'AO!

385 W Data output_fifo Ox00020000 0x000005E3 «<Data> OxE3 Ox05 '‘\O' '"\O!

400 E Data 0x000082DC 0x00004490 <Data> 0xS0 Oxid '\O' '"\O!

401 E Data input 0x00004490 OxFFFFFSEE <Datax '.' OxFS OxFF OxFF

402 E Data 0x000052D8 O0x00004460 <Data> 'l' Oxad '\O' "»wO!

403 R Data output_port 0x00004460 0x000zZ0000 <Data> 'y0' '\0' Ox02 'AO!

404 W Data output_fifo Ox00020000 OxFFFFFSEE <Datax '.' OxFS OxFF OxFF

408 E Data 0x000082DC 0x00004490 <Data> 0xS0 Oxid '\O' '"\O!

409 E Data input+0x0d 0x00004494 0x0000087F <Data> Ox7F Ox06 '\O' '"\O!

410 E Data 0x000052D8 O0x00004460 <Data> 'l' Oxad '\O' "»wO!

411 R Data output_port 0x00004460 0x000zZ0000 <Data> 'y0' '\0' Ox02 'AO!

412 W Data output_fifo Ox00020000 0x0000087F <Data> Ox7F Ox06 '\O' '"\O!

416 E Data 0x000082DC 0x00004490 <Data> 0xS0 Oxid '\O' '"\O!

417 E Data input+0x08 0x00004495 OxFFFFF7AE <Data> OxiAE OxF7 OXFF OxFF

418 E Data 0x000052D8 O0x00004460 <Data> 'l' Oxad '\O' "»wO!

419 R Data output_port 0x00004460 0x000zZ0000 <Data> 'y0' '\0' Ox02 'AO!

420 W Data output_fifo Ox00020000 OxFFFFF7AE <Data> OxiAE OxF7 OXFF OxFF

424 E Data 0x000082DC 0x00004490 <Data> 0xS0 Oxid '\O' '"\O!

425 E Data input+0x0C O0x0000449C OxFFFFFS34 <Datax ':' OxF5 OxFF OxFF

426 E Data 0x000052D8 O0x00004460 <Data> 'l' Oxad '\O' "»wO!

4z7 R Data output_port 0x00004460 0x000zZ0000 <Data> 'y0' '\0' Ox02 'AO!

428 W Data output_fifo Ox00020000 OxFFFFFS34 <Datax ':' OxF5 OxFF OxFF

433 Return main Ox0000529C OxEAFFFFES B Ox5248 <TRACEY#77>

4| k| Trace ,(Sourc:e KProfiIe / 4 j 4

Tracing enabled

Figure 62

Perform a search for the symbol GetAverage using "Find - Find Symbol Name" from the
Analysis Window:

&¥ Enter Value X

i Enter Symbol Mame to search with
[Mate: wildeard matches are not available on this view]:

Find | Cancel |

|Gebﬂverage

Figure 63

In GetAverage(), observe how the array input[ ] is accessed sequentially to compute "average"
and how the array elements are represented in the Symbolic column. The last data operation in
the function is a write to "average". In this particular run, the average of array input[ ] is 0x6E7.
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&F Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached]

M= X

O File Edit Yiew

=& [

Find Filter Sort Trace Data Profiling Data Help

Elem | Type | Symbolic Address | Data/Hex | Opcode 0ther

12935 Return main 0x00005294 0xEEFFFFoL EL Getdverage <0x5104-
12939 Call Getdverage Ox00005104 OxE3400000 MOV rd, #0 |

12944 R Data 0x0000820C 000004490 <Data> 0xS0 Oxid '\O' '"\O!
12945 E Data input 000004490 Ox00000ZE4 <Data> OxBA Ox02 '\O' '"\O!
12950 R Data 0x0000820C 000004490 <Data> 0xS0 Oxid '\O' '"\O!
12951 R Data input+0x04 Ox00004454 O0x00000721 <Datax '!' 'ha' '"hwOo'oho!
12956 R Data 0x0000820C 000004490 <Data> 0xS0 Oxid '\O' '"\O!
12957 E Data input+0x03 0x00004495 0xFFFFF434 <Data> ':' OxF4 OxFF OxFF
12962 R Data 0x0000820C 000004490 <Data> 0xS0 Oxid '\O' '"\O!
12963 E Data input+0x0C 000004490 Ox00000F24 <Data> '§' Ox0OF '\O' '"»wO!
12965 R Data 0x0000820C 000004490 <Data> 0xS0 Oxid '\O' '"\O!
12969 E Data input+0x10 000004440 000001340 <Data> OxAC Ox13 '‘\O' '"\O!
12974 R Data 0x0000820C 000004490 <Data> 0xS0 Oxid '\O' '"\O!
12975 R Data input+0xl4 000004484 0x00001732 <Datax 'Z' 0«17 '"\O' 'O
12980 R Data 0x0000820C 000004490 <Data> 0xS0 Oxid '\O' '"\O!
12981 E Data input+0xl13 O0x00004445 0x00000355 <Datax 'U' 0«03 '\O' "»wO!
12986 R Data 0x0000820C 000004490 <Data> 0xS0 Oxid '\O' '"\O!
12987 E Data input+0x1C 000004440 0x0000072F <Datax '/' 'ha' 'hot oot
12992 R Data 0x0000820C 000004490 <Data> 0xS0 Oxid '\O' '"\O!
12993 E Data input+0xz0 000004450 0x000006EE «<Data> OxEE Ox06 '‘\O' '\O!
12995 R Data 0x0000820C 000004490 <Data> 0xS0 Oxid '\O' '"\O!
12999 R Data input+0xz4 000004454 0x00000255 <Data> Ox88 Ox02 '\O' '"\O!
13004 R Data 0x0000820C 000004490 <Data> 0xS0 Oxid '\O' '"\O!
13005 E Data input+0xzZ3 0x000044E5 0x000007FE <Data> OXFE '‘a' '\0O' '"\O!
13010 R Data 0x0000820C 000004490 <Data> 0xS0 Oxid '\O' '"\O!
13011 E Data input+0xzZC Ox000044EC Ox00000Co4 <Data> Ox04 'Z£' '"\O' "\oO!
13016 R Data 0x0000820C 000004490 <Data> 0xS0 Oxid '\O' '"\O!
13017 E Data input+0x30 Ox000044C0 0x00001013 <Datax Ox13 Ox10 '‘\O' '"\O!
13022 R Data 0x0000820C 000004490 <Data> 0xS0 Oxid '\O' '"\O!
13023 R Data input+0x34 Ox000044C4 0x00000666 <Data> 'f£' Ox06 '\O' '"wO!
13025 R Data 0x0000820C 000004490 <Data> 0xS0 Oxid '\O' '"\O!
13029 E Data input+0x33 0x000044C5 000000350 <Datax '\A\' Ox03 '"\O' "\o!
13034 R Data 0x0000820C 000004490 <Data> 0xS0 Oxid '\O' '"\O!
13035 E Data input+0x3C Ox000044CC 0xFFFFF459 <Data> O0x89 O0xF4 OxFF OxFF
13044 R Data O0x00008200 O0x00004470 <Data> 'p' Oxad '"\0O' "wO!
13045 W Data average 0x00004470 0x000006E7 <Data> OxE7 Ox06 'y0' 'yv0O!
13047 Return main 0x00005298 OxEEFFFFS1 EL SendData <0x80ad-
4| k| Trace ,(Sourc:e KProfiIe / 4

e

Tracing enabled

Figure 64

In the preceding Data Trace captures, both the data address and the value of the data were traced.

RVD allows you to select what data is traced using the "Edit - Data Tracing Mode" menu as

shown below.
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&F Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached]

M= X

[ Eile | Edit “iew Find Filter Sort Trace Data Profiling Data Help
= & By Copy

12938
12944
12945
12950
12851
12956
12957
1lz962
12963
12968
12969
12974
12975
12980
12981
12986

Elen ¥ Connect/Disconnect Analyzer

12935 Bl Tracing Enabled

Configure Analyzer Properties...

Set Trace Buffer Size...

Store Confrol-Elow Changes Only

Buffer Full Mode

Trigger Mode

Data Tracing Mode
Automatic Tracing Mode
Set/Edit Event Triggers...
Clear &l Event Triggers

Cirl+C

Physical to Logical Address Mapping. ..

12987
12992
12993
12995
12599
13004
13005
13010
13011
13016
13017
l30zz
13023
13028
13028
13034
13035
13044
13045

13047

Foata INPUTFC L oA =al
R Data 0x0000820C
R Data input+0x20 0x000044E0
R Data 0x0000820C
R Data input+0x24 0x000044E4
R Data 0x0000820C
R Data input+0x25 0x000044E5
R Data 0x0000820C
R Data input+0xzZC 0x000044EC
R Data 0x0000820C
R Data input+0x30 0x000044C0
R Data 0x0000820C
R Data input+0x34 0x000044C4
R Data 0x0000820C
R Data input+0x35 0x000044C5
R Data 0x0000820C
R Data input+0x3C 0x0000&4CC
R Data O0x00008200
W Data average 0x00004470
Return main 0x00005298

4| k| Trace ,(Sourc:e KProfiIe /

rr

| Data/Hex | Opcode 0ther S
0xEEFFFFoL EL Getdverage <0x5104-
0xE 3400000 MOV r0,#0 |

000004490 <Data> 0x90 OxAd '%0' 'y0°
0x00000264 <Data> OxBA 0x02 '%0' '\0°
000004490 <Data> 0x90 OxAd 'v0' 'y0°
0200000721 <Data> "1 'hal 00!
000004490 <Data> 0x90 OxAd 'v0' 'y0°
0xFFFFF434 <Datas ':' 0xF4 0xFF OxFF
000004490 <Data> 0x90 OxAd 'v0' 'y0°

Address Only <Data> '§' Ox0OF '\O' '"»wO!

<Data> 0x90 0xA4 '30' '\0°

Data Cnly <Data> OxAC Ox13 '30' '40

g g
+ oot s e oI
O0x00004490 <Data> 0xS0 Oxid '\O' '"\O!
0x00000355 <Datax 'U' 0«03 '\O' "»wO!
0x00004490 <Data> 0xS0 Oxid '\O' '"\O!
0x0000072F <Datax '/' 'ha' 'hot oot
0x00004490 <Data> 0xS0 Oxid '\O' '"\O!
0x000008EE «<Data> OxEE Ox06 '‘\O' '\O!
0x00004490 <Data> 0xS0 Oxid '\O' '"\O!
0x00000288 <Data> Ox88 Ox02 '\O' '"\O!
0x00004490 <Data> 0xS0 Oxid '\O' '"\O!
0x000007FE <Data> OXFE '‘a' '\0O' '"\O!
0x00004490 <Data> 0xS0 Oxid '\O' '"\O!
Ox00000C04 <Data> Ox04 'Z£' '"\O' "\oO!
0x00004490 <Data> 0xS0 Oxid '\O' '"\O!
0x00001013 <Datax Ox13 Ox10 '‘\O' '"\O!
0x00004490 <Data> 0xS0 Oxid '\O' '"\O!
0x00000666 <Data> 'f£' Ox06 '\O' '"wO!
0x00004490 <Data> 0xS0 Oxid '\O' '"\O!
0x0000035C <Datax '\A\' Ox03 '"\O' "\o!
0x00004490 <Data> 0xS0 Oxid '\O' '"\O!
OxFFFFF489 <Data> Ox89 OxF4 OxFF OxFF
0x00004470 <Data> 'p' Oxad '"\0O' "wO!
0x000008E7 <Data> OxE7 Ox06 '‘\O' '"\O!
OxEEFFFFS1 EL SendData <0x80ad-

e

Tracing enabled

Figure 65

The default Data Tracing mode is "Data and Address". You can use the "Address Only" and
"Data Only" options to reduce the amount of data collected by the ETM, and this will lessen the
possibility of trace overflow. If the same capture is made with Data Tracing Mode set to
"Address Only", data value information is not traced and the Data / Hex column is empty:
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o .
£ Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =Jokd
[ File Edit wiew Find Filter Sort Trace Data Profiling Data Help
=E U2
Elem | Type | Symbolic | Address | Data/Hex | Opcode Other S
281103 Return main 0x00005294 O0xEEFFFF94 EL Getdverage <0x5104-
251104 Call Getdverage Ox00005104 OxE3A00000 MOV rd, #0 |
251109 E Data 0x000082DC <Data> 'Z0' 'P' Ox40 OxE1l
251110 E Data input 0x00004490 <Data> '“r' O0x10 OxiA0 OxEL
261115 E Data 0x000082DC <Data> OxA0 OxCZ 'g' OxEOD
281116 E Data input+0x0d 0x00004494 «<Data» '2' '@' '-' OxEZ
261121 E Data 0x000082DC <Data> Ox0Z ' ' OxAZ OxEOD
2811z E Data input+0x08 0x00004495 <Data> 'Z0' OxCO OxA0 OxEL
281127 E Data 0x000082DC <Data> '30' 'A0' 0x8D OxES
Z811&8 E Data input+0x0C O0x0000449C <Data> 'l' '\0' 0x9F OxES
261133 E Data 0x000082DC «Data» Ox01 0Ox0Z '@' ' !
261134 R Data input+0x10 O0x0000A440 <Data> OxiA0 OxCl 'g' OxEOD
261139 E Data 0x000082DC «Data» ' ' '@' OxBD OxES
251140 E Data input+0xld O0x00004444 <Data> OxA0 OxC3 'g' OxEOD
4| k| Trace ,(Sourc:e KProfiIe / 4 j 4
Tracing enabled

Figure 66

If another capture is made with Data Tracing Mode set to "Data Only", data address information
is not traced and the Address column is empty for all data accesses:

o .
£ Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =Jokd
[ Eile Edit Yiew Find Filter Sort Trace Data Profiling Data Help
=E U2
Elem | Type | Symbolic | Address | Data/Hex | Opcode Other S
9372 Return main 0x00005294 O0xEEFFFF94 EL Getdverage <0x5104-
9373 Call Getdverage Ox00005104 O0xE3400000 MOV rd, #0 |
9375 R Data 000004490 <Data> 0xS0 Oxid '\O' '"\O!
9379 R Data 0xFFFFFACD <Data> OxCD OxF9 OxFF OxFF
9354 R Data 000004490 <Data> 0xS0 Oxid '\O' '"\O!
93585 R Data 0xFFFFFES7 <Data> '7' OXFBE OxFF OxFF
9390 R Data 000004490 <Data> 0xS0 Oxid '\O' '"\O!
9391 R Data 000000504 <Data> OxD4 '‘\t' '\O' "\o!
9396 R Data 000004490 <Data> 0xS0 Oxid '\O' '"\O!
9397 R Data 0xFFFFF45E <Data> O0x8E OxF4 OxFF OxFF
9402 R Data 000004490 <Data> 0xS0 Oxid '\O' '"\O!
9403 R Data 0xFFFFESCE <Data> OxCE OxES OxFF OxFF
94035 R Data 000004490 <Data> 0xS0 Oxid '\O' '"\O!
9409 R Data 0xFFFFE395 <Data> O0x95 OxE3 OxFF OxFF
4| k| Trace ,(Sourc:e KProfiIe / 4 j 4
Tracing enabled

7.2

Tracing Data from an Instruction Trace Range

Figure 67

In Section 6 Trace Ranges were used to isolate the region of trace to a specified address range.
This same trace operation can be used to also capture data accesses. This type of trace capture
is valuable if you need to analyze how a particular segment of code is accessing data memory.

Remove any previous trace points and trace SendData() using the following Trace Range:

. Start of Trace Range (Instruction and Data) at opening brace

. End of Trace Range (Instruction and Data) at closing brace
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FIRVDEBUG = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached]

M= X

[ File Edit Yiew Target Debug Tools Help

D EE & 2Rl BE srnret +dX | EEl 885

J_lFiIeItrac:e.c: [Find I LI [Line I |
: ol |
L
Hame Ualue
woid SendData (woid) [+ sawverage *0x00004470
1 i ) ) average 0x00000000
int 1, num xmit; = output_port| *0x0000446C
L 0x20000
w num ¥mit = (average & OxF) + 1; :l *
*output _port = HEADER: /% output header packet */
*output_port = average; ¥ output average value #/
for (1=0; i<num xmit; i++)
{
*output port = input[i]:
i
W 1 /% end SendDatai) ¥/
« | » [ Bsm f5re jtrace o < | O s[4 Pstem fvaichz Ji 2
1' trace,prompt “YTRACE'\#Z25:0
O | trace,prompt VTRACE}#241:1
hd
Stop>
4| v b omd FStao fFieFind fLog ;| _>|
Stopped [tn 79, cal 58 [ A

Figure 68

Reload TRACE.AXF and change the Data Tracing Mode back to "Data and Address" if you
modified it in Section 7.1. Run the program for a few seconds and stop it. Open the Analysis
window. Enable "Instructions" and "Function Boundaries" and disable "Data" from the "Trace
Data" menu and observe that trace is paused between runs of SendData():
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&F Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached]

M= X

[ File Edit wiew Find Filter Sort Trace Data Profiling Data Help

=& [

Elem | Type | Symbolic | Address | Data/Hex | Opcode Other S
793 Exec SendDatah#23d 0x000050FS OxELlS00001 CHP rd,rl
794 NoExec SendData’#234 0x000080FC 0xBAFFFFF? ELT OxG0e0 <TRACEY#Z37>
794 Warning: Trace pause
Sendbata |
785 Exec Sendlhata 0x00005044 OxESSF2zZ24 LDR ra, 0xgado
796 Exec SendDatab #2285 0x00005045 0xES92Z000 LDE ra,[rz,#0]
787 Exec SendDatab #2285 O0x0000504AC 0xE20ZZ00F AND ra,re, #0xf
798 Exec SendDatab #2285 0x000050ED 0xE2521001 ADD rl,r2,#1
789 Exec JendData’ #229. . 230 0x000050E4 OxESSF2Z158 LDR rz,0x5zd4
g0o Exec SendDatah #2350 0x000050ES OxESSF3Z158 LDR r3,0x82d45
801 Exec SendDatah #2350 0x000050EC 0xES933000 LDE 3, [r3,#0]
g0z Exec SendDatah #2350 0x000050C0 0xESS32000 3TER ra, [r3,#0]
803 Exec SendDatah #2351 O0x000050Cd OxES8F2z04 LDR rz,0x8z2d0
04 Exec SendDatah #2351 0x000050CE 0xES92Z000 LDE ra,[rz,#0]
805 Exec SendDatah #2351 Ox000080CC OxES8F3204 LDR r3,0x82d45
g0e Exec SendDatah #2351 0x000050D0 0xES933000 LDE 3, [r3,#0]
g07 Exec SendDatah #2351 0x000050D4 0xESS32000 3TER ra, [r3,#0]
g0s Exec JendData’\ #232. . #234 0x000050D8 OxE3A00000 MOV rl, #0
09 Exec SendDatah#23d 0x000050DC 0xEA000005 B OxS0E5 <TRACEY#Z34»
gl0 Exec SendDatah#23d 0x000050FS OxELlS00001 CHP rd,rl
g1l Exec SendDatah#23d 0x000080FC 0xBAFFFFF? ELT OxG0e0 <TRACEY#Z37>
glz Exec JendData’ #235. . 237 0x000050ED OxESSF21F4 LDR rz,0xgz2de
813 Exec SendDatah #237 0x000050E4 OxE7522100 LDR rz,[rZ,e0,L3L #2]
gld Exec SendDatah #237 0x000050ES OxESSF31ES LDR r3,0x82d45
815 Exec SendDatah #237 0x000050EC 0xES933000 LDE 3, [r3,#0]
gle Exec SendDatah #237 0x000050F0 0xESS32000 3TER ra, [r3,#0]
817 Exec SendDatah#23d 0x000050F4 0xE2500001 ADD r0,x0,#1
818 Exec SendDatah#23d 0x000050FS OxELlS00001 CHP rd,rl
§l9 Exec SendDatah#23d 0x000080FC 0xBAFFFFF? ELT OxG0e0 <TRACEY#Z37>
a0 Exec JendData’ #235. . 237 0x000050ED OxESSF21F4 LDR rz,0xgz2de
gzl Exec SendDatah #237 0x000050E4 OxE7522100 LDR rz,[rZ,e0,L3L #2]
gaz Exec SendDatah #237 0x000050ES OxESSF31ES LDR r3,0x82d45
823 Exec SendDatah #237 0x000050EC 0xES933000 LDE 3, [r3,#0]
gad Exec SendDatah #237 0x000050F0 0xESS32000 3TER ra, [r3,#0]
8§25 Exec SendDatah#23d 0x000050F4 0xE2500001 ADD r0,x0,#1
2o Exec SendDatah#23d 0x000050FS OxELlS00001 CHP rd,rl
a7 Exec SendDatah#23d 0x000080FC 0xBAFFFFF? ELT OxG0e0 <TRACEY#Z37>
8§28 Exec JendData’ #235. . 237 0x000050ED OxESSF21F4 LDR rz,0xgz2de
a9 Exec SendDatah #237 0x000050E4 OxE7522100 LDR rz,[rZ,e0,L3L #2]
&30 Exec SendDatah #237 0x000050ES OxESSF31ES LDR r3,0x82d45
831 Exec SendDatah #237 0x000050EC 0xES933000 LDE 3, [r3,#0]
g3z Exec SendDatah #237 0x000050F0 0xESS32000 3TER ra, [r3,#0]
833 Exec SendDatah#23d 0x000050F4 0xE2500001 ADD r0,x0,#1
§3d Exec SendDatah#23d 0x000050FS OxELlS00001 CHP rd,rl
8§35 NoExec SendData’#234 0x000080FC 0xBAFFFFF? ELT OxG0e0 <TRACEY#Z37>
835 Warning: Trace pause
Sendlhata
836 Exec Sendlhata 0x00005044 OxESSF2zZ24 LDR ra, 0xgado
837 Exec SendDatab #2285 0x00005045 0xES92Z000 LDE ra,[rz,#0]
4| k| Trace ,(Sourc:e KProfiIe / 4 j 4

Tracing enabled

Note
Your trace capture may differ.

Figure 69

Now enable "Data" and disable "Instructions” from the "Trace Data" menu. Scroll through the
buffer and observe that each time SendData() runs there is not a consistent number of words

written to output_fifo (address 0x20000):
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&¥ Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached]

M= X

[ Eile Edit Yiew Find Filter Sort Trace Data Profiling Data Help

=& [

Elem | Type | Symbolic | Address | Data/Hex | Opcode Other

523 W Data output_fifo 0x00020000  0x00001147 <Datar 'G' Oxll '300 400
527 Sendhata 000008044 OxES9F2224 LDR rz, OxBzd0 |

527 R Data 0x000082D0  0x0000A470 <Datar 'p' Oxdd 300 40
Lza R Data average 0x00004470 0x00000141 <Data> Oxial Ox01 'y0' 'yv0!
531 R Data 0x000082D4  OxAAAARAAL <Data> Oxhi Oxhi Oxdd Oxdd
532 R Data 0x000082D8  Ox0000A46C <Datar 'l' Oxdd '300 400
533 P Data output_port 0x0000446C  0x00020000 <Data> 'y0' '\0' Ox02 'AO!
534 (W Data’output_fifo 0x00020000  OxAAAARRAL <Data> Oxdd Oxdd Oxdd Oxdd
535 R Data 0x000082D0  0x0000A470 <Data> 'p' Oxdd "0 40
536 R Data average 0x00004470 0x00000141 <Data> Oxial Ox01 'y0' 'yv0!
537 R Data 0x000082D8  Ox0000A46C <Datar 'l' Oxdd '300 400
538 R Data output_port 0x0000A46C  0x00020000 <Data> '40' 400 0x0Z 40
533 (W Data’output_fifo 0x00020000  0x00000141 <Data> OxAl 0xOL '400 'y0°
544 R Data 0x000082DC  Ox0000A490 <Data> 0x90 OxAd 400 40
545 R Data input 0x000044590  OxFFFFFS34 <Data> '4' OxF8 OxFF OxFF
546 R Data 0x000082D8  Ox0000A46C <Datar 'l' Oxdd '300 400
547 R Data output_port 0x0000446C  0x00020000 <Data> 'y0' '\0' Ox02 'AO!
548 W Datadoutput_fifo 0x00020000  OxFFFFFE34 <Data> '4' 0xFA OxFF OxFF
552 R Data 0x000082DC  Ox0000A490 <Data> 0x90 OxAd 400 40
553 R Data input+0x04 0x00004494  OxFFFFFSET <Data> OxB7 OxFS OxFF OxFF
554 R Data 0x000082D8  Ox0000A46C <Datar 'l' Oxdd '300 400
555 R Data output_port 0x0000A46C  0x00020000 <Data> '40' 400 0x0Z 40
556 (W Darayoutpur_fifo 0x00020000  OXFFFFFSET <Data> 0xB7 OxFS OxFF OxFF
560 sendbata 000008044 OXES9F2224 LDR £z, 0xg2do

560 R Data 0x000082D0  0x0000A470 <Data> 'p' Oxdd 300 40
18 R Data average 0x00004470 0x00000303 <Data> O0x03 Ox03 '\0' 'yv0!
564 R Data 0x000082D4  OxAAAARAAL <Data> Oxhi Oxhi Oxdd Oxdd
565 R Data 0x000082D8  Ox0000A46C <Datar 'l' Oxdd '300 400
566 R Data output_port 0x0000446C  0x00020000 <Data> 'y0' '\0' Ox02 'AO!
567 ut,put,_fifo 0x00020000  OxARAARAAL <Data> Oxhi Oxhi Oxdd Oxdd
568 K Data 0x000082D0  0x0000A470 <Data> 'p' Oxdd "0 40
Lea R Data average 0x00004470 0x00000303 <Data> O0x03 Ox03 '\0' 'yv0!
570 R Data 0x000082D8  Ox0000A46C <Datar 'l' Oxdd '300 400
571 R _Data output_port 0x0000446C  0x00020000 <Data> 'y0' '\0' Ox02 'AO!
572 < W Data output_fifo 0x00020000  0x00000303 <Datas 0x03 0x03 '30' 'O
577 R Data 0x000082DC  Ox0000A490 <Data> 0x90 OxAd 400 40
578 R Data input 0x00004490  OxFFFFFDAZ <Data> 'B' OxFD OxFF OxFF
579 R Data 0x000082D8  Ox0000A46C <Datar 'l' Oxdd '300 400
550 R Data output_port 0x0000446C  0x00020000 <Data> 'y0' '\0' Ox02 'AO!
581 (W Datadoutpur_fifo 0x00020000  OxFFFFFD4Z <Data> 'B' OxFD OxFF OxFF
585 K Data 0x000082DC  Ox0000A490 <Data> 0x90 OxAd 400 40
586 R Data input+0x04 0x00004494  0x00000615 <Datar Oxl5 0x06 '40' 40
587 R Data 0x000082D8  Ox0000A46C <Datar 'l' Oxdd '300 400
538 R Data output_port 0x0000A46C  0x00020000 <Data> '40' 400 0x0Z 40
589 ¢ W Data’output_fifo 0x00020000  0x00000615 <Datar Oxl5 0x06 '40' 40
593 R Data 0x000082DC  Ox0000A490 <Data> 0x90 OxAd 400 40
594 R Data input+0x0s 0x00004498  OxOO00OBEE <Data> OxEE 'yw' 400 140
595 R Data 0x000082D8  Ox0000A46C <Datar 'l' Oxdd '300 400
596 R Data output_port 0x0000446C  0x00020000 <Data> 'y0' '\0' Ox02 'AO!
597 out,put,_fifo 0x00020000  0x00000BEE <Data» OxEE '\w' '\0' '\0
601 R Data 0x000082DC  Ox0000A490 <Data> 0x90 OxAd 400 40
602 R Data input+0x0C 0x0000A49C  Ox00000FZF <Datar '/' OxOF '300 'y00
603 R Data 0x000082D8  Ox0000A46C <Datar 'l' Oxdd '300 400
604 R Data output_port 0x0000446C  0x00020000 <Data> 'y0' '\0' Ox02 'AO!
4|k [} Trace ,(Sourc:e KProfiIe / 4

e

Tracing enabled

If you reference TRACE.C, you will find that SendData() transmits a packet header

Figure 70

(0xAAAAAAAA), the computed average and a variable number of input samples. The number
of input samples written in SendData(), num_xmit, is determined by the computed average:

num_xmit = (average & OxF) + 1;

You can further isolate accesses to a particular address by applying a post-processing filter.
Apply a filter to examine all accesses to 0x20000. To do this, use the "Filter - Filter on Address
Expression" menu:
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£ Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =Jokd

[ Eile Edit Yiew Find |Filter Sort Trace Data Profiling Data Help
== B ¥ Filter on Position...

Elem Symbc Filter on Tirmestarmp... Data/Hex | Opcode Other S

G EIBGTL

523 W Data output Filter on Address Expression... 0x00001147 <Data> 'G' Ox1l 'y0' 'hO
527 SendDa  Filter on Data Value... 0xES8F2224 LDR rz,0x82d0 |
527 R Data 000004470 <Data> 'p' Oxad '"\0O' "wO!
528 R Data awverag Filter on Symbal Mame... 0x00000141 <Data> Oxal 0x01 '\0' 'y0'
531 E Data . OxAABAADLAL <Data> Oxhd Oxdd Oxdd Oxdid
532 R Data =T @ AEEEES THEE. 0x0000A4EE <Data> 'l' Oxkd4 '%0' '\0
533 R Data output Eilter on Percent Time. .. 0x00020000 <Data> 'y0' '\0' Ox02 'AO!
53d W Data output OxAABAADLAL <Data> Oxhd Oxdd Oxdd Oxdid
535 R Data v OR all Filters 0x00004470 <Data> 'p' OxAd '40' '10!
536 R Data averaq 0x00000141 <Data> Oxial Ox01 'y0' 'yv0!
537 R Data AND Al Filters 0%0000A46C <Data> 'L' Oxd4 '\0' O
538 R Data output Hvoon 0x00020000 <Data> 'y0' '\0' Ox02 'AO!
539 ¥ Data outpur,  LWertFiltering (NOT) 000000141 <Data> OxAl 0xOL '400 'y0°
544 R Data Clear Filtering Ox00004490 <Data> 0xS0 Oxid '\O' '"\O!
545 E Data input 0xFFFFF334 <Data> '4' OxF§ OxFF OxFF
546 R Data O0x00008205 Ox00004460 <Data> 'l' Oxad '\O' "»wO!
547 R Data output_port 0x0000446C  0x00020000 <Data> 'y0' '\0' Ox02 'AO!
545 W Data output_fifo 000020000 0xFFFFF334 <Data> '4' OxF§ OxFF OxFF
552 R Data 0x0000820C 000004490 <Data> 0xS0 Oxid '\O' '"\O!
553 R Data input+0x04 Ox00004454 0xFFFFFSE7 <Data> OxB7 O0xF§ OxFF OxFF
554 R Data O0x00008205 Ox00004460 <Data> 'l' Oxad '\O' "»wO!
555 R Data output_port 0x0000446C  0x00020000 <Data> 'y0' '\0' Ox02 'AO!
556 W Data output_fifo 000020000 0xFFFFFSE7 <Data> OxB7 O0xF§ OxFF OxFF
S60 SendData Ox00008044 0xES9FZ224 LDE rz,0x8z2d0
S60 R Data O0x00008200 O0x00004470 <Data> 'p' Oxad '"\0O' "wO!
18 R Data average 0x00004470 0x00000303 <Data> O0x03 Ox03 '\0' 'yv0!
LG4 R Data Ox00008204 OxABibhdid <Data> Oxbd Oxbdd Oxbdd Oxdd
565 R Data O0x00008205 Ox00004460 <Data> 'l' Oxad '\O' "»wO!
566 R Data output_port 0x0000446C  0x00020000 <Data> 'y0' '\0' Ox02 'AO!
567 W Data output_fifo Ox00020000 OxAABAADLAL <Data> Oxhd Oxdd Oxdd Oxdid
565 R Data O0x00008200 O0x00004470 <Data> 'p' Oxad '"\0O' "wO!
Lea R Data average 0x00004470 0x00000303 <Data> O0x03 Ox03 '\0' 'yv0!
570 R Data O0x00008205 Ox00004460 <Data> 'l' Oxad '\O' "»wO!
571 R Data output_port 0x0000446C  0x00020000 <Data> 'y0' '\0' Ox02 'AO!
572 W Data output_fifo 000020000 000000303 <Data> O0x03 O0x03 '\O' '"\O!
577 R Data 0x0000820C 000004490 <Data> 0xS0 Oxid '\O' '"\O!
578 E Data input 000004490 0xFFFFFD 42 <Data> 'B' OxFI' OxFF OxFF
579 R Data O0x00008205 Ox00004460 <Data> 'l' Oxad '\O' "»wO!
550 R Data output_port 0x0000446C  0x00020000 <Data> 'y0' '\0' Ox02 'AO!
581 W Data output_fifo 000020000 0xFFFFFD 42 <Data> 'B' OxFI' OxFF OxFF
4| k| Trace ,(Sourc:e KProfiIe / 4 j 4
Use expression to create address or auto-range to filker what is shown Tracing enabled

Figure 71
Enter 0x20000 from the Address Expression dialogue:
&¥ Enter Value X

-
\11) Enter Address Expression for Address or auto-range to filter with:

| 0x20000

Filter | Cancel |

Figure 72

You can now more readily observe all the accesses to 0x20000. Find a trace element that writes
the packet header word, 0OXAAAAAAAA. Observe that each packet consists of the header
word, the computed average and 1 to 16 input samples (based on the least-significant nibble of
the average).
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&F Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached]

M= X

[ Eile Edit Yiew Find Filter Sort Trace Data Profiling Data Help

=& [

Elem | Type | Symbolic Address | Data/Hex | Opcode Other ~
433 W Data output_fifo Ox00020000 OxFFFFECGE <Data> 'n' OxEC OxFF OxFF
441 W Data output_fifo Ox00020000 OxFFFFESED <Data> OxE0 OxES OxFF OxFF
452 W Data output £ifo 0x00020000 OxAABA0000 <Datar Oxdd Oxdd Oxdd Oxdid
457 W Data output_fifo Ox00020000 OxFFFFFCDO <Data> OxD0 OxFC OxFF OxFF
466 W Data output_fifo Ox00020000 Ox00000604 <Data> Ox04 Ox06 '‘\O' '"\O!
477 W Data output_fifo Ox00020000 OxAABAADLAL <Data> Oxhd Oxdd Oxdd Oxdid
452 W Data output_fifo Ox00020000 O0x0000014d <Data> Oxid Ox0L '\O' '"\O!
491 W Data output_fifo Ox00020000 OxFFFFFDSS <Datax 'U' OxFD OxFF OxFF
499 W Data output_fifo Ox00020000 0x0000044C <Data> OxAC Ox04 '\O' '"\O!
507 W Data output_fifo Ox00020000 OxFFFFF4EC «<Data> OxEC OxF4 OxFF OxFF
515 W Data output_fifo Ox00020000 0x00000EAS <Data> OxiAd Ox0E '‘\O' '"\O!
523 W Data output_fifo Ox00020000 0x00001147 <Data> 'G' 0«11 '»O' '"wO!
53d W Data output_fifo Ox00020000 OxAABAADLAL <Data> Oxhd Oxdd Oxdd Oxdid
539 W Data output_fifo Ox00020000 O0x00000141 <Data> Oxil OxOL '‘\O' '"\O!
545 W Data output_fifo Ox00020000 OxFFFFFE3d <Data> '4' OxF§ OxFF OxFF
556 W Data output_fifo Ox00020000 0xFFFFFSE? «<Data> OxE7 OxFS OxFF OxFF
@ W Data output_fifo Ox00020000 OxAABAADLAL <Data> Oxhd Oxdd Oxdd Oxdid
572 W Data output_fifo Ox00020000 0x00000303 <Data> O0x03 O0x03 '\O' '"\O!
581 W Data output_fifo Ox00020000 OxFFFFFD 42 <Data> 'B' OxFD OxFF OxFF
589 W Data output_fifo Ox00020000 0x00000615 <Data> Ox15 Ox06 '‘\O' '\O!
587 W Data output_fifo Ox00020000 0x00000BEE <Data> OxEE '‘w' '\0O' "\O!
605 W Data output_fifo Ox00020000 0x00000FZF <Datax '/' Ox0OF '\O' '"»wO!
4| k| Trace ,(Sourc:e KProfiIe / 4 j 4
Tracing enabled
Figure 73
In the trace above, SendData() has run four times:
Table 2
Header Element Average Input Words Written  Total Words Written
452 OxFFFFFCDO 1 3
4717 0x000001A4 5 7
534 0x000001A1 2 4
567 0x00000303 4 6
7.3 Tracing Data Accesses to a Specific Address
In the previous scenario, data trace was captured based on execution from a specified address
range. This type of capture is useful for most situations. However, an alternate method of data
trace is provided by the ETM based solely on data accesses (not instruction accesses). This
allows you to trace specific data accesses made from anywhere in your program. You may find
this type of trace useful if you have a global variable that is corrupted by a stray write or if you
want to see how frequently a variable is accessed.
In this scenario only accesses to *output_port (address 0x20000) are traced. You can configure
this type of capture using a Detailed Trace Point. Delete all previous trace points and reload
TRACE.AXF. Click on the left gutter of the Source window and select "Set Detailed
Tracepoint".
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FARVDEBUG = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =JoEd

[ File Edit Yiew Target Debug Tools Help

D EE & 2Rl BE srnret +dX | EEl 885

File |trace.c Find
|Fie] (Find |

e

int main (wvoid)

i

/% initialize board and data %/
Init():

Set Break
Go To Here
Scope to Here

Show Disassermbly/Source at this Location

int sample_num=0; /% local to track nuwher of samples */

tinually in main control loop */
ny;

i

Set Break...

Set BreakIf..

Set/Toggle Tracepoint...
Set Detailed Tracepoint...
Set Trace Fange

Break Infa...

g and determine if ADC has new data */
le_ready is zero %/

uence %/
Fdvn", sample num+) ;

Patch Asrm Interactive. ..
Set PC 1o Here

voo4% end while(l) */

Yoo/* end maini) *S

4 |k |\ Dam fSrc ytracec <| | _bIM
=
j=|
=l
Stop>
4| v b omd FStao fFieFind fLog ;| _>|

Stopped [n 67, col 2 [ A

Figure 74

The Set/Edit Tracepoint dialogue will open. This allows you to set both simple and detailed

trace points:

#f]Set/Edit Tracepoint

— Optional Settings:

Trigger ;I on Ilnstr Exec ;I when I TRACEWTZ: jﬂ iz equal to jﬂ

Pass I o] times
Size of Data Access IAny - l
Check Condition Code Ilgnore - l

Sets one tracepoint

Cancel | Help |

Figure 75

Use this dialogue to configure an instruction and data trace for all accesses of output_port, the
pointer to output_fifo. The top three parameters need to be modified:
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# Set/Edit Tracepoint X
|Trac:e Instr and Datsﬂ on |Data Access ﬂ when |@‘trace\\otﬂptﬂjm (g)ﬂ is equal to j ﬂ

Optional Settings:

Pasz |n times
Size of Data Access Any -

Sets one tracepoint

Jsrore -]
Ok Cancel Help

Figure 76

Use the circled down selector to open the <Variable list...> menu and browse for "output_port
of @trace". When this variable is selected it will appear as "@trace\\output_port" in the
dialogue:

# Set/Edit Tracepoint X
|Trac:e Instr and Datsﬂ an |Data Access ﬂ when |@‘lFaCE\\0lﬂplﬂJ30ﬁ |} I ;CIear entrys j ﬂ
Optional Settings: . <Function list... >
P.ass v time= <Variable list.,.>
Size of Data Access | any - <Module list...>
:I <Register list...=
Sets one tracepoint main
oK Cancel YWTRACEW#52
Favorites...
@tracethoutput_port
0x0000321c

Figure 77

Click the "OK" button to save the trace point. Observe that the Cmd tab of the output window
displays the command used to set the trace point. If you prefer, you may manually enter trace
points using the command line from the Cmd tab of the output window. A full description of

the command line interface is provided in the RealView Debugger Command Line Reference

Guide.

llolx

trodacoess, hw_out: "Tracepoint Type=Trace Instr and Data”™ @trace)’output_port
Stop>
< | » \cma fstao JFieFind fLog / J J
Stopped Lnh 57, Col 9

Figure 78

Trace points can be viewed, modified and cleared using the "View - Break/Tracepoints"” menu
from RVD. View the trace point you just set to confirm that it is set correctly. Since output_port
is a pointer, all accesses to the value of the pointer when the trace point was set (0x20000) will
be traced.
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Break/ Tracepoints
Og ~| E
Type Ualue
- & W|Trace Data Access Ox00020000
Address Ox00020000
Conmarid trodacoess, hw_out: "Tracepoint Type=Trace Instr and Data”™ @trace)’output_port
Figure 79

Run the program for a few seconds and stop it. Open the Analysis window and configure the
view of the trace capture. If you applied a trace filter from Section 7.2, remove the filter using
the "Filter - Clear Filtering" menu from the Analysis window. Also enable the Data/Hex and
Instruction trace view by selecting "Data Value in Hex" and "Instructions” in the "Trace Data"
menu (see Section 7.1).

Now scroll through the trace buffer and observe that only three instructions from SendData() are
traced. Trace is paused between each traced instruction. The three instructions are all STR

instructions from address 0x80CO (which writes the packet header), 0x80D4 (which writes the
average) and 0x80F0 (which writes the input samples):

£ Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =Jokd
[ File Edit view Find Filter Sort Trace Data Profiling Data Help
=1" [
Elem | Type | Symbolic | Address | Data/Hex | Opcode Other S
73 Warning: Trace pause
74 Exec sendDatal #230 0x000080C0 0xE5632000  STR vz, [r3,#0] |
74 W Data output_fifo Ox00020000 OxAABAADLAL <Data> Oxhd Oxdd Oxdd Oxdid
74 Warning: Trace pause
75 Exec SendDatah #2351 0x000050D4 OxESE32000 STR ra, [r3,#0]
75 W Data output_fifo Ox00020000 0x000003ED <Data> OxBO Ox03 '\O' '"\O!
75 Warning: Trace pause
76 Exec SendDatah #237 0x000050F0 OxESE32000 STR ra, [r3,#0]
76 W Data output_fifo Ox00020000 O0x00000348 <Datax 'J' 0«03 '"\O' 'O
78 Warning: Trace pause
7 Exec SendDatah #2350 0x000050C0 OxESE32000 STR ra, [r3,#0]
7 W Data output_fifo Ox00020000 OxAABAADLAL <Data> Oxhd Oxdd Oxdd Oxdid
77 Warning: Trace pause
75 Exec SendDatah #2351 0x000050D4 OxESE32000 STR ra, [r3,#0]
75 W Data output_fifo Ox00020000 O0x00000552 <Data> 'R' '"‘b'O'hO'OhO!
78 Warning: Trace pause
78 Exec SendDatah #237 0x000050F0 OxESE32000 STR ra, [r3,#0]
78 W Data output_fifo Ox00020000 0x00000656 <Data> '¥' Ox06 '\O' '"wO!
79 Warning: Trace pause
g0 Exec SendDatah #237 0x000050F0 OxESE32000 STR ra, [r3,#0]
g0 W Data output_fifo Ox00020000 0x000007ES <Data> OxES '‘“a' '\O' "\O!
g0 Warning: Trace pause
gl Exec SendDatah #237 0x000050F0 OxESE32000 STR ra, [r3,#0]
gl W Data output_fifo Ox00020000 0x0000054C <Data> 'L' '‘b'O'hO'hO!
g1 Warning: Trace pause
gz Exec SendDatah #2350 0x000050C0 OxESE32000 STR ra, [r3,#0]
gz W Data output_fifo Ox00020000 OxAABAADLAL <Data> Oxhd Oxdd Oxdd Oxdid
g2 Warning: Trace pause
4| k| Trace ,(Sourc:e KProfiIe / 4 j 4
Tracing enabled

Figure 80

This capture was configured to trace all accesses to *output_port. RVD allows one to specify
the data access type - either a read or write. In this program only writes are made to
*output_port, so the same trace capture can be obtained using a trace point that specifies "Data
Write" instead of "Data Access":
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£f]Set/Edit Tracepoint

X]

|Trac:e Inztr and Datsﬂ il |Data Wnitite

Optional Settings:

Pasz |n times

Size of Data Access Any -

J hen | @tracetioutput_port

jﬂ iz equal to l— jﬂ

Sets one tracepoint

OK Cancel

Help

Figure 81

The variable "average" is both read and written in the program. To trace only the reads of
"average", delete the previous trace point and set the following trace point:

#f]Set/Edit Tracepoint

X]

|Trac:e Inztr and Datsﬂ @ |Data Read

Optional Settings:

Pasz |n times
Size of Data Access Any -

ﬂ when |@tracd@average )]

jﬂ iz equal to l— jﬂ

Sets ane tracepoint|

Jsrore -]
Ok Cancel

Help

Note

Figure 82

To trace accesses to a variable, you must manually precede the symbol name with an ampersand
to de-reference the address of the variable. To trace accesses to average, you must select
"average @trace" from the variable browser. This will be displayed as " @trace\\average" in the
dialogue. You must then manually add the ampersand to the "when" field to create

"@trace\\&average".

This results in the following command:

ﬂ trodread,hw_out:"Tracepoint Type=Trace Instr and Data™ @rracel’saverage
[
hd
Stop>
< | » \cma fstao JFieFind fLog / J J
Stopped Lh 52, Col 1
Figure 83

Confirm that the trace point is properly set using "View - Break/Tracepoints" from RVD :

Break/ Tracepoints
Og ~| E
Type Ualue
=& WTrace Da. — 0x00004470
Address 0x00004470
Conmarid trodread,hw_out:"Tracepoint Type=Trace Instr and Data™ @rracel’saverage
Figure 84
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Run the program for a few seconds and stop it, you will see that average is only read from two
instructions. It is read both times from SendData: once to compute the number of input samples
to output (from address 0x80AS), and a second time so that it may be output (from address
0x80CS8). In both cases the value of average will always be the same (0x227 in the highlighted
line), but it will vary the next time SendData() executes.

£ Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =Jokd
[ Eile Edit Yiew Find Filter Sort Trace Data Profiling Data Help
=1" [
Elem | Type | Symbolic | Address | Data/Hex | Opcode Other S
37 Warning: Trace pause
38 Exec sendData\#228 0x00008048 0xE5922000 LDE. vz, [r2,#0] |
38 R Data average 0x00004470 0x00000227 <Datax 'N'' Ox02 '\vO0'o'h0!
35 Warning: Trace pause
39 Exec SendDatah #2351 0x000050CE 0xES92ZZ000 LDE ra,[rz,#0]
39 R Data average 0x00004470 0x00000227 <Datax 'N'' Ox02 '\vO0'o'h0!
39 Warning: Trace pause
40 Exec SendDatab #2285 0x00005045 0xES92ZZ000 LDE ra,[rz,#0]
40 R Data average 0x00004470 0x00000493 <Data> 0x%93 Ox04 '\0' 'yvO!
40 Warning: Trace pause
41 Exec SendDatah #2351 0x000050CE 0xES92ZZ000 LDE ra,[rz,#0]
41 R Data average 0x00004470 0x00000493 <Data> 0x%93 Ox04 '\0' 'yvO!
41 Warning: Trace pause
42 Exec SendDatab #2285 0x00005045 0xES92ZZ000 LDE ra,[rz,#0]
42 R Data average 0x00004470 0x00000183 <Data> 0x83 Ox01 '»O0' 'yvO!
42 Warning: Trace pause
43 Exec SendDatah #2351 0x000050CE 0xES92ZZ000 LDE ra,[rz,#0]
43 R Data average 0x00004470 0x00000183 <Data> 0x83 Ox01 '»O0' 'yvO!
43 Warning: Trace pause
44 Exec SendDatab #2285 0x00005045 0xES92ZZ000 LDE ra,[rz,#0]
44 R Data average 0x00004470 0x00000841 <Data> 'A' '‘b' 'yo'otvo!
44 Warning: Trace pause
45 Exec SendDatah #2351 0x000050CE 0xES92ZZ000 LDE ra,[rz,#0]
45 R Data average 0x00004470 0x00000841 <Data> 'A' '‘b' 'yo'otvo!
45 Warning: Trace pause
46 Exec SendDatab #2285 0x00005045 0xES92ZZ000 LDE ra,[rz,#0]
465 R Data average 0x00004470 0x00000593 <Data> 0x%93 Ox05 '\0' 'yvO!
45 Warning: Trace pause
47 Exec SendDatah #2351 0x000050CE 0xES92ZZ000 LDE ra,[rz,#0]
47 R Data average 0x00004470 0x00000593 <Data> 0x%93 Ox05 '\0' 'yvO!
4| k| Trace ,(Sourc:e KProfiIe / 4 j 4
Tracing enabled

Figure 85

Now modify the trace point to trace data writes to &average:

X|
jﬂ iz equal to l— jﬂ

#f]Set/Edit Tracepoint

J when | @tracetigaverage

Optional Settings:

Pasz |n times
Size of Data Access Any -

Sets one tracepoint

Jsrore -]
Ok Cancel Help

Figure 86

Run the program for a few seconds (it doesn't have to be re-loaded) and stop it. Observe that
&average is only written to at one location in the program (in GetAverage()):
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&F Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached]

M= X

O File Edit Yiew

Find Filter Sort Trace Data Profiling Data Help

=1" [

Elem | Type | Symbolic | Address | Data/Hex | Opcode Other S
19 Exec Gethverage' #1885 O0x0000813C 0xESSC3000 STR. r3, [rl&,#0]

19 W Data average 0x00004470 0x00000113 <Data> Ox13 Ox01 'y0' 'yv0!
19 Warning: Trace pause

20 Exec Getdverage' #188 0x0000813C 0xE5S6C3000  STR r3,[rl2,$0] |

z0 W Data average 0x00004470 0x00000014 <Data> Ox14 '\O0' '\o0' 'ho!
20 Warning: Trace pause

Z1 Exec Gethverage' #1885 O0x0000813C 0xESSC3000 STR. r3, [rl&,#0]

Z1 W Data average 0x00004470 0x0000039E <Data> O0x%E Ox03 '\0' 'yvO!
21 Warning: Trace pause

ZZ Exec Gethverage' #1885 O0x0000813C 0xESSC3000 STR. r3, [rl&,#0]

22 W Data average 0x00004470 0x00000494 <Data> O0x%4 Ox04 '\0' 'yv0O!
22 Warning: Trace pause

23 Exec Gethverage' #1885 O0x0000813C 0xESSC3000 STR. r3, [rl&,#0]

23 W Data average 0x00004470 0xFFFFFOES <Data> OxE5 O0xF9 OxFF OxFF
23 Warning: Trace pause

Z4 Exec Gethverage' #1885 O0x0000813C 0xESSC3000 STR. r3, [rl&,#0]

24 W Data average 0x00004470 0xFFFFFF74 <Data> 't' O0xFF OxFF OxFF
24 Warning: Trace pause

Z5 Exec Gethverage' #1885 O0x0000813C 0xESSC3000 STR. r3, [rl&,#0]

25 W Data average 0x00004470 0x000001C7 <Data> OxC7 Ox01 'y0' 'yvO!
25 Warning: Trace pause

Z6 Exec Gethverage' #1885 O0x0000813C 0xESSC3000 STR. r3, [rl&,#0]

26 W Data average 0x00004470 0x0000068E <Data> Ox8E Ox06 'y0' 'yvO!
26 Warning: Trace pause

27 Exec Gethverage' #1885 O0x0000813C 0xESSC3000 STR. r3, [rl&,#0]

27 W Data average 0x00004470 0x000004D7 <Data> OxD7 Ox04 '\O0' 'yv0!
27 Warning: Trace pause

28 Exec Gethverage' #1885 O0x0000813C 0xESSC3000 STR. r3, [rl&,#0]

28 W Data average 0x00004470 0xFFFFF77C <Datax '|' OxF7 OxFF OxFF
28 Warning: Trace pause

4| k| Trace ,(Sourc:e KProfiIe / 4 j 4

Tracing enabled

Figure 87
7.4 Tracing Data Accesses to an Address Range
In Section 7.3 data traces are configured to trace accesses to a specific address - either
*output_port or &average. The ETM also allows data trace to be configured for an address
range. In this scenario, all read accesses to the input[ ] array will be traced. Add the input][ ]
array to the Watch window to determine the location of the array in memory. The 16-word array
resides from 0xA490 (index 0) through 0xA4CF (index 15):
Watch
Og ~ =]
Hame | Ualue -~
=l input [Ox00004450]
[o] 0xFFFFFDAL
[1] 0x00000471
[2] 0xFFFFF459
[3] 0xFFFFF1&F
[4] 0x00001F61
[5] 0xFFFFECE6
[6] 0xFFFFFESD
[7] 0xFFFFFE04
[8] 0xFFFFFFCL
[9] 0xFFFFFF7C
[10] O0x00000721
[11] 0xFFFFF364
[1z] 0xFFFFEEED
[13] 0xFFFFFACOE
[14] 0xFFFFFGLE
[15] 000000913
< v \wateht finiatenz fweteha £ 4 | e
Figure 88
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To trace data reads from a memory range, the command line interface must be used. Reload
TRACE.AXF, remove any previous trace points and set the following data trace point using the
command window:

> trcdread,hw_out:"Tracepoint Type=Trace Instr and Data" 0xa490..0xadcf

ﬂ trodread, hw_out:"Tracepoint Type=Trace Instr and Data™ OxadS0..0xadcf
[
hd
Stop>
4| » \cmd fstao JFieFind JLog / J J
Stopped Ln 200, Col 38
Figure 89
Break/ Tracepoints
Og ~| E
Type Ualue
=& WTrace Da. —0x00004490
Address 0x00004490
Address O0x000044CF
Commard trodread, hw_out:"Tracepoint Type=Trace Instr and Data™ OxadS0..0xadcf
Figure 90

Now run the program for a few seconds and stop it. Scroll through the Analysis window and
observe the following:

. Read accesses to input[ ] are made from GetData(), GetAverage() and SendData(). This
is most readily observed by clicking on the "Source" tab in the Analysis window.

o All 16 words of input[ ] are read and traced

. Some instructions that don't access the data trace range are traced
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&F Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached]

M= X

O File Edit Yiew

Find Filter Sort Trace Data Profiling Data Help

4| k| Trace ,(Sourc:e KProfiIe /

=1" [
Elem | Type | Symbolic | Address | Opcode Other ~
551 Warning: Trace pause
552 Exec SendDatah #237 0x000050E4 0xE792Z100 LDE rz,[rZ,e0,L3L #2]
552 R Data input+0x14 0x00004444 <Data> 0x91 OxE3 OxFF OxFF
552 Warning: Trace pause
553 Exec sendDatal #237 0x000080E4 0xE7922100 LLE. rz, [rz,r0,L5L #27 |
553 R Data input+0x15 0x00004445 <Data> ':' O0xFZ OxFF OxFF
553 Warning: Trace pause
554 Exec GetData\#153 0x00005148 0xES911000 LDE rl,[rl,#0]
554 R Data input 0x00004490 <Data> O0x8E 'ha' '\0' 'hvo!
555 Exec GetData\#153 0x0000514C 0xES9FZ185 LDE rz,0xgz2de
555 Warning: Trace pause
556 Exec GetData\#153 0x00005150 0xES92203C LDE ra, [rZ,#0x3c]
R Data input4+0x3C 0x000044CC <Datax O0x93 '\vo'o'yo't o 'vao!

557 Exec GetData\#153 0x00005154 0xE3403001 Moy r3, #l
558 Exec GetData\#153 0x00005158 0xE0S320C2 ADD rZ,r3,ri,A5R #1
559 Exec GetData\#153 0x0000815C 0xE0Z211002 EOR rl,rl,ra

El Warning: Trace pause
S60 Exec GetData' #157 0x00005174 0xE7911100 LDE rl,[rl,r0,L3L #2]
S60 R Data input+0x04 Ox00004454 <Data> O0x9Z OxFi OxFF OxFF
561 Exec GetData' #157 0x00005178 0xE2402001 SUB ra,r0,#1
Lel Warning: Trace pause
S62 Exec GetData' #157 0x00005180 0xE7932102 LDE rz,[r3,r2,L3L #2]
S62 R Data input 000004490 <Data> 'A' 0«03 '"\O' 'O
563 Exec GetData' #157 0x00005154 0xE3403001 Moy r3, #l
LG4 Exec GetData' #157 0x00005188 0xE0S320C2 ADD rZ,r3,ri,A5R #1
565 Exec GetData' #157 O0x0000518C 0xE0Z211002 EOR rl,rl,ra
565 Warning: Trace pause
S66 Exec GetData' #157 0x00005174 0xE7911100 LDE rl,[rl,r0,L3L #2]
S66 R Data input+0x05 0x00004495 <Data> Ox0E OxF&6 OxFF OxFF
567 Exec GetData' #157 0x00005178 0xE2402001 SUB ra,r0,#1
587 Warning: Trace pause
565 Exec GetData' #157 0x00005180 0xE7932102 LDE rz,[r3,r2,L3L #2]
565 R Data input+0x04 Ox00004454 <Data> '3' OxFBE OxFF OxFF
569 Exec GetData' #157 0x00005154 0xE3403001 Moy r3, #l
570 Exec GetData' #157 0x00005188 0xE0S320C2 ADD rZ,r3,ri,A5R #1
571 Exec GetData' #157 O0x0000518C 0xE0Z211002 EOR rl,rl,ra
571 Warning: Trace pause
572 Exec GetData' #157 0x00005174 0xE7911100 LDE rl,[rl,r0,L3L #2]
572 R Data input+0x0C 000004490 <Data> O0x06 OxF4 OxFF OxFF
573 Exec GetData\ #157 000005175 OxE2402001 SUB ra,r0,#1

<

| 2 e

Tracing enabled

Figure 91

The most interesting item in the capture is that the even some instructions that don't make a data
access are traced (such as circled elements 557 - 559). Even though this appears to be a problem
with the trace, this behavior is defined in the ETM Architecture Specification. Namely, when a
data access is made within the specified data range, trace is activated and stays active until a data

access is made outside the range.

The instruction at element 556 performs a read of input[15] and this activates trace. The three
circled instructions only perform internal register operations so they are also traced. If you

reference the Dsm tab of the main RVD window you will see that the next executed instruction
is "LDR 12, 0x82DC" (located at 0x8160). This instruction makes a data access outside the trace
range so it is not traced and trace is deactivated (paused).
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8 Tracing a Running Target
The trace examples presented in Sections 4 - 7 generate trace displays by halting the running
target. When a target is halted with trace enabled, the captured trace buffer stored in Real View
Trace or the target's ETB is automatically dumped to RVD for display. There may be times
when your target can not be stopped to generate a trace capture because it is controlling
hardware which must continue to operate. In these situations you will have to make a trace
capture from a running target.
There are two methods to perform a capture with a running target. You can either disable trace
or use a trace trigger. Both of these scenarios are described in this section.
8.1 Connecting the Analyzer and Disabling Trace
Remove all trace points and breakpoints that you may have set. Ensure that the trace analyzer
is not connected. If the trace analyzer is connected, disconnect it using the "Edit -
Connect/Disconnect Analyzer" menu from the Analysis window:
£ Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattac... |- 024
[ File | Edit View Find Filter Sort Trace Data Profiling Data Help
= b By Copy Cr+c
El&ﬂ Connect/Disconnect Analyzer | Address | Opcode Othe |~
<No D:
Tracing Enabled
Configure Analyzer Properties...
Set Trace Buffer Size...
Store Confrol-Flow Changes Only
Buffer Full Mode
Trigger Mode
Data Tracing Mode
Automatic Tracing Mode
Set/Edit Event Triggers...
Clear &l Event Triggers
Physical to Logical Address Mapping. ..
4 | ¥ Nrroeegreeresgrrome “ 2
Toggle Connection to Logic Analyzer or other Analysis mechanism, Tracing enabled
Figure 92
When you disconnect the trace analyzer from the Analysis window, the following message is
displayed in the RVD command window:
ﬁ analyzer,disconnect
g tracebuffer,qui,close
=
Stop>
< | » \cma fstao JFieFind fLog / J J
Stopped Lh 52, Col 1
Figure 93
Additionally, the status bar of the Analysis window indicates that the trace analyzer is not
connected. When the trace analyzer is not connected, trace is disabled on the target:
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£ Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =Jokd
[ Eile Edit Yiew Find Filter Sort Trace Data Profiling Data Help
IR I T

Elem | Time/pico | Type | Symbolic | Address | Opcode 0ther A
<No Analyzer Connected and No File Loaded: Tl

4| k| Trace ,(Sourc:e KProfiIe / J Jv
Mot connecgeD

Figure 94

Load TRACE.AXF and run the program. Connect the trace analyzer from the RVD "Tools -
Analyzer/Trace Control - Connect Analyzer/Analysis" menu. When the analyzer is first
connected, trace is enabled with Auto Tracing (see Section 4). In the status bar, observe that
trace is now enabled:

£ Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =Jokd
[ Eile Edit Yiew Find Filter Sort Trace Data Profiling Data Help
=1 nEE-

Elem | Time/pico | Type | Symbolic | Address | Opcode 0ther A
<No Data in Buffer:> W

4 | k| Trace ,(Sourc:e KProfiIe / J Jv
< [Tracing enabled >
Figure 95

Even though tracing is enabled, no trace data is displayed in RVD until the target is halted,
tracing is disabled or a trigger point is reached. When the trace buffer is full, trace continues to
be captured by overwriting the oldest trace sample in the buffer.

If you need to change the ETM configuration, you can do this even while the target is running.
Use the "Tools - Analyzer/Trace Control - Configure Analyzer Properties" menu as described in
Section 3. For configuration changes to take effect, tracing is stopped and restarted while your
target continues to run. If you do make a change in the configuration, RVD prompts you to allow
the change to occur. If you changed the ETM configuration, click the "Yes" button in the RVD
prompt:
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£l Prompt X

These changes will nat take effect until
tracing hag been restarted.

\i,) Fiestart tracing now?

Mo |

Figure 96

With the program running and trace enabled, disable trace capture from the "Edit - Tracing
Enabled" menu in the Analysis window. This selection toggles tracing on and off:

£ Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattac... |- 024

<No D:

[ File | Edit View Find Filter Sort Trace Data Profiling Data Help
= b By Copy Cr+c
Elem @ Connect/Disconnect snalyzer

Tracing Enabled

Configure Analyzer Properties...
Set Trace Buffer Size...

Store Confrol-Flow Changes Only
Buffer Full Mode

Trigger Mode »
Data Tracing Mode »
Automatic Tracing Mode 2
Set/Edit Event Triggers...

Clear &l Event Triggers

Physical to Logical Address Mapping. ..

| Address | Opcode Othe |~

A | r e

kil el

E— e

Enables/Disables tracing on the analyzer.

Tracing enabled

Figure 97

Observe that when the selection is made, tracing is disabled, the trace buffer is dumped to RVD

and the target continues to run:

&F Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached]

M= X

[ Eile Edit Yiew Find Filter Sort Trace Data Profiling Data Help

w & i U g

Elem | Time/inst | Type | symbolic | address | opcode Other -
u] Warning: Debug state

0 -326099 Exec _sys_write 0x00008FED  OxE2EDDOLO ADD sp,sp, #0x10

1 -326095 Exec _S¥s5_write 0x00005FE4 0xESEDS010 rorP {rd,pcl

Z -326097 Exec _writebuf O0x0000891C 0xES94100C LDE rl,[rd,#0xc]

3 -326096 Exec _writebuf O0x00008920 0xE3CO0Z102 BIC ra, 0, #0x50000000

4 -326095 Exec _writebuf Ox00008924 0xE0462002 SUB rZ,rf,ri

5 -326094 Exec _writebuf 0x00008925 0xE3511701 OFE rl,rl,#0x40000

& -326093 Exec _writebuf Ox0000892C OxESS4100C STR rl,[rd,#0xc]

7 -326092 Exec _writebuf 000008930 0xES941015 LDE rl,[rd,#0x15]

g -326091 Exec _writebuf 0x000059354 0xE3500000 CHFP rl, #0

9 -326090 Exec _writebuf 0x00008935 0xE0S11002 ADD rl,rl,ra

10 -326089 Exec _writebuf 0000089350 0xES541015 STR rl,[rd,#0x15]

11 -326088 Exec _writebuf 000005940 Ox0ADO0D0Z BEQ 0x5950 <_writebuf+0x9d-

1z -326087 Exec _writebuf 000008950 0xESEDOLFO FOP {rd-ri}

13 -326086 Exec _writebuf Ox00005954 0xE49DF004 FOP {pc}

14 -326085 Exec _ flsbuf Ox000094CC 0xE3500000 CHFP rl, #0

15 -326084 Exec _ flsbuf 000009400 Ox0A00000L BEQ OxSade <_ flsbuf+0x3ZCx

4| k| Trace ,(Sourc:e KProfiIe / 4 | | j 4

Tracing disabled >

Figure 98
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Toggle tracing on and off from the "Edit - Tracing Enabled" menu a few times and observe how
new trace captures are made each time tracing is disabled. With tracing enabled and your
program running, set the Automatic Tracing Mode to "Instructions and Data" from the Edit

menu:

i .
£ Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =Jokd
[ Eile | Edit “iew Find Filter Sort Trace Data Profiling Data Help

= [ B Copy Ciric

Elem @ Cpnnect/Disconnect snalyzer Address [ Opcode Other ~

0

0 Tracing Enabled %x00008FEQ  OxE2EDDOL0 ADD ap,3p, #0x10

1 Configure Analyzer Broperties. .. x0000SFE4  0xESEDS0L0 POF {rd,po}

z ®0000831C  0xE5941000 LDR rl,[rd,#0xc]

3 Set Trace Buffer Sige... x00008920  0xE3C02102 BIC r2,r0,#0x50000000

4 x00008924  0xE0462002 SUE rZ,r6,r2

5 Stare Cantral-Elow Changes Only x00008925  OxE3511701 ORE rl,rl,#0x40000

6 ®0000892C  0xE5541000 5TR rl,[rd,#0xc]

7 Buffer Full Mode %00008930  OxE5941018 LDR rl,[£4, #0x18]

3 Trigger Mode , Dx00008934  0xE3500000 CHP r0,#0

a - x00008935  0xE0511002 ADD rl,rl,r2

10 Diata Tracing Mode b Dx00008930 OxES841018 STR rl,[r4d,$0x18]

11 . . --anoanoan oennanoans BRQ 0x8950 <_writehuf+0x94s

12 Automatic Tracing Mode D Off (Use Tracepoints) | pop {rd-ra}

13 ) ) ) POP {pch

1a Set/Edit Event Triggers... v Instructions Only P £0,#0

15 Clear &l Event Triggers Data Orily EEQ Ox%ade <_ flshuf+0x320C>

18 cHrp 6, $0

17 Physical to Logical Address Mapping. .. Instructions and Data BEQ Ox5b04 «_ flshuf+lx354s

13 =EZTTOT EXET “rTERUT TEOUOOYETE UXESYE000C LDE r0,[r4,#0xc]

13 -621699 Exec  _ flshuf 0x00009B05  0xE3100502 TST r0, #0x800000

4|k [} Trace ,(Sourc:e KProfiIe / 4 | | j w
Trace both instructions and data accesses Tracing enabled

Figure 99

And click "Yes" for the prompt to restart tracing with the new trace settings:

£l Prompt X

These changes will nat take effect until
tracing hag been restarted.

\i,) Fiestart tracing now?

Mo |

Figure 100

Now disable trace from the "Edit - Tracing Enabled" menu in the Analysis window to perform
the trace capture. Observe how both instruction execution and data accesses are now traced:
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8.2

Application Note 168

£ Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =Jokd

[ Eile Edit Yiew Find Filter Sort Trace Data Profiling Data Help

w & i U g

Elem | Time/inst | Type | symbolic | address | opcode Other -
u] Warning: Debug state

0 -707474 Exec _sys_write 0x0O000SFED  OxEZEDDOLO ADD sp,sp, #0x10

1 -707473 Exec s¥s write 0x00005FE4 0xESEDS010 rorP {rd, pcl

1 F Data 0x0000AEDD <Datar OxFO OxAS '40' 400 |

1 R Data 0x0000ABD 4 <Datar OxlC 0x89 400 40

2 -707472 Exec _writebuf 0x0000891C  OxESS41000 LR rl,[r4, #0xc]

z _ stdout+0x0C 0x0000A5FC <Datas O0x02 '*' 'E' 'O

3 -707471 Exec _writebuf 0x00008920  OxE3C02102 EIC r2,r0, $0xE0000000

4 -707470 Exec _writebuf 0x00008924  OxE0462002 SUB £Z,r6,r2

5 -707459 Exec _writebuf 0x00008928  OxE3811701 ORR rl,rl, #0:40000

3 -7074658 Exec _writebuf 0x0000892C  OxES841000 STR rl,[r4, #0xc]

& _ stdout+0x0C Ox0000ASFC <Data» Ox0Z '*' 'E' '\0

7 -707457 Exe _writebuf 0x00008930  OxESS41018 LR rl,[r4,#0x18]

7 " stdout+0xls 0x0000A608 <Data» 0x16 'P' '30' 30

8 -707456 Exec _writebuf 0x00008934  OxE3500000 cHp 0,40

g -707455 Exec _writebuf 0x00008938  OxE0811002 ADD rl,rl,r2

10 -707464 Exe _writebuf 0x0000893C  OxES841018 STR rl,[r4,#0x18]

10 _ stdout+0xls 000004608 <Data» '-' 'F' '\0' 30

11 -707453 Exee _writebuf 0x00008940  0x0A000002 BEQ 0x8950 <_writebuf+ixdds
1z -707452 5 _writebuf 0x00008950  OxESEDOLFD FOP {rd-ra}

1z <Data> OxFO 0xAS '40' '\0' Ox0z '%
1z <Datax '30' '30' 400 300 OxFO OxA7
1z <Data> OxO1l '30' '40' '40°

13 -707451 EXE _writebuf 0x00008954  OxE49DFO04 FOP {pc}

13 Ox0000ABEC <Data> OxCC 0x94 '30' '40

14 -707450 wE _ flshut 0x0000SACC  OxE3500000 cHp 0,40

15 -707453 Exec _ flshut 0x00009ADO  0x0A00000L BEQ OxSade <_ flshuf+0x32Cs
16 -707458 Exec _ flshut 0x00009ADE  OxE3560000 cHp 6,40

17 -707457 Exec _ flshut 0xO000SAED  0x0A000007 BEQ OxSh04 <_ flshuf+0x35ds
18 -707456 Exec _ flshut 0x00009B04  OxESS40000 LR 0, [£4, #0xc]

18 " stdout+0x0C 0X0000ASFC <Data» 0x0Z '*' 'E' 'y0"

139 -707455 Exec _ flshut 0x00009BO8  OxE3100502 TST £0, #0x800000

20 -707454 Exec _ flshut 0x0000BOC  0x0A000007 BEQ OxSh30 <_ £lshuf+0x3s0s
21 -707453 Exec _ flshut 0x00009B30  OxEZ0BE0FF AND r6,rll, #0xEE

22 -707452 Exec _ flshut 0x00009B34  OxE3580000 cHp 8,40

23 -707451 NoExec — _ flshuf 0x00009B38  0x0A000001 BEQ OxShdd <_ flshuf+0x3gds
z4 -707450 Exec _ flshut 0x00009B3C  OxELAD00O9 now 0,19

25 -707449 Exec _ flshut 0x00009B40  0xELA0D0000 nov 0,10

4| k| Trace ,(Sourc:e KProfiIe / 4 | j 4

Tracing disabled

Figure 101

Simple Trace Triggers

Triggers are used to initiate a trace capture based upon a user-defined trigger condition. When
the trigger condition is met, the target will continue to run and the trace buffer will fill with new
data. When the trace buffer is full, the contents of the buffer will be dumped to RVD for
analysis. After the trace capture is made, trace is no longer enabled even though your target
continues running.

In this scenario a trace capture similar to that from Section 4 will be made with the use of a Trace
Trigger instead of Auto Tracing with breakpoints. A trigger will be used to make a trace capture
which includes the execution of the C library startup code and entry into the while(1) loop of
main().

If you disabled trace in Section 8.1, enable trace as described in Section 3. Set the Automatic
Tracing Mode back to "Instructions Only" from the Edit menu in the Analysis Window. Reload
TRACE.AXF and remove all trace points. Place a Trigger point at the call to Init() in main():
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Application Note 168

FARVDEBUG = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =JoEd
[ File Edit Yiew Target Debug Tools Help

ODEd & mEElE seaipe s ¢3Sl E8EE-5-
Fileltrace.c Find | j Line

"/ ]
int main (wvoid)
int sample_num=0; /% local to track nuwher of samples */

/% initialize board and data %/
= Init():

A% enter program executive, loop contimually in main control loop */
printf ("Entering main control loopin™):

while(l)

i

A% bunp global execution counter */
num_runs+=1;

/% use rand() to simulate polling and determine if ADC has new data */
A% ADC data iz awailable if sample_ready is =zero */
sample_ready = (rand():N):

if (sample_ready==0)
i
/% start data processing secquence ¥/
printf ("Processing Sample: %dvn", sample num+) 2
GetDatal);
Getdverage(]:
SendDatal);
vo4% end if () *S

voo4% end while(l) */

Yoo/* end maini) *S

LR \DsmKSrc i trace.c / 4 j[v]
fﬂ trace,prompt YTRACE,#659:1
[
hd

Stop>

< | » \cma fstao JFieFind fLog / J J

Stopped Lh 65, Col 1
Figure 102

Open the Trace Analysis window from the "View - Analysis" menu in RVD. Run the program.
If you are using RVT, observe that almost immediately the "TRIG" LED lights on the bottom
right of the unit. This indicates the trace trigger has been reached. Wait several seconds for the
Analysis window to populate with trace data as your program continues to run. Examine the
Analysis window and observe that tracing starts from the program entry point (0x8000):
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Application Note 168

& Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] M=1X
[ File Edit View Find Filter Sort Trace Data Profiling Data Help

= EEF-

Elem | Time/inst | Type | Symbolic | Address | Opcode Other ~

1] Warning: Debug state

a -14393 Exec main 000005000 0xEA0Q0000 E scatterload rt2 <0x8008 |

1 -1492 Exec _ scatterload rt2 000005005 OxEZ5F0025 ADE 0, {pci+0x30 ; Ox5038

2 -1491 Exec _ scatterload rta 0x0000500C OxESS00C00 LM ro,{rl0,rll}

3 -1450 Exec _ zcatterload rt2 000008010 OxE084A000  ADD rlo,xl0,r0

4 -1439 Exec _ scatterload rt2 0x00005014  OxE0S8BEOOO  ADD rll,rll,r0

5 -14a8 Exec _ scatterload rt2 000005018 OxEZ447001 SUE r7,rlo, #1

[} -14a7 Exec _ scatterload null 0x0000G01C 0xE154000E CHP rlo,rll

7 -1436 NoExec  _ scatterload rmll 000008020 Ox0&00018E  BEQ __rt_entry <0xS8654>

g -1455% Exec _ scatterload null Ox00005024 0xESEBAODODOF LIM rlo!  {r0-r3}

9 -1454 Exec _ scatterload null 000005025 OxEZ4FE014 ADE lr,{pci-0Oxc ; Ox80lc

10 -1483 Exec _ scatterload mull Ox0000G02C OxE3130001  TaT r3, #1

11 -14582 NoExec _ zcatterload null 0=00008030 0x1047F003 SUENE pc,r?,r3

1z -1481 Exec _ scatterload null Ox000080354 OxELlAOFO03 Hov po,r3

13 -14&0 Exec _ scatterload copy 000005040 OxEZ2522010 SUBS ri,ra, #0x10

14 -1479 NoExec _ scatterload copy 000005044 0x=5E00075 LDMCS ro!,{fr3-ra6}

15 -1478 NoExec _ scatterload copy 0x00008043 Ox28A10078 STHCS rl!, fr3i-ra}

15 -147%7 NoExec  _ scatterload copy 000005040 OxSAFFFFFE  EHI __scatterload _copy <0x8040>

17 -147& Exec _ scatterload copy 0x00005050 OxE1EQZESE L3LE LZ, L, #29

15 =-1475 NoExec _ scatterload copy 000005054 Ox25E00030 LDMCS ro!,frd, r5}

19 -1474 NoExec _ scatterload copy 0x00008058 Ox28A410030 STHCS rl!, frd,e51

20 -1473 Exec __scatterload_copy Ox0000805C Ox45904000 LDEMI rd,[x0,#0]

z1 -1472 Exec _ scatterload copy 0x00005050 Ox<45514000 STEMI rd, [zl,#0]

22 =-1471 Exec _ scatterload copy 000005064 OxE1AQFOCE MoV pc,lr

23 -1470 Exec _ scatterload mmll 000008010 0xE1 540008 CHP rlo,rll

24 -1469 NoExec  _ scatterload null 000005020 0x0&000158E  BEQ _ rt_entry <0xS654>

25 -1465 Exec _ scatterload null 0x00005024 OxESBAOOOF LM rilg! , {r0-r3}

26 -1487 Exec _ =zcatterload mull 0x00008028 O<EZ4FEO014 ADR lr,{pci-0xc @ OxE01c

27 -1466 Exec _ scatterload nmll 000005020 OxE3130001  TaT 3, #1

Z8 -1465 NoExec _ scatterload null 000005030 0x1047F003 SUBNE pc,r7,r3

| » I\ Trace fsource [Profile / 4| | ﬂ v

Tracing enabled

Figure 103

Search for the Trigger in the trace buffer using the "Find - Find Trigger" menu:
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&¥ Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached]

M= X

[ Eile Edit Yiew  Find Filter Sort Trace Data Profiling Data Help

== Find Trigger

Elem Time/ir Find Position. .. AltHFZ Address | Opcode 0ther ~
o] Warning: . n

[ “1493 Find Timestarmp... 0x00008000 _ OxEAO00000 B scatterload rtz <0x8008> |
1 -l43z Find Address Expressian. .. 0x00008008  OxE28F0028  ADR 0, {pc}+0x30 ; OxB033

Z -1491 Ox0000800C OxES900C00 LM r0,{rl0,rll}

3 -1490 Find Data Yalue... 0x00008010  0xEOSAA000  ADD £l0,rl0,x0

4 -1459 . 0x00005014 0xEOQSEEQOO ADD rll,rll,x0

5 -1488 Find Syrnbal Narme. . 0x00008018  OxE2447001  SUB r7,rl0,#1

& -1457 Find Mext =] Ox0000801C 0xE154000E CHP rlo,rll

7 -1456 Ox00008020 Ox0ADO01SE BEQ _ rt_entry <0x8654-

g -1455 Find Previous Shift+F3 Ox00005024 OxESEADOOF LM rln!, {x0-r3}

9 -1454 = — ITHTT O0x00008025 0xEZ4FE014 ADE. lr,{pc}-Oxc ; OxG0lc

10 -1483 Exec _ scatterload null Ox0000802C OxE3130001  TaT r3, #l

11 -1452 HoExec _ scatterload null 0x00003030 0x1047F003 SUBNE pc,r7,r3

1z -14s1 Exec _ scatterload null 0x00005034  OxElAQFO03 MOV pc,r3

13 -14350 Exec _ scatterload copy 0x00003040 0xEZ522010 SUBS rz,rz,#0x10

14 -1479 HoExec _ scatterload copy 0x00005044 0x25B00073 LDMCS r0! , {r3-r6}

15 -1475 HoExec _ scatterload copy 0x00003045 0x25410073 STHMCS rl!, {r3-re}

16 -1477 NoExec  _ scatterload copy O0x0000504C OxSAFFFFFE = EBHI _ scatterload copy <0x8040-
17 -1478 Exec _ scatterload copy 0x00003050 0xE1E0ZESZ L3L% ri,rz, #29

15 -1475 HoExec _ scatterload copy 0x00005054 0x25E00030 LDMCS r0!, frd,r5}

19 -1474 HoExec _ scatterload copy 0x00003055 0x25410030 STHMCS rl!, {rd,r5}

20 -1473 Exec _ scatterload copy 0x0000305C 0x45904000 LDEMI rd,[r0,#0]

21 -1472 Exec _ scatterload copy 0x000030&0 0x45514000 STREMI rd,[rl,#0]

22 -1471 Exec _ scatterload copy 0x00005064 0xE140F00E MoV pc,lr

Z3 -1470 Exec _ scatterload null O0x0000501C OxEL1SA000E CHFP rlo,rll

24 -1469 NoExec  _ scatterload null 0x00005020 0x0AQODLSE  EBEQ __rt entry <0x5654

25 -1485 Exec _ scatterload null 0x00005024 0xESEA000F LDM rlo! , fr0-r3}

26 -1487 Exec _ scatterload null 0x00003025 0xEZ4FE014 ADR lr,{pc}-0Oxc ; Ox80lc

7 -l466 Exec _ scatterload null Ox0000802C OxE3130001  TaT r3, #l

258 -1485 HoExec _ scatterload null 0x00003030 0x1047F003 SUBNE pc,r7,r3

4| k| Trace ,(Sourc:e KProfiIe / 4 | | j 4

Select an enfry by next/only trigger

Tracing enabled

Figure 104

Observe that the focus (red letterbox) is brought to the trigger location. The trigger is designated
with an asterisk by the Element number:
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8.3

Application Note 168

£ Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =Jokd
[ Eile Edit Yiew Find Filter Sort Trace Data Profiling Data Help

=1" [

Elem | Time/inst| Type | Symbolic | address | opcode Other -

1325 -leg Exec __ rt_entry 0x00008678 OxEEFFFEEC  EL main <0xE230-

1326 -167 Exec wmain 0x00008230 0xESZD 4070 PUSH {rd-r6,lr}

1327 -166 Exec main' #66 0x00005234 0xE3404000 Moy rd, #0

1325 -165 Exec main' #67. . #69 O0x00008235 0xEEFFFFD 4 EL Init <0x&5laf>

1329 -164 Exec Init 000005145 OxESA00FFL MO 0, #0x3ed

1330 -163 Exec Inith#113 Ox000051AC 0xESSFL1ES LDE rl,0x8z2dc

1331 -162 Exec Inith#113 0x000051ED 0xES510000 STR. 0, [rl,#0]

1332 -161 Exec Inity#114 0x000051E4 0xE3A00E7D Moy rl, #0x7d0

1333 -160 Exec Inity#114 0x000051ES OxES510004 STR. 0, [rl,#4]

1334 -159 Exec Inith#115 0x000081EC 0xESSFOL1C LDE r0,0x8zZe0

1335 -155 Exec Inith#115 0x000081C0 0xES510005 STR. 0, [rl,#58]

1336 -157 Exec Inith#lle O0x000051C4 0xE2400FF4 SUB 0, r0, #0x3ed

1337 -156 Exec Inith#lle 0x000081CE OxES51000C STR. 0, [rl,#0xc]

1338 -155 Exec Inith#117 O0x000081CC 0xESSF0L10 LDE r0,0x52Zed

1339 -154 Exec Inith#117 0x000051D00 0xES510010 STR. 0, [rl, #0x10]

1340 -153 Exec Inith#lla 0x000051D4 0xE2500FF4 ADD 0, r0, #0x3ed

1341 -152 Exec Inith#lla 0x000051D8 O0xES510014 STR. 0, [rl,#0x14]

1342 -151 Exec Inith#119 0x000051DC OxESSF0104 LDE r0,0x82ed

1343 -150 Exec Inith#119 0x000051ED 0xES510015 STR. 0, [rl, #0x18]

1344 -149 Exec Inith#lz0 O0x000051E4 0xE1&00050 L3L r0,x0,#1

1345 -145 Exec Inith#lz0 0x000051ES 0xES51001C STR. 0, [rl, #0xlc]

1346 -147 Exec Inith#l2l 0x000081EC 0xE3A00E7D Moy rl, #0x7d0

1347 -148 Exec Inith#l2l 0x000051F0 0xES510020 STR. 0, [rl,#0xz20]

1345 -145 Exec Inith#l22 0x000051F4 0xESA00FF4 Moy rl, #0x3ed

1349 -144 Exec Inith#l22 0x000051FS OxES510024 STR. 0, [rl,#0xz24]

1350 -143 Exec Inith#123 O0x000081FC 0xESSFO0ES LDE r0,0x8zZec

1351 -14z Exec Inith#123 O0x00005200 0xESS10025 STR. 0, [rl,#0x25]

1352 -141 Exec Inith#lz4 Ox00005204 0xE2400FF4 SUB 0, r0, #0x3ed

1353 -140 Exec Inith#lz4 O0x00005208 0xESS1002C STR. 0, [rl,#0x2c]

1354 -139 Exec Inith#125 Ox0000520C 0xE2500D7D ADD 0,0, #0x1£40

1355 -135 Exec Inith#125 Ox00005210 0xES510030 STR. 0, [rl,#0x30]

4| k| Trace ,(Sourc:e KProfiIe / 4 j 4

Tracing enabled

Figure 105

Advanced Trace Triggers

For more complex trace situations on running targets, you can use a conditional trigger point.
A conditional trigger point allows you to specify the number of times an event (such as
instruction execution or data access) must occur for trace to trigger. You can also specify a
specific data access as a trigger point, similar to an RVD watchpoint. The exact capability of a
conditional trigger point is based on the event resources supported by your ETM.

Using a Pass Counter for Program Execution

In this scenario a trigger is used to capture trace on the 10th execution of SendData(). Remove
your previous trigger point and set a simple trace trigger at the computation of num_xmit in
SendData():
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FARVDEBUG = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] |- |04
[ File Edit Yiew Target Debug Tools Help

O ed &l: 2aBR BrHPE 0 33X & @
L B~ K | [[Fie ftracec Find | e[

woid SendData (woid)
i
int i, num xmit;
=3 num ¥mit = (average & OxF) + 1;
*output _port = HEADER: A% output header packet */
*output_port = average; ¥ output average value #/
for (1=0; i<num xmit; i++)

i

*output port = input[i]:

v 4% end SendData() */ [El

LR \DsmKSrc i trace.c / 4 j[v]

ﬁ clear,h 1
Ol b trace,prompt \TRACE)#228:1

=

Stop>
< | » \cma fstao JFieFind fLog / J J

Stopped Lh 120, Col 22

Figure 106

Reload TRACE.AXF and run it. Wait for the Analysis window to populate with your trace
capture. After your trace is displayed, search for SendData using the "Find - Find Symbol
Name" menu from the Analysis window:

flEnter Value X
Enter Symbol Mame to search with
[Mate: wildeard matches are not available on this view]:
|SendData
Find | Cancel |

Figure 107

Observe that the trace trigger is located two instructions after the very first call to SendData() at
trace element 9481:
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£ Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =Jokd

[ File Edit wiew Find Filter Sort Trace Data Profiling Data Help

=& [

Elem | Time/inst| Type | Symbolic | address | opcode Other

9479 -Z22 Exec Gethverage' #1885 O0x0000813C 0xESSC3000 STR. r3, [rl&,#0]

9450 -221 Exec Getdverage'\ #1559.. #1591 0Ox00005140 0xE1ZFFF1E EBX 1r

9451 -220 Exec main' #59 O0x00005295 0xEEFFFFS1 EL sendData <0x80ags |
94352 -z1%9 Exec SendData Ox00008044 OxESOFZ224 LDE rz,0x8z2d0
FO453 -zZl5 Exec SendDatah #2285 000005045 OxES9ZZ000 LDE. ra, [rz,#0]

9454 -z17 Exec SendDatab #2285 O0x0000504AC OxE20ZZ00F AN ra,re, #0xf

9435 -zZl8 Exec SendDatab #2285 0x000050ED 0xE2521001 ADD rl,r2,#1

9436 -Z15 Exec JendData’ #229. . 230 O0x000080E4 0xES9FZ215 LDE rz,0x5zd4

9457 -zl4 Exec SendDatah #2350 0x000050ES 0xES9F3215 LDE r3,0x82d45

94355 -z13 Exec SendDatah #2350 0x000050EC 0xES933000 LDE 3, [r3,#0]

94359 -zZlz2 Exec SendDatah #2350 0x000050C0 0xESS32000 STR. ra, [r3,#0]

9490 -z11 Exec SendDatah #2351 O0x000050Cd OxESSFZ204 LDE rz,0x8z2d0

9491 -zlo Exec SendDatah #2351 0x000050CE 0xES92ZZ000 LDE ra,[rz,#0]

9492 -z09 Exec SendDatah #2351 Ox000080CC OxESSF3204 LDE r3,0x82d45

9493 -z05 Exec SendDatah #2351 0x000050D0 0xES933000 LDE 3, [r3,#0]

9494 -z07 Exec SendDatah #2351 0x000050D4 0xESS32000 STR. ra, [r3,#0]

9495 -zZ0& Exec JendData’\ #232. . #234 000008005 0xE3400000 Moy rl, #0

9498 -z05 Exec SendDatah#23d 0x000050DC 0xEA000005 E OxS0E5 <TRACEY#Z34»
9497 -z04 Exec SendDatah#23d 0x000050FS 0xE1500001 CHP rd,rl

9495 -203 Exec SendDatah#23d 0x000080FC 0xBAFFFFF? ELT OxG0e0 <TRACEY#Z37>
9499 -z0z2 Exec JendData’ #235. . 237 0x000080ED 0xESSFZ1F4 LDE rz,0xgz2de

9500 -z01 Exec SendDatah #237 0x000050E4 0xE792Z100 LDE rz,[rZ,e0,L3L #2]

4| k| Trace ,(Sourc:e KProfiIe / 4 j 4

Tracing enabled

Figure 108

Halt your target. Now display the trigger using the "View - Break/Tracepoints" menu:

Break/ Tracepoints

Og ~| E
Type Ualue
- & M| Trace InstrExec 0x00005044
Address 0x00005044
Commard trociexec,hw_out:"Tracepoint Type=Trigger™ 0x000050ad
Figure 109

Right-click on the trace point and select "Edit Break/Tracepoint". Modify the trace point such
that the trigger occurs after the instruction is executed 10 times. Do this is by setting the "Pass"

parameter to "10":

#f]Set/Edit Tracepoint

Size of Data Access Any -
Check Condition Code lgnore -

[Trigger =] o [instr Exec = when |0x000080ad =] v =] v

Sets one tracepoint
Ok Cancel Help

Figure 110

Clear the previous trace from the Analysis window using the "View - Clear Trace Buffer" menu.

Reload TRACE.AXF and run the program again. Wait for the Analysis window to populate

with the new trace capture.

Observe that the new capture starts from the program entry point at 0x8000. Search the buffer
again for the trigger point using "Find - Find Trigger". Observe that the trigger is now located

at element 63562:

DAI0O168B

Copyright © 2006. All rights reserved.

73



Application Note 168

£ Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =Jokd

[ Eile Edit Yiew Find Filter Sort Trace Data Profiling Data Help

=& [

4| k| Trace ,(Sourc:e KProfiIe / 4 j 4

Elem | Time/inst | Type | Symbolic | Address Opcode 0ther A
63559 -292 Exec Getdverage' #159. . 4191 Ox00005140 0xE1ZFFF1E EX 1r

63560 -291 Exec main' #59 0x00008295 0xEEFFFFE1 EL SendData <Dx8034>|
63561 -z90 Exec SendData Ox00008044 0xES9FZ224 LDE rz,0x8z2d0

FEI56Z -Z39 Exec SendData’\ #2235 000005045 0xES9ZZ000 LDE rz,[rZ,#0]

63563 -Z58 Exec SendData'\ #2235 000008040 0xE20ZZ00F AND rZ,r2,#0xE

63564 -237 Exec SendData'\ #2235 O0x000080E0 0xE2521001 ADD rl,r2, #1

63565 -Z86 Exec SendDatah#229. . #230 O0x000080E4 0xES9FZZ15 LDE rz,0x5zd4

63566 -Z35 Exec SendData’\#230 0x000080E5 0xES9F3215 LDE r3,0x82d45

63567 -84 Exec SendData’\#230 0x000080EC 0xES933000 LDE r3,[r3,#0]

63565 -Z83 Exec SendData’\#230 Ox000080C0 0xESS32000 3TER rz,[r3,#0]

63569 -Z82 Exec SendData’\#231 Ox000080C4 0xES9FZ204 LDE rz,0x8z2d0

63570 -231 Exec SendData’\#231 0x000080C5 0xES92Z000 LDE rz,[rZ,#0]

63571 -Z30 Exec SendData’\#231 Ox000080CC 0xES9F3204 LDE r3,0x82d45

63572 -Z79 Exec SendData’\#231 000008000 0xES933000 LDE r3,[r3,#0]

63573 -Z78 Exec SendData’\#231 000008004 0xESS32000 3TER rz,[r3,#0]

63574 -277 Exec SendDatah #232. . #234 000008005 0xE3400000 MOV rl, #0

63575 -Z76 Exec SendData’ #234 000008000 0xEA000005 B 0x50£8 <TRACE\#23d-
63576 -Z75 Exec SendData’ #234 0x000080F5 0xE1500001 CHP r0,rl

63577 -z74 Exec SendData’ #234 O0x000080FC 0xBAFFFFF? ELT Ox50e0 <TRACE\#237>
63575 -273 Exec SendDatah#235. . #237 0x000080ED 0xES9FZ1F4 LDE rz,0xgz2de

63579 -Z72 Exec SendData’\#237 Ox000080E4 0xE792Z100 LDE rz,[rZ,e0,L3L #2]
635580 -271 Exec SendData’\#237 0x000080ES 0xESSF31ES LDE r3,0x82d45

Tracing enabled

Figure 111

Scroll back to the top of the trace buffer, and search for address 0x8298 using the "Find - Find
Address Expression" menu. As shown above, address 0x8298 contains the call to SendData:

flEnter Value X

-
\11) Enter Address Expreszion for Address or auto-range to search with:

|xs29g

Find | Cancel |

Figure 112

Repeat the search 9 times using the "Find - Find Next" menu (or "F3") to confirm that the trigger
occurred on the 10th execution of the num_xmit computation. Observe that after the 9 searches
you return to trace element 63560.

Note
If you are tracing with an ETB, your trace buffer may not be large enough to hold all 10
executions of SendData(). To see the effects of the pass counter, reduce the trigger's pass count
accordingly and perform another trace capture.

Using a Pass Counter for Data Accesses

In this scenario a trigger is used to capture the 2000th data write to *output_port. Begin by
enabling data trace by setting the Automatic Tracing Mode to "Instructions and Data" as in
Section 7.1:
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£ Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] |- [O/03
O Eile ,H Wiew Find Filter Sort Trace Data Profiling Data Help
|| = & By copy iz
Elem @ Cpnnect/Disconnect snalyzer | address | opcode | other ~
<o Di Tracing Enabled
Configure Analyzer Properties...
Set Trace Buffer Size...
Store Confrol-Elow Changes Only |
Buffer Full Mode 3 1
Trigger Mode »
Data Tracing Mode >
Automatic Tracing Mode 3 Off {Use Tracepaints)
Set/Edit Event Triggers... |7 Instructions Cnly N |
4 | » |\ Clear &l Event Triggers Data Only _>IM
Trace b  Physical to Logical Address Mapping... Instructions and Data fring enabled A
Figure 113

Remove the trigger point set in Section 8.3.1. Set a new trigger point by clicking anywhere in
the left gutter and selecting "Set Detailed Tracepoint...":

FARVDEBUG = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =JoEd
[ File Edit Yiew Target Debug Tools Help
D EE & 2Rl BE srnret +dX | EEl 885

J_lFiIeItrac:e.c: [Find I LI [Line I |

int main (wvoid)
int sample_num=0; /% local to track nuwher of samples */

/% initialize board and data %/

Init():
| Set Break tinually in main control loop */ |j

n'y;

Go To Here

Scope to Here

Show Disassermbly/Source at this Location i

Set Break...
g and determine if ADC has new data */

Set BreakIf.. le_ready is zero */

Set/Toggle Tracepoint...
Set Detailed Tracepoint...
Set Trace Fange Quence *f

Braak Infa Fdvn", sample num+) ;

Patch Asrm Interactive. ..
Set PC 1o Here

ARA\ Ny, 1 | ol
=
j=|
=l
Stop>
4| v b omd FStao fFieFind fLog ;| _>|

Stopped ltn 83, cal 33 [ A

Figure 114

Following the instructions in Section 7.3, set the trigger to activate on the 2000th data write to
output_port:
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# Set/Edit Tracepoint X
|Trigger ﬂ an |DataWr'rte ﬂ when |@'trac:e\\omputJaor1 jﬂ iz equal to jﬂ

times

Size of Data Access Any -

Sets one tracepoint

Jsrore -]
Ok Cancel Help

Figure 115

Inspect the trace point using "View - Break/Tracepoints" from RVD to confirm that it has been
set correctly:

Break/ Tracepoints
Og ~| E
Type Ualue
- W Trace Data Write Ox00020000
Address Ox00020000
Commard trodwrite, hw_out:"Tracepoint Type=Trigger™,hw _pass: 2000 Btrace’’output_port
Figure 116

Reload TRACE.AXF and run it. If you are using RVT, observe that the TRIG LED lights soon
after the program prints "Processing Sample: 200" in RVD. Wait several seconds for RVD to
display the trace. When the trace is displayed, search for the trigger point using "Find - Trigger".
Observe that the trigger point occurs just after the 2000th write:

£ Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =Jokd
[ File Edit wiew Find Filter Sort Trace Data Profiling Data Help
=1" [
Elem | Time/inst | Type [ Symbolic | address | opcode Other -
1458422 -15 Exec SendDatah #237 0x000050ES OxESSF31ES  LDER r3,0x82d45
1455422 E Data 0x000052D8 <Data> 'l' Oxad '\O' "»wO!
1455423 -14 Exec SendDatah #237 0x000050EC 0xES933000 LDR 3, [r3,#0]
1453423 R Data output port 0x00004460 <Data> 'y0' '\0' Ox02 'AO!
1455424 -13 Exec SendDatah #2357 O0x000050F0 0xES532000 35TR ra, [r3,#0]
1455424 W Data output fifo Ox00020000 <Datar Oxd6 0x13 '40' 4a' |
*l455425 -12 Exec Sendhatal #2344 O0x000050F4 OxEE500001  ADD r0,e0,#1
1458426 -11 Exec SendDatah#23d 0x000050FS OxELlS00001 CHP rd,rl
1455427 -10 Exec SendDatah#23d 0x000080FC OxBAFFFFF? ELT OxG0e0 <TRACEY#Z37>
1455428 -9 Exec JendData’ #235. . 237 0x000050ED OxES8F2Z1F4  LDER ra,0xdade
1455428 E Data 0x000082DC <Data> 0xS0 Oxid '\O' '"\O!
1455429 -8 Exec SendDatah #237 0x000050E4 OxE7522100 LDER rz,[rZ,e0,L3L #2]
1455429 E Data input+0xld O0x00004444 <Data> OxFl OxE3 OxFF OxFF
1455430 -7 Exec SendDatah #237 0x000050ES OxESSF31ES  LDER r3,0x82d45
1455430 E Data 0x000052D8 <Data> 'l' Oxad '\O' "»wO!
1455431 -6 Exec SendDatah #237 0x000050EC 0xES933000 LDR 3, [r3,#0]
1453431 R Data output port 0x00004460 <Data> 'y0' '\0' Ox02 'AO!
1458432 -5 Exec SendDatah #237 0x000050F0 0xES532000 STR ra, [r3,#0]
1455432 W Data output_fifo Ox00020000 <Data> OxFl OxE3 OxFF OxFF
4| k| Trace ,(Sourc:e KProfiIe / 4 j 4
Tracing enabled

Figure 117

Triggering on a Specific Data Accesses

A trace trigger can also be used to capture a specific data value access to a specific data address.
In this scenario the trace trigger will occur when the value OXFFFFFFOE is written to
*output_port. In TRACE.AXEF, the value OxFFFFFFOE is the 100th computed average so we
expect this value to be written to *output_port.
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Edit the trigger point set in Section 8.3.2 to activate when the value OxFFFFFFOE is written to
*output_port:

# Set/Edit Tracepoint X

|Trigger ﬂ on |DataWr'rte ﬂ when |@'trac:e\\oL,dpL,ﬂJJDr‘t jl@@ jﬂ

Ot :
Size of Data Access Any -

Ok Cancel Help

Sets one tracepoint

Figure 118

Inspect the trace point using "View - Break/Tracepoints" from RVD to confirm that it has been
set correctly:

Break/ Tracepoints
Og ~| E
Type Ualue
- M| Trace Data Write Ox00020000
Address Ox00020000
Commard trodwrite, hw_out:"Tracepoint Type=Trigger™,hw_dwalue: (Ox£EEE£££0e) Brrace)’output_port
Figure 119

Reload TRACE.AXF and run it. If you are using RVT, observe that the TRIG LED lights soon
after the program prints "Processing Sample: 100" in RVD. Wait several seconds for RVD to
display the trace. When the trace is displayed, search for the trigger point using "Find - Trigger".
Observe that the trigger point occurs just after the write of OxXFFFFFFOE to address 0x20000
(*output_port):

£ Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =Jokd
[ Eile Edit Yiew Find Filter Sort Trace Data Profiling Data Help
=1" [
Elem | Timesinst | Type | Symbolic | address | patasHex | Opcode Other ~
729315 -14 Exec  SendDatal#23l 0x00005004 0xE5§32000  STR vz, [r3, #0]
729315 W Data cutput fifo 0x00020000  O0xFFFFFFOE «Data» OxOE OxFF 0xFF OxFF |
*7293l6  -13 Exec  HendDatal#232..#234 0x0000500E 0xE3A00000 MOV i, #0
729317 -12 Exec  SendData\#234 0x0000500C 0xEAD00005 B OxE0EE <TRACE, #2344
729318 -1l Exec  SendData\#234 0x000050FG 0xE1500001  CHP i, rl
729319 -10 Exec  SendData\#234 0x000050FC OxBAFFFFF?  BLT OxE0el <TRACEL#Z37>
729320 -9 Exec  HendData\#235..#237 0x000050ED 0xES9FZ1F4  LDR rz,x5zdc
729320 F Data 0x0000820C  0x00004490 <Datar 0x90 Oxad4 '\0' 'O
729321 -8 Exec  SendData\#237 0x000050E4 0xE7922100 LR rz,[rZ,r0,L5L #2]
729321 F Data input 0x00004490  0x0000065C <Datar OxBC Ox06 'v0' 'O
729322 -7 Exec  SendData\#237 0x000050ES 0xES9F31EE  LDR r3,0x52d3
729322 F Data 0x0000820&  O0x0000&460 <Datax 'l' Oxad '\0' 'O
729323 -8 Exec  SendData\#237 0x000050EC 0xE5933000  LDR r3, [r3,40]
729323 F Data output_port 0x0000446C  0x00020000 <Datax '40' 400 Ox0Z 'O
729324 -5 Exec  SendData\#237 0x000050F0 0xE5832000  STR vz, [r3,#0]
729324 W Data output_fifo 0x00020000  0x0000065C <Datar OxBC Ox06 'v0' 'O
729325 -4 Exec  SendData\#234 0x000050F4 0xEZE00001  ADD rd, 0, #1
729326 -3 Exec  SendData\#234 0x000050FG 0xE1500001  CHP i, rl
729327 -2 Exec  SendData\#234 0x000050FC OxBAFFFFF?  BLT OxE0el <TRACEL#Z37>
;l;l\'l’rai)(%urce KProfiIe / 4 | j 4
Tracing enabled

Figure 120

Scroll up in the trace buffer and observe that in fact 0OXFFFFFFOE is the average value computed
in GetAverage and written to "average" (located at 0xA470):
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£ Analysis = @ ARM1136JF-S_1:ARM-ARM-NW [Unattached] =Jokd

[ File Edit wiew Find Filter Sort Trace Data Profiling Data Help

=& [

Elem | Timesinst | Type | Symbolic | address | patasHex | Opcode Other ~
729300 -a9 Exec Getdverage' #1585 O0x0000513C OxESEC3000 STR r3, [rla, #0]

729300 W Data average 0x00004470 0xFFFFFFOE <Data> O0x0E OxFF OxFF DxFF|
729301 -28 Exec Getdverage'\ #159.. #1591 (Ox00005140 OxELZFFFLE BX 1r

729302 -a7 Exec nain' #589 0x00005298 OxEEFFFFS1 EL SendData <0x80ad-
729303 -Z6 Exec Sendlhata 0x00005044 OxESSF2z2d LDE ra, 0xgado

729303 E Data 0x000052D0 0x00004470 <Data> 'p' Oxad '"\0O' "wO!
729304 -&5 Exec SendDatab #2285 0x00005045 OxES522000 LDE ra,[rz,#0]

729304 R Data average 0x00004470 0xFFFFFFOE <Data> Ox0E OxFF OxFF OxFF
729305 24 Exec SendDatab #2285 O0x0000504AC OxEZ0ZZ00F  AND ra,re, #0xf

7293068 &3 Exec SendDatab #2285 0x000050ED OxEZEz1001 ADD rl,r2,#1

729307 -2z Exec JendData’ #229. . 230 0x000050E4 OxESSFZZ18 LDE ra,0xgadd

729307 E Data 0x000052D4 OxAABAADLAL <Data> Oxhd Oxdd Oxdd Oxdid
729308 -2l Exec SendDatah #2350 0x000050ES OxESSF3218 LDE 3, 0x8ads

729308 E Data 0x000052D8 O0x00004460 <Data> 'l' Oxad '\O' "»wO!
729309 -&0 Exec SendDatah #2350 0x000050EC OxES533000 LDE 3, [r3,#0]

729309 E Data output_port O0x00004460 Ox00020000 <Data> 'A0' 400 Ox02 'O
728310 -19 Exec SendDatah #2350 0x000050C0 OxESE32000 STR ra, [r3,#0]

728310 W Data output_fifo Ox00020000 OxAABAADLAL <Data> Oxhd Oxdd Oxdd Oxdid
728311 -15 Exec SendDatah #2351 O0x000050Cd OxESSF2z04 LDE ra, 0xgado

728311 E Data 0x000052D0 0x00004470 <Data> 'p' Oxad '"\0O' "wO!
729312 -17 Exec SendDatah #2351 0x000050CE OxES522000 LDE ra,[rz,#0]

729312 R Data average 0x00004470 0xFFFFFFOE <Data> Ox0E OxFF OxFF OxFF
TE9313 -lg Exec SendDatah #2351 Ox000080CC OxESSF3204 LDE 3, 0x8ads

TE9313 E Data 0x000052D8 O0x00004460 <Data> 'l' Oxad '\O' "»wO!
729314 -15 Exec SendDatah #2351 0x000050D0 OxES533000 LDE 3, [r3,#0]

729314 E Data output_port O0x00004460 Ox00020000 <Data> 'A0' 400 Ox02 'O
729315 -14 Exec SendDatah #2351 0x000050D4 OxESE32000 STR ra, [r3,#0]

729315 W Data output_fifo Ox00020000 0xFFFFFFOE <Data> Ox0E OxFF OxFF OxFF
FTZ93516 -13 Exec JendData’ #232. . #2534 000005008 OxE3200000 How 0, #0

729317 -1z Exec SendDatah#23d 0x000050DC OxEADO000S E OxS0E5 <TRACEY#Z34»
729318 -11 Exec SendDatah#23d 0x000050FS OxELS00001 CHFP rd,rl

4| k| Trace ,(Sourc:e KProfiIe / 4 | j 4

Tracing enabled

Figure 121

Scroll further up the trace buffer and look for another value that is written to *output_port.
Modify the trace point to trigger on the data write to *output_port of this new value. Reload
TRACE.AXF and repeat the trace capture using the new trigger point. Confirm that the trigger
point of the second capture is located at the correct location.
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