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Chapter 1 
Getting Started with AMBA Designer

This chapter contains topics to introduce you to some of the AMBA Designer concepts and 
explain how to launch the Canvas, the Graphical User Interface (GUI) of AMBA Designer. It 
contains the following sections:
• About AMBA Designer suite on page 1-2.
• AMBA Designer workflow on page 1-3.
• Starting AMBA Designer Canvas on page 1-5.
• AMBA Designer batch mode for component configuration on page 1-7.
• Getting AMBA Designer help on page 1-8.
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Getting Started with AMBA Designer 
1.1 About AMBA Designer suite
AMBA Designer tools enable you to create AMBA-compliant systems. AMBA Designer 
supports CoreLink and CoreSight™ devices that use AMBA protocols.

AMBA Designer supports IP-XACT versions 1.2 and 1.4.

AMBA Designer supports the following design tasks:
• Configuring CoreLink and CoreSight devices.
• Generating RTL for the configured devices.
• Optimizing the AMBA interconnects.
• Stitching together interconnects and CoreLink or CoreSight components into an 

AMBA-compliant system with IP-XACT stitching.

AMBA Designer generates configurations that are compatible across platforms, and can 
generate the RTL Verilog files and the associated Out Of Box (OOB) testbenches for verifying 
the RTL.

In the AMBA Designer Canvas, you can configure IP components and use them to create 
systems using a graphical representation that shows the components, their ports, and the 
connections between ports.

You can also use AMBA Designer from the command line in batch mode.

1.1.1 See also

Tasks 
• For requirements, see the ARM® AMBA® Designer ADR-400 Installation Guide.
• For information on which protocol an interconnect or device supports, see the Release 

Note for the IP bundle.
• For information about which interconnect and device is compatible with which IP-XACT 

version, see the ARM® AMBA® Designer ADR-400 Release Note.
• Starting AMBA Designer Canvas on page 1-5.
• Configuring an AMBA 2 or AMBA 3 component in the Canvas on page 3-3.
• Configuring an AMBA 4 component and generating RTL for it on page 4-2.
• Stitching on page 6-12.
• Setting general IP-XACT preferences on page 7-4.

Reference 
• AMBA Designer batch mode for component configuration on page 1-7.
• AMBA Designer Canvas overview on page 8-2.
• Launch parameters for AMBA Designer Canvas on page 9-2.
• AMBA Designer batch mode commands on page 9-3.

AMBA protocol and AMBA Design Kit documentation 
• ARM® AMBA® AXI and ACE Protocol Specification (ARM IHI 0022).
• ARM® AMBA® APB Protocol Specification (ARM IHI 0024).
• ARM® AMBA® 3 AHB-Lite Protocol Specification (ARM IHI 0033).

• ARM® AMBA® Design Kit Technical Reference Manual (ARM DDI 0243).
ARM DUI 0333O Copyright © 2006-2013 ARM. All rights reserved. 1-2
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Getting Started with AMBA Designer 
1.2 AMBA Designer workflow
This section describes the general flow for configuring components and creating systems. 
Peripherals and interconnects in SoC systems are highly configurable. To speed up the flow, 
consider the component and interconnect configurations that you might require before you use 
the tools.

Prerequisites

• Install the required ARM IP bundles and register them with AMBA Designer. For 
instructions and prerequisites, see the relevant Supplement documents to the ARM® 
AMBA® Designer User Guide.

• To generate RTL, you must have the required tools installed. For information on which 
tools are required for a particular IP bundle, see the Release Note for the IP bundles.

Figure 1-1 shows a typical design flow when you use AMBA Designer Canvas. The overall 
workflow is the same for AMBA 2, AMBA 3, and AMBA 4 components.

Figure 1-1 Design flow with AMBA Designer Canvas
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Getting Started with AMBA Designer 
You can configure all components with AMBA Designer in the following ways:
• Setting parameters in the Configurator Window in the Canvas.
• Loading a batch XML configuration file in the Configurator Window in the Canvas.
• From the XML configuration file in batch mode.

Note
 You can only configure one component at a time both in the Canvas and in batch mode. In batch 
mode, you can use the XML configuration file from the command line or in scripts. However, 
batch mode only configures one component at a time.

1.2.1 See also

Tasks 
• For instructions and prerequisites for a particular IP bundle, see the relevant Supplement 

documents to the ARM® AMBA® Designer User Guide.
• For information on which tools are required for a particular IP bundle, see the Release 

Note for the IP bundles.
• For information about the tool versions that you require for a particular AMBA Designer 

release, see the ARM® AMBA® Designer ADR-400 Release Note.
• ARM® AMBA® Designer ADR-400 Installation Guide.
• Starting AMBA Designer Canvas on page 1-5.
• Configuring an AMBA 2 or AMBA 3 component in the Canvas on page 3-3.
• Configuring an AMBA 2 or AMBA 3 component from an XML configuration file on 

page 3-11.
• Configuring an AMBA 4 component and generating RTL for it on page 4-2.
• Generating AMBA 2 or AMBA 3 components in batch mode on page 3-10.
• Rendering AMBA 4 components in batch mode on page 4-8.
• Adding components to a new system on page 6-2.
ARM DUI 0333O Copyright © 2006-2013 ARM. All rights reserved. 1-4
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Getting Started with AMBA Designer 
1.3 Starting AMBA Designer Canvas
You can carry out the majority of tasks in AMBA Designer in the GUI called the Canvas.

1. Ensure that the UNIX environment is ready AMBA Designer.
Enter one of the following commands depending on the system shell you use:
Bourne source <AMBA_Designer_install_directory>/etc/setup.sh

C-Shell source <AMBA_Designer_install_directory>/etc/setup.csh

2. Start the Canvas.
adcanvas

• To launch the Canvas with a blank Diagram Window, do not specify any option 
argument.

• To launch the Canvas and to open a specific, existing, system, use the following 
command:

adcanvas <filename.adg>

The Canvas is now ready for use. The Configurators Window shows the list of 
components that are available for configuration.

Figure 1-2 AMBA Designer Canvas window - first use

AMBA Designer starts in Edit Mode by default.
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Getting Started with AMBA Designer 
1.3.1 See also

Tasks 
• For instructions about setting up the environment, see the ARM® AMBA® Designer 

ADR-400 Installation Guide.

Reference 
• AMBA Designer Canvas overview on page 8-2.
• AMBA Designer Canvas modes on page 8-6.
• Launch parameters for AMBA Designer Canvas on page 9-2.
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Getting Started with AMBA Designer 
1.4 AMBA Designer batch mode for component configuration
AMBA Designer batch mode is available for all licensed IP. Batch mode makes it possible to 
delete the relatively large RTL file when it is not used, and regenerate it from the smaller XML 
configuration file when necessary. Other users can use the configuration file in other AMBA 
Designer installations if they have the license for a suitable AMBA Designer release.

AMBA Designer provides several options for the generation of RTL. You can use these from 
the command line, too:
• Generate RTL.
• Generate RTL and simulate.
• Generate RTL and synthesize.
• Generate RTL, simulate, and synthesize.

You can choose simulation and synthesis settings:
• The simulator that AMBA Designer uses.
• Enable or disable Open Verification Library (OVL) assertions.
• Use or do not use Logical Equivalence Checking (LEC).

Figure 1-3 Design flow with AMBA Designer in batch mode

1.4.1 See also

Tasks 
• Creating a configuration file for AMBA 2 or AMBA 3 components on page 3-9.
• Generating AMBA 2 or AMBA 3 components in batch mode on page 3-10.
• Saving a batch configuration XML file for AMBA 4 components on page 4-6.
• Rendering AMBA 4 components in batch mode on page 4-8.

Reference 
• AMBA Designer batch mode commands on page 9-3.
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Getting Started with AMBA Designer 
1.5 Getting AMBA Designer help
You can use the command line interface to find information about AMBA Designer, see 
Table 1-1.

1.5.1 See also

Tasks 
• Starting AMBA Designer Canvas on page 1-5.

Reference 
• Launch parameters for AMBA Designer Canvas on page 9-2.
• AMBA Designer batch mode commands on page 9-3.

Table 1-1 AMBA Designer help from the command line

Option Example usage Description

-v or --version adcanvas --version Print the version of the tool without starting it

-h, --help adcanvas --help Print the usage information
ARM DUI 0333O Copyright © 2006-2013 ARM. All rights reserved. 1-8
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Chapter 2 
Conventions and Feedback

This chapter describes the typographical conventions and how to give feedback:

Typographical conventions 
The following typographical conventions are used:
monospace Denotes text that can be entered at the keyboard, such as commands, 

file and program names, and source code.
monospace Denotes a permitted abbreviation for a command or option. The 

underlined text can be entered instead of the full command or option 
name.

monospace italic 
Denotes arguments to commands and functions where the argument is 
to be replaced by a specific value.

monospace bold 
Denotes language keywords when used outside example code.

italic Highlights important notes, introduces special terminology, denotes 
internal cross-references, and citations.

bold Highlights interface elements, such as menu names. Also used for 
emphasis in descriptive lists, where appropriate, and for ARM® 
processor signal names.

Feedback on this product 
If you have any comments or suggestions about this product, contact your 
supplier and give:
• Your name and company.
ARM DUI 0333O Copyright © 2006-2013 ARM. All rights reserved. 2-1
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Conventions and Feedback 
• The serial number of the product.
• Details of the release you are using.
• Details of the platform you are using, such as the hardware platform, 

operating system type and version.
• A small standalone sample of code that reproduces the problem.
• A clear explanation of what you expected to happen, and what actually 

happened.
• The commands you used, including any command-line options.
• Sample output illustrating the problem.
• The version string of the tools, including the version number and build 

numbers.

Feedback on content 
If you have comments on content then send an e-mail to errata@arm.com. Give:
• The title.
• The number, ARM DUI 0333O.
• If viewing online, the topic names to which your comments apply.
• If viewing a PDF version of a document, the page numbers to which your 

comments apply.
• A concise explanation of your comments.
ARM also welcomes general suggestions for additions and improvements.

ARM periodically provides updates and corrections to its documentation on the ARM 
Information Center, together with knowledge articles and Frequently Asked Questions (FAQs).

Other information 
• ARM Information Center, http://infocenter.arm.com/help
• ARM Technical Support Knowledge Articles, 

http://infocenter.arm.com/help/topic/com.arm.doc.faqs
• Support and Maintenance, 

http://www.arm.com/support/services/support-maintenance.php

• ARM® Glossary, 
http://infocenter.arm.com/help/topic/com.arm.doc.aeg0014-/index.html
ARM DUI 0333O Copyright © 2006-2013 ARM. All rights reserved. 2-2
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Chapter 3 
Configuring AMBA 2 and AMBA 3 Components

This chapter describes how to configure an IP component before you can use your licensed IP 
bundle in an AMBA-compliant system design. It contains the following sections:

• Prerequisites for creating a component on page 3-2.

• Configuring an AMBA 2 or AMBA 3 component in the Canvas on page 3-3.

• Generating RTL for an AMBA 2 or an AMBA 3 component on page 3-6.

• Adding an AMBA 2 or AMBA 3 component to the Component Library on page 3-8.

• Creating a configuration file for AMBA 2 or AMBA 3 components on page 3-9.

• Generating AMBA 2 or AMBA 3 components in batch mode on page 3-10.

• Configuring an AMBA 2 or AMBA 3 component from an XML configuration file on 
page 3-11.

• Reconfiguring an AMBA 2 or AMBA 3 component on page 3-13.
ARM DUI 0333O Copyright © 2006-2013 ARM. All rights reserved. 3-1
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Configuring AMBA 2 and AMBA 3 Components 
3.1 Prerequisites for creating a component
Prerequisites:
• You require the relevant AMBA Designer license.
• You must have installed and registered the relevant IP bundle.

3.1.1 See also

Tasks 
• For information about the registration script for the IP, see the Release Note of the IP 

bundle.
• FlexNet for ARM® Tools License Management Guide (ARM DUI 0209).
• ARM® AMBA® Designer ADR-400 Installation Guide.
• Starting AMBA Designer Canvas on page 1-5.
• Configuring an AMBA 2 or AMBA 3 component in the Canvas on page 3-3.
• Configuring an AMBA 2 or AMBA 3 component from an XML configuration file on 

page 3-11.

Reference 
• Launch parameters for AMBA Designer Canvas on page 9-2.
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Configuring AMBA 2 and AMBA 3 Components 
3.2 Configuring an AMBA 2 or AMBA 3 component in the Canvas
1. Make sure that the AMBA Configuration Window is visible in AMBA Designer Canvas. 

If it is not visible, select Window → Configuration Window from the main menu.
Make sure that the Configurators tab is active. See Figure 3-1.

Figure 3-1 AMBA Configuration Window

2. Double-click the name of the component in the AMBA Configuration Window.
A component configurator window appears. Figure 3-2 on page 3-4 shows an example.
ARM DUI 0333O Copyright © 2006-2013 ARM. All rights reserved. 3-3
ID092413 Non-Confidential



Configuring AMBA 2 and AMBA 3 Components 
Figure 3-2 Example Configurator Window of an AMBA 3 component

3. Fill in the necessary configuration information.
To complete the configuration in the Canvas, select the appropriate tabs and buttons for 
the available options.

4. To complete the configuration, click OK.

5. A component instance appears in the Canvas.
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Configuring AMBA 2 and AMBA 3 Components 
Figure 3-3 Example new AMBA 3 component

6. To save an XML configuration file, right-click the component in the Canvas, and select 
Design → Save <component_name> Batch Mode Config....
Canvas saves the component configuration in your work space.

Before you can use it in a system and stitch it, you must generate the RTL for the component 
and add it to the Component Library.

3.2.1 See also

Tasks 
• Generating RTL for an AMBA 2 or an AMBA 3 component on page 3-6.
• Adding an AMBA 2 or AMBA 3 component to the Component Library on page 3-8.
• Configuring an AMBA 2 or AMBA 3 component from an XML configuration file on 

page 3-11.
• Reconfiguring an AMBA 2 or AMBA 3 component on page 3-13.

Reference 
• For specific configuration information for your chosen component, see the relevant 

Supplement document to the ARM® AMBA® Designer User Guide.
ARM DUI 0333O Copyright © 2006-2013 ARM. All rights reserved. 3-5
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Configuring AMBA 2 and AMBA 3 Components 
3.3 Generating RTL for an AMBA 2 or an AMBA 3 component
You can only generate RTL for a component after you have configured it.

Prerequisites:

• If you require LEC, make sure that the appropriate location for your chosen LEC tool is 
configured. For instructions, see the Release Note for the IP bundle.

• If the device supports Open Verification Library (OVL) assertions, you can, if required, 
simulate using OVL assertions. For information about how to install OVL, see the Release 
Note for the IP bundle.

Note
 It is not necessary to install or enable OVL assertions to simulate any of the examples 

supplied with the IP bundles.

1. Right-click the component in the Diagram Window, and select Design → 
<component_name> RTL Design Flow Manager....
The RTL Design Flow Manager dialog box appears. See Figure 3-4.

Figure 3-4 Example RTL Design Flow Manager dialog box

2. Click Generate RTL.
The Commands pane of the RTL Design Flow Manager shows a progress bar.

3. To simulate and synthesize the generated component RTL in the current RTL Design Flow 
Manager session, leave the dialog box open.
Otherwise, end the current RTL Design Flow Manager session by clicking Close.

4. (Optional) Run the simulation:
a. Ensure that the RTL simulation settings are appropriately configured.
b. Click Simulate in the RTL Design Flow Manager dialog box.

The simulate RTL process starts. The progress bar in the Commands pane of the 
RTL Design Flow Manager dialog box displays the progress.
To see more information, click the Details tab.

c. To synthesize the generated component RTL in the current RTL Design Flow 
Manager session, leave the dialog box open.
Otherwise, end the current RTL Design Flow Manager session by clicking Close.

5. (Optional) Run the synthesis:
a. To use LEC, select it in the RTL preferences.
b. Click Synthesize in the RTL Design Flow Manager dialog box.
ARM DUI 0333O Copyright © 2006-2013 ARM. All rights reserved. 3-6
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Configuring AMBA 2 and AMBA 3 Components 
The synthesizing process starts. The progress bar in the Commands pane of the RTL 
Design Flow Manager dialog box displays the progress.
To see more information, click the Details tab.

c. Click Exit to close the RTL Design Flow Manager dialog box.

You must add the component to the Component Library before you can stitch it.

3.3.1 See also

Tasks 
• For instructions about preparing for LEC, see the Release Note for the IP bundle.
• For information about how to install OVL, see the Release Note for the IP bundle.
• Configuring an AMBA 2 or AMBA 3 component in the Canvas on page 3-3.
• Adding an AMBA 2 or AMBA 3 component to the Component Library on page 3-8.
ARM DUI 0333O Copyright © 2006-2013 ARM. All rights reserved. 3-7
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Configuring AMBA 2 and AMBA 3 Components 
3.4 Adding an AMBA 2 or AMBA 3 component to the Component Library
You can only add a component to the Component Library after you have configured it and 
generated RTL for it.

1. Right-click the component on the Canvas and select Design → Add <component_name> 
to Component Library....
Progress dialogs appear to show the status of the process.

2. If the dialog does not close, check the error messages in the Output Window, and correct 
the configuration errors.

The component is now ready to be stitched. You can also save its configuration for later batch 
processing.

3.4.1 See also

Tasks 
• Configuring an AMBA 2 or AMBA 3 component in the Canvas on page 3-3.
• Generating RTL for an AMBA 2 or an AMBA 3 component on page 3-6.
• Creating a configuration file for AMBA 2 or AMBA 3 components on page 3-9.
• Generating AMBA 2 or AMBA 3 components in batch mode on page 3-10.
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Configuring AMBA 2 and AMBA 3 Components 
3.5 Creating a configuration file for AMBA 2 or AMBA 3 components
You can save an XML file with the configuration information to use it to configure another 
component in the Canvas or in batch processing mode.

You must have configured the component before you can save a batch configuration file for it.

1. Right-click the component on the canvas, and then select Design → Save 
<component_name> Batch Mode Config....

2. Navigate to the location where the XML configuration file is to be stored and click Save.

3.5.1 See also

Tasks 
• Generating AMBA 2 or AMBA 3 components in batch mode on page 3-10.
• Configuring an AMBA 2 or AMBA 3 component from an XML configuration file on 

page 3-11.

Reference 
• AMBA Designer batch mode commands on page 9-3.
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3.6 Generating AMBA 2 or AMBA 3 components in batch mode
AMBA Designer batch mode is available for all licensed IPs.

Prerequisites:
• You must have the relevant AMBA Designer license.
• The IP bundle must have been installed and registered.
• The RTL preferences must have been set.
• The XML configuration file must be available.

1. Ensure that the UNIX environment has been set up for AMBA Designer.
Enter one of the following commands depending on the system shell you use.
Bourne source <AMBA_Designer_install_directory>/etc/setup.sh

C-Shell source <AMBA_Designer_install_directory>/etc/setup.csh

2. Launch AMBA Designer from the command line in batch mode:
adcanvas -b <file>.xml -<product> [options]

3.6.1 See also

Tasks 
• Configuring an AMBA 2 or AMBA 3 component in the Canvas on page 3-3.
• Creating a configuration file for AMBA 2 or AMBA 3 components on page 3-9.

Reference 
• AMBA Designer batch mode commands on page 9-3.
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3.7 Configuring an AMBA 2 or AMBA 3 component from an XML configuration file
1. Double-click the name of the component in the Configuration Window.

A component configurator window appears.

2. To load the XML file for the configuration, click Browse, navigate to the location where 
the batch configuration file is stored, and then click Open.

Figure 3-5 Browse button in the Configurator Window

Note
 The Configuration Window shows the default settings for all parameters rather than the 

values imported from the XML file.

3. Click OK. A new tab appears in the Diagram Window with the new component part 
displayed.

4. To re-open the Configurator Window, right-click the component in the Diagram Window, 
and then select Design →  Reconfigure new <component_name>.

5. Check the values that have been loaded from the XML file.
If no changes are necessary, click Cancel.
If you have modified any parameter values, click OK to save the changes.

You must generate the RTL for the component and add the component to the Component 
Library before you can stitch it.
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3.7.1 See also

Tasks 
• Configuring an AMBA 2 or AMBA 3 component in the Canvas on page 3-3.
• Generating RTL for an AMBA 2 or an AMBA 3 component on page 3-6.
• Adding an AMBA 2 or AMBA 3 component to the Component Library on page 3-8.
• Reconfiguring an AMBA 2 or AMBA 3 component on page 3-13.

Reference 
• For specific configuration information for your chosen component, see the relevant 

Supplement document to the ARM® AMBA® Designer User Guide.
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3.8 Reconfiguring an AMBA 2 or AMBA 3 component
1. To open the component configuration window, do one of the following:

• Right-click the component on the Canvas to display the context-sensitive menu and 
select Design → Reconfigure component.

• Right-click the component in the Component Window and select Reconfigure 
component.

2. Change the parameters as required and select OK.

3. Right-click the component in the Diagram Window, and select Design → 
<component_name> RTL Design Flow Manager....
The RTL Design Flow Manager dialog appears.

4. Rerun the RTL generation, simulation, and synthesis as required.

5. To add the reconfigured component to the Component Library, right-click it, and then 
select Design → Add component to the library.

6. To make sure that the instances of the component are updated in all open projects in the 
Canvas, close and reload the projects that contain this component.
a. Select File → Close from the menu.
b. Right-click on the background of the Component Window and select Refresh 

Component List.
c. To reopen the updated component, drag it from the Component Window onto the 

Canvas.
To reopen an existing system, select it from File → Open.

3.8.1 See also

Tasks 
• Configuring an AMBA 2 or AMBA 3 component in the Canvas on page 3-3.
• Generating RTL for an AMBA 2 or an AMBA 3 component on page 3-6.

Reference 
• For specific configuration information for your chosen component, see the relevant 

Supplement document to the ARM® AMBA® Designer User Guide.
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Chapter 4 
Configuring AMBA 4 Components

You must create a component configuration before you can use your licensed IP in an 
AMBA-compliant system design. It contains the following sections:
• Configuring an AMBA 4 component and generating RTL for it on page 4-2.
• Saving a batch configuration XML file for AMBA 4 components on page 4-6.
• Finding out the phase number of a generator for an AMBA 4 component on page 4-7.
• Rendering AMBA 4 components in batch mode on page 4-8.
• Reconfiguring an AMBA 4 component on page 4-9.

For information on prerequisites, see Prerequisites for creating a component on page 3-2.
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4.1 Configuring an AMBA 4 component and generating RTL for it
1. Make sure that the AMBA Configuration Window is visible in AMBA Designer Canvas. 

If it is not visible, select Window → Configuration Window from the menu.
Make sure that the Configurators tab is active. See Figure 4-1.

Figure 4-1 AMBA Configurator Window - AMBA 4

2. Double-click the name of the component in the AMBA Configuration Window.
A component Configurator Window appears. Figure 4-2 on page 4-3 shows an example 
of a Configurator Window.
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Figure 4-2 Example configurator window for an AMBA 4 components

3. Fill in the necessary configuration information in the Configurator Window.
Components might have more than one configuration tab or pane. To complete the 
configuration, select the appropriate tabs and buttons for all available options.

4. To complete the configuration, click Next.
The RTL rendering dialog appears, see Figure 4-3 on page 4-4. 
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Figure 4-3 Example RTL generation window for AMBA 4 components

5. Some IPs support copying the files that are not configuration-dependent to the destination 
directory. If the IP supports this feature, click Browse to select the directory.

6. Select the generators to run. By default all available generators are enabled.
Each AMBA 4 IP includes generators that define what is rendered for the IP during RTL 
generation. The IP might support simulation or synthesis, or the generation of other files, 
for example synthesis constraints. For information on what is supported, see the Release 
Note for the IP bundle.

7. If you want AMBA Designer to copy the files that are not configuration-dependent into 
the destination directory, select Copy files.
By default, this option is disabled and AMBA Designer references the IP files from their 
original location and does not copy them into the destination directory of the component.

8. Click Run to generate the RTL for the IP.
The lower part of the RTL rendering dialog shows the output of the rendering scripts when 
they are running.

9. When the component RTL has been rendered, click Finish to close the configuration 
window.
The configured and rendered component is added to the Component Window.
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Figure 4-4 Example new AMBA 4 component
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4.2 Saving a batch configuration XML file for AMBA 4 components
1. To open the component configuration window, do one of the following:

• Double-click the component name in the AMBA Configuration Window to start a 
new component configuration.

• Right-click the component in the Component Library and select Reconfigure 
Component to start a component configuration from a saved one.

2. Ensure that the parameters are set as required.

3. If required, update the name for the XML configuration in the Configuration name field. 
See Figure 4-5.

Figure 4-5 Configuration file name for AMBA 4 batch mode

4. Select Save, browse to the location where you want to save the configuration file, and 
select OK.

5. Select Cancel to close the component configuration window.
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4.3 Finding out the phase number of a generator for an AMBA 4 component
In some cases, it can be useful not to run all generators for an IP, only specific ones, in batch 
mode. To run only some of the generators, you must know their phase number to give it as a 
command line argument. The number of generators depends on the IP bundle and each generator 
has a phase number that you can check in AMBA Designer.

To find out the phase numbers for the generators of a particular IP:
1. Right-click the component on the canvas and select Reconfigure component.
2. Click Next to open the RTL configuration dialog.
3. Note down the phase numbers that you require.
4. Click Cancel to exit the dialog without changing any settings.

4.3.1 See also

Reference 
• AMBA Designer batch mode commands on page 9-3.
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4.4 Rendering AMBA 4 components in batch mode
AMBA Designer batch mode is available for all licensed IPs. For AMBA 4 components, RTL 
is rendered by a set of generators associated with the IP. For most common cases, the default 
setting is appropriate. By default, all generators run and they create all necessary files for the IP. 
In certain cases, however, it is useful to run only some of the generators. For information on 
what generators are available for a IP component, see the Release Note for the IP bundle.

Prerequisites for rendering AMBA4 components in batch mode:
• Make sure that the XML configuration file is available before starting batch mode.
• You require the relevant AMBA Designer license.
• You require the IP bundle installed.
• You can use generators to generate synthesis constraints or other files that are required for 

a component. Check the phase number associated with each generator.

1. Launch AMBA Designer from the command line in batch mode and include the XML file 
name and the IP name in the command.
• Use the following command to execute all generators and to render the RTL for the 

IP:
adcanvas -b <file>.xml -<IP_name> -gen

Where <file>.xml is the name of the batch configuration file and <IP_name> contains 
the release version, for example XYZr1p2.

• Typically, all generators that are associated with the IP are run. To use only one of 
the generators, enter its phase number as a command-line argument:
adcanvas -b <file>.xml -gen -phase <num> -<IP_name>

For example:
adcanvas -b example.xml -gen -phase 1 -CXTMCr0p0

• If you want AMBA Designer to copy the IP files to the destination directory instead 
of referencing them from their original location, use the copyfiles argument:
adcanvas -b <file>.xml -<IP_Name> -gen -copyfiles

4.4.1 See also

Tasks 
• Configuring an AMBA 4 component and generating RTL for it on page 4-2.
• Saving a batch configuration XML file for AMBA 4 components on page 4-6.
• Finding out the phase number of a generator for an AMBA 4 component on page 4-7.

Reference 
• AMBA Designer batch mode commands on page 9-3.
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4.5 Reconfiguring an AMBA 4 component
1. To open the component configuration window, do one of the following:

• Right-click the component on the Canvas and select Design → Reconfigure 
component.

• Right-click the component in the Component Window and select Reconfigure 
component.

Note
 This option is available only when the system in the Canvas has already been saved.

2. Update the configuration parameters as required.

Note
 By default, the component is reconfigured, the configuration name is kept, and the new 

configuration replaces the old configuration in the Component Library. If you want to 
save the modified configuration with a different name, make sure that you change the 
name in the configuration window.

3. Click Next.

4. To regenerate the RTL, run the generators by clicking Run.

5. Click Finish.

The reconfigured component is added to the Component Library.

4.5.1 See also

Tasks 
• Configuring an AMBA 4 component and generating RTL for it on page 4-2.

Reference 
• For specific configuration information for your chosen component, see the relevant 

Supplement document to the ARM® AMBA® Designer User Guide.
ARM DUI 0333O Copyright © 2006-2013 ARM. All rights reserved. 4-9
ID092413 Non-Confidential



Chapter 5 
Configuring Bus Matrices and Interconnects

This chapter provides an overview of how to configure and render ARM bus matrices and 
interconnects and how to modify them. It contains the following section:
• Configuring and rendering bus matrices and interconnects on page 5-2.
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5.1 Configuring and rendering bus matrices and interconnects
This is an overview. For IP-specific instructions on how to generate bus matrices and 
interconnects, see the AMBA Designer supplement documents.

1. Make sure that the AMBA Configuration Window is visible in AMBA Designer Canvas. 
If it is not visible, select Window → Configuration Window.
Make sure that the Configurators tab is active.

2. Double-click the name of the bus matrix or interconnect in the AMBA Configuration 
Window.
The component configurator window appears.

3. To configure the bus matrix or interconnect, fill in the necessary configuration 
information.
Select the appropriate tabs and buttons for the available options.

4. Create the address map and the interconnect. These step is different for each bus matrix 
and interconnects. Follow the instructions in the AMBA Designer Supplement document 
for the IP.

5. Generate the bus matrix or interconnect.

6. Generate the RTL.

7. Add the generated bus matrix or interconnect to the Component Library.

5.1.1 See also

Tasks 
• ARM® PrimeCell AHB Bus Matrix BP010 Supplement to ADR-400 AMBA® Designer User 

Guide.
• NIC-301, for revisions:

r1p2 and earlier ARM® AMBA® NIC-301 Network Interconnect Supplement to 
ADR-400 AMBA® Designer User Guide.

r2p0 onwards ARM® CoreLink™ NIC-301 Network Interconnect Supplement to 
ADR-400 AMBA® Designer User Guide.
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Chapter 6 
Creating and Configuring a System

This chapter describes how you can create and configure an AMBA-compliant system. It 
contains the following sections:
• Adding components to a new system on page 6-2.
• Creating external ports on page 6-3.
• Connecting components on page 6-4.
• Changing a full-width connection to a bit-slice connection on page 6-9.
• Tying off input ports on page 6-11.
• Stitching on page 6-12.
• Stitching parameters on page 6-14.
• Recreating a stitched system from exported configuration files on page 6-16.
• Adding labels to the project on page 6-17.
• Using stitched systems as components on page 6-18.
• Reconfiguring a stitched system on page 6-19.
• Replacing a component in the system on page 6-20.
ARM DUI 0333O Copyright © 2006-2013 ARM. All rights reserved. 6-1
ID092413 Non-Confidential



Creating and Configuring a System 
6.1 Adding components to a new system
Add component instances to the current system in the Canvas in one of the following ways:

• Drag them from the Component Window onto the Canvas.

• Use the context-sensitive menu in the Diagram Window:
1. Right-click the Diagram Window to open the context-sensitive menu.
2. Select Add Component.... The Select Component dialog box appears.
3. Choose the component from the list.

You can type a name for the component in the Instance Name (Optional): field.
4. Click OK.
5. Position the component in the Diagram Window.

Note
 You cannot place a component on top of another object in a system.

• Select Insert → Add Component... in the main menu and use the Select Component 
dialog box to add your chosen component.
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6.2 Creating external ports
You must create external ports for all connections that are to be brought up to the top level 
during stitching. To achieve this, start from either a component port or the main menu.

From a component port:

1. Right-click on a component port and select Create External Port.
AMBA Designer automatically connects an appropriately named external port connector 
and connecting wire to the component port.

2. Drag the external connector to the position you require and left-click.

From the main menu do one of the following:

• Select Insert → Add External Port....
1. Select the port type, enter a name for the external port, and then click OK.
2. The external port is added to the Canvas. You can connect it to a component port 

later.
or:

• Select Insert → Add Connection....
1. Select the component that you want to create an external port for from the 

Component Instance A list.
2. Select Create External Port from the Component Instance B list.
3. Click the OK button to create the external port.

Note
 AMBA Designer automatically generates the external port name. If you require a 

specific name then use one of the other methods.
ARM DUI 0333O Copyright © 2006-2013 ARM. All rights reserved. 6-3
ID092413 Non-Confidential



Creating and Configuring a System 
6.3 Connecting components
You can connect ports graphically in the Diagram Window or by selecting the start and end point 
from port lists.

When you are connecting components, you must observe the following rules:
• You must connect bus interface port outputs to bus interface port inputs of the same type.
• You must connect signal port outputs to signal port inputs.

Note
 To create a bit-slice connection, first create a full-width connection between two ports by 
selecting Tools → IP-XACT Connections, and then edit the connection. For instructions, see 
Changing a full-width connection to a bit-slice connection on page 6-9.

To connect ports graphically:

1. Make sure that the Canvas is in Connect mode by clicking Connect in the toolbar.

2. Place the cursor over the first port to be connected. The cursor changes to the Connect 
Ports Mode cursor and the port is highlighted.

3. Left-click the port and move the cursor to the second port to be connected.
The Canvas automatically creates an orthogonal wire when you move the cursor to the 
second port. To complete the connection, place the cursor over the second port to be 
connected, and when the port is highlighted, left-click the mouse to complete the 
connection. You can cancel the connection by pressing Esc any time before left-clicking 
the second port connection.

Note
 If you attempt to connect ports that are not of the correct types, the connection is not made.

4. To move a connection line or change the names that AMBA Designer automatically 
generates for a connection, switch to Edit mode by clicking Edit in the toolbar.

5. To move a connection line, left-click it, grab a control point, and then shift the line.

6. To rename a connection, right-click it, then select Rename.
Edit the name field and click OK.

To connect ports by selecting them from lists:

1. Make sure that the Canvas is in Edit mode by clicking Edit in the toolbar.

2. Right-click on an empty section of the Diagram Window and select Add Connection.... 
The Create IP-XACT Connection dialog box appears, see Figure 6-1 on page 6-5.
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Figure 6-1 Create IP-XACT Connection

The Bus Interface tab enables you to connect the bus interfaces and create external ports.

3. To create a connection:
a. Select a port in the left-hand Select a Port pane.
b. Select a port in the right-hand Select a Port pane.
c. Click Connect to connect the selected ports.

4. To create external bus interface ports:
a. Select Create External Port (Multi Select).
b. Press the Ctrl key and select one or more ports in the left-hand Select a Port pane.
c. Click Connect to create an external port for each of the selected ports.

Table 6-1 shows the settings you can use to filter the ports to display and name a bus interface 
connection.

Table 6-1 Create IP-XACT Connection, Bus Interface settings

Option Description

Auto Gen Connection Name When selected, AMBA Designer assigns a name for the connection.
When deselected, you can enter a name for the connection. However, you cannot enter a name 
if Create External Port (Multi Select) is selected.

Show Unconnected Ports Only When selected, the Select a Port pane displays unconnected ports only.

Connection Name Displays the name of the connection.

Select a Bus Interface Type

Vendor When selected, the drop-down list displays the vendor name.

Library When selected, the drop-down list displays the library name.
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The Ports tab enables you to connect ports, tie-off ports to fixed values, and create external 
ports.

5. To create a connection:
a. Select a port in the left-hand Select a Port pane.
b. Set the left-hand Left and Right fields to select which bits of the port you require.

Note
 This step is only applicable to multi-bit ports, that is, when the Left or Right fields 

display nonzero values.

c. Select a port in the right-hand Select a Port pane.
d. Set the right-hand Left and Right fields to select which bits of the port you require. 

The bit width must match that chosen in step b.

Note
 This step is only applicable to multi-bit ports.

e. Click Connect to connect the selected ports.

6. To tie a port to a fixed value:
a. Select a port in the left-hand Select a Port pane. You must select an input port.
b. Click Enable.
c. Set the left-hand Left and Right fields to select which bits of the port you require.

Note
 This step is only applicable to multi-bit ports, that is, when the Left or Right fields 

display nonzero values.

d. Enter a value in the Value field. The value sets the tie-off value and must be 
appropriate to the bit width you chose in step c.

e. Click Connect to tie off the port.

Name When selected, the drop-down list displays the product name.

Version When selected, the drop-down list displays the product version.

Select Component A and port

Select a Port Displays bus interfaces. To filter the results, you can:
• Use the Select Component A and port drop-down list.
• Enter text in the Select Component A and port search box.
• Use the Select Bus Interface Type drop-down list.

Create External Port (Multi 
Select)

When selected, you can select multiple bus interfaces and create an external port for each 
interface.

Select Component B and port

Select a Port Displays bus interfaces. To filter the results, you can:
• Use the Select Component B and port drop-down list.
• Enter text in the Select Component B and port search box.
• Use the Select Bus Interface Type drop-down list.

Table 6-1 Create IP-XACT Connection, Bus Interface settings (continued)

Option Description
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7. To change a tie-off input port value:
a. Select an input port in the left-hand Select a Port pane. The right-hand Select a Port 

pane displays the tie-off value.
b. Click on the tie-off value in the right-hand pane. 
c. Enter a value in the Value field. The value must be appropriate to the bit width that 

the Left and Right fields display.
d. Click Update Connection to update the tie-off value.

8. To remove a tie-off input port value:
a. Select an input port in the left-hand Select a Port pane. The right-hand Select a Port 

pane displays the tie-off value.
b. Click on the tie-off value in the right-hand pane.
c. Click Disconnect to remove the tie-off.

9. To create external ports:
a. Select Create External Port (Multi Select).
b. Press the Ctrl key and select one or more ports in the left-hand Select a Port pane.
c. Click Connect to create an external port for each of the selected ports.

The Clk/Reset tab enables you to connect clocks, connect resets, and create external ports.

10. To connect clocks:
a. Set the Select Clk or Reset port type drop-down list to CLK.
b. Press the Ctrl key and select one or more clock ports in the Select Ports to connect 

pane.
c. Click Connect to connect the selected clocks.

11. To connect clocks to an external clock port:
a. Set the Select Clk or Reset port type drop-down list to CLK.
b. Press the Ctrl key and select one or more clock ports in the Select Ports to connect 

pane.
c. Select an external clock port from the Select destination port drop-down list.
d. Click Connect to connect the selected clocks to the selected external clock port.

12. To connect resets:
a. Set the Select Clk or Reset port type drop-down list to RESET.
b. Press the Ctrl key and select one or more reset ports in the Select Ports to connect 

pane.
c. Click Connect to connect the selected resets.

13. To connect resets to an external reset port:
a. Set the Select Clk or Reset port type drop-down list to RESET.
b. Press the Ctrl key and select one or more reset ports in the Select Ports to connect 

pane.
c. Select an external reset port from the Select destination port drop-down list.
d. Click Connect to connect the selected resets to the selected external reset port.

6.3.1 See also

Tasks 
• Creating external ports on page 6-3.
• Changing a full-width connection to a bit-slice connection on page 6-9.
• Setting general IP-XACT preferences on page 7-4.
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Reference 
• Component ports on page 10-6.
• External ports on page 10-11.
• Connections in a system on page 10-12.
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6.4 Changing a full-width connection to a bit-slice connection
By default, the port signals are full bit-width connections, that is, no bit-slices have been 
specified. To make a bit-slice connection from a signal port to other component or external 
ports:

1. In the main menu, select Tools → IP-XACT Connections....
The IP-XACT Connections dialog box appears and lists all the IP-XACT connections for 
the system.

Figure 6-2 IP-XACT Connections listing before editing

2. To create a bit-slice, edit the L and R values in the port listing to define the bit range 
required for each bit-slice.

Note
 The following ad-hoc connections are not supported:

• Signals from external bus interfaces.
• Non-contiguous bit-slicing of two ad-hoc signals connected together.

Figure 6-3 shows the edited IP-XACT connections for the system.

Figure 6-3 IP-XACT Connections listing after editing

3. Click OK to save the new L and R signal port values and close the IP-XACT Connections 
dialog box. Figure 6-4 on page 6-10 shows the sliced connection.
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Figure 6-4 Multiple bit-slice connections

6.4.1 See also

Tasks 
• Setting general IP-XACT preferences on page 7-4.
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6.5 Tying off input ports
1. Right-click the input port to tie off and select Create Tied Value.

The IP-XACT Connections dialog box is displayed. See Figure 6-5.

Figure 6-5 IP-XACT Connections dialog box

2. By default, the port is given a tied value of 0.
To change the default tied value for a port:
a. Left-click the port listing below the Tied Value header.
b. In the text entry field that appears, enter the new tied value.
To delete a tied value, click the port in the list and then click Delete Tied Value.

3. To finalize the settings and to close the dialog box, click OK.

The color of the tied-off port is solid light green.

6.5.1 See also

Tasks 
• Setting general IP-XACT preferences on page 7-4.
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6.6 Stitching

Note
 • You can only stitch one system at a time.

• AMBA Designer does not support stitching third-party IP-XACT components.

• AMBA Designer stitches systems that comply with IP-XACT. In particular, bus interface 
connections must be wired point-to-point connections and no bus interface fanout is 
supported. For example, on the NIC-301 AMBA Interconnect APB master interfaces, 
AMBA Designer extracts each individual APB slave slot so that you can stitch each of 
these slots individually.

1. In the main menu, select Design → IP-XACT RTL Stitching....
AMBA Designer displays the AMBA Designer - RTL Design Flow Manager dialog box.

2. Click Preferences to open the Stitcher Preferences dialog box. For information on the 
stitching settings, see Stitching parameters on page 6-14.
Make the necessary changes and click OK.

Note
 • If the Auto Add Stitched System to Component Library flag is selected in the 

IP-XACT Stitching tab, the system is automatically added to the Component 
Library when you close the dialog box. Otherwise, no action is taken.

• To bring all the unconnected signal ports in the system up to the top level, select 
Export all unconnected in the AMBA Designer - RTL Design Flow Manager 
Preferences dialog box.

3. In the AMBA Designer RTL Design Flow Manager dialog box, click Stitch RTL to start 
the process.

4. Click Close to close the AMBA Designer - RTL Design Flow Manager dialog box.

If the Auto Add Stitched System to Component Library flag was set in the Preferences 
dialog, the new component representing the stitched system is added to the Component Library. 
It appears in the Component Window with a system icon and the name you gave it when you 
saved it. Figure 6-6 shows the example system saved as NIC_301_PL340.

Figure 6-6 Saved stitched system in Component Window

IP stitching generates reports in the following directory during the stitching process:

/home/<user>/.ARM/AMBA_Designer/3.0/Designs/<SysName>_RTL/

The reports depend on the components that you include in your design.
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6.6.1 See also

Tasks 
• Stitching parameters on page 6-14.
• Recreating a stitched system from exported configuration files on page 6-16.
• Using stitched systems as components on page 6-18.
• Reconfiguring a stitched system on page 6-19.
• Setting general IP-XACT preferences on page 7-4.
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6.7 Stitching parameters
Stitching parameters can be only set from the RTL Design Flow Manager Preferences dialog 
that is available when you have started IP-XACT stitching. For instructions, see Stitching on 
page 6-12.

Table 6-2 IP-XACT stitching settings

Option Description

IP-XACT_Stitching

Ignore IP-XACT Bus Definitions 
VLNV Version Fields

When selected, bus interface version fields on components are not compared against bus 
definition versions when checking for bus compatibility.

Run IP-XACT Stitching Process 
in Verbose Mode

When selected, an extended messaging mode is used that provides additional progress 
information.

Create verbose comments in the 
generated RTL

When selected, basic comments are added to the RTL during the stitching process.

Run IP-XACT Stitching Process 
in Strict Mode

When selected, forces a strict strategy to be used when stitching. This is useful for IP-XACT 
design verification, and the following policies apply:
• Failure when an invalid default value is detected for input or bidirectional signals, in 

IP-XACT component definitions.
• Failure when connected signals do not have the same size, or the same left and right bits.
• Additional warning messages are output.

Output VC file When selected, a <design name>.vc file is generated at the same location as the top-level <design 
name>.v file. The .vc file contains references to all the .v files, directories, and other directory 
dependencies, and you can use it to compile the entire design.

Auto Add Stitched System to 
Component Library

When selected, AMBA Designer adds the stitched system to the Component Library.

Absolute path for .v files in 
generated IP-XACT file

When selected, the generated IP-XACT file includes the absolute path to the .v files instead of the 
relative path.

Signal Options

Use instance names in nets When selected, the instance name of the components being connected are used as part of the net 
name.

Note
 If you require this option then you must also select Export all unconnected in the Signal Options 
pane.

Export all unconnected When selected, all the unconnected signal ports are exported to the top level of the design. This 
is equivalent to manually creating external ports for all the unconnected signal ports in the design.

Note
 Only signal ports, not bus interface ports, are exported to the top level of the design.
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6.7.1 See also

Tasks 
• Setting general IP-XACT preferences on page 7-4.

Bus Interface Options

Export all unconnected When selected, all the unconnected bus interfaces are exported to the top level of the design. This 
is equivalent to manually creating external ports for all the unconnected bus interfaces in the 
design.

Stitcher Plugins

System Configuration Export When selected, AMBA Designer outputs the system configuration files and a script file 
render.csh into a subdirectory called <SysName>_config. You can then move the content of the 
subdirectory to some other system on which AMBA Designer and other required IP and licences 
are installed to recreate the system there by executing render.csh.
For instructions, see Recreating a stitched system from exported configuration files on page 6-16.

Table 6-2 IP-XACT stitching settings (continued)

Option Description
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6.8 Recreating a stitched system from exported configuration files

Note
 • You must have the IP bundle and appropriate versions of AMBA Designer and other EDA 

tools installed on the system on which you want to recreate the stitched system from 
configuration files.

• You cannot use the render.csh script to rerender components that have not been originally 
rendered in AMBA Designer, even if they were used in a system. Reconfigure such 
systems outside AMBA Designer, and then add them to the Component Library.

1. Run the render.csh script by specifying a destination directory for the design as a 
command-line argument:
render.csh <SysName>_config <target_directory>

The full hierarchical system is recreated in the target directory.

2. Open the system in AMBA Designer:
adcanvas <SysName>_config/<SysName>.adg

3. You can now use and modify the system in AMBA Designer.

6.8.1 See also

Tasks 
• For instructions and prerequisites for a particular IP bundle, see the relevant Supplement 

document to the ARM® AMBA® Designer User Guide.
• For information on which tools are required for a particular IP bundle, see the Release 

Note for the IP bundle.
• For information about the tool versions that you require for a particular AMBA Designer 

release, see the ARM® AMBA® Designer ADR-400 Release Note.

• ARM® AMBA® Designer ADR-400 Installation Guide.
• Starting AMBA Designer Canvas on page 1-5.
• Adding a component to the default Component Library from the command line on 

page 11-5.

Reference 
• AMBA Designer batch mode commands on page 9-3.
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6.9 Adding labels to the project
1. Right-click the spot in the Diagram Window where you want to place the label, and then 

select Add Label.

2. Edit and format the label as required and click OK.
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6.10 Using stitched systems as components
You can add stitched systems to the Component Library. This is done automatically if you 
enable the Auto Add Stitched System to Component Library option in the is stitching 
preferences. You can then use such hierarchical components or subsystems in more complex 
systems the same way as you use simple components.

6.10.1 See also

Tasks 
• Stitching parameters on page 6-14.
• Adding a component to the Component Library from an IP-XACT XML file on page 11-4.
• Adding a component to the default Component Library from the command line on 

page 11-5.
ARM DUI 0333O Copyright © 2006-2013 ARM. All rights reserved. 6-18
ID092413 Non-Confidential



Creating and Configuring a System 
6.11 Reconfiguring a stitched system

Note
 If you reconfigure a subcomponent in a stitched system, you must restitch not only that 
subsystem, but also all intermediate and top-level systems that include the reconfigured 
subcomponent. You must restitch hierarchical systems in a bottom-up fashion, starting with the 
lowest-level component that changed.

1. To open the configuration window for the hierarchical component, do one of the 
following:
• Right-click the component in the Canvas, and then select Design → Reconfigure 

Component.
• Right-click the component in the Component Window, and then select Reconfigure 

component.

2. Change the system as required and save it.

3. Restitch in a bottom-up fashion all interim subsystems and systems from the level on 
which you changed the component to the top level.

6.11.1 See also

Tasks 
• Reconfiguring an AMBA 2 or AMBA 3 component on page 3-13.
• Reconfiguring an AMBA 4 component on page 4-9.
• Using stitched systems as components on page 6-18.
• Missing port in subcomponent on page 13-5.
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6.12 Replacing a component in the system
You can replace a component with another one in the system design. AMBA Designer attempts 
to reconnect all connections to the same ports of the new component. If the same port does not 
exist, AMBA Designer deletes the connection. The tool preserves the size of the component.

Caution
 Use this option with care. It might adversely affect the design of your system.

1. Right-click the component in the Diagram Window, and select Replace Selected 
Components....

2. Select the replacement component from the list and click OK.

Note
 When you replace a component, the bit-slice connections and tie-off values of the old 
component are not kept for the new component.
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Chapter 7 
AMBA Designer General Reference

This chapter describes the general configuration options for AMBA Designer, both in the 
Canvas and in batch mode. It contains the following sections:
• AMBA Designer Preferences dialog on page 7-2.
• Setting general IP-XACT preferences on page 7-4.
• Design Preferences dialog on page 7-5.
• Files and directories used by AMBA Designer on page 7-8.
• Changing the permissions of generated files on page 7-9.
• Enabling logging on page 7-10.
ARM DUI 0333O Copyright © 2006-2013 ARM. All rights reserved. 7-1
ID092413 Non-Confidential



AMBA Designer General Reference 
7.1 AMBA Designer Preferences dialog
Use the AMBA Designer Preferences dialog box to configure preferences about the tool in 
general.

Figure 7-1 AMBA Designer Preferences dialog box

1. Select File → Preferences....
This opens the AMBA Designer Preferences dialog box.

2. Click General in the left-hand pane to set the following:
• Home directory.
• Text editor.
• Browser to open the htm files.

3. Click General → Design Preferences in the left-hand pane to set the following:

Note
 AMBA Designer only supports absolute paths.

• Global and user preferences.
• Path to the generated design model.
• Path to the generated component file.
• Path to the configuration file.

4. Click General → Component Library in the left-hand pane to set the following:
• Working directory for component configuration files.
• List of additional locations with component configuration files.

5. Click Canvas in the left-hand pane to set the following:
• Output messages saved in a text file.
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• Reload projects on a startup.
• Saving options, such as creating a subdirectory for a new project automatically or 

generating backup files, autosave.

6. Change the appropriate items in the right-hand pane and then click OK.

7.1.1 See also

Tasks 
• Setting general IP-XACT preferences on page 7-4.
• Setting drawing preferences in AMBA Designer Canvas on page 8-11.
• Customizing the appearance of AMBA Designer Canvas on page 8-12.

Reference 
• Paths to relative directories on page 13-4.
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7.2 Setting general IP-XACT preferences
1. To set general IP-XACT preferences, select File → Preferences → IP-XACT.

You can set the following options:
• Suppress IP-XACT Repository warning messages.

Caution
 Use this option with care.

• Bus Definitions Paths.
Specifies where the tool searches for the bus definition files. Click Edit to display 
the IP-XACT Directories dialog box and enter the directory paths.

• IP-XACT Files.
Lists the IP-XACT files according to certain filters: bus definition, component, and 
design files are listed separately.

7.2.1 See also

Tasks 
• Stitching on page 6-12.
• Stitching parameters on page 6-14.
• Viewing the IP-XACT properties of a component on page 10-3.
• Adding a component to the Component Library from an IP-XACT XML file on page 11-4.

Reference 
• Design Preferences dialog on page 7-5.
• Files and directories used by AMBA Designer on page 7-8.
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7.3 Design Preferences dialog
From the AMBA Designer Preferences, you can also edit the project preferences in the Design 
Preferences... dialog, see Figure 7-2.

Figure 7-2 General Design Preferences dialog box

To change the defined path or file, perform one of the following actions:

• Enter the new directory path in the associated field then click OK to save the preferences 
and close the Design Preferences dialog box.

• Click Browse... to open a file browser dialog box. Use this dialog box to:
1. Navigate to the appropriate directory or file.
2. Select the appropriate directory or file.
3. Click OK to close the file browser dialog box.
4. Click OK to save the preferences, and close the Design Preferences dialog box.

The preferences are:

Global User Preferences 
The path to the location of the global preferences.

Local User Preferences 
The path to the location of your local preferences.

Generated Design Model Path 
After you configure an AMBA component, AMBA Designer generates the 
IP-XACT component and saves it in this directory.

Note
 AMBA Designer only supports absolute paths.

During the RTL generation process, the tools create the relevant RTL directory 
structure for the AMBA component in this directory. AMBA Designer uses this 
directory structure to save the RTL files that it generates.
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Generated Component File 
AMBA Designer uses the Component Library file to store the configured 
components in the AMBA Designer Component Library. The configuration 
process for AMBA components consists of the tools writing the resultant 
IP-XACT and Verilog files to the Generated Design Model Path directory.
This file contains the library configuration entry information for generated 
components that you have added to the IP-XACT Component Library.

Design Configuration Target Path 
This directory contains the design configuration files. These files contain the 
parameter, address, and sparse information that AMBA Designer uses to generate 
the AMBA component.

Note
 AMBA Designer only supports absolute paths.

Generated Design Permissions 
This field enables you to apply file protection bits, and optionally, assign a default 
group. The tools use these settings each time you generate new RTL for a 
component or system. The field provides a summary of the permissions for the 
following categories:
• User.
• Group.
• Other.
It also shows the name of the user group. To change these permissions, click 
Set.... This opens the AMBA Designer - Generated Design File Permissions 
dialog box. See Figure 7-3.

Figure 7-3 Generated Design File Permissions dialog box

Use this dialog box to change:
• The permissions for each of the categories.
• The user group. You can select this from the drop-down list.

Note
 • The Linux OS restricts the list of groups available to those groups that you, 

the current user, are subscribed to.
• These settings only apply to newly-generated IP. If you change these 

settings between sessions for RTL generation, the tools do not apply them 
retrospectively.
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Generated Design Logfile 
The path to the location of the generated logfile. To enable this option, select the 
check box, and specify the path to the location where the log files are to be stored.

Note
 AMBA Designer only supports absolute paths.

7.3.1 See also

Tasks 
• Setting general IP-XACT preferences on page 7-4.
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7.4 Files and directories used by AMBA Designer
Table 7-1 shows the files and directories used by AMBA Designer.

7.4.1 See also

Tasks 
• Setting general IP-XACT preferences on page 7-4.

Table 7-1 Files and directories used by AMBA Designer

Name Description Setting Default location

AMBA_Designer

_Prefs.ini

AMBA Designer 
preferences file

AMBA Designer 
Preferences dialog on 
page 7-2

/home/<user>/.ARM/AMBA_Designer/3.0

.conf AMBA Designer 
component library

Adding a Component 
Library .conf file to the 
preferences on page 11-7

Default Component Library:
$home/<user>/.ARM/AMBA_Designer/3.0/AMBA_Designer_
MaxLib.conf 

You define the location of the other .conf files.

Files generated during 
stitching

Stitching parameters on 
page 6-14

/home/<user>/.ARM/AMBA_Designer/3.0/Designs/<SysNa
me_RTL>

.xml Configuration file for batch 
configuration and RTL 
generation

• Creating a 
configuration file 
for AMBA 2 or 
AMBA 3 
components on 
page 3-9

• Saving a batch 
configuration XML 
file for AMBA 4 
components on 
page 4-6

You define the location when you save the XML file.

.adg Project file for a stitched 
system

- You define the location when you save the project file.

.xml IP-XACT file for the 
stitched system

Stitching parameters on 
page 6-14

/home/<user>/.ARM/AMBA_Designer/3.0/Designs/<compo
nent_name>_RTL/logical/<component_name>/ipxact

.vc Output VC Verilog file.a /home/<user>/.ARM/AMBA_Designer/3.0/<SysName_RTL>/
logical/<SysName>/verilog

<SysName>_con

fig

Directory into which 
AMBA Designer exports 
configuration files and a 
render.csh file for the 
<SysName> system

You define the location before stitching the system in 
AMBA Designer.
For instructions, see Stitching parameters on 
page 6-14.

render.csh Script generated by AMBA 
Designer. You can use it to 
recreate the stitched system 

When stitching export is enabled, AMBA Designer 
creates this script while it creates and populates 
<SysName>_config with configuration files during 
stitching.

a. More than one VC Verilog file is created for interconnects.
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7.5 Changing the permissions of generated files

Note
 • The Linux OS restricts the list of groups available to those groups that you, the current 

user, are subscribed to.

• These settings only apply to newly-generated IP. If you change these settings between 
sessions for RTL generation, the tools do not apply them retrospectively.

1. Select File → Preferences....
This opens the AMBA Designer Preferences dialog box.

2. To change these permissions, for the files that AMBA Designer generates, click 
General → Design Preferences → Generated Design Permissions → Set....
This opens the AMBA Designer - Generated Design File Permissions dialog box. See 
Figure 7-4.

Figure 7-4 Generated Design File Permissions dialog box

Use this dialog box to change:
• The permissions for each of the categories.
• The user group. You can select this from the drop-down list.
Change the appropriate items in the right-hand pane and then click OK.

3. Click OK to save the changes in the preferences.

7.5.1 See also

Tasks 
• Starting AMBA Designer Canvas on page 1-5.

Reference 
• AMBA Designer Canvas overview on page 8-2.
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7.6 Enabling logging
1. Select File → Preferences....

This opens the AMBA Designer Preferences dialog box.

2. To change these permissions, for the files that AMBA Designer generates, click 
General → Design Preferences → Generated Design Log File. and select the Enabled 
option.

3. Click Browse..., navigate to the location where you want to store the log files, and click 
Save.

4. Click OK to save the changes in the preferences.

7.6.1 See also

Tasks 
• Starting AMBA Designer Canvas on page 1-5.

Reference 
• AMBA Designer Canvas overview on page 8-2.
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Chapter 8 
AMBA Designer Canvas Reference

This chapter describes the AMBA Designer Canvas reference. It contains the following 
sections:
• AMBA Designer Canvas overview on page 8-2.
• Working in the Design Window on page 8-5.
• AMBA Designer Canvas modes on page 8-6.
• Mouse cursors, tool tips, and status information on page 8-7.
• AMBA Designer Canvas shortcuts on page 8-9.
• Setting drawing preferences in AMBA Designer Canvas on page 8-11.
• Customizing the appearance of AMBA Designer Canvas on page 8-12.
• Clearing recent file history list in AMBA Designer Canvas on page 8-13.
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8.1 AMBA Designer Canvas overview
AMBA Designer Canvas is a graphical application that you can use to create new systems and 
load and modify existing systems. A system can consist of connected components and existing 
systems. You create and edit systems using the Canvas interface. This interface shows the 
components, ports, and connections between the ports. You can add external ports for a system, 
and add labels to annotate the diagram. Figure 8-1 shows the main Canvas window.

Figure 8-1 Combined Canvas window

You can select the windows that appear. Not all windows appear in the default view.
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Table 8-1 shows the main parts of the GUI.

Table 8-1 User interface elements

Element Description Undockable

Title bar The title bar of the application window contains the name of the application, the 
name of the current system being edited, and the state of the project. If you 
modified the system and did not yet save it, an asterisk is displayed to the right of 
the system name.

No

Main menu The main menu presents commands with their corresponding keyboard shortcuts. No

Toolbar The toolbar contains buttons for frequently-used features. No

Component Window This window contains a list of all the components available for use in your system.
You can:
• View the components as a list or as icons.
• Add tabs to show only certain components by filtering them by type.
• Enter text in its search box, to find specific components.

No

Configuration Window This window contains tabs for AMBA component configurators and the design 
hierarchy of the components and external ports in the current system. You can 
enter text in its search box, to find configurators and hierarchies.

No

Parameter Window This window contains all the parameters of the selected component.

Note
 This applies only to legacy components. This window does not display IP-XACT 
component parameters.

No

Diagram Window This window contains a graphical representation of the system. If the system is 
small, the window can display the entire system. For large systems, the view is of 
a small portion of the total system. There is no limit to the size of the system other 
than the limits imposed by the operating system or computer hardware.
The Diagram Window behaves in a similar way to a block diagram editor, or 
flow-charting tool. Use this window to:
• Place components.
• Place external ports.
• Connect the objects together.
Figure 8-1 on page 8-2 shows a Diagram Window containing an example system.

No

Output Window This window appears below the Diagram Window and displays system console 
output and system check information.
The Output Window displays system console output and system check 
information.

Yes

Status bar The status bar displays information about menu items, commands, buttons, and 
components.
If you:
• Select a menu on the menu bar and use the up and down keys to select a 

menu item, Canvas displays a short description of what the action does in 
the status bar.

• Place the cursor over a toolbar button, Canvas displays a short description 
of the button action in the status bar.

• Place the cursor over a component in the Diagram Window, the status bar 
shows the instance name, the component name, and the type of component. 

No
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8.1.1 See also

Tasks 
• Starting AMBA Designer Canvas on page 1-5.
• Customizing the tabs in the Component Window on page 11-3.

Reference 
• AMBA Designer batch mode for component configuration on page 1-7.
• Mouse cursors, tool tips, and status information on page 8-7.
• AMBA Designer Canvas shortcuts on page 8-9.
• Launch parameters for AMBA Designer Canvas on page 9-2.

Master Output Window This window shows the complete system console output and system check 
information from the start of a session.

No

Tools Window The Component Window, AMBA Configuration Window, and Parameter Window 
comprise the tools window. See Figure 8-1 on page 8-2.

Yes

Projects tab The tabs below the Diagram Window list the projects that are currently loaded. If 
only one project is open, only one tab is displayed. Clicking on a tab displays the 
Diagram Window and Tools Window for that project.

No

Context-sensitive menus When you right-click in the Diagram Window, a context-sensitive menu appears. 
The menu depends on what you have selected before you right-click:
• If you have not selected a component, the general context-sensitive menu 

appears. The entries duplicate the functionality of the main menus.
• If you have selected a component, the component context-sensitive menu 

appears.

No

Table 8-1 User interface elements (continued)

Element Description Undockable
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8.2 Working in the Design Window
Moving the view port in the Design Window 

1. Change to Edit mode
2. Press and hold Ctrl and move the view port with the mouse within the 

system diagram.
The limits to the movement are the same as the limits for the scroll bars.

Zooming You can zoom the diagram in or out within the range of 10%-500%. When 
zooming out, the contents of the components change as the size of the 
components become smaller. Canvas attempts to display the most important 
information about objects when zooming out. You can hover the mouse cursor 
over an object to display its name in the status bar.
To access the zoom feature, press Shift+Ctrl, and use the left or right mouse 
buttons to zoom in or out.

Selecting objects 
• To select a single object, left-click the object in the Diagram Window.
• To select multiple objects, make selections while holding down Ctrl.

You can also use the lasso feature to select several objects. Click and drag 
the mouse to select all objects within the lasso rectangle. Canvas includes 
any object that is partially contained within the bounding rectangle in your 
selection.

• To select all objects, select Edit → Select All or lasso the entire system.
• To clear the selection list, click in the background area of the Diagram 

Window.
• To remove a single object from the selection list, hold down Ctrl, and 

left-click the object.

Drag-and-drop 
Drag-and-drop is supported for components in the Component Window.

Change display options 
You can disable the display of the object type, port list, and subcomponent list in 
the Canvas preferences settings:
• General appearance.
• Canvas appearance.
ARM DUI 0333O Copyright © 2006-2013 ARM. All rights reserved. 8-5
ID092413 Non-Confidential



AMBA Designer Canvas Reference 
8.3 AMBA Designer Canvas modes
AMBA Designer operates in the modes that Table 8-2 shows.

The cursor appearance changes to indicate the mode. In Connect Mode for example, moving the 
cursor over a valid connection port outlines the port in a green shaded pattern, and the cursor 
changes to the connect icon.

To exit Connect Mode and return to Edit Mode, press Esc. To temporarily enter Connect Mode 
while in Edit Mode, hold down Shift, with no component selected, and make a connection.

Table 8-2 AMBA Designer Canvas modes

Cursors Mode Description

Edit For normal editing, for example, for adding, moving, cutting, copying, pasting, and deleting

Movement For moving system components around within the Diagram Window using the mouse

- Connect For connecting ports of components and external ports
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8.4 Mouse cursors, tool tips, and status information
Table 8-3 shows all the cursors that the Diagram Window uses. The cursor column shows what 
the actual cursor looks like. The typical usage column shows how the cursor looks in typical use.

Canvas displays the standard tool tips and status information in the Status Bar whenever you 
select a menu item using the up-down keys, or hover the cursor over a toolbar button. Hovering 
the cursor over an object in the Diagram Window displays information in the Status Bar.

Table 8-3 Mouse cursors

Cursor Typical usage Description

- This is the standard selection cursor. Moving this cursor over an object and clicking on the object 
selects that object. You can also use this cursor to lasso multiple objects.

This is the drag-and-drop cursor. If the component is in the Diagram Window, Canvas displays the 
object under the cursor.

- This is the cursor for movement mode.

This is the general cursor for actions that are invalid or not applicable.

This is one of the eight resize cursors. There is one cursor for each of the compass points and corners.

This is the cursor for selecting ports. Clicking on a port of a component selects that port and deselects 
all other ports.

This is the start connection cursor. If in connection mode, before you start a connection, this cursor 
appears when over a valid port.

This is the end connection cursor. When you have started a connection and not yet completed it, this 
cursor appears over a valid end port.

This cursor appears when you move a connection end point. This cursor appears when you select and 
place items.

This is the move connection line cursor. This cursor appears when you select points and manually place 
them.
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8.4.1 See also

Tasks 
• Starting AMBA Designer Canvas on page 1-5.

Reference 
• AMBA Designer Canvas overview on page 8-2.
• AMBA Designer Canvas shortcuts on page 8-9.
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8.5 AMBA Designer Canvas shortcuts
Table 8-4 shows the keyboard shortcuts for AMBA Designer Canvas.

8.5.1 See also

Tasks 
• Starting AMBA Designer Canvas on page 1-5.

Table 8-4 AMBA Designer Canvas shortcuts

Key Action

Ctrl+N File → New

Ctrl+O File → Open

Ctrl+S File → Save

Ctrl+F4 File → Close

Ctrl+P File → Print

Ctrl+Q File → Exit

Ctrl+Z Edit → Undo

Ctrl+Y Edit → Redo

Ctrl+X Edit → Cut

Ctrl+C Edit → Copy

Ctrl+V Edit → Paste

Ctrl+D Edit → Duplicate

Del Edit → Delete

Ctrl+A Edit → Select All

Ctrl+Shift+S Edit → Edit Mode

Ctrl+Shift+C Edit → Connect Ports Mode

Ctrl+G View → Grid

Ctr + + View → Zoom In

Ctrl + – View → Zoom Out

Ctrl+1 View → Set Zoom to 100%

Ctrl+F View → Zoom to Fit

Ctrl+R View → Center on Selected Object(s)

Ctrl+I View → Center Diagram

Ctrl + Page Down Window → Next Window

Ctrl + Page Up Window → Previous Window

F1 Help → AMBA Designer (ADR-400) User Guide
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Reference 
• Mouse cursors, tool tips, and status information on page 8-7.
ARM DUI 0333O Copyright © 2006-2013 ARM. All rights reserved. 8-10
ID092413 Non-Confidential



AMBA Designer Canvas Reference 
8.6 Setting drawing preferences in AMBA Designer Canvas
1. Select File → Preferences....

This opens the AMBA Designer Preferences dialog box.

2. Select Canvas → Diagram in the left-hand pane to set the following:
Grid options 

Visibility, snapping to grid, grid spacing.
Draw Diagram with Color 

Force Canvas to draw the diagram using only black, gray, and white.
Auto arrange ports when resizing component 

Set the tool to move ports automatically if the component is made smaller. 
Ports move back to their original positions when the component is made larger.

Select Background Color... 
Change the default white background to some other color.
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8.7 Customizing the appearance of AMBA Designer Canvas
1. Select File → Preferences....

This opens the AMBA Designer Preferences dialog box.

2. Select General in the left-hand pane to set the following:
• Tooltip visibility.
• Status bar visibility.
• Splash screen visibility.
• Last Visited Directory for Open/Save.
Click General → Appearance in the left-hand pane to set the following:
• Tool Bar options (icon size and text labels).
• Font settings.

3. Change the appropriate items in the right-hand pane and then click OK.

8.7.1 See also

Tasks 
• Starting AMBA Designer Canvas on page 1-5
• Changing the permissions of generated files on page 7-9.
• Customizing the tabs in the Component Window on page 11-3

Reference 
• AMBA Designer Canvas overview on page 8-2.
ARM DUI 0333O Copyright © 2006-2013 ARM. All rights reserved. 8-12
ID092413 Non-Confidential



AMBA Designer Canvas Reference 
8.8 Clearing recent file history list in AMBA Designer Canvas

Note
 You cannot cancel this operation after you have clicked Clear Recent File History List.

1. Launch the preferences dialog.

2. Click Clear Recent File History List to clear the recent file list that appears under the 
main File menu.

8.8.1 See also

Tasks 
• Starting AMBA Designer Canvas on page 1-5.

Reference 
• Changing the permissions of generated files on page 7-9.
• AMBA Designer Canvas overview on page 8-2.
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Chapter 9 
AMBA Designer Command Line Reference

This chapter describes the AMBA Designer command line options. It contains the following 
sections:
• Launch parameters for AMBA Designer Canvas on page 9-2.
• AMBA Designer batch mode commands on page 9-3.
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9.1 Launch parameters for AMBA Designer Canvas
Table 9-1 shows the available command line options for AMBA Designer Canvas.

9.1.1 See also

Tasks 
• Starting AMBA Designer Canvas on page 1-5.

Table 9-1 Command line options for AMBA Designer Canvas

Option Example usage Description

--background color adcanvas --background 8000 Set the default background color and an application 
palette. Light and dark shades are calculated based on 
the new palette.

--button color adcanvas --button 8000 Set the default button color.

--cmap adcanvas --cmap Install a private color map on an 8-bit display.

--display display_option adcanvas --display $DISPLAY Set the X display. The default is $DISPLAY.

--font new_font adcanvas --font arial Set the application font.

--foreground color adcanvas --foreground 8000 Set the default foreground color.

--geometry new_geometry adcanvas --geometry new_geometry Set the client geometry of the main window.

--maxlib component library adcanvas --maxlib mymaxlib.conf Start Canvas with the specified library file loaded.

--ncols count adcanvas --ncols 216 Limit the number of colors allocated in the color cube 
on an 8-bit display. If the count is 216, a 6×6×6 color 
cube is used, that is, six levels of red, blue, and green. 
For other values, the system uses a cube approximately 
proportional to a 2×3×1.

--visual Truecolor adcanvas --visual Truecolor Force the application to use TrueColor on an 8-bit 
display.

-n, --nomaxlib adcanvas --nomaxlib
adcanvas –n

Start Canvas without loading any components.

<file>.adg adcanvas mySystem.adg Start Canvas with the specified file open. The 
specified file must be a *.adg file.
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9.2 AMBA Designer batch mode commands
Table 9-2 shows the available batch mode command line options for AMBA Designer Canvas.

Table 9-2 Command line options for AMBA Designer in batch mode

Option Example usage Description

-b adcanvas -b <file>.xml -<product> 
[options]

Start Canvas in batch mode.
product is the product code for an AMBA component. See the 
ARM® AMBA® Designer ADR-400 Release Note for the list of 
product codes.

-copyfiles adcanvas -b <file>.xml -<product> 
[-copyfiles]

Copy the files that are not configuration-dependent into the 
destination directory of the IP.

-gen, -generate adcanvas -b <file>.xml -<product> [-gen] Generate RTL only.

-all adcanvas -b <file>.xml -<product> [-all] Generate RTL, simulate, and synthesize. This is the default 
behavior.

--addcomp adcanvas --addcomp <file>.xml [--loc 
user|central] 

Add a configured IP-XACT component to the default 
Component Library,
~/.ARM/AMBA_Designer/3.0/AMBA_Designer_MaxLib.conf.
If you use the --loc optional option:
• With user option specified, then the configured 

IP-XACT component is added to the default component 
library: 
~/.ARM/AMBA_Designer/3.0/AMBA_Designer_MaxLib.conf.

• With central option specified, then the configured 
IP-XACT component is added to: 
$AD_HOME/ADCL/etc/all_conf_files.adcl.

--addconfigurator adcanvas --addconfigurator <file>.xml 
[--loc user|central] 

• Add the IP-XACT configurator of a component to 
$AD_HOME/ADCL/etc/all_conf_files.adcl.
If you use the --loc optional option:
— With user option specified, then the IP-XACT 

configurator of a component is added to the 
default component library: 
~/.ARM/AMBA_Designer/3.0/AMBA_Designer_MaxLi

b.conf.
— With central option specified, then the 

IP-XACT configurator of a component is added 
to: $AD_HOME/ADCL/etc/all_conf_files.adcl.

• Add a symbolic link to the IP-XACT file of the 
component in $AD_HOME/AMBADesigner/etc/ip_links.

--removecomp adcanvas --removecomp <file>.xml [--loc 
user|central]

Remove a configured IP-XACT component from the default 
Component Library,
~/.ARM/AMBA_Designer/3.0/AMBA_Designer_MaxLib.conf.
If you use the --loc optional option:
• With user option specified, then the configured 

IP-XACT component is removed from the default 
component library: 
~/.ARM/AMBA_Designer/3.0/AMBA_Designer_MaxLib.conf.

• With central option specified, then the configured 
IP-XACT component is removed from: 
$AD_HOME/ADCL/etc/all_conf_files.adcl.
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9.2.1 See also

Tasks 
• Starting AMBA Designer Canvas on page 1-5.
• Finding out the phase number of a generator for an AMBA 4 component on page 4-7.

--removeconfigurator adcanvas --removeconfigurator <file>.xml 
[--loc user|central] 

• Remove the IP-XACT configurator of a component 
from $AD_HOME/ADCL/etc/all_conf_files.adcl.
If you use the --loc optional option:
— With user option specified, then the IP-XACT 

configurator of a component is removed from the 
default component library: 
~/.ARM/AMBA_Designer/3.0/AMBA_Designer_MaxLi

b.conf.
— With central option specified, then the 

IP-XACT configurator of a component is 
removed from: 
$AD_HOME/ADCL/etc/all_conf_files.adcl.

• Remove the symbolic link to the IP-XACT file of the 
component from $AD_HOME/AMBADesigner/etc/ip_links.

AMBA 2 or AMBA 3 components, bus matrices or network interconnects

-sim, -simulate adcanvas -b <file>.xml -<product> [-sim] Generate RTL and simulate.

-syn, -synth, 
-synthesise

adcanvas -b <file>.xml -<product> [-syn] Generate RTL and synthesize.

-ovl, -noovl adcanvas -b <file>.xml -<product> [-ovl] Enable or disable OVL assertions during simulation.
The default is to use predefined preferences.

-lec, -nolec adcanvas -b <file>.xml -<product> [-lec] Enable or disable LEC of synthesized netlist against RTL.
The default is to use predefined preferences.

AMBA 4 components

-gen -phase adcanvas -b <file>.xml -<product> -gen 
-phase <num>

Call a specific generator for an IP based on the phase number.
See Finding out the phase number of a generator for an AMBA 
4 component on page 4-7 for the simulator options.

Stitched systems

render.csh render.csh <directory> Recreate a stitches system for which configuration files had 
been exported into <directory>.
See Recreating a stitched system from exported configuration 
files on page 6-16.

Table 9-2 Command line options for AMBA Designer in batch mode (continued)

Option Example usage Description
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Chapter 10 
Components, Ports, and Connections

This chapter describes the objects in AMBA Designer and what you can do with them. It 
contains the following sections:
• Component instances on page 10-2.
• Viewing the IP-XACT properties of a component on page 10-3.
• Viewing and editing the IP-XACT model parameters of a component instance on 

page 10-4.
• Viewing the hierarchical structure of a component on page 10-5.
• Component ports on page 10-6.
• Enabling and disabling ports on page 10-8.
• Hidden component ports on page 10-9.
• Hiding and unhiding ports on page 10-10.
• External ports on page 10-11.
• Connections in a system on page 10-12.
• Hiding and unhiding signal or bus connections in a design on page 10-13.
ARM DUI 0333O Copyright © 2006-2013 ARM. All rights reserved. 10-1
ID092413 Non-Confidential



Components, Ports, and Connections 
10.1 Component instances
Figure 10-1shows a component instance as it appears in the Diagram Window.

Figure 10-1 Component description

The title bar shows the instance name of the component and the component name in parentheses.

component 
The object visible in the Component Window, a configuration for an IP bundle.

component instance 
The object visible on the Canvas. You connect this component instance to instances of other 
components, for example to stitch them together into an AMBA-compliant system with 
IP-XACT stitching.

10.1.1 See also

Tasks 
• Viewing the IP-XACT properties of a component on page 10-3.
• Viewing and editing the IP-XACT model parameters of a component instance on 

page 10-4.

Reference 
• Component ports on page 10-6.
• External ports on page 10-11.
• Connections in a system on page 10-12.
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10.2 Viewing the IP-XACT properties of a component
You can inspect the IP-XACT properties of a configured component in AMBA Designer:

1. Right-click the component in the Component Window and select IP-XACT Properties....

2. Use the following tabs to inspect the IP-XACT parameter settings:
Bus Interfaces 

Generic properties and bus signals for each bus.
Parameters 

Top-level or component IP-XACT parameters.

Note
 You cannot modify these parameters from the IP-XACT Properties dialog. If 

you require different top-level parameters, you must reconfigure the 
component or create a new component configuration.

Signals Signal name, direction, left and right connection widths, the export state, and 
whether the signal is assigned to a bus interface.
Check the Show Unassigned Signals Only option to show unassigned signals 
only in the dialog box.

3. Click OK to close the dialog.

10.2.1 See also

Tasks 
• Configuring an AMBA 2 or AMBA 3 component in the Canvas on page 3-3.
• Configuring an AMBA 2 or AMBA 3 component from an XML configuration file on 

page 3-11.
• Reconfiguring an AMBA 2 or AMBA 3 component on page 3-13.
• Configuring an AMBA 4 component and generating RTL for it on page 4-2.
• Reconfiguring an AMBA 4 component on page 4-9.
• Setting general IP-XACT preferences on page 7-4.
• Viewing and editing the IP-XACT model parameters of a component instance on 

page 10-4.

Reference 
• Adding a component to the Component Library from an IP-XACT XML file on page 11-4.
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10.3 Viewing and editing the IP-XACT model parameters of a component instance
You can inspect and edit the IP-XACT properties of a component instance in AMBA Designer.
1. Right-click the component in the Canvas and select Component IP-XACT Properties....
2. Use the tabs to inspect the IP-XACT parameter settings:

Bus Interfaces 
Generic properties and bus signals for each bus.

Model Params 
These are IP-XACT parameters that AMBA Designer translates directly to 
Verilog parameters.
You can modify these parameters from the Canvas.

Note
 Modifying model parameters is an advanced feature to override the default 

IP-XACT model parameters for one instance of the component. Depending on 
the component, you can safely modify some model parameters in this dialog 
for instantiation. However, other model parameters require that you 
reconfigure and rerender the component. Make sure that you thoroughly 
understand the IP-XACT file of the component before you modify model 
parameters for an instance.

Signals Signal name, direction, left and right connection widths, the export state, and 
whether the signal is assigned to a bus interface.
Check the Show Unassigned Signals Only option to show unassigned signals 
only in the dialog box.

3. Use the tabs to inspect the IP-XACT parameter settings.
4. If changes are required to a model parameter:

a. Select the Model Params tab.
b. Select the parameter from the list, and click the Edit (advanced) button.
c. Enter the new parameter value and click OK.

5. Click OK to save the changes and to close the IP-XACT Properties dialog.

10.3.1 See also

Tasks 
• Configuring an AMBA 2 or AMBA 3 component in the Canvas on page 3-3.
• Configuring an AMBA 2 or AMBA 3 component from an XML configuration file on 

page 3-11.
• Reconfiguring an AMBA 2 or AMBA 3 component on page 3-13.
• Configuring an AMBA 4 component and generating RTL for it on page 4-2.
• Reconfiguring an AMBA 4 component on page 4-9.
• Setting general IP-XACT preferences on page 7-4.
• Viewing the IP-XACT properties of a component on page 10-3.

Reference 
• Stitching on page 6-12.
• Stitching parameters on page 6-14.
• Adding a component to the Component Library from an IP-XACT XML file on page 11-4.
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10.4 Viewing the hierarchical structure of a component
1. Drag the component from the Component Window to the Diagram Window.

2. Click the Hierarchy tab in the Configuration Window.
The component is displayed as the root node of the tree and the tree includes all its 
components and external ports. For an example, see Figure 10-2.

Figure 10-2 Hierarchy tab

3. You can also navigate in the component as it is visible in the Diagram Window from the 
element tree in the Hierarchy tab:
• Left-click an object in the Hierarchy tab to highlight and center the object in the 

Diagram Window for easy location.
• Right-click an object in the Hierarchy tab to display a context-sensitive menu 

containing command options specific to the object type.
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10.5 Component ports

Note
 AMBA Designer does not support IP-XACT Phantom ports.

AMBA Designer supports the following port types:

Bus interface Solid colors.

Signal Shaded colors.

Ports can be master or slave ports. Master bus interface ports always point out of the component, 
output ports, and slave interface bus ports always point into the component, input ports.

Figure 10-3 shows an example for each component port type as a master and a slave, 
respectively.

Figure 10-3 Component port types

You can move component ports around the edges of the component.

Table 10-1 lists the color scheme that the Canvas uses for component ports.

Table 10-1 Port colors

Color Component type or visibility in the Canvas

Yellow APB

Dark cyan AXI3

Green AXI4

Cyan ACE

Magenta ACE-Lite

Dark magenta ATB
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10.5.1 See also

Tasks 
• Creating external ports on page 6-3.
• Connecting components on page 6-4.
• Changing a full-width connection to a bit-slice connection on page 6-9.
• Tying off input ports on page 6-11.
• Stitching on page 6-12.
• Hiding and unhiding signal or bus connections in a design on page 10-13.

Dark green Unhidden disabled port

Light green Tied-off input port

Black General port color that AMBA Designer uses if there is no color reserved for the type or status

Table 10-1 Port colors (continued)

Color Component type or visibility in the Canvas
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10.6 Enabling and disabling ports
In some cases, you might not use certain ports, or you might not require connections to certain 
ports. Because the tools check that all ports are connected, these ports cause an error or warning 
message.

• To change the status of a port, right-click it in the Diagram View, and then select 
Enable/Disable Port.

• To disable all unconnected ports in the component, right-click an empty area of the 
component, and then select Disable All Unconnected Ports.

AMBA Designer Canvas grays out disabled ports.

10.6.1 See also

Tasks 
• Creating external ports on page 6-3.
• Connecting components on page 6-4.
• Changing a full-width connection to a bit-slice connection on page 6-9.
• Tying off input ports on page 6-11.
• Stitching on page 6-12.
• Hiding and unhiding signal or bus connections in a design on page 10-13.
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10.7 Hidden component ports
Hidden ports are unused ports that are not visible in the Canvas by default. For example, all 
signals that are part of a component bus interface are hidden.

You can use, connect, and tie off such signals in an ad-hoc manner by first unhiding the required 
signal port, and then using the normal connection and tie-off methods. Unhidden ports are solid 
dark grey in the Canvas.

Hidden component ports are invisible in the Canvas by default. You can unhide them so that 
they appear in the component outline

10.7.1 See also

Tasks 
• Creating external ports on page 6-3.
• Connecting components on page 6-4.
• Changing a full-width connection to a bit-slice connection on page 6-9.
• Tying off input ports on page 6-11.
• Stitching on page 6-12.
• Hiding and unhiding signal or bus connections in a design on page 10-13.
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10.8 Hiding and unhiding ports
Restrictions:

• If a component has both a bus interface and a signal with the same name, then you cannot 
unhide the signal to show it on the Canvas for use as an ad-hoc connection.

• Hidden ports are not made visible when connections are made visible, see Hiding and 
unhiding signal or bus connections in a design on page 10-13.

• If you unhide a single physical port that is mapped to multiple bus interfaces in a 
component IP-XACT file, the component that represents this IP-XACT file in the Canvas 
shows the physical port mapped to the first bus interface and displays the physical port 
only once.

Hiding ports:

• To hide a port, right-click it the Design View and select Hide Port.

• To hide all disabled ports, right-click an empty area in the component and select Hide All 
Disabled Ports.

Revealing hidden ports:

• To reveal a port, right-click an empty area in the component, select Unhide Port, select 
the port from the list, and then click OK.

10.8.1 See also

Tasks 
• Creating external ports on page 6-3.
• Connecting components on page 6-4.
• Changing a full-width connection to a bit-slice connection on page 6-9.
• Tying off input ports on page 6-11.
• Stitching on page 6-12.
• Hiding and unhiding signal or bus connections in a design on page 10-13.
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10.9 External ports
External ports connect hierarchical systems. A system that you intend to instantiate within a 
higher-level system must have external ports. A top-level system or a flat system typically does 
not have external ports.

When you instantiate a stitched system as a component, each external port appears as a port.

10.9.1 See also

Tasks 
• Creating external ports on page 6-3.
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10.10 Connections in a system
AMBA Designer supports the following connection types:
• Bus connections.
• Signal connections, also called ad-hoc connections.

You can convert full-width, bit-wide, connections to bit-slice connections.

Rules that apply to connections of signal ports:

If the unhidden port is a signal that is part of a bus interface, the following rules control how the 
connections are shown in the Canvas:

• If the port is left unconnected, but the bus interface is connected, the signal is connected 
according to the original bus interface connection.

• If the port is connected through an ad-hoc connection, the resulting Verilog code connects 
the signal first according to this new connection, and then the original bus interface 
connection.

• If the port is tied-off, the new tie-off takes precedence over the original bus interface 
connection and the resulting Verilog code ties off the signal.

10.10.1 See also

Tasks 
• Changing a full-width connection to a bit-slice connection on page 6-9.
• Hiding and unhiding signal or bus connections in a design on page 10-13.
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10.11 Hiding and unhiding signal or bus connections in a design
You can hide and unhide component ports and connections in the active project in the Diagram 
Window.

Hiding and revealing connections:

• To change the visibility all signal ports and signal connections, click the toggle button 
Signal in the main toolbar.

• To change the visibility of all bus ports and bus connections, click the toggle button Bus 
in the main toolbar.
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Chapter 11 
AMBA Designer Component Library

This chapter describes the Component Library and describes how to manage it in the AMBA 
Designer Canvas. It contains the following sections:

• Setting Component Library preferences on page 11-2.

• Customizing the tabs in the Component Window on page 11-3.

• Adding a component to the Component Library from an IP-XACT XML file on page 11-4.

• Adding a component to the default Component Library from the command line on 
page 11-5.

• Removing a component from the Component Library on page 11-6.

• Adding a Component Library .conf file to the preferences on page 11-7.
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11.1 Setting Component Library preferences
1. Open the General area of the AMBA Designer Preferences dialog box.

2. Specify where the tool searches for the Component Library files. AMBA Designer uses 
the components in these files to fill the list in the Component Window. You can choose 
from the following options:
• Use current directory. This is the directory in which AMBA Designer starts. This is 

the default setting.
• Use the specified directory.
• Use the location of the current AMBA Designer project, *.adg, file for the working 

directory.

3. If you changed the preferences, refresh the Component Window:
a. Select File → Close from the menu.
b. Right-click on the background of the Component Window and select Refresh 

Component List.
c. To reopen the updated component, drag it from the Component Window onto the 

Canvas.

Note
 The system diagrams that are currently open are not updated automatically. You must 

close and reload affected systems to see changes in the Component Library components.

11.1.1 See also

Tasks 
• Adding a component to the Component Library from an IP-XACT XML file on page 11-4.
• Adding a Component Library .conf file to the preferences on page 11-7.
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11.2 Customizing the tabs in the Component Window
You can configure the Component Window tabs to organize the components.

Note
 You cannot edit or delete the All tab. You can disable the All tab, and any custom tab, so that 
they do not appear in the Component Window, by unchecking them in the Window Tabs panel.

1. Right-click the background of the Component Window, or next to the tabs, and select 
Manage Tabs....
The Component Window Tab Manager dialog box appears. See Figure 11-1.

Figure 11-1 Component Window Tab Manager

2. Add or remove tabs, or change their order as necessary.
Click Reset to set the component tabs back to their original configuration. If you have 
added custom tabs, Reset disables them without deleting them.

3. Click OK to finalize the changes.
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AMBA Designer Component Library 
11.3 Adding a component to the Component Library from an IP-XACT XML file
If you have a configured ARM IP-XACT XML component file, you can use the component in 
AMBA Designer by adding it to the Component Library.

Note
 AMBA Designer only supports adding configured ARM IP-XACT components to the 
Component Library.

1. Start the Component Library Repository Wizard from Tools → Add IP-XACT 
Component to Component Library....

2. Enter or browse to the directory where the IP-XACT (xml) source for the component is 
located and click Next to display the next dialog box in the Wizard. Select the Component 
Library Repository to add the component to. You can choose to enter either the absolute 
or relative path to the Component Library Repository location or click Browse to locate it.

3. Click Next to display the next dialog box in the Wizard. This provides a summary of the 
source and destination to be used.

4. If the information is correct, click Finish to add the IP-XACT component to the 
Component Library. If it is necessary to change any entries, click Back to display the 
required dialog box. You can cancel the Wizard at any time by clicking Cancel in any of 
the dialog boxes.

Note
 If the destination is a new Component Library, you are given the option to add the library 

to your preferences.

11.3.1 See also

Tasks 
• Configuring an AMBA 2 or AMBA 3 component in the Canvas on page 3-3.
• Generating RTL for an AMBA 2 or an AMBA 3 component on page 3-6.
• Setting general IP-XACT preferences on page 7-4.
• Adding a component to the default Component Library from the command line on 

page 11-5.

Reference 
• For specific configuration information for your chosen component, see the relevant 

Supplement document to the ARM® AMBA® Designer User Guide.
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11.4 Adding a component to the default Component Library from the command line
If you have an ARM IP-XACT XML component file, you can use the component in AMBA 
Designer by adding it to the default Component Library, MaxLib.

Note
 AMBA Designer only supports adding ARM IP-XACT components to the Component Library.

• Use the following command from the UNIX prompt:
adcanvas --addcomp <file>.xml

Where <file>.xml is the name of the IP-XACT configuration file for the IP.

11.4.1 See also

Tasks 
• Configuring an AMBA 2 or AMBA 3 component in the Canvas on page 3-3.
• Generating RTL for an AMBA 2 or an AMBA 3 component on page 3-6.
• Setting general IP-XACT preferences on page 7-4.
• Adding a component to the Component Library from an IP-XACT XML file on page 11-4.

Reference 
• For specific configuration information for your chosen component, see the relevant 

Supplement document to the ARM® AMBA® Designer User Guide.
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11.5 Removing a component from the Component Library

Note
 The component is only removed from the Component Library. The configuration file and RTL 
that you generated are not deleted. However, it is the Component Library entry that stitched 
systems use. If the component was used in a stitched system, the system can no longer reference 
it.

1. Right-click the component in the Component Window and select Remove Component 
from the Component Library.
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11.6 Adding a Component Library .conf file to the preferences
1. Select File → Preferences.

2. Select Component Library in the left-hand pane.

3. Click Add below the list of configuration files.

4. Navigate to the .conf file and click OK.

5. Make sure that the order of the configuration files is correct. If more than one 
configuration files are in the list for a component, AMBA Designer uses the first one and 
ignores the second one.

11.6.1 See also

Tasks 
• Configuring an AMBA 2 or AMBA 3 component in the Canvas on page 3-3.
• Generating RTL for an AMBA 2 or an AMBA 3 component on page 3-6.

Reference 
• For specific configuration information for your chosen component, see the relevant 

Supplement documents to the ARM® AMBA® Designer User Guide.
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Chapter 12 
Migrating from AMBA Designer r2px

This chapter describes how to migrate designs from AMBA Designer r2px. It contains the 
following sections:
• Migrating components configured in AMBA Designer r2px on page 12-2.
• Migrating old systems to AMBA Designer r3px on page 12-3.
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Migrating from AMBA Designer r2px 
12.1 Migrating components configured in AMBA Designer r2px
Add and reconfigure the legacy component:

1. To add a component configured in AMBA Designer version r2px, run the following 
script:
$AD_HOME/etc/MigrateADr2toADr3.csh

After running the script, the component appears in the Component Library and you can 
drag and drop it into the Diagram Window to connect, stitch, and save in the new .adg file 
format.

2. Load the component definition, .xml, that you created in AMBA Designer r2px into the 
Configuration Window for the same component.

Note
 For the NIC-301r2 configurator, you can locate and load the component definition, .xml, 

by selecting File → Open... from the main menu of the component configuration window. 
For all other IP, click Browse in the File Creation Options pane of the configurator 
window.

3. Click OK to generate the new component configuration and close the Configuration 
Window.

4. In the Diagram Window, right-click the generated component and select Reconfigure.

5. Save the new component configuration, or follow the normal steps to render the 
component.

12.1.1 See also

Tasks 
• Configuring an AMBA 2 or AMBA 3 component in the Canvas on page 3-3.
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Migrating from AMBA Designer r2px 
12.2 Migrating old systems to AMBA Designer r3px
AMBA IP-XACT components now have a one-to-one mapping with the RTL. This is not the 
case for systems that use .mxp files created in AMBA Designer r2px versions, and you cannot 
open these directly.

1. Convert the .mxp system file to an .adg file by migrating the components using the 
method that Migrating components configured in AMBA Designer r2px on page 12-2 
describes.

2. Re-instantiate and reconnect the migrated components in the Canvas.

12.2.1 See also

Tasks 
• Replacing a component in the system on page 6-20.
• Setting general IP-XACT preferences on page 7-4.
• Viewing the hierarchical structure of a component on page 10-5.
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Chapter 13 
Troubleshooting AMBA Designer

This chapter describes the solutions to some common problems. It contains the following 
sections:
• Invalid components on page 13-2.
• Support for more than one IP revision on page 13-3.
• Paths to relative directories on page 13-4.
• Missing port in subcomponent on page 13-5.
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Troubleshooting AMBA Designer 
13.1 Invalid components
In Figure 13-1, the NewP component has a NOT symbol around the component icon. This 
indicates that the component is not available for use. This can occur if the component is missing 
from the Component Library, or AMBA Designer cannot create it.

Figure 13-1 Component Window with bad component

To fix an invalid component, check that the IP-XACT file on your system is valid, for example 
by comparing it to the IP-XACT file that was delivered with the IP bundle. If necessary, 
re-import the IP-XACT file to your system and restart AMBA Designer Canvas.

13.1.1 See also

Tasks 
• Configuring an AMBA 2 or AMBA 3 component in the Canvas on page 3-3.
• Adding components to a new system on page 6-2.
• Setting general IP-XACT preferences on page 7-4.
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Troubleshooting AMBA Designer 
13.2 Support for more than one IP revision
AMBA Designer does not support switching between multiple versions of the same IP-XACT 
component. To use different versions of the same component, include the version string in the 
component name to differentiate them. For example, Figure 13-2 shows two versions of the 
DMC (PL340) in the Component Window.

Figure 13-2 Component Window with versions in list view

13.2.1 See also

Tasks 
• Configuring an AMBA 2 or AMBA 3 component in the Canvas on page 3-3.
• Adding components to a new system on page 6-2.
• Setting general IP-XACT preferences on page 7-4.
ARM DUI 0333O Copyright © 2006-2013 ARM. All rights reserved. 13-3
ID092413 Non-Confidential



Troubleshooting AMBA Designer 
13.3 Paths to relative directories
AMBA Designer only supports absolute paths. Make sure that you do not use relative paths in 
the AMBA Designer Preferences dialog.

13.3.1 See also

Reference 
• AMBA Designer Preferences dialog on page 7-2.
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Troubleshooting AMBA Designer 
13.4 Missing port in subcomponent
If you remove any ports from a subcomponent that is itself a system or a standalone component, 
or modify its associated .adg file, then an error message is generated when higher level 
components are refreshed in AMBA Designer. Figure 13-3 shows this error message.

Figure 13-3 Subcomponent error message

If the immediate higher level component of which this subcomponent is a part is not currently 
open in AMBA Designer then the error message is not generated. This delay in displaying the 
message can lead to a false assumption that the hierarchy is valid.

ARM recommends that if the message is generated, or you have modified the .adg file, then you 
must restitch that subcomponent and all the components of which it is a part. See Reconfiguring 
a stitched system on page 6-19.
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Appendix A 
License Text

This appendix contains the license text for reference purposes. It contains the following section:
• Verilog Parser copyright notice on page A-2.
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License Text 
A.1 Verilog Parser copyright notice
ARM acknowledges and thanks the respective owners for the Verilog Parser software that 
AMBA Designer uses:

/*
* Copyright (c) 1992, Bakul Shah <bvs@BitBlocks.com>
* All Rights Reserved.
*
* Permission to use, copy, modify, distribute or sell this software and
* its documentation for any purpose is hereby granted without fee, subject
* to the following conditions.
*
* 1. The above copyright, this list of conditions and the following
*    disclaimer must appear UNCHANGED in all copies of the software and
*    related documentation, and their derivative works or modified
*    versions
*
* 2. Binary distribution must be accompanied by documentation that
*    reproduces the above copyright, this list of conditions and the
*    following disclaimer.
*
* 3. Any modifications to the source code must be clearly marked as such.
*
* 4. The author's name may not be used to endorse or promote products
*    derived from this software without specific prior written permission.
*
* This software is provided by the author AS IS. The author DISCLAIMS
* any and all warranties of merchantability and fitness for a particular
* purpose. In NO event shall the author be LIABLE for any damages
* whatsoever arising in any way out of the use of this software.
*/
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Appendix B 
Revisions

This appendix describes the technical changes between released issues of this book.

Table B-1 Differences between issues A to F

Change Location

No revision history recorded -

Table B-2 Differences between issue F and issue G

Change Location

Removed references to SoC Designer and SoC Designer Simulator Throughout book

Removed references to cycle accurate modeling

Removed references to Microsoft Windows

Moved all third-party EDA tool specific content to introduction

Removed references to Bandwidth Monitoring Components (BMCs)

Added information on third-party tools EDA tools

Added information on third-party software

Removed Installation chapter and moved information to separate book ARM® AMBA® Designer Installation Guide

Removed description of MemMap dialog -

Changed description of Component Wizard Using the Components Wizard
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Revisions 
Changed description of command line options AMBA Designer batch mode commands

Added reference content for canvas -

Removed What’s This from the Help menu Section Help menu

Removed IP-XACT Properties... from the Component Context menu Component context-sensitive menu

Removed description of System Properties dialog

Added reference content for keyboard shortcuts AMBA Designer Canvas shortcuts on page 8-9

Table B-3 Differences between issue G and issue H

Change Location Affects

Changed the description for the Help menu to match the new functionality Section Help menu r2p3

Added bullet points stating that hierarchical IP stitching is not supported, and that you must 
specify default tie-off values in binary format and not in hexadecimal format

Section Limitations

Table B-4 Differences between issue H and issue I

Change Location Affects

Removed all references to the Component Wizard. Use of this tool is now subject to an 
additional license agreement

- r3p0

Removed all references to dummy components. IP-XACT 1.4 is now supported natively Throughout book

Removed all references to component models because they are no longer supported

Described all the new IP-XACT component features added to Preferences, the main and 
context-sensitive menus, the toolbar and existing and new dialog boxes

Table B-5 Differences between issue I and issue J

Change Location Affects

Removed all references to generic IP stitching Throughout book r3p0

Note added, the Hierarchy Window option controls the display of the AMBA 
Configuration Window

Updated the location of the preferences .ini file -

Updated the keyboard shortcuts AMBA Designer Canvas shortcuts on 
page 8-9

r0p0

Table B-2 Differences between issue F and issue G (continued)

Change Location
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Revisions 
Table B-6 Differences between issue J and issue K

Change Location Affects

Book has been restructured Throughout book All

Updated product number to ADR-400 Document title and references r3p1

Added information about AMBA 4 components Chapter 4 Configuring AMBA 4 Components

Added information about exporting stitched components AMBA Designer batch mode commands on page 9-3

Added information about command options -copyfiles and 
--addconfigurator

AMBA Designer batch mode commands on page 9-3

Table B-7 Differences between issue K and issue L

Change Location Affects

Added information about editing model 
parameters

Viewing and editing the IP-XACT model parameters of a component instance 
on page 10-4

r3p1

Table B-8 Differences between issue L and issue M

Change Location Affects

Updated the following option commands:
--addcomp

--addconfigurator

--removecomp

--removeconfigurator

Table 9-2 on page 9-3 r3p2

Table B-9 Differences between issue M and issue N

Change Location Affects

Added information about a new method for creating an external port connection 
for a component.

Creating external ports on page 6-3 r3p3

Added description of reason why error message might appear when updating 
system subcomponents.

Missing port in subcomponent on 
page 13-5

r3p0

Table B-10 Differences between issue N and issue O

Change Location Affects

Additional features in the Create IP-XACT Connection dialog Connecting components on page 6-4 r3p4

Added requirement to select the Export all unconnected option when using the 
Use instance names in nets stitching option

Table 6-2 on page 6-14 r3p0

Added Bus Interface Options pane r3p4

Added search box for the Component Window and Configuration Window Table 8-1 on page 8-3

Added port colors for AXI4, ACE, ACE-Lite, and ATB Table 10-1 on page 10-6
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