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Preface

This preface introduces the Integrator/CP Board Support Package for Windows CE 
.NET Application Developer's Guide. It contains the following sections:

• About this book on page x

• Feedback on page xiii.
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Preface 
About this book

This is the Application Developer's Guide (DG) for the Integrator/CP Board Support 
Package for Windows CE .NET. It describes the use of the system on the following core 
modules:

• CM920T

• CM922T-XA10

• CM926EJ-S

• CM1026EJ-S.

Product revision status

The rnpn identifier indicates the revision status of the product described in this guide, 
where:

rn Identifies the major revision of the product.

pn Identifies the minor revision or modification status of the product.

Intended audience

This guide is written for developers who are creating Windows CE .NET applications 
for the ARM Integrator/CP. This guide assumes that you are familiar with eMbedded 
Visual C++.

Using this manual

This manual is organized into the following chapters:

Chapter 1 Introduction 

Read this chapter for an overview of the Integrator/CP application 
development system.

Chapter 2 Development Environment 

Read this chapter for a description of how to configure and use the 
Windows CE .NET OS development environment.
x Copyright © 2004 ARM Limited. All rights reserved. ARM DUI 0272A



Preface 
Typographical conventions

The following typographical conventions are used in this book:

italic  Highlights important notes, introduces special terminology, 
denotes internal cross-references, and citations.

bold  Highlights interface elements, such as menu names. Denotes 
ARM processor signal names. Also used for terms in descriptive 
lists, where appropriate.

monospace Denotes text that can be entered at the keyboard, such as 
commands, file and program names, and source code.

monospace Denotes a permitted abbreviation for a command or option. The 
underlined text can be entered instead of the full command or 
option name.

monospace italic Denotes arguments to monospace text where the argument is to be 
replaced by a specific value.

monospace bold Denotes language keywords when used outside example code.

Further reading

This section lists publications from both ARM Limited and third parties.

ARM Limited periodically provides updates and corrections to its documentation. See 
http://www.arm.com for current errata sheets, addenda, and the ARM Limited 
Frequently Asked Questions list.

ARM publications

This manual contains information that is specific to the Integrator/CP Development 
System. See o the following document(s) for other relevant information:

• Integrator/CP Compact Platform User Guide for Windows CE .NET Board 
Support Package (ARM DUI 0272)

• ARM Integrator documents:

— ARM Integrator/CP Compact Platform User Guide (ARM DUI 0159)

— ARM Integrator/CM920T, CM920T-ETM, and CM940T User Guide (ARM 
DUI 0149)

— ARM Integrator/CM926EJ-S, CM946E-S, CM966E-S, and CM1026EJ-S 
User Guide (ARM DUI 0138)

— ARM Integrator/CM922T-XA10 Core Module User Guide (ARM DUI 
0184)
ARM DUI 0272A Copyright © 2004 ARM Limited. All rights reserved. xi



Preface 
• ARM Multi-ICE documents:

— Multi-ICE Version 2.2 User Guide (ARM DUI 0048)

— Multi-ICE Version 2.2 Installation Guide (ARM DSI 0005).

• ADS Version 1.2 AXD and armsd Debuggers Guide (ARM DUI 0066)

• Trace Debug Tools Version 1.2 User Guide (ARM DUI 0118)

Other publications

This section lists relevant documents published by third parties:

• Microsoft, Microsoft eMbedded Visual C++ 4.0, available at 
http://msdn.microsoft.com/visualc/

• Microsoft, Microsoft ActiveSync, available at 
http://www.microsoft.com/windowsmobile.
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Preface 
Feedback

ARM Limited welcomes feedback on both the Integrator/CP Development System, and 
its documentation.

Feedback on the Integrator/CP Development System

If you have any comments or suggestions about this product, contact your supplier 
giving:

• the product name

• a concise explanation of your comments.

Feedback on this book

If you have any comments on this manual, send email to errata@arm.com giving:

• the title

• the number

• the relevant page number(s) to which your comments apply

• a concise explanation of your comments.

ARM Limited also welcomes general suggestions for additions and improvements.
ARM DUI 0272A Copyright © 2004 ARM Limited. All rights reserved. xiii
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Chapter 1 
Introduction

This chapter provides an overview of the Integrator/CP application development 
system. It contains the following section:

• About the Windows CE .NET Board Support Package on page 1-2.
ARM DUI 0272A Copyright © 2004 ARM Limited. All rights reserved. 1-1



Introduction 
1.1 About the Windows CE .NET Board Support Package

This section gives a brief outline of the Windows CE .NET Board Support Package 
(BSP) for the Integrator/CP:

• Features

• Tools

• Software revisions.

1.1.1 Features

The Integrator/CP Application Development System for Windows CE .NET is designed 
for use with the following core modules:

• CM920T

• CM922T-XA10

• CM926EJ-S

• CM1026EJ-S.

This BSP enables you to take the working system and add your own applications to help 
make a fully functional product in a short time. It supports:

• VGA and Color LCD screen output, at 640x480 in 16-bit

• User interaction using a PS/2 mouse and PS/2 keyboard

• Audio playback and record. 

1.1.2 Tools

You build and test your applications with Microsoft eMbedded Visual C++ 4.0. You 
then download these applications with Microsoft ActiveSync. 

1.1.3 Software revisions

The software revisions for use with the BSP are:

• Microsoft eMbedded Visual C++ 4.0, with Service Packs 1 and 2 installed. You 
can download Microsoft eMbedded Visual C++ Service Packs from 
www.microsoft.com.

• Microsoft ActiveSync 3.7. You can download ActiveSync from 
www.microsoft.com. 

• Windows CE .NET version 4.2.
1-2 Copyright © 2004 ARM Limited. All rights reserved. ARM DUI 0272A



Chapter 2 
Development Environment

This chapter describes how to configure and use the Windows CE .NET development 
environment. It contains the following sections:

• Host workstation on page 2-2

• Connecting to the Integrator/CP development board on page 2-3

• Booting the OS on page 2-4

• Building a sample application on page 2-5

• Using ActiveSync to download the sample application on page 2-8.
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Development Environment 
2.1 Host workstation

The recommended host workstation is a Windows NT or Windows 2000 OS-based PC, 
with two free serial ports, and HyperTerminal or a similar application installed.

2.1.1 eMbedded Visual C++

You must ensure that Microsoft eMbedded Visual C++ 4.0 is properly installed on the 
host PC. During installation, you must select support for at least ARMv4 Interworking 
(ARMv4I) and the Windows CE Emulator (WCE). This ensures that the correct CPU 
support packages are available when you build your applications.

The WCE emulator enables you to debug your applications before downloading them 
to the Integrator/CP.
2-2 Copyright © 2004 ARM Limited. All rights reserved. ARM DUI 0272A



Development Environment 
2.2 Connecting to the Integrator/CP development board

See the Integrator/CP Board Support Package for Windows CE .NET User Guide for 
instructions on how to set up the target platform.

To connect to the Integrator/CP development board:

1. Connect a null-modem or crossover cable between port B (bottom serial port) on 
the Integrator/CP platform and the host PC COM2.

2. Connect another serial cable between port A (top serial port) on the CP board and 
the host PC COM1.

3. Ensure that the null-modem cable wiring is interconnected between two nine-pin 
female connectors, as shown in Table 2-1, or ActiveSync cannot work.

Table 2-1 Null-modem cable interconnections for ActiveSync

Purpose Abbreviation From pin To pin

Data Carrier Detect DCD 1 4

Received Data RD or Rx 2 3

Transmitted Data TD or Tx 3 2

Data Terminal Ready DTR 4 1 and 6

Signal Ground SG or GND 5 5

Data Set Ready DSR 6 4

Request To Send RTS 7 8

Clear To Send CTS 8 7

Ring Indicator RING or RI 9 9
ARM DUI 0272A Copyright © 2004 ARM Limited. All rights reserved. 2-3



Development Environment 
2.3 Booting the OS

Launch a HyperTerminal session on the host PC:

1. Configure the port settings as follows. Set:

• bits per second to 38400

• data bits to 8

• parity to none

• stop bits to 1

• flow control to none.

2. Follow the instructions in the Integrator/CP Board Support Package for Windows 
CE .NET User Guide to set up the DIP switches and flash images on the platform 
so that the Windows CE .NET OS can boot up.

When the OS starts to run, the HyperTerminal window shows the text Windows 
CE Kernel for ARM and other boot sequence output.

3. Figure 2-1 shows that loading and initialization have completed. You can now 
download your user-developed application.

Note
 The icons displayed in the main window might vary from those shown in 

Figure 2-1. They depend on which OS binary is shipped.

Figure 2-1 Windows CE .NET ready screen
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Development Environment 
2.4 Building a sample application

This section shows you how use eMbedded Visual C++ to produce a simple HelloWorld 
application.These instructions assume that you are familiar with the eMbedded Visual 
C++ interface.

1. Launch eMbedded Visual C++.

2. Select File → New… from the menus.

3. Select a WCE MFC AppWizard (exe) project and name it HelloWorld in the 
New dialog box. 

4. Choose a suitable work directory location for the project and select Win32 (WCE 
ARMV4I) and Win32 (WCE emulator) as the CPU support. Click OK.

5. The WCE MFC AppWizard (exe) dialog now appears:

a. Select Single Document without Document/View architecture support 
in step 1. Click Next >.

b. Select Next > again to accept the defaults in step 2.

c. Choose the Statically linked MFC library option in step 3.

d. Click Finish to accept the defaults in the rest of the steps.

e. A review of your chosen options is shown in the next dialog, select OK to 
create the project.

6. Now find the OnPaint method of the CChildView class in the ChildView.cpp file.

Note
 There are several ways of achieving this. See the eMbedded Visual C++ help for 

more information on using its development interface.

7. Change the code in the OnPaint function so it resembles the code below:

void CChildView::OnPaint()
{

CPaintDC dc(this); // device context for painting
CString s = “Hello World”;
CRect rect;
GetClientRect(&rect);
dc.DrawText( s, -1, &rect, DT_SINGLELINE | DT_CENTER | DT_VCENTER );

}

8. Select Tools → Options from the menus. Alter the Download options tab so that 
Always download binary to the target and Always download dependencies to 
the target are turned OFF.
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Development Environment 
9. Compile and build your program using the Build → Build HelloWorld.exe menu 
option. This builds the WCE emulator version by default.

10. Select Build → Start Debug → Go from the menus. This starts the emulator and 
downloads the test application.

11. You are asked to find commdlg.dll to enable full debugging. Select Cancel.

Figure 2-2 shows the WCE emulator window when the application is running.

Figure 2-2 HelloWorld application running on the WCE emulator

12. In eMbedded Visual C++, select Debug → Stop Debugging. This leaves the 
WCE emulator running but you can close this as well.

13. Select Build → Set Active Configuration… and choose HelloWorld - Win32 
(WCE ARMV4I) Release from the Set Active Project Configuration dialog list 
box. Click OK.

14. Use Build → Build HelloWorld to compile again but this time it is for the target 
device.
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Development Environment 
15. The ARMV4IRel directory in your project directory contains HelloWorld.exe. You 
can now download this to your target using ActiveSync. See Using ActiveSync to 
download the sample application on page 2-8 for a description of how to do this.

16. You can start the application on the target and see the same results as the WCE 
Emulator when it is downloaded.
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Development Environment 
2.5 Using ActiveSync to download the sample application

ActiveSync is the standard method for providing PC connectivity for Windows CE 
devices. It contains two parts:

• The host-side Windows application named ActiveSync. This can be downloaded 
from the Microsoft web site.

• The target (device) end component named rep1log. This might not be included in 
the OS binary for some releases. Check the release notes for details.

2.5.1 Setting up the target connection properties

Before initiating the connection, you first set up the target (device) end connection 
properties. You must do this every time you reset the target:

1. Open the target (device) end Control Panel. Use Start → Settings → Control 
Panel or navigate from My Computer.

2. Select Network and Dial-up Connections, then select Make New Connection. 
Figure 2-3 shows the Make New Connection dialog box that appears.

Figure 2-3 Make New Connection dialog box

3. Select Direct Connection for the connection type and then choose Next >. 
Ensure that Serial Cable on COM1: is selected as the connection device. 

4. Click on Configure…. The Device Properties dialog box is displayed.

Figure 2-4 Device Properties dialog box
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Development Environment 
5. Select the settings listed in Table 2-2. 

6. Select OK on the Device Properties dialog box and again on the subsequent 
Windows CE Networking dialog box about the changes.

7. Select Finish to complete the new connection.

8. Return to the Control Panel by closing the Network Connections window.

9. Select PC Connection, then select Change… in the PC Connection Properties 
dialog box shown in Figure 2-5.

Figure 2-5 PC Connection Properties dialog box

10. Choose My Connection from the drop-down in the Change Connection dialog 
box, and press OK.

11. Select OK to the connection change in the PC Connection Properties dialog 
box.

Table 2-2 ActiveSync configuration settings

Parameter Setting

Manual Dial  no

Use Terminal window before dialing  no

Use terminal window after dialing  no

Baud Rate  57600

Data Bits 8

Parity None

Stop Bits 1

Flow Control  None
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Development Environment 
2.5.2 Using ActiveSync

To use ActiveSync:

1. Start the ActiveSync program on the host PC to display the Get Connected 
dialog box shown in Figure 2-6. 

Figure 2-6 ActiveSync Get Connected dialog box

If it is not displayed, select File → Get Connected… from the ActiveSync 
program menu.

2. Start the Repllog.exe application on the target. This program is located in the 
Windows directory, or you can enter Repllog into the Start → Run… dialog box. 
Figure 2-7 shows the dialog box.

Figure 2-7 Repllog connection dialog box on target

3. Return to the host PC and press Next > on the Get Connected dialog. ActiveSync 
now searches for a target to connect to.

4. If you have performed Steps 2 and 3 within four seconds then the connection is 
made and, after a short time, ActiveSync indicates this on the host PC.
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Development Environment 
If the connection is not successful, the Get Connected dialog box displays the 
failure:

a. Check all of your connection settings.

b. Check that the cable is plugged in to the correct target port.

c. Return to step 2 and try again.

5. A new dialog box named New Partnership displays on the host PC, select No 
and then choose Next >.

6. Press the Explore button on the ActiveSync window toolbar to bring up an 
explorer window. This shows the contents of the target desktop and enables you 
to copy files to and from your target. Figure 2-8 shows the ActiveSync window.

Figure 2-8 ActiveSync window after connection to the target

7. Copy your HelloWorld.exe from your sample application project directory (see 
Building a sample application on page 2-5, step 15), and paste it into the Explorer 
window for the target.
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