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1 Introduction
The ARM® Cortex-M1 processor is the first ARM processor designed specifically for implementation in 
FPGAs.

The Cortex-M1 FPGA Development Kit is used with the Altera Cyclone III Starter Board. It enables you to 
implement, prototype, and test the Cortex-M1 processor in an FPGA system design. It provides an example 
system design that contains the components, buses, and memory map that you require to run deeply 
embedded software kernels or real-time operating systems (RTOS), such as RTX™ RTOS from Keil™.

The following subsections describe:

• Contents of the Cortex-M1 FPGA Development Kit

• Supported platforms.

1.1 Contents of the Cortex-M1 FPGA Development Kit
The kit contains the following items:

• Cortex-M1 FPGA Development Kit Install CD

• Cortex-M1 FPGA Development Kit Cortex-M1 User Guide (ARM DUI 0395)

• Cortex-M1 IP Encryption License Card

• Cortex-M1 RealView® Microcontroller Development Kit (MDK) License Card.

If you are using an evaluation version of the kit, information about evaluation licenses is provided when you 
download the files.

Note
 The kit does not include an Altera FPGA development board. ARM recommends that you obtain a suitable 
development board, such as the Altera Cyclone® III Starter Board (DK-START-3C25N), when using the 
Cortex-M1 FPGA Development Kit.

1.2 Supported platforms
The Cortex-M1 FPGA Development Kit v1.1 is supported on computers running both:

• Microsoft Windows XP Professional, Service Pack 2 or later

• Altera Quartus II v8.0 or later.

The kit also supports the following additional tools:

• ModelSim-Altera 6.1g for Quartus II v8.0 or later.
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2 Installing Altera Quartus II and ModelSim-Altera
The following subsections describe the installation:

• Altera software

• Downloading software

• Installing software

2.1 Altera software
You must install the following Altera products:

Quartus® II Software The design environment and productivity tools for the Altera family of FPGA 
devices. This software includes the Altera MegaCore® IP Library.

Note
 The Cortex-M1 FPGA Development Kit requires Version 8.0 or higher.

ModelSim®-Altera Software that provides simulation support. The evaluation version of the 
Cortex-M1 FPGA Development Kit does not support simulation, so this software 
is not required if you are using an evaluation version of the kit.

2.2 Downloading software
Download the software from the Altera website download area at:

http://www.altera.com/download

Altera provides the software using the following licenses:

Web Edition You can download this edition of a product free of charge, after completing a 
license agreement.

Note
 A Web Edition license might not give access to some features.

Subscription Edition You must purchase a subscription from Altera to download this edition of a 
product.

2.3 Installing software
Install the software in the following order:

1. Quartus II Software

2. ModelSim-Altera, if applicable.

To install the software, run the supplied installation application and follow the on-screen prompts.
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3 Installing the Cortex-M1 FPGA Development Kit with RealView MDK
The Cortex-M1 FPGA Development Kit v1.1 contains:

• the Cortex-M1 processor design

• an example system design

• the RealView MDK development environment

• example software for the Cortex-M1 processor

• documentation.

To install the Cortex-M1 FPGA Development Kit v1.1:

1. From CD-ROM:

• Insert the installation CD into the CD-ROM drive. 

• The product installation wizard starts automatically. If it does not start, run the program setup.exe 
in the top-level directory on the CD.

From an online download:

• Unpack the downloaded file and run the installation program.

2. Follow the instructions that the Wizard provides to install the Cortex-M1 FPGA Development Kit and the 
RealView MDK software.

Figure 1 shows the directory structure for the Cortex-M1 FPGA Development Kit when the software 
installation is complete.

Figure 1 Cortex-M1 FPGA Development Kit installation directory structure

Note
 Figure 1 shows the directory structure when the Wizard installs the software in the default location. If you 
select an alternative install location then you must ensure that none of the folder names in the directory path 
contain any spaces, otherwise the Quartus II Software might not operate correctly with the Cortex-M1 
FPGA Development Kit.

C:\

ARM\

Utilities\

CortexM1_DevKit\

Documentation\

ExampleDesign\

Component\

ExampleSoftware\
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4 Connecting the Altera Cyclone III Starter Board
See the Altera Cyclone III Starter Board Quick Start Guide for information about:

• connecting the Cyclone® III Starter Board to your computer

• connecting a suitable power supply to the Cyclone III Starter Board

• installing the USB-Blaster driver software.

For more information about the Cyclone III Starter Board refer to the Altera website at:

http://www.altera.com
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5 Licensing the software and Cortex-M1 processor
You must obtain licenses from ARM and Altera before you can use the Cortex-M1 processor in an Altera 
FPGA design. The following sections describe how to obtain and install the licenses:

• Obtaining ARM licenses

• Obtaining Altera licenses

• Installing ARM and Altera licenses

• Quartus II license configuration on page 6.

5.1 Obtaining ARM licenses
You require the following ARM licenses:

• Cortex-M1 processor

• RealView MDK.

The Cortex-M1 FPGA Development Kit contains license cards that give your product serial numbers and tell 
you how to obtain your licenses.

Note
 Do not discard the license cards. Each card contains a unique serial number for the specified product.

Evaluation versions of the development kit include information about obtaining evaluation serial numbers.

5.2 Obtaining Altera licenses
You require the following Altera licenses:

• Quartus II Software

• ModelSim-Altera, if applicable.

Obtain these licenses from the support section of the Altera website at:

http://www.altera.com

5.3 Installing ARM and Altera licenses
After you receive the necessary licenses you must:

• save the licenses to your computer

• create or modify an LM_LICENSE_FILE environment variable to define the location of the licenses.

To create or modify an LM_LICENSE_FILE environment variable on your computer:

1. On your Desktop, right-click the My Computer icon. Select Properties from the menu. The System 
Properties window opens.

2. In the System Properties window, click the Advanced tab.

3. In the Advanced tab, click Environment Variables to open the Environment Variables window.

4. In the Environment Variables window, check the User variables pane, scrolling if necessary, to see if the 
LM_LICENSE_FILE variable is defined.

If the variable exists then:

a. In the User variables list, double-click on the LM_LICENSE_FILE variable to open the Edit User 
Variable window.

b. Add the licenses to the LM_LICENSE_FILE variable, as described in Adding the license files to a 
User Variable or System Variable on page 6.

c. Continue from step 8 of these instructions.

If the LM_LICENSE_FILE variable does not exist in the User variables pane then continue with the next 
step.

Note
 If an LM_LICENSE_FILE variable is defined in the User variables list, Windows ignores any System 

variable named LM_LICENSE_FILE.

5. In the Environment Variables window, check the System variables pane, scrolling if necessary, to see if 
the LM_LICENSE_FILE variable is defined.
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If the variable exists then:

a. In the System variables list, double-click on the LM_LICENSE_FILE variable to open the Edit 
System Variable window.

b. Add the licenses to the LM_LICENSE_FILE variable, as described in Adding the license files to a 
User Variable or System Variable.

c. Continue from step 8 of these instructions.

If the LM_LICENSE_FILE variable does not exist in the System variables pane then continue with the 
next step.

6. In the User variables pane, click New to open the New User Variable dialog box.

7. In the New User Variable dialog box, edit the fields as follows:

Variable name Enter the text LM_LICENSE_FILE

Variable value Enter the licenses, as described in Adding the license files to a User Variable 
or System Variable.

8. Click OK to save the value of the LM_LICENSE_FILE variable and close the Edit Variable or New 
Variable dialog box.

9. In the Environment Variables window, click OK to close the window.

10. In the System Properties window, click OK to close the window.

Adding the license files to a User Variable or System Variable

You add the licenses by defining the full path of each of the license files in the Variable value field for an 
LM_LICENSE_FILE variable. Each path must include the file name of the license file:

• if you are defining a new LM_LICENSE_FILE variable, enter the paths in the Variable value field, using 
a semicolon to separate the paths

• if you are editing an existing LM_LICENSE_FILE variable, add the paths to the existing contents of the 
Variable value field, using semicolons to separate:

— the new license file paths from the existing contents of the field

— the license file paths.

Note
 When a Windows variable holds multiple values the values must be separated by semicolons.

Check that the Variable value field for the LM_LICENSE_FILE variable lists the paths to all the licenses 
described in Obtaining ARM licenses on page 5 and Obtaining Altera licenses on page 5.

5.4 Quartus II license configuration
Configure Quartus II to use the LM_LICENSE_FILE variable as follows:

1. Start the Quartus II Software application.

2. Select Tools → License Setup from the Main menu, to open the Licensing window.

3. Select the Use LM_LICENSE_FILE check box.

4. Click on OK to close the Licensing window.

To force the Altera applications to use this new license configuration you must restart the following 
applications:

• Quartus II Software

• ModelSim-Altera, if it is running.
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6 Adding the Cortex-M1 processor to the SOPC Builder Library
You must add the Cortex-M1 processor to the Quartus II System On Programmable Chip (SOPC) Builder 
Library, so that SOPC Builder can use the Cortex-M1 processor in System-on-Chip (SoC) designs. Add the 
processor to the library as follows:

1. Start the Quartus II Software application.

2. Select File → Open Project from the Main menu, to open a project.

Note
 It does not matter which project you open. By default, the Cortex-M1 FPGA Development Kit installation 

process creates an example system project file in the following location:

C:\ARM\CortexM1_DevKit\ExampleDesign\CortexM1_ExampleDesign.qpf

If you did not use the default location for the installation, change this path to specify your chosen 
installation directory.

Use the file browser window to select a Quartus project file and click OK to open the project.

3. Select Tools → SOPC Builder from the Main menu, to start SOPC Builder.

Note
 When SOPC Builder starts it might output error messages because the Cortex-M1 processor is not in 

the Library.

4. After SOPC Builder starts you must update the IP search path.

Select Tools → Options from the Main menu in SOPC Builder, to open the Options window.

5. In the Options window, select the IP Search Path category and click Add to open a file browser window.

6. In the file browser window, navigate to the following folder:

C:\ARM\CortexM1_DevKit\Component\arm_avalon_cortexm1

Note
 If you did not use the default location for the installation, change this path to specify your chosen 

installation directory.

Select this folder and then click Open to return to the Options window.

7. In the Options window, click Finish to accept the changes and close the window.

8. Close and re-open SOPC Builder to make the changes take effect.

The Cortex-M1 processor now appears in the SOPC Builder Library component list, as Figure 2 on page 8 
shows.
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Figure 2 The Cortex-M1 component in the SOPC Builder Library
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7 Configuring SOPC Builder to use the Altera-ModelSim simulator

Note
 You can skip this step if you are using an evaluation version of the Cortex-M1 FPGA Development Kit. The 
evaluation version of the development kit does not support simulation.

To run a simulation on your design you must configure SOPC Builder with the location of the simulator 
application.

When SOPC Builder is running you can configure the location of the Altera-ModelSim application, as 
follows:

1. Select Tools → Options from the SOPC Builder Main menu, to open the Options window.

2. In the Options window, click on HDL Simulator to open the HDL Simulator Options window.

3. Select Mentor Graphic's ModelSim-Altera from the list of simulators.

4. To set the path to this simulator, click on … to open a file browser window.

5. In the file browser window, navigate to the following folder:

C:\altera\80\modelsim_ae\win32aloem

Note
 • If you did not use the default location when you installed ModelSim-Altera, change this path to 

specify your chosen installation directory.

• The path to the win32aloem file depends on the Mentor Graphics ModelSim-Altera release, and 
might not match the example path given here.

Select this folder and click Open to confirm the directory and close the file browser window.

6. In the Options window, click Finish to accept the changes and close the window.
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8 Using the Example System
The Cortex-M1 FPGA Development Kit provides the Example SOPC System Tutorial documentation that 
describes how to use the Example System.

Access the Example SOPC System Tutorial as follows:

1. Click the Windows Start icon to open the Start menu.

2. In the start menu, select Programs → Cortex-M1 FPGA Development Kit → Documentation

3. Select Example System Tutorial to open the document.

Note
 From the Programs → Cortex-M1 FPGA Development Kit → Documentation menu you can also access 
the Cortex-M1 FPGA Development Kit Cortex-M1 User Guide. This guide describes how to incorporate and 
program the Cortex-M1 processor in an Altera Cyclone III Starter Board.
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9 Additional information
For each of the applications described in this guide, the application Help menu gives help on using the 
application.

The FPGA section on the ARM web site, http://www.arm.com, gives more information about ARM 
FPGA implementations. The most up-to-date documentation for ARM products can be found on the ARM 
InfoCenter at http://infocenter.arm.com.

For technical support, please contact your distributor.

Note
 The Design Files are provided for use in a compatible release of the Altera Quartus II Tool, or other 
compatible Altera tool. You will need to obtain a license from Altera Corporation for the relevant tool in order 
to use the Design Files.
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