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Preface

This preface introduces the Arm® DS-5 Eclipse for DS-5 User Guide.

It contains the following:
*  About this book on page 10.
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Preface
About this book

About this book

This book introduces the Arm® plug-ins for use with Eclipse, and describes how you can use them with
other tools from DS-5. It describes how to build, debug, monitor, and manage projects for Arm targets. It
is also available as a PDF.

Using this book
This book is organized into the following chapters:

Chapter 1 Getting started with Eclipse
The following topics describe how to get started with Eclipse, the C/C++ perspective, the DS-5
Debug perspective, and associated features.

Chapter 2 Working with projects
You can use Eclipse to create projects for Arm targets. Projects are top level folders in your
workspace that contain related files and sub-folders. A project must exist in your workspace
before a new file can be added or an existing file can be imported.

Chapter 3 Working with editors
The following topics describe how to use the editors when developing a project for an Arm target.

Chapter 4 Terminology, shortcuts and icons
This following topics describe some of the terminology used in Eclipse for DS-5 User Guide,
useful keyboard shortcuts, and menu and toolbar icons.

Glossary

The Arm® Glossary is a list of terms used in Arm documentation, together with definitions for those
terms. The Arm Glossary does not contain terms that are industry standard unless the Arm meaning
differs from the generally accepted meaning.

See the Arm® Glossary for more information.

Typographic conventions

italic
Introduces special terminology, denotes cross-references, and citations.

bold
Highlights interface elements, such as menu names. Denotes signal names. Also used for terms
in descriptive lists, where appropriate.

monospace
Denotes text that you can enter at the keyboard, such as commands, file and program names,
and source code.

monospace
Denotes a permitted abbreviation for a command or option. You can enter the underlined text
instead of the full command or option name.

monospace 1italic
Denotes arguments to monospace text where the argument is to be replaced by a specific value.

monospace bold
Denotes language keywords when used outside example code.

<and>
Encloses replaceable terms for assembler syntax where they appear in code or code fragments.
For example:

MRC p15, @, <Rd>, <CRn>, <CRm>, <Opcode_2>

SMALL CAPITALS
Used in body text for a few terms that have specific technical meanings, that are defined in the
Arm® Glossary. For example, IMPLEMENTATION DEFINED, IMPLEMENTATION SPECIFIC, UNKNOWN, and
UNPREDICTABLE.

100951_0528 00_en Copyright © 2010-2017 Arm Limited (or its affiliates). All rights reserved. 10
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Feedback

Preface
About this book

Feedback on this product

If you have any comments or suggestions about this product, contact your supplier and give:

* The product name.

* The product revision or version.

* An explanation with as much information as you can provide. Include symptoms and diagnostic
procedures if appropriate.

Feedback on content
If you have comments on content then send an e-mail to errata@arm.com. Give:

* The title Arm DS-5 Eclipse for DS-5 User Guide.

* The number 100951 0528 00 en.

» If applicable, the page number(s) to which your comments refer.
* A concise explanation of your comments.

Arm also welcomes general suggestions for additions and improvements.

Note

Arm tests the PDF only in Adobe Acrobat and Acrobat Reader, and cannot guarantee the quality of the
represented document when used with any other PDF reader.

Other information

o Arm® Developer.

*  Arm® Information Center.

o Arm® Technical Support Knowledge Articles.
o Technical Support.

o Arm® Glossary.
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Chapter 1
Getting started with Eclipse

The following topics describe how to get started with Eclipse, the C/C++ perspective, the DS-5 Debug
perspective, and associated features.

It contains the following sections:

» 1.1 About Eclipse on page 1-14.

* 1.2 Launching Eclipse on page 1-15.

* 1.3 The welcome screen on page 1-16.

» 1.4 Overview of the workbench window on page 1-17.
* 1.5 Workbench features on page 1-19.

* 1.6 Workspace on page 1-20.

* 1.7 Resources on page 1-21.

* 1.8 About working sets on page 1-25.

* 1.9 Creating a working set on page 1-26.

* 1.10 Changing the top level element when displaying working sets on page 1-29.
» [.11 Deselecting a working set on page 1-30.

» [.12 Perspectives and views on page 1-31.

* [.13 Menus on page 1-34.

» [.14 Toolbars on page 1-35.

» [.15 Editing source code on page 1-36.

» 1.16 Configuring Eclipse on page 1-37.

» [.17 Preferences dialog box on page 1-38.

» [.18 Properties dialog box on page 1-40.

* .19 Importing and exporting options on page 1-42.
* 1.20 Using the Import wizard on page 1-43.

» 1.21 Using the Export wizard on page 1-44.

o 1.22 Accessing the dynamic help on page 1-45.

100951_0528 00_en Copyright © 2010-2017 Arm Limited (or its affiliates). All rights reserved.
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1.23 Installing new features on page 1-46.
1.24 Restrictions of use on page 1-47.
1.25 Data collection in DS-5 on page 1-48.

1 Getting started with Eclipse
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1 Getting started with Eclipse
1.1 About Eclipse

1.1 About Eclipse

Eclipse for DS-5 is an Integrated Development Environment (IDE) that combines the Eclipse IDE from
the Eclipse Foundation with the compilation and debug technology of the Arm tools. It also combines the
GNU toolchain for Arm Linux targets.

You can use Eclipse for DS-5 as a project manager to create, build, debug, monitor, and manage projects
for Arm targets. It uses a single folder called a workspace to store files and folders related to specific
projects.

Related information
Eclipse Foundation.
GCC, the GNU Compiler Collection.

100951_0528_00_en

Copyright © 2010-2017 Arm Limited (or its affiliates). All rights reserved. 1-14
Non-Confidential


http://eclipse.org
http://gcc.gnu.org

1 Getting started with Eclipse
1.2 Launching Eclipse

1.2 Launching Eclipse

How you launch Eclipse depends on your platform.

To launch Eclipse:
* On Windows, select Start > All Programs > Arm DS-5 > Eclipse for DS-5.
¢ On Linux:
— If you installed the shortcut during installation, you can select Eclipse for DS-5 in the
Applications menu.
— If you did not install the shortcut during installation:

1. Add the install_directory/bin directory to your PATH environment variable. If it is already
configured, then you can skip this step.

2. Open Unix bash shell.

3. Enter eclipse at the prompt.

When Eclipse launches for the first time, the Workspace Launcher dialog box opens. This enables you
to select your workspace and accept the default settings. After you select your workspace, click OK. You
are then presented with the Welcome screen.

Language packs

Some features of the workbench are translated into different languages. You can download language
packs from the Eclipse website when available.

There are two ways to launch the workbench with a different language pack:

» If your operating system is running in the language that you want to use, then the workbench
automatically displays the translated features.

» If your operating system is not running in the language that you want to use, then you must specify
the -nL command-line argument when launching the workbench.

For example, to use the Japanese language pack, enter:
eclipse -nl ja

Note

Arm Compiler 6 does not support Japanese characters in source files.

100951_0528_00_en
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1.3 The welcome screen

1 Getting started with Eclipse
1.3 The welcome screen

The welcome screen contains an overview of the main development environment and links to other pages

to help you get started.

Note

Some of the links require an active internet connection.

= ARMDS

Development Tools

Welcome to ARM® DS-5™

ARM Development Studio (DS-5) is a professional software development solution for Linux-based and
bare-metal embedded systems, covering all stages in development from boot code and kernel porting to
application debug and performance analysis.

The workbench is the main development environment where you can manage individual projects,
associated sub-folders, and source files. It uses a single folder called a workspace to store files and
folders related to specific projects. A typical workbench window contains one or more perspectives a set
of related views, editors, menus, and toolbars.

DS-5 uses the C/C++ and DS-5 Debug perspectives.

To return to this page, select Welcome to DS-5 from the Help menu.

If you have any feedback, suggestions or ideas regarding DS-5 please send an email to feedback-

ds5@arm.com

DS-5 on the ARM website

Visit the ARM website for the latest D5-5 product information and updates. The DS-5
web resources include a quick-start guide, links to the forums for general discussion on
DsS-5, to the knowledgebase where hints, tips and workarounds are documented, and
to any software updates that are available.

-
= (/C++ - Eclipse Platform =NNSE X
File Edit Source Refactor Mavigate Search Project Run  Window Help
=5 Welcome to D5-5 2 = &

DS-5 Resources...
@ Welcome to DS-5

) How Do I...?

@ Tutorial Videos, Cheat Sheets
and Examples

(3) DS-5 Documentation

@ Go to the workbench

To access the main development environment, either:
* Click on the close icon in the Welcome to DS-5 tab.

Figure 1-1 Welcome screen

¢ Click on the Go to the Workbench link on the welcome screen.

Select Welcome to DS-5 from the Help menu at any time to return to the welcome screen.

100951_0528 00_en Copyright © 2010-2017 Arm Limited (or its affiliates). All rights reserved.
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1 Getting started with Eclipse
1.4 Overview of the workbench window

14 Overview of the workbench window

A typical workbench window contains a collections of views that are associated with a specific
perspective.

For example, the Project Explorer view, C/C++ editor, Progress view, Console view, and Problems
view are all associated with the C/C++ perspective. Each perspective automatically adds the most useful
views when you select it.

DS-5 uses the C/C++ and DS-5 Debug perspectives.

Window

Editor Perspective

Perspective toolbar

View toolbar

View menu

& CIC++ - calendar/calendar.c - Eclipse

Fle Edit Source Refackor Mavigate Search Run Pioject  Window Help

i @ o B ig- & Hfre- i8-8 i$-0-Q- i@ F- BN B [ D5-5Debug L Remote Syste... | I Cjce+ |
- e a
AR el [ T 52 outin 82 @ Make ] Task | T @ | Bl Cheat Shests 2 g
= 4_:‘4) ~, 1!/* calendar.c siwmple program to output a calends#A laz W \\XS e ¥ ¥ Creating anewC Project
=125 calendar ~ 2 B stdio.h d
B [8] calendar.c 3/% Copyright (C) ARM Limited, 2009-2011. A1l ric ey & it ®
(51 calendar.a 4 : y ++ nestday(eid) : void This cheat sheet explains how ta create
iﬂ' calendar-beagle. axf 5/* This code contains a deliberate bug for wyou t £+ calcDaysInMonthivoid) : void & new C praject For your ARM tools,
] calendar-beagle-exa 3 @ date : struct Date_Format &1 Click to Beain
@; calendar-Cortex-Ad- = l ¢ @ daysInManth ; ink
u calendar-Cortes A ?| G#include <stdio.h> ®  main(vaid) | int b Select CfC++ perspective g
& Makefile g ®  nextdaviveid) : vaid » Do you wankt more infarmation on ':?:'
@ readme kil g N T S D W ® cakDaysinMonthfunid) : void P
L i i ¥ Create a new project
B Eﬁ e 11// The D3-5 Deb\?lgger .Enables sem].hu.stlng aut?mat e i
® h§ pp_library 124/ "__auto_semihosting” or "_ semihosting libre
& ﬁﬁcppax 13/// The ARN Compiler 5.0 adds "_ semihosting libr
I b§ cppese_library 14 // at link time if that image uses any semihost
123 distribution 15// If compiling with ggc or an earlier release c
& b§ example_library Ay
125 fireworks_beagle i
RS Fireworks_panda 15 gtruct Date_Format
125 Firewarks_rtsm gelt 3
+ ﬁﬁ gnometris Y :!.nt, dx A
S hello o T
-85 kerned mochile S22 ST 2
23 }:
24
o ARM Streamii 22 -4 z5roid nextdpy(void); 7
@ | % ¢ el e i 5
Address: | 10.1,20¢ E‘E [0 problems 22 & 224 | B console | 5] properties v =7
4 12 errors, 0 warnings, § others
Description Resource Path Locat,,,  Type

# @ Errors (12 itents)

A A

2 0~

‘Writable Srnart Insert 1:1

Views

Figure 1-2 Typical workbench window
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1 Getting started with Eclipse
1.4 Overview of the workbench window

To close the workbench window and exit Eclipse, select Exit from the File menu or click on the close
icon in the top corner of the window. On exit, Eclipse saves your settings automatically so that when you
next open it, the window returns to the same perspective and views.
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1.5 Workbench features

The workbench is the main development environment where you can manage individual projects,
associated sub-folders, and source files.

Each workbench window is linked to one workspace. If you want to use different workspaces at the same
time, you can launch several workbench windows and link each one to a different workspace.

The main workbench features are:

Editors
Editors enable you to view and modify the content of a file, for example source files. The tabs in
the editor area show files that are currently open for editing.

Menus and Toolbars
The main menu and toolbar are located at the top of the Eclipse window. Other toolbars
associated with specific features are located at the top of each perspective or view.

Perspectives
Perspectives define the layout of your selected views and editors in Eclipse. They also have their
own associated menus and toolbars.

Resources
Resources are projects, files, and folders that exist in your workbench.

Views
Views provide related information corresponding to the active file in the editor. They also have
their own associated menus and toolbars.

Workspace
Workspace is an area designated on your file system to store files and folders related to your
workbench projects and also your personal workbench settings.
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1.6 Workspace

The workspace is an area designated on your file system to store files and folders related to your
workbench projects and also your personal workbench settings.

Note

Arm recommends that you select a dedicated workspace folder for your workbench projects only. If you
select an existing folder containing resources that are not related to workbench projects, you cannot
access them in Eclipse. These resources might also cause a conflict later when you create and build
projects.

Changes to the customized settings in the Window > Preferences dialog box are saved in your
workspace. If you select a different workspace then these settings might be different.

When Eclipse launches for the first time, the Workspace Launcher dialog box opens enabling you to
select your workspace.

On subsequent launches the last saved workspace is shown as the default selection in the drop-down
menu. You can select another workspace by clicking on the down arrow or the Browse... button.

&= Workspace Launcher &J

Select a workspace

Eclipse Platform stores your projects in a folder called a workspace.
Choose a workspace folder to use for this session.

Workspace: CADS-3_Workspace - Browse...

[Tlilse this as the default and do not ask againi

0K l [ Cancel

. A

Figure 1-3 Workspace Launcher dialog box
If required, select the option to disable the Workspace Launcher dialog box from opening on
subsequent launches.
Note

You can change the default workspace at any time by selecting Switch Workspace... from the File
menu.

Alternatively, to open Eclipse and automatically link to a specific workspace you can use the -data
command-line argument. For example:

eclipse -data h:\workspace

Editing files outside Eclipse

Project sub-folders and files can be edited even when Eclipse is not running. When you next launch
Eclipse, the default preferences enable the relevant views to refresh and update. Alternatively, if you
change the default preferences to disable auto-refresh, you can click on the updated sub-folder or file in
the Project Explorer view and select Refresh from the File menu.
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1.7 Resources

A resource is a generic term used to describe a project, file, folder or a combination of these. Resources
exist in Eclipse but might not always exist in the workspace.

The types of resource are:

Project
A project is displayed in the Project Explorer view and can be stored within the workspace
folder or can be a linked resource.

A project must exist in Eclipse before other resources can be imported or linked to that project.
The project creation process creates additional configuration files and folders, for example,
build properties. These additional files and folders must not be edited or deleted.

Folder
A folder is displayed in the Project Explorer view and can be located within the project folder
or can be a linked resource.

File
A file is displayed in the Project Explorer view and can be located within the project folder or
can be a linked resource.

Linked resources
Resources can be shared between projects or they can exist in the file system outside of your selected
workspace. To do this a link must be created within Eclipse.

Note

A linked file or folder must have a project as its parent resource.

Deleting, moving or copying a linked resource only affects the link in your workspace and not the
resource that it links to. However, deleting a child resource from within a linked folder also deletes it
from the file system.
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Linked file
To link an existing file to a project in your workspace instead of copying it, you can use the
advanced options of the New File wizard. By default the advanced options are not visible, click
on the Advanced button to reveal them. A path variable can also be used to reference a file. For
more information on referencing with path variables, use the dynamic help.

= New File o o

File

Create a new file resource from a template.

= |

Enter or select the parent folder:

HelloWorld

(=
+ L=+ distribution
4|5 HelloWorld
= Debug
=F RemoteSysternsTempFiles

File name: HelloWorld.c

Use template: [Default C source template vl [ Configure...

[¥] Link to file in the file system

CADS-5_Waorkspace\HelloWorld\gee.ld Browse... ] [ Variables...

Cheoose file system:

@' [ Finish J [ Cancel

A

Figure 1-4 Linked file
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Linked folder
To link an existing folder to a project in your workspace instead of copying it, you can use the
advanced options of the New Folder wizard. By default, the advanced options are not visible,
click on the Advanced button to reveal them. A path variable can also be used to reference a
file. For more information on referencing with path variables, use the dynamic help.

= MNew Folder [ =] &J

Folder —

Create a new folder resource. i :’

Enter or select the parent folder:

HelloWaerld/Debug

» = distribution
4 [ HellowWorld
= Debug
=" RemoteSystemsTempFiles

Folder name:  Files

@ (= Use default location
) (p Folder is not located in the file systemn (Virtual Folder)
) [f Link to alternate location (Linked Folder)

Browse... Variables...
default
Resource Filters...
) : T 3
':2/' | Einish | [ Cancel
e A
Figure 1-5 Linked folder
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Linked project
Eclipse uses the Import wizard to create a link to an existing project. This can be useful if you

have a central folder with shared projects. By default, the Copy projects into workspace option
is selected to ensure that a copy of your project is placed in your current workspace. If you want
to leave your project where it is and create a link to it, you must deselect this option.

& Import

Import Projects

Select a directory to search for existing Eclipse projects.

Iy

@ Select root directory: - Browse...
() Select archive file: Browse...
Projects:

Select All
Deselect All

Refresh

1

Options
Search for nested projects
[¥] Copy projects into werkspace
[ Hide projects that already exist in the workspace
Working sets
[] Add project to working sets

Select...

4

Figure 1-6 Linked project

Disabling the use of linked resources
You can disable the use of linked resources by changing the General > Workspace > Linked

Resources settings in the Preferences dialog box.
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1.8 About working sets

A working set enables you to group projects together and display a smaller subset of projects.

The Project Explorer view usually displays a full list of all your projects associated with the current
workspace. If you have a lot of projects it can be difficult to navigate through the list to find the project
that you want to use.

To make navigation easier, group your projects into working sets. You can select one or more working
sets at the same time, or you can use the Project Explorer View Menu to switch between one set and
another. To return to the original view, select the Deselect Working Sets options in the View Menu.

Working sets are also useful to refine the scope of a search or build projects in a specific working set.
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1.9 Creating a working set
Create working sets to group related projects together.
To create a working set for related projects:
Procedure
1. Click the View Menu icon in the Project Explorer view toolbar.

2. Select the Select Working Set... option.
3. In the Select Working Set dialog box, click New....

= Select Working Set uﬂléj

Select a working set:

() Window Working Sets

@ No Working Sets

(") Selected Working Sets

[T] 5 ARMWT Linux Applications Mew...

Edit...
Remove
SelectAll | | DeselectAll |
@' [ oK l [ Cancel

Figure 1-7 Creating a new working set
4. Under Working set type, select Resource to group related projects.
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P
= Mew Working Set

o) B S |

Select a working set type

FESOUICE,

Working set type:

A general purpose working set that can contain any type of file-based Eclipse

=

oo Breakpoint
J.f,‘l]ava
R C/Ce+
o) .
! Back MNext = Finish

4

Figure 1-8 Selecting the resource type for the new working set

Click Next.

In the Working set name field, enter a suitable name.

In the Working set contents panel, you can select existing projects that you want to associated with

this working or you can return to the wizard later to add projects.

P
& Mew Working Set

Resource Working Set

Enter a working set name and select the working set resources,

Working set name:
HelloWarlds
Working set contents:

E—
v

. [ 5 application_rewind_1
. [ 5 application_rewind_2
. [ = distribution
s[5 gnometris

. [7]E5 hello

. [¥] =5 HelloWorld

. 15 kemel_module

> [0 = RemoteSystemsTempFiles
. [[] 5 Streamline_annotate
o [ threads

o [ xaos

| SelectAll || DeselectAll |

Finish

| [ Cancel

y

Figure 1-9 Adding new resources to a working set

8. Click Finish.
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9. Ifrequired, repeat these steps to create more working sets.

1 Getting started with Eclipse
1.9 Creating a working set

10. In the Select Working Set dialog box, select the working sets that you want to display in the Project

Explorer view.

11. Click OK.

-

= Select Working Set

Bl [ |

Select a working set:
() Window Working Sets
7 No Working Sets
1@ Selected Working Sets

® &5

[T] 5 ARMWT Linux Applications New...

Remove

| SelectAll || Desclectall |

| ok || Cancel

A

Figure 1-10 Select the required working set

The filtered list of projects are displayed in the Project Explorer view. Another feature of working
sets that can help with navigation is the option to change the top level element in the Project

Explorer view.
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1.10 Changing the top level element when displaying working sets

In the Project Explorer view, if you have more than one working set then you might want to display the
projects in a hierarchical tree with the working set names as the top level element. This is not selected by
default.

To change the top level element in the Project Explorer view:

Procedure
1. Click on the View Menu icon in the Project Explorer view toolbar.
2. Select Top Level Elements from the context menu.

3. Select either Projects or Working Sets.
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1.1 Deselecting a working set

You can change the display of projects in the Project Explorer view and return to the full listing of all
the projects in the workspace.

To do this:

Procedure

1. Click on the View Menu icon in the Project Explorer view toolbar.
2. Select Deselect Working Set from the context menu.
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1.12 Perspectives and views

The main workbench window contains one or more perspectives and each perspective contains one or
more Views.

Perspectives

Perspectives can be opened and customized using the options from the Window menu or you can use the
Perspective toolbar. By default, a perspective opens in the same window, however, you can change the
default settings in the Preferences dialog box.

Eclipse for DS-5 focuses on the C/C++ perspective and the DS-5 Debug perspective. You can change
perspective by using the Perspective toolbar or you can select Window > Open Perspective from the

main menu.
| B
Figure 1-11 Changing perspective using the toolbar menu
Views

A view is a small visual component within Eclipse to navigate through resources or to display specific
properties. An editor is a special type of view that enables viewing and editing source files.

Views can be moved or docked as applicable by dragging and dropping them into position. Double-
clicking on a view tab toggles the maximize/restore options for that view or you can use the relevant
toolbar icons.

Tip
@5 To reset all the views in a perspective to the initial settings and layout, click Reset Perspective...
in the Window menu.

The following views are useful when building and debugging C/C++ applications:

Editors
Editors are associated with specific file types and open the related editor view automatically
when you open an editable file from the Project Explorer view.

General views

Console
Displays output messages when building projects and also execution messages when
running or debugging an application.

Outline
Displays a structured list of C/C++ elements in the active file. Clicking on an element
changes the editor focus to the position of that element in the active file.

Problems
Displays error messages encountered during a build. Selecting an error message opens
the associated file and moves the focus to the line causing the problem.

Progress
Displays the progress meter when a task is in progress.

Project Explorer
Provides a hierarchical view of resources relevant to C/C++ project files. Right-clicking
on a resource produces a context menu for specific tasks.

Properties
Displays names and values for the selected item. For example, the last modified time/
date for a file.

Help views
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Help Contents
Displays the installed documentation.
Dynamic Help
Displays dynamic help for the selected feature.
Cheat Sheets
Displays step by step instructions to help you complete a specific task. Use the view
menu to access the list of cheat sheets.

DS-5 Debugger views

App Console
Enables you to interact with the I/O capabilities provided by the semihosting
implementation in the Arm C libraries.
Arm Asm Info
Enables you to view more information on an Arm or Thumb® instruction or directive.
Breakpoints
Displays all the breakpoints and the respective locations in source code or target
memory. Using this view you can add, edit, delete, enable, or disable breakpoints.
Commands
Provides access to the scripting functionality of the debugger. Most debugger actions
are echoed here and you can also execute DS-5 Debugger commands.
Debug Control
Contains a tree hierarchy showing debug connection states, processors, threads and
stack frames as applicable.
Disassembly
Displays disassembled code.
Expressions
Enables you to view and edit expressions.
Functions
Enables you to view ELF data associated with function symbols for all loaded images.
History
Provides a historical log of all the executed debugger commands.
Memory
Enables you to view and edit the contents of memory.
Modules
Enables you to view shared libraries or loaded Operating System (OS) modules.
Registers
Enables you to view and edit registers associated with the selected stack frame. When
your application stops, modified values are highlighted.
Screen
Enables you to display a block of memory as a graphical image. For example, a frame
buffer.
Scripts
Provides access to run and edit script files.
Target
Displays a list of capabilities for the target device that is currently connected to the
debugger.
Trace
Displays the captured trace information from the debug agent.
Variables
Enables you to view and edit variables associated with the selected stack frame.

Remote Systems views

Remote Scratchpad
Enables you to copy and paste or drag and drop local resources to an electronic
clipboard for use at a later point in time.
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Remote Systems
Enables you to create connections and access resources on the host workstation and
remote targets.

Terminals
Enables you to enter shell commands directly on the target without launching any
external application.

Other views can be added to a perspective but they might not be compatible with all perspectives. To add
a view to a perspective:

1. Ensure that you are in the relevant perspective.

2. Select Window > Show View > Other... to open the Show View dialog box.

3. Select the required view.

4. Click OK.

For more information on the other views not listed here, use the dynamic help.

Trim bar

Minimized views are placed in the trim bar at the edge of the current perspective. By default, the trim bar
is on the right-hand margin of the perspective but you can drag and drop it to another location if you
prefer. In the trim bar, you can double-click on a view to restore it or click on the restore icon to restore
all the minimized views.

(=)=

oo

L

1)

Figure 1-12 Minimized views in the trim area
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113 Menus

The main menu is located at the top of the Eclipse window and can be customized to your personal
preferences. The contents might vary depending on the installed plug-ins and also the active perspective.

Eclipse supports the following options from the main menu:

File
Enables you to create, save, close, print, import, and export resources. You can also manage
project and file property settings.

Edit
Enables you to cut, copy, paste, find, and replace text within a resource.

Navigate
Enables you to navigate and quickly find specific resources.

Search
Provides an advanced filter for searching through resources.

Project
Enables you to manage project build configurations and perform specific builds. You can also
customize the build settings for Arm tools.

Run
Enables you to run, send to, debug or configure external tools. You can also manage breakpoints
and watchpoints.

Window
Enables you to open, close, and customize perspectives, views and editors.

Help
Provides documentation on Eclipse and the Arm tools and software updates. You can also access
the menu option About Arm DS-5 to open a dialog box that displays the version and build
number for the current product.

Right-clicking on a resource produces a context menu for specific tasks. For more information on the
other menu options not listed here, use the dynamic help.
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114 Toolbars

The main toolbar is located at the top of the Eclipse window and can be customized to your personal
preferences. The toolbar icons vary depending on the installed plug-ins and also the active perspective.

' i oo ' a0 i
i R R R AT SRS TR A SRR Ao

Figure 1-13 Workbench toolbar

Other toolbars associated with specific features are located at the top of each perspective or view.

= | BE
Figure 1-14 Perspective toolbar
=R=S

Figure 1-15 View toolbar
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1.15 Editing source code

You can use the editors provided with Eclipse to edit your source code or you can use an external editor.
If you work with an external editor you must refresh Eclipse to synchronize the views with the latest
updates.

To do this, in the Project Explorer view, you can click on the updated project, sub-folder, or file and
select Refresh from the File menu. Alternatively you can enable the automatic refresh option by
selecting General > Workspace > Refresh automatically in the Preferences dialog box.

When you open a file in Eclipse, a new editor tab appears with the name of the file. An edited file
displays an asterisk (*) in the tab name to show that it has unsaved changes.

When you have two or more editor tabs open, you can tile them for side-by-side viewing by clicking on a
tab and dragging it over an editor border.

In the left-hand margin of the editor tab you can find a vertical bar that displays markers relating to the
active file.

Navigating

There are several ways to navigate to a specific resource within Eclipse. You can use the Project
Explorer view to open a resource by browsing through the resource tree and double-clicking on a file.
An alternative is to use the keyboard shortcuts or use the options from the Navigate menu.

Searching

To locate information or specific code contained within one or more files in Eclipse, you can use the
options from the Search menu. Textual searching with pattern matching and filters to refine the search
fields are provided in a customizable Search dialog box. You can also open this dialog box from the
main workbench toolbar.

Content assist

The C/C++ editor, Arm assembler editor, and the DS-5 Debugger Commands view provide content
assistance at the cursor position to auto-complete the selected item. Using the Ctrl+Space keyboard
shortcut produces a small dialog box with a list of valid options to choose from. You can shorten the list
by partially typing a few characters before using the keyboard shortcut. From the list you can use the
Arrow Keys to select the required item and then press the Enter key to insert it.

Bookmarks

You can use bookmarks to mark a specific position in a file or mark an entire file so that you can return
to it quickly. To create a bookmark, select a file or line of code that you want to mark and select Add
Bookmark from the Edit menu. The Bookmarks view displays all the user defined bookmarks and can
be accessed by selecting Window > Show View > Bookmarks from the main menu. If the Bookmarks
view is not listed then select Others... for an extended list.

To delete a bookmark, open the Bookmarks view, click on the bookmark that you want to delete and
select Delete from the Edit menu.
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1.16 Configuring Eclipse

You can customize Eclipse to your own settings by changing the layout, key bindings, file associations,
and color schemes.

You can also:

Configure Projects and files to use the build system in different ways by modifying the properties for
the selected resource.

Open and customize perspectives using the options from the Window menu or you can use the
perspective toolbar. By default a perspective opens in the same window, however, you can change the
default settings in the Preferences dialog box.

Move or dock views as applicable by dragging and dropping them into position. Double-clicking on
the title bar of a view toggles the maximize/restore options or you can use the relevant toolbar icons.
If you have minimized a view you can restore it by clicking on the restore icon in the toolbar at the
side of the perspective. By default this is on the right-hand side of the perspective but you can drag
and drop it to another location if you prefer. To reset all the views in a perspective to the initial
settings and layout select Reset Perspective... in the Window menu.
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1.17 Preferences dialog box

You can customize workbench settings using the Preferences dialog box.

To access the Preferences dialog box select Preferences... from the Window menu. Changes to these
settings are saved in the current workspace. If you want to copy your workbench settings to another
workspace, use the Export wizard.

The contents of the preferences hierarchy tree include the following groups:

General
Controls the workspace, perspectives, editors, build order, linked resources, file associations,
path variables, background operations, keyboard and mouse settings.

C/C++
Controls the C/C++ environment settings, CDT build variables, syntax formatting, and default
project wizard settings.

DS-5
Controls the default DS-5 environment settings, presentation and formatting for DS-5 editors
and views, target configuration database search locations, and the automatic checks for DS-5
product updates.

Help

Controls how the context help is displayed.
Install/Update
Controls the update history, scheduler, and policy.
Remote Systems
Controls the settings used by the Remote System Explorer.
Run/Debug
Controls the default perspectives, breakpoint, build, and launch settings before running and
debugging.

For more information on the other options not listed here, use the dynamic help.
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ARM Assembler
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Debugger

Developer Account
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Scatter File Editor
Streamline

Target Configuration Ex
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Updates

> Help
Install/Update
> Java
Library Hover
> PyDev
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Run/Debug
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Figure 1-16 Window preferences dialog box
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1.18 Properties dialog box

You can customize project settings using the Properties dialog box.

To access the Properties dialog box select a project and then select Properties... from the Project menu.
Changes to the customized settings are saved in the project folder in your workspace. You can also
customize the C/C++ properties for a single file for example, if you want to apply a specific compiler
option to a file during the build.

Note

If you specify different options for a single file, it overrides the options specified in the project
configuration panels that apply to all related source files.

The contents of the properties hierarchy tree for a project include the following:

Resource
Displays the resource location, modification state, and file type.
Builders
Controls builders available for the selected project.
C/C++ Build
Controls the environment, build, and tool chain settings for the active configuration.
C/C++ General
Controls documentation, file types, indexer and path/symbol settings.
Project References
Controls project dependencies.

For more information on the other options not listed here, use the dynamic help.
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Figure 1-17 Project properties dialog box
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1.19 Importing and exporting options

A resource must exist in a project within Eclipse before you can use it in a build.

If you want to use an existing resource from your file system in one of your projects, the recommended
method is to use the Import wizard. To do this, select Import... from the File menu.

If you want to use a resource externally from Eclipse, the recommended method is to use the Export
wizard. To do this, select Export... from the File menu.

There are several options available in the import and export wizards:

General
This option enables you to import and export the following:
 Files from an archive zip file.
+ Complete projects.
» Selected source files and project sub-folders.
*  Workbench preference settings.

C/C++
This option enables you to import the following:
* C/C++ executable files.
+ C/C++ project settings.
+ Existing code as Makefile project.

You can also export C/C++ project settings and indexes.

Remote Systems

This option enables you to transfer files between the local host and the remote target.
Run/Debug

This option enables you to import and export the following:

* Breakpoint settings.

* Launch configurations.

Scatter File Editor
This option enables you to import the memory map from a BCD file and convert it into a scatter
file for use in an existing project.

For information on the other options not listed here, use the dynamic help.
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1.20 Using the Import wizard

You can be use the Import wizard to import complete projects, source files and, project sub-folders in
addition to breakpoint and preference settings.

Select Import... from the File menu to display the Import wizard.

Importing complete projects

To import a complete project either from an archive zip file or an external folder from your file system,
you must use the Existing Projects into Workspace wizard. This ensures that the relevant workbench
project files are also imported into your workspace.

Importing source files and project sub-folders

Individual source files and project sub-folders can be imported using either the Archive File or File
System wizard. Both options produce a dialog box similar to the following example. Using the options
provided you can select the required resources and specify the relevant options, filename, and destination
path.

r%lmport l [=] &ﬁ

Archive file
Source must not be empty. [ |
pty — 4
From archive file: -
Filter Types... Select All Deselect All
[] Overwrite existing resources without warning

. A

Figure 1-18 Typical example of the import wizard

With the exception of the Existing Projects into Workspace wizard, files and folders are copied into
your workspace when you use the Import wizard. To create a link to an external file or project sub-
folder you must use the New File or New Folder wizard.
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1.21 Using the Export wizard

You can use the Export wizard to export complete projects, source files and, project sub-folders in
addition to breakpoint and preference settings.

Select Export... from the File menu to display the Export wizard.

The procedure is the same for exporting a complete project, a source file, and a project sub-folder. If you
want to create a zip file you can use the Archive File wizard, or alternatively you can use the File
System wizard. Both options produce a dialog box similar to the example shown here. Using the options
provided you can select the required resources and specify the relevant options, filename, and destination
path.

r%Exp-crrt l Elih1

Archive file 3
Please enter a destination archive file, w=-
="
+ [W]|i=% HelloWorld - .cproject
[ = RemoteSystemsTempFiles project
» [[]5 Streamline_annotate = gecld
+ [ =% application_rewind_1 3 [ hello_werld.c

» 125 application_rewind_2
» 7] = distribution

» ]85 gnemetris

> [ 5 hello

» 125 kernel_module

e

| Filter Types... | | SelectAll || Deselect Al

To archive file: - Browse...

Options
(@ Save in zip format (@ Create directory structure for files
() Save in tar format (7) Create only selected directories

Compress the contents of the file

. A

Figure 1-19 Typical example of the export wizard
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1.22 Accessing the dynamic help

Dynamic help provides help on the currently selected view. When you select a different view, the help
changes to help for that view.

To access the dynamic help for a specific workbench feature you must:

Procedure
1. Click on an editable field for the feature that you want to use.
2. Do one of the following:

* Click on the question mark icon.
* Select Dynamic Help from the Help menu.
» Use a keyboard shortcut:

— On Windows, F1 key.

— On Linux, Shift+F1 key combination.

Dynamic help for the selected feature appears in a panel. Other possible search results are also listed.

100951_0528_00_en

Copyright © 2010-2017 Arm Limited (or its affiliates). All rights reserved. 1-45
Non-Confidential



1 Getting started with Eclipse
1.23 Installing new features

1.23 Installing new features

When a new feature is available, you can install it using Eclipse.

To install new features:

Procedure

1.

o

Select Install New Software... from the Help menu.

2. Select a site from the Work with drop-down list or click Add... to add a new site.
3. Select the required plug-in check boxes and click Next >.

4.
5

. Read each of the license agreements and accept them. If you do not accept a license agreement, you

Review the list of plug-ins that you are about to install and click Next >.

cannot install that feature.
Click Finish.

7. Click Yes to restart Eclipse and complete the installation.

Note

*  You can only update features that you have installed on top of the ones provided by DS-5. To
update a feature, select Check for Updates from the Help menu.

*  You can change the default setting for downloading and installing updated features by selecting
Install/Update > Automatic Updates in the Preferences dialog box.
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1.24 Restrictions of use

There are specific restrictions and peculiarities that apply when using Eclipse.
These are:

Organizing projects
The recommended structure for project source files is to create them in the project folder or sub-
folder. If a source file is created in a folder that is higher than the project, an absolute link is
created.

Opening an existing Eclipse project
You must use the import wizard to import an existing Eclipse project into your workspace.

Inter-project dependencies
Nested projects are not supported. Each project must be organized as a discrete entity. Inter-
project dependencies can be set up by referencing other projects that reside in your workspace.
Select Project > Properties > Project References from the main menu to manually add
references.

Link order
Specifying the link order of your object files within the same project is not possible with
Eclipse. As a workaround, if you split your object files into different projects, you can specify
the project build order. Select Window > Preferences... > General > Workspace > Build
Order from the main menu.

Restore Defaults
Restoring the defaults of a project discards all information that is not a part of the project type.
All settings changed in the New Project Wizard are lost.
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1.25 Data collection in DS-5

Arm periodically collects anonymous DS-5 usage data.

Collecting anonymous data helps Arm better understand how you use DS-5 features so it can be
improved.

The collected data contains no personal information and is anonymous.

To disable data collection, from the main menu, select Window > Preferences > DS-5 > General, and
deselect the Allow collection of anonymous analytics data option.

= Preferences [ =] &J

t}"pEﬁltEl’tEXt General - v v
» General - -
Ant [¥] Allow collection of anonymous analytics data
- An
» LT+ +
a4 D55

ARM Assembler
Configuration Database
Debugger

Developer Account
General
Scatter File Editor
Target Configuration Ec
Teolchains
Updates

Help

Install/Update

Java

Library Hover
PyDev

Remote Systems

Run/Debug
Team

Terminal

] 1 b [REStore Qefaults.] [ Apply l

@ [ ok ][ canca |

L 4

Figure 1-20 DS-5 General options - Data collection
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Chapter 2
Working with projects

You can use Eclipse to create projects for Arm targets. Projects are top level folders in your workspace
that contain related files and sub-folders. A project must exist in your workspace before a new file can be
added or an existing file can be imported.

It contains the following sections:

* 2.1 Project types on page 2-50.

* 2.2 Creating a new C or C++ project on page 2-52.

* 2.3 Creating an empty Makefile project on page 2-54.

» 2.4 Creating a new Makefile project with existing code on page 2-55.

* 2.5 Importing an existing Eclipse project on page 2-57.

o 2.6 Setting up the compilation tools for a specific build configuration on page 2-59.
» 2.7 Configuring the C/C++ build behavior on page 2-61.

» 2.8 Using Eclipse from the command-line to clean and build your projects on page 2-63.
* 2.9 Updating a project to a new toolchain on page 2-65.

* 2.10 Adding a new source file to your project on page 2-66.

o 2.11 Sharing Eclipse projects on page 2-67.
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21 Project types

Different project types are provided with Eclipse, depending on the requirements of your project.

Note

Bare metal projects require a software license for Arm Compiler to successfully build an ELF image.

Bare-metal Executable
Uses Arm Compiler to build a bare-metal executable ELF image.
Bare-metal Static library
Uses Arm Compiler to build a library of ELF object format members for a bare-metal project.
Note

It is not possible to debug or run a stand-alone library file until it is linked into an image.

Executable
Uses the GNU Compilation Tools to build a Linux executable ELF image.
Shared Library
Uses the GNU Compilation Tools to build a dynamic library for a Linux application.
Static library
Uses the GNU Compilation Tools to build a library of ELF object format members for a Linux
application.

Note

It is not possible to debug or run a stand-alone library file until it is linked into an image.

Makefile project
Creates a project that requires a makefile to build the project. However, Eclipse does not
automatically create a makefile for an empty Makefile project. You can write the makefile
yourself or modify and use an existing makefile.
Note

Eclipse does not modify Makefile projects.

Build configurations
By default, the new project wizard provides two separate build configurations:

Debug
The debug target is configured to build output binaries that are fully debuggable, at the expense
of optimization. It configures the compiler optimization setting to minimum (level 0), to provide
an ideal debug view for code development.

Release
The release target is configured to build output binaries that are highly optimized, at the expense
of a poorer debug view. It configures the compiler optimization setting to high (level 3).

In all new projects, the Debug configuration is automatically set as the active configuration. You can
change this in the C/C++ Build Settings panel of the Project Properties dialog box.

Note

C project
This does not select a source language by default and leaves this decision up to the compiler.
Both GCC and Arm Compiler default to C for .c files and C++ for .cpp files.

C++ project
Selects C++ as the source language by default, regardless of file extension.
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In both cases, the source language for the entire project a source directory, or individual source file can
be configured in the build configuration settings.
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2.2 Creating a new C or C++ project

Use the options in the C Project dialog to create a new C or C++ project.

To create a new C or C++ Project:

Procedure

Select File > New > Project... from the main menu.
Expand the C/C++ group.

Select either C Project or C++ Project.

Click on Next.

Enter a Project name.

AN e

Leave the Use default location option selected so that the project is created in the default folder
shown. Alternatively, deselect this option and browse to your preferred project folder.

7. Select the type of project that you want to create.

=] [ |

= C Project

C Project
Create C project of selected type

Project name:  myCProject

Use default location
CADS-5_WorkspacemyCProject Browse...

default

Project type: Toolchains:

4 = Executable
& Empty Project
& Hello World AMSI C Project
> [= Shared Library
> (= Static Library
> = Makefile project

ARM Compiler 5 (D5-5 built-in)

ARM Compiler & (D5-5 built-in)

GCC 4.x [arm-linux-gnueabihf] (D5-5 built-in)
GCC for ARM Bare-metal

MinGW GCC

Show project types and teolchains enly if they are supported on the platform

Ned> || Einsh || Cancel

4

Figure 2-1 Creating a new C project

8. Select a Toolchain.

9. Click on Finish to create your new project.

You can view the project in the Project Explorer view.
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Note

C project
This does not select a source language by default and leaves this decision up to the compiler.
Both GCC and Arm Compiler default to C for .c files and C++ for . cpp files.

C++ project
Selects C++ as the source language by default, regardless of file extension.

In both cases, the source language for the entire project, a source directory or individual source file can
be configured in the build configuration settings.
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23 Creating an empty Makefile project

Sometimes, you might want to create an empty C or C++ Makefile project.

This example shows how to do this for an Arm Linux target:

Procedure

IR .

% =

10.

11

12.

13.

14.

Select File > New > Project... from the main menu.
Expand the C/C++ group.

Select either C Project or C++ Project.

Click on Next.

Enter a project name.

Leave the Use default location option selected so that the project is created in the default folder
shown. Alternatively, deselect this option and browse to your preferred project folder.

Expand the Makefile project group.

. Select Empty project in the Project type panel.

Select the toolchain that you want to use when building your project. For example if your project is
for an Arm Linux target, select the appropriate GCC toolchain.

Click on Finish to create your new project. The project is visible in the Project Explorer view.

. Before you can build the project, a Makefile containing all the compilation tool settings is required.

The easiest way to create one is to copy the Makefile from the example project, hello and paste it into
your new project. The hello project is in the Linux examples provided with DS-5.

Edit the Makefile as follows:

Locate the line that contains 0BJS = hello.o.

Replace hello.o with the names of the object files corresponding to your source files.

Locate the line that contains TARGET = hello.

Replace hello with the name of the target image file corresponding to your source files.
Save the file.

Right-click the project and then select Properties > C/C++ Build to access the build settings. In the
Builder Settings tab, ensure that the Build directory points to the location of the Makefile.

Add your C/C++ files to the project.

oo o

Postrequisites

You can now build the new project:

1.
2.

In the Project Explorer view, select the project that you want to build.
Select Project > Build Project from the main menu.
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24 Creating a new Makefile project with existing code

You can create a new Makefile project in Eclipse with your existing source code.

The following procedure shows how to create a new Makefile project in the same directory as your
source code:

Procedure

IR .

Select File > New > Project... from the main menu.

Expand the C/C++ group.

Select Makefile Project with Existing Code.

Click on Next.

Enter a project name and enter the location of your existing source code.

Select the toolchain that you want to use for Indexer Settings. Indexer Settings provide source code
navigation in the Eclipse IDE.

% Mew Project I?IE

Import Existing Code

Create a new Makefile project from existing code in that same directory

Project Mame
My _Project

Existing Code Location

CAMy_Project

Languages

I: I:++

Toolchain for Indexer Settings

<none>
ARM Compiler 5 (D5-5 built-in)

ARM Compiler & (D5-5 built-in)
GCC 4.x [arm-linux-gnueabihf] (D5-5 built-in)
GCC for ARM Bare-metal

Show only available teolchains that suppert this platform

@ Next > Finish || Cancel

Figure 2-2 Creating a new Makefile project with existing code

Click on Finish to create your new project. The project and source files are visible in the Project
Explorer view.

Before you can build the project, a Makefile, containing all the compilation tool settings, is required.
The easiest way to create one is to copy the Makefile from an example project, and paste it into your
new project.

Edit the Makefile for your new project.
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10. Right-click the project and then select Properties > C/C++ Build to access the build settings. In the
Builder Settings tab, ensure that the Build directory points to the location of the Makefile.
11. Add any other source files you need to the project.

Postrequisites

You can now build the new project:
1. In the Project Explorer view, select the project that you want to build.
2. Select Project > Build Project from the main menu.
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2.5 Importing an existing Eclipse project
If you have an existing Eclipse project, you can import it into your workspace.
To import an existing Eclipse project into your workspace:
Procedure

1. Select Import... from the File menu.

2. To import an existing project, select Existing Project into Workspace. Click on Next.
( & Import l S] |- )

Select
\4
Create new projects from an archive file or directory. I g 5 ]

Select an import source:

type filter text

4 = General
JE Archive File
[ Existing Projects into Workspace
[} File Systern
[T Preferences
= C/C++
= CVS
= Install

= Remote Systems

= Run/Debug
= Scatter File Editor
= Target Configuration Editor

= Team

':?3' < Back Mext > Finish

. A

Figure 2-3 Selecting the import source type
3. Click on Browse to select the import folder containing the project that you want to import.
4. In the Projects panel select the project that you want to import.

5. Select Copy projects into workspace if required or deselect to create links to your existing
project(s) and associated files.

6. If you are not using working sets to group your projects then you can skip this step.

a. Select Add project to working sets.

b. Click on Select....

c. Select an existing working set or create a new one and then select it.
d. Click OK.

7. Click on Finish.
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2.5 Importing an existing Eclipse project

= Import [ =] éj
Import Projects T
Select a directory to search for existing Eclipse projects. J
() Select root directory: Browse...
@ Select archive file: | - Browse...
Projects:
Select All
Deselect All
Options
Search for nested projects
Copy projects into workspace
[ Hide projects that already exist in the workspace
Working sets
[] Add project to working sets
Select...
., —

4

Figure 2-4 Selecting an existing Eclipse projects for import

Note

If your existing project contains project settings from an older version of the build system, you are
given the option to update your project. Using the latest version means that you can access all the

latest toolchain features.

The imported project is visible in the Project Explorer view.
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2.6 Setting up the compilation tools for a specific build configuration

The C/C++ Build configuration panels enable you to set up the compilation tools for a specific build
configuration, in your project. The settings in these panels determine how the compilation tools build an
Arm executable image or library.

To access the build configuration panels:

Procedure

1.

Select the source file or project in the Project Explorer view.

2. Select Properties from the Project menu.

3. Expand C/C++ Build in the Properties dialog box.
4.
5

. The Configuration panel shows the active configuration. If required, click Manage Configurations...

Select Settings.

from the Configuration panel to create a new build configuration or change the active setting.
The compilation tools available for the current project, and their respective build configuration panels
are displayed in the Tool Settings tab. Click on this tab and configure the build as required.

Note

Makefile projects do not use these configuration panels. The Makefile must contain all the required
compilation tool settings.
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2.6 Setting up the compilation tools for a specific build configuration

-
= Properties for HelloWorld

B ) |

type filter text

> Resource
Builders
4 C/C++ Build
Build Variables
Environment
Logging
Settings
Tool Chain Editor
4 C/C++ General
> Code Analysis
Documentation
File Types
Formatter
Indexer
Language Mappings
Paths and Symbols
Preprocessor Include P:
Project References
Run/Debug Settings

Settings

(=

| »

Configuration: ’Debug [ Active ]

'] ’Manage Configurations...

% Tool Settings |.ﬁ' Build Steps

Build Artifactl Binary Parsersl & Error Parsers

a4 B3 ARM C Compiler 5
(22 Target
(22 Preprocessor
(2 Includes
(% Source Language
(2 Optimizations
(2 Debugging
(# Warnings and Errars
(2 Miscellaneous
a4 3 ARM Assembler 5
(22 Target
(22 Preprocessor
(2 Debugging
(# Warnings and Errors
(2 Miscellaneous
a4 3 ARM Linker 5
(22 Target
(2 Image Layout
(2 Libraries
(# Optimizations
(# Additional Information
(# Warnings and Errors
(# Miscellaneous

Command:  armcc

Alloptions:  _00 -g

Expert settings:
Command
line pattern:

S{COMMAND} S{FLAGS} S{OUTPUT_FLAG} S{OUTPUT_PREFLX}S{OUTPUT} 5{INPUTS}

m

OK ] ’ Cancel ]

7. Click OK to save the settings.

J

Figure 2-5 Typical build settings dialog box for a C project
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2.7 Configuring the C/C++ build behavior

A build is the process of compiling and linking source files to generate an output file. A build can be
applied to either a specific set of projects or the entire workspace. It is not possible to build an individual
file or sub-folder.

Eclipse provides an incremental build that applies the selected build configuration to resources that have
changed since the last build. Another type of build is the Clean build that applies the selected build
configuration to all resources, discarding any previous build states.

Automatic
This is an incremental build that operates over the entire workspace and can run automatically
when a resource is saved. This setting must be enabled for each project by selecting Build on
resource save (Auto build) in the Behaviour tab. By default, this behavior is not selected for
any project.

> C/C++ General
Project References
Run/Debug Settings

= Properties for HelloWorld L@éj
type filter text C/C++ Build f=TR 2 r v
> Resource
Builders
.| C/C++ Build Cenfiguration: ’Debug [ Active ] '] ’Manage Configurations...

[E] Builder Settings| @ Behavior | & Refresh Poli
g D oy

Build settings
[¥] Stop on first build error [C] Enable parallel build
@ Use optimal jobs (4)
Use parallel jobs: | 4
Use unlimited jobs
Workbench Build Behavior
Workbench build type: Make build target:

[ Build on resource save (Aute build) | all Variables...

MNote: See Workbench automatic build preference

[¥] Build (Incremental build) all
[¥] Clean clean

’ Restore Defaults ] ’ Apply ]

[ ok || Cance |

S

Figure 2-6 Workbench build behavior

You must also ensure that Build Automatically is selected from the Project menu. By default,
this menu option is selected.
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2 Working with projects
2.7 Configuring the C/C++ build behavior

This is an incremental build that operates over the entire workspace on projects with Build
(Incremental build) selected. By default, this behavior is selected for all projects.

You can run an incremental build by selecting Build All or Build Project from the Project
menu.

Note

Manual builds do not save before running so you must save all related files before selecting this
option! To save automatically before building, you can change your default settings by selecting
Preferences... > General > Workspace from the Window menu.

This option discards any previous build states including object files and images from the
selected projects. The next automatic or manual build after a clean, applies the selected build
configuration to all resources.

You can run a clean build on either the entire workspace or specific projects by selecting
Clean... from the Project menu. You must also ensure that Clean is selected in the C/C++
Build > Behaviour tab of the Preferences dialog box. By default, this behavior is selected for all
projects.

Build order is a feature where inter-project dependencies are created and a specific build order is defined.
For example, an image might require several object files to be built in a specific order. To do this, you
must split your object files into separate smaller projects, reference them within a larger project to ensure
they are built before the larger project. Build order can also be applied to the referenced projects.
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2.8 Using Eclipse from the command-line to clean and build your projects

You can run Eclipse from the command-line to clean and build your projects. This might be useful, for
example, when you want to create scripts to automate build procedures.

Procedure

1. Launch a DS-5 command-line console to load Eclipse, make, and other utilities on your PATH
environment variable. To do this:
*  On Windows, select Start > All Programs > ArmDS-5 > DS-5 Command Prompt.
*  On Linux, run bs-5_install_directory/bin/suite_exec <shell> to open a shell.

2. Run eclipsec.exe (on Windows) or eclipse (on Linux) with the following Eclipse arguments as
required.

Note

* Ensure the DS-5 Eclipse session is closed before running the eclipsec.exe command.

*  On Windows, you must run eclipsec.exe from either the DS-5 Command Prompt or directly
from the DS-5_install_directory\bin directory (not the one in DS-5_1install_directory\sw
\eclipse directory).

The eclipsec.exe file in DS-5_install_directory\bin acts as a wrapper for eclipsec.exe in
DS-5_1install_directory\sw\eclipse. Running eclipsec.exe file in the DS-5_install_directory
\bin directory sets up the DS-5 environment (paths, environment variables, and other similar
items) in the same way as the DS-5 Command Prompt.

For example:

C:\>"C:\Program Files\DS-5 v5.28.0\bin\eclipsec.exe" -nosplash -application
org.eclipse.cdt.managedbuilder.core.headless build -data "C:\path\to\your\workspace" -
cleanBuild startup_Cortex-R8

Table 2-1 Eclipse arguments

Argument Description

-nosplash Disables the Eclipse splash screen.

--launcher.suppressErrors Causes errors to be printed to the console instead of being reported in a graphical
dialog.

-application Mandatory argument telling Eclipse to run the headless builder.

org.eclipse.cdt.managedbuilder.core.headl

essbuild

-data {workspaceDir} Specify the location of your workspace.

-import {projectDir} Import the project from the specified directory into your workspace.
Use this option multiple times to import multiple projects.
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Table 2-1 Eclipse arguments (continued)

Argument

Description

-build {projectName[/configName] | all}

Build the project with the specified name, or all projects in your workspace.

By default, this argument builds all the configurations within each project. You
can limit this action to a single configuration, such as Debug or Release, by
specifying the configuration name immediately after your project name, separated
with '/'.

Use this option multiple times to build multiple projects.

-cleanBuild {projectName[/configName] |
all}

Clean and build the project with the specified name, or all projects in your
workspace.

By default, this argument cleans and builds all the configurations within each
project. You can limit this action to a single configuration, such as Debug or
Release, by specifying the configuration name immediately after your project
name, separated with '/'.

Use this option multiple times to clean and build multiple projects.

Example 2-1 Examples

To list and view the full set of available options, use the command:
eclipsec.exe -nosplash -application org.eclipse.cdt.managedbuilder.core.headlessbuild
To clean and build att the projects in a workspace at the c:\workspace location, use the command:
eclipsec.exe -nosplash -application org.eclipse.cdt.managedbuilder.core.headlessbuild -

data C:\workspace -cleanBuild all
To build the Release configuration of project Myproject in workspace c:\workspace, use the

command:

eclipsec.exe -nosplash -application org.eclipse.cdt.managedbuilder.core.headlessbuild -

data C:\workspace -build MyProject/Release
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29 Updating a project to a new toolchain

If you have several products installed, only the latest toolchain is listed in the New Project wizard.
Therefore, if you have projects that use an older toolchain, you must update them to the latest toolchain.

To update them to use the new toolchain:

Procedure
1. Right-click on the project in the Project Explorer view.
2. Select Convert To... from the context menu to display the Project Converters dialog box.

3. Select the required toolchain.

Note
Beware that if you convert back to an earlier version you might lose toolchain functionality.

4. Click OK.
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2.10 Adding a new source file to your project

210 Adding a new source file to your project
You can add a new source file to your project.
To do this:
Procedure

1. Select File > New > DS-5 Debugger script from the main menu.

2. Click Workspace or File System... in the Location field to add the project folder or sub-folder path
in the New Script dialog box.

& New Script |:|E|E|

Mew DS-5 Debugger Script

L,
W

Ready ko create the new D5-5 Debugger Script, |

Location | $warkspace_lockmyFolder | [File Syskem, .. ] ['-.-'u'u:urkspace...

File Mame | mySource, C |

@:‘ Einish l [ Cancel

Figure 2-7 Adding a new file to your project
3. Enter a filename with the relevant extension in the File Name field.
4. Click on Finish.
The new source file is visible in the Project Explorer view.

* You can also create files, or drag and drop files directly into the project folder, using the file
system. To update the views in Eclipse, click on the relevant project in the Project Explorer view
and select Refresh from the File menu.

*  You can also drag and drop files directly into a project folder, in the Project Explorer view of
Eclipse.
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2.11 Sharing Eclipse projects

You can share Eclipse projects between users if necessary.

Note

* There are many different ways to share projects and files, for example, using a source control tool.
This topic covers the general principles of sharing projects and files using Eclipse, and not the
specifics of any particular tool.

» To share files, it is recommended to do so at the level of the project and not the workspace. Your
source files within Eclipse are organized into projects, and projects exist within your workspace. An
Eclipse workspace contains many files, including files in the .metadata directory, that are specific to
an individual user or installation.

Within each project, the files that must be shared beyond just your source code are:

* .project - Contains general information about the project type, and the Eclipse plug-ins to use to edit
and build the project.

* .cproject - Contains C/C++ specific information, including compiler settings.

Eclipse places built files into the project directory, including auto-generated makefiles, object files, and
image files. Not all files have to be shared. For example, sharing an auto-generated makefile might be
useful to allow building the project outside of Eclipse, but if projects are only built within Eclipse then
this is not necessary.

You must be careful when creating and configuring projects to avoid hard-coded references to tools and
files outside of Eclipse that might differ between users.

To ensure that files outside of Eclipse can be referenced in a user agnostic way, use the ${workspace_Loc}
built-in variable or custom environment variables.
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Chapter 3
Working with editors

The following topics describe how to use the editors when developing a project for an Arm target.

It contains the following sections:

» 3.1 About the C/C++ editor on page 3-69.

* 3.2 About the Arm assembler editor on page 3-70.

* 3.3 About the ELF content editor on page 3-71.

* 3.4 ELF content editor - Header tab on page 3-72.

* 3.5 ELF content editor - Sections tab on page 3-73.

* 3.6 ELF content editor - Segments tab on page 3-74.

» 3.7 ELF content editor - Symbol Table tab on page 3-75.
* 3.8 ELF content editor - Disassembly tab on page 3-76.
* 3.9 About the scatter file editor on page 3-77.

» 3.10 Creating a scatter file on page 3-78.

»  3.11 Importing a memory map from a BCD file on page 3-80.
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3 Working with editors
3.1 About the C/C++ editor

31 About the C/C++ editor

The standard C/C++ editor is provided by the CDT plug-in that provides C and C++ extensions to
Eclipse. It provides syntax highlighting, formatting of code and content assistance when editing C/C++
code.

Embedded assembler in C/C++ files is supported by the Arm Compiler but this editor does not support it
and so an error is displayed. This type of code is Arm-specific and accepted Eclipse behavior so you can
ignore the syntax error.

If this is not the default editor, right-click on a source file in the Project Explorer view and select Open
With > C/C++ Editor from the context menu.

See the C/C++ Development User Guide for more information. Select Help > Help Contents from the
main menu.
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3 Working with editors
3.2 About the Arm assembler editor

3.2 About the Arm assembler editor

The Arm assembler editor provides syntax highlighting, formatting of code and content assistance for
labels in Arm assembly language source files. You can change the default settings in the Preferences
dialog box.

If this is not the default editor, right-click on your source file in the Project Explorer view and select
Open With > Arm Assembler Editor from the context menu.

The following shortcuts are also available for use:

Table 3-1 Arm assembler editor shortcuts

Content assist

Content assist provides auto-completion on labels existing in the active file. When entering a label for a branch
instruction, Partially type the label and then use the keyboard shortcut Ctrl+Space to display a list of valid auto-
complete options. Use the Arrow Keys to select the required label and press Enter to complete the term. Continue

typing to ignore the auto-complete list.

Editor focus

The following options change the editor focus:

* Outline View provides a list of all areas and labels in the active file. Click on an area or label to move the focus
of the editor to the position of the selected item.

» Select a label from a branch instruction and press F3 to move the focus of the editor to the position of the
selected label.

Formatter Press Ctrl+Shift+F to activate the formatter settings.

activation

Block Block comments are enabled or disabled by using Ctrl+Semicolon. Select a block of code and apply the keyboard
comments shortcut to change the commenting state.
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3.3 About the ELF content editor

3.3 About the ELF content editor

The ELF content editor creates forms for the selected ELF file. You can use this editor to view the
contents of image files and object files. The editor is read-only and cannot be used to modify the contents
of any files.

If this is not the default editor, right-click on your source file in the Project Explorer view and select
Open With > ELF Content Editor from the context menu.

The ELF content editor displays one or more of the following tabs depending on the selected file type:

Header

Form view showing the header information.
Sections

Tabular view showing the breakdown of all section information.
Segments

Tabular view showing the breakdown of all segment information.
Symbol Table

Tabular view showing the breakdown of all symbols.
Disassembly

Textual view of the disassembly with syntax highlighting.
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3 Working with editors
3.4 ELF content editor - Header tab

34 ELF content editor - Header tab

The Header tab provides a form view of the ELF header information.

arh grometris &3 =0
Header £

Machine class ELFCLASS3Z (32-bit)

Data encoding ELFDATAZLSE (Little endian)

Header version EV_CURREMT {Current wersion)

Operating System ABI [glalyts]

ABI version ]

File type ET_EXET {Executable File) {23

Machine EM_ARM (dvanced RISC Machines ARM)

Image entry point Cx0000Z0485

Flags EF_ARM_HASENTRY

Header 5Size 57 bytes (0x34)

Segment header entry size 32 bytes (0x20)

Section header entry size 40 bykes (Ox23)

Program header entries g

Section header entries 39

Program header offset 52

Section header offset 195956

Section header string table index 36

Header | Sections | Symbol Table | Disassembly

Figure 3-1 Header tab
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3.5

ELF content editor - Sections tab

The Sections tab provides a tabular view of the ELF section information.

To sort the columns click on the column headers.

|8 griometris 3

Sections

MNumber | Mame

1 \inkerp

2z note, ABI-tag

3 .hash

4 .dynsym

5 Jdynstr

& .gnu.version

7 Jgriu,version_r
g rel.dyn

9 .rel.ple

10 Jinit

11 plt

1z et

13 fini

14 .rodata

15 JARM,extab

16 ARM, Exidi

17 Jinit_array

18 Jfimi_array

19 .jer

20 Jdynamic

21 .gok

22 .data

23 .bss

24 JARM, attributes
25 .comment

26 .debug_aranges
27 .debug_pubnames
za .debug_info

29 .debug_abbrev
30 .debug_line

31 .debug_frame
32 .debug_str

33 .debug_loc

34 .debug_pubtypes
35 .debug_ranges
36 .shstrtab

37 symtab

35 .strtab

Header | Sections | Symbol Table | Disassembly

ELF Offset

0x0000015 4
0x00000145
0x00000165
0x0000055C
0x000017EC
0x00002C24
0x0000ZELD
0x0000ZELD
Ox0000ZEES
0x000035DE
0x000035E4
0x00004045
Ox0000ASS4
0x00004S60
0x00008B4DC
0x0000EBASO
Ox00o0acooo
0x0000C004
0x0000C00s8
Ox0000cCooC
0x0000C164
0x0000C504
0x0000CDF 4
0x0000CDF 4
0x0000CELD
Ox0000CE47Y
0x0000CFae7
0x0000DD3 4
Ox0001ECZE
0x0002054E
Ox000237FC
0x000Z245ES
O0x000294F6
0x000Z2D7D6E
0x00030497
0x000307AF
O0x00030F 44
Ox000334F 4

Address

0x00005154
0x00005145
0x00008168
Ox00005855C
0x000097EC
Ox0000ACZ4
0x0000LELD
Ox0000AEAD
0x0000LEES
0x0000ESDE
0x0000ESE4
0x0000C0LS
0x00012554
0x00012560
O0x000134DC
0x00013 480
Ox0001C000
0x0001C004
O0x0001C0038
0x0001cCoo0C
0x0001C164
0x0001C504
0x0001CDFS
0x00000000
0x00000000
Ox00000000
0x00000000
Ox00000000
0x00000000
Ox00000000
0x00000000
0x00000000
0x00000000
0x00000000
0x00000000
0x00000000
Ox00000000
0x00000000

3 Working with editors
3.5 ELF content editor - Sections tab

Size (Bytes)

Ox00000013
Ox000000z0
Ox000006F 4
Ox00000F &0
O0x00001465
Ox000001EC
Ox00000050
Ox000000158
Ox00000720
Ox0000000ac
Ox00000ACS
Ox0000644C
Ox00o0000s
Ox00000F7C
Ox00000544
O0x000003F5
Ox00o00004
Ox00000004
Ox00000004
O0x00000158
Ox000003 40
Ox000005F0
Ox00000060
Ox00000029
Ox0000002 &
Ox00000120
Ox00000DC
Ox00010EFA
O0x0000191D
O0x00003 280
O0x000010EC
Ox00004C0OE
Ox000042E0
Ox00002CC1
O0x00000318
Ox00000174h
Ox0000ZBEO
Ox0000Z A3 A

%

Figure 3-2 Sections tab

100951_0528_00_en

Copyright © 2010-2017 Arm Limited (or its affiliates). All rights reserved.

Non-Confidential

3-73



3 Working with editors
3.6 ELF content editor - Segments tab

3.6 ELF content editor - Segments tab

The Segments tab provides a tabular view of the ELF segment information.

To sort the columns click on the column headers.

gnometris &3 =08
Segments R
MNumber Type Virtual Address Memory Size (Bytes) File Size (Bytes) Flags

a PF_ARM_EXTDX Bx@aa13A86 1816 177@ PF_R

1 PT_PHDR Bxepasas4 256 4ae PF_X+PF_R

2 PT_INTERP Bxeeeasli4 19 23 PF_R

3 PT_LOAD exgeRasRRE 48768 13717@ PF_X+PF_R

4 PT_LOAD exeeelCaes 3672 6764 PF_W+PF_R

5 PT_DYNAMIC exeeelCeac 344 538 PF_W+PF_R

6 PT_NOTE BxBeRa8148 32 48 PF_R

7 BxB474E551 s dclajalellolalo] 5] 5] PF_W+PF_R

Header | Sections | Segments | Symbol Table | Disassemnbly

Figure 3-3 Segments tab
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3.7 ELF content editor - Symbol Table tab
The Symbol Table tab provides a tabular view of the symbols.

To sort the columns click on the column headers.

|8 griometris 3

Symbol Table

Murmnber Address

a 000000000
1 O0x000051:534
2 O0x00005145
3 O0x00005165
4 O 0000555C
5 0x0000976C
B Ox0000AC24
7 0x0000AE10
g O0000AEAD
9 0x0000AEES
10 000008508
11 0x0000ESE4
12 00000045
13 0x00012554
14 O0x00012560
15 0000134002
16 0x00013450
17 Q0001000
15 00001004
19 Q0001008
20 Ox0001Ca0C
21 00001164
z2 00001504
23 Ox0001C0FS
24 000000000
25 000000000
26 000000000
27 000000000
28 000000000
29 000000000
30 000000000
31 000000000
32 000000000
33 000000000
54 000000000
35 000000000
i1 0x0000C0E4
37 0x0000C0E4
et 00000100
39 Ox0000BS0E
40 0x00012554

MNarmne

$a
call_gmon_skark
4d
$a
$a

Header | Sections | Symbol Table | Disassembly

Binding Tyvpe
STE_LOCAL STT_MNO...
STE_LOCAL STT_SEC...
STE_LOCAL STT_SEC...
STE_LOCAL STT_SEC...
STE_LOCAL STT_SEC...
STE_LOCAL STT_SEC...
STE_LOCAL STT_SEC...
STE_LOCAL STT_SEC...
STE_LOCAL STT_SEC...
STE_LOCAL STT_SEC...
STE_LOCAL STT_SEC...
STE_LOCAL STT_SEC...
STE_LOCAL STT_SEC...
STE_LOCAL STT_SEC...
STE_LOCAL STT_SEC...
STE_LOCAL STT_SEC...
STE_LOCAL STT_SEC...
STE_LOCAL STT_SEC...
STE_LOCAL STT_SEC...
STE_LOCAL STT_SEC...
STE_LOCAL STT_SEC...
STB_LOCAL STT_SEC...
STE_LOCAL STT_SEC...
STE_LOCAL STT_SEC...
STE_LOCAL STT_SEC...
STE_LOCAL STT_SEC...
STE_LOCAL STT_SEC...
STE_LOCAL STT_SEC...
STE_LOCAL STT_SEC...
STE_LOCAL STT_SEC...
STE_LOCAL STT_SEC...
STE_LOCAL STT_SEC...
STE_LOCAL STT_SEC...
STE_LOCAL STT_SEC...
STE_LOCAL STT_SEC...
STE_LOCAL STT_SEC...
STE_LOCAL STT_MNO...
STE_LOCAL STT_FUNC
STE_LOCAL STT_MNO...
STE_LOCAL STT_NQ...
STE_LOCAL STT_MNO...

Section

3 Working with editors

3.7 ELF content editor - Symbol Table tab

Yisibility
STW_DEFALLT
STW_DEFALLT
STW_DEFALLT
STW_DEFALLT
STV_DEFALLT
STW_DEFALLT
STY_DEFALLT
STW_DEFALLT
STY_DEFALLT
STW_DEFALLT
STW_DEFALLT
STW_DEFALLT
STW_DEFALLT
STW_DEFALLT
STW_DEFALLT
STW_DEFALULT
STW_DEFALLT
STY_DEFALLT
STW_DEFALLT
STY_DEFALLT
STW_DEFALLT
STW_DEFALLT
STW_DEFALLT
STW_DEFALLT
STW_DEFALLT
STW_DEFALLT
STW_DEFALULT
STW_DEFALLT
STY_DEFALLT
STW_DEFALLT
STY_DEFALLT
STW_DEFALLT
STW_DEFALLT
STW_DEFALLT
STW_DEFALLT
STW_DEFALLT
STW_DEFALLT
STW_DEFALLT
STW_DEFALLT
STV_DEFALLT
STW_DEFALLT

Size
Q00000000
Q00000000
Q00000000
Q00000000
000000000
Q00000000
000000000
Q00000000
000000000
Q00000000
000000000
Q00000000
Q00000000
Q00000000
Q00000000
Q00000000
Q00000000
000000000
Q00000000
000000000
Q00000000
000000000
Q00000000
Q00000000
Q00000000
Q00000000
Q00000000
Q00000000
000000000
Q00000000
000000000
Q00000000
000000000
Q00000000
Q00000000
Q00000000
Q00000000
Q00000000
Q00000000
000000000
Q00000000

%

Figure 3-4 Symbol Table tab
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3 Working with editors
3.8 ELF content editor - Disassembly tab

3.8 ELF content editor - Disassembly tab

The Disassembly tab displays the output with syntax highlighting. The color schemes and syntax
preferences use the same settings as the Arm assembler editor.

There are several keyboard combinations that can be used to navigate around the output:
» Use Ctrl+F to open the Find dialog box to search the output.

* Use Ctrl+Home to move the focus to the beginning of the output.

» Use Ctrl+End to move the focus to the end of the output.

» Use Page Up and Page Down to navigate through the output one page at a time.

You can also use the Copy and Find options in the context menu by right-clicking in the Disassembly
view.

st} arometris &3 =0
Disassembly e

** Zection #10 .initc #% G
_init

O0x0000ESDS: PUSH {r3,3r}

O0x0000ESDC: BL call gmon start ; OxCOE4

O0x0000ESEQ: POP {r3, pch
**% Section #11 .plt *%

O0x0000ESE4: PUSH {1r}

0x0D000BSES: LDR ir, [pc, #4] : [0xBSF4] = 0OxO

O0x0000ESEC: ADD dr,pe,1r

0x0000BSFO: LDR pa, [1r, #8] !

O0x0000ESF4: DCD Ox00010E70

0x0000BSFS: ADD riz, pe,f0, 12 ; #O

Ox0000ESFC: ADD rizZ, ri12,#0x10, 20 : #0x10000

0x0000B600: LDR pc, [£12,#0xh70] !

0x0000B604: ADD riz, pe,#0, 1z ; #O

O0x0000E&0S: ADD rizZ, ri12,#0x10, 20 : #0x10000

0x0000B60C: LDR pc, [£12,#0xh6E] !

0x0000B610: ADD riz, pe,#0, 1z ; #O

Ox0000E&S14: ADD rizZ, ri12,#0x10, 20 : #0x10000

0x0000B618: LDR pc, [£12,#0xh60] !

0x0000B61C: ADD riz, pe,#0, 1z ; #0

Ox0000E&Z0: ADD rizZ, ri12,#0x10, 20 : #0x10000

0x0000B624: LDR pc, [£12,#0xh5E8] !

Ox0000B6Z5: ADD rlz, po,#0, 12 : #0O

Ox0000EGZC: ADD rizZ, ri12,#0x10, 20 : #0x10000

0x0000B630: LDR pc, [£12,#0xh50] !

0x0000B634: ADD riz, pe,#0, 12 ; #0O

O0x0000E&35: ADD rizZ, ri12,#0x10, 20 : #0x10000

0x0000B63C: LDR pc, [£12, #0xh4a] !

0x0000B620: ADD riz, pe,#0, 12 ; #0O

Ox0000EG34: ADD rizZ, ri12,#0x10, 20 : #0x10000

0x0000B648: LDR pc, [12,#0xh40] ! .

Header | Sections | Symbol Table | Disassembly

Figure 3-5 Disassembly tab
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3.9 About the scatter file editor

The scatter file editor enables you to easily create and edit scatter files for use with the Arm linker to
construct the memory map of an image.

It provides a text editor, a hierarchical tree and a graphical view of the regions and output sections of an
image. You can change the default syntax formatting and color schemes in the Preferences dialog box.

If this is not the default editor, right-click on your source file in the Project Explorer view and select
Open With > Scatter File Editor from the context menu.

The scatter file editor displays the following tabs:

Source
Textual view of the source code with syntax highlighting and formatting.

Regions/Sections
A graphical view showing load and execute memory maps. These are not editable, however, you
can select a load region to show the related memory blocks in the execution regions.

The scatter file editor also provides a hierarchical tree with associated toolbar and context menus using
the Outline view. Clicking on a region or section in the Outline view moves the focus of the editor to the
relevant position in your code. If this view is not visible, from the Window menu, select Show View >
Outline.

Note

The linker documentation for Arm Compiler describes in more detail how to use scatter files.

Before you can use a scatter file you must add the --scatter=file option to the project within the C/C++
Build > Settings > Tool settings > ARM Linker > Image Layout panel of the Properties dialog box.
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3 Working with editors
3.10 Creating a scatter file

3.10 Creating a scatter file

Create a scatter file to specify more complex memory maps that cannot be specified using compiler
command-line memory map options.

To create a scatter file:

Procedure
1. Use an existing project or create a new project.

2. Create a new project and add a new empty text file with the extension .scat. For example
scatter.scat.

3. Using the Outline view, click on the Add load region toolbar icon or right-click and select Add load
region from the context menu.

4. Enter a load region name, for example, LR1.

& Add Load Region *

Marme:

| LR1

Figure 3-6 Add load region dialog box
5. Click OK.
6. Modify the load region as shown in the following example.
Simple scatter file
LR1 0x0000 0x8000
LR1_erl 0x0000 0x8000
* (+RO)
LR1_er2 0x10000 0x6000
* (+RW,+ZI)
}

7. Click on the Regions/Sections tab to view a graphical representation.
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€] mySource,c |=] scatter.scat £2
0xFFFFFFFF |
LR1
000000000

Load Regions

Reqions/Sections | scatter.scat

8. Save your changes.

Note

3 Working with editors
3.10 Creating a scatter file

=08

OxFFFFFFFF | '
LR1_er2
FHRW,+2T)
000010000
LR1_erl
*RO)
(00000000

Execution Regions

Figure 3-7 Graphical view of a simple scatter file

Before you can use a scatter file you must add the --scatter=file option to the project within the
C/C++ Build > Settings > Tool settings > ARM Linker > Image Layout panel of the Properties

dialog box.
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3.1 Importing a memory map from a BCD file

3 Working with editors
3.11 Importing a memory map from a BCD file

If you have a BCD file that defines a memory map, you can import this into the Scatter file editor.

To import a memory map from a BCD file:

Procedure
1. Select Import from the File menu.
Select Scatter File Editor > Memory from a BCD File.

& Import

Select
Memuory fram a BCD file,

Select an import wizard:

type filter text

[E=]

= General
= C/C++
= CVS
= D55
= Git
= Install
= Remuote Systems
= Run/Debug
w [ Scatter File Editor
';J::: Mermaory from a BCD File
(= Target Configuration Editor
= Team

@' < Back Mext =

Finish

Cancel

Figure 3-8 Import memory map for the scatter file editor

2. Enter the location of the BCD file or click on Browse... to select the folder.

3. Select the required file containing the memory map that you want to import.
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3 Working with editors
3.11 Importing a memory map from a BCD file

& Import O *
Select a BCD file i@
BCTnge=

Select a BCD file to import memory.

Select a BCD file

Search directery: | C:\DS-5_Workspace | Browse...

EB_1136.bcd

Options
() Add to current scatter file

(®) Create new scatter file template

Inte destination folder: | BCD File import Browse...
@ < Back Next > Finish Cancel

Figure 3-9 BCD file selection for the scatter file editor

4. Select Add to current scatter file if you want to add specific memory regions to an existing scatter
file.

Note
The scatter file must be open and active in the editor view before you can use this option.

5. Select Create new scatter file template if you want the wizard to create a new file with the same
name as the BCD file but with a . scat file extension.
Select the destination project folder.
By default, all the memory regions are selected. Modify the selections and table content as required.
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3 Working with editors
3.11 Importing a memory map from a BCD file

& Import

Select Memory Blocks
Select memory blocks from the table to create a scatter file template, You can change j

O x

BCD @

memaory names, start addresses and sizes to suit your regicns. P
Memory Mame Start Address Size Type &3

M_REMAP_MOR_FLASH 000000000 Dp04000000 Flash
M_REMAP_MNAND_FLASH 000000000 Dp04000000 Flash
M_REMAP_SDRAM Cx00000000 De00000000 M/ &
M_REMAP_PISMO_CS0 000000000 De00000000 M/ &
M_REMAP_PISMO_CS1  0xD0D0D0D0 De00000000 M/ &
M_REMAP_PISMO_CS2 000000000 De00000000 M/ &
M_REMAP_PISMO_CS3  (xD0D0D000 De00000000 M/ &
M_BRD_SYS_REGS Ox 10000000 000001000 M/ &
M_BRD_SYS5_CON Ox 10001000 000001000 M/ &
M_BRD_I2C_CTRL Ox 10002000 000001000 M/ &

M_BRD_RSVDO Ox 10003000 000001000 M/ &

M_BRD_AACI Ox 10004000 000001000 M/ &

M_BRD_MMCI Ox 10005000 000001000 M/ &

M_BRD_KMID Ox 10006000 000001000 M/ &

M_BRD_KMI Ox 10007000 000001000 M/ & v

Select All Deselect All
?\ < Back Mext = Cancel

Figure 3-10 Memory block selection for the scatter file editor

8. Click Finish to complete the scatter file.

Note

Before you can use a scatter file you must add the --scatter=file option to the project within the
C/C++ Build > Settings > Tool settings > ARM Linker > Image Layout panel of the Properties

dialog box.
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Chapter 4
Terminology, shortcuts and icons

This following topics describe some of the terminology used in Eclipse for DS-5 User Guide, useful
keyboard shortcuts, and menu and toolbar icons.

It contains the following sections:

e 4.] Terminology on page 4-84.

* 4.2 Keyboard shortcuts on page 4-85.

e 4.3 Menu and toolbar icons on page 4-86.
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4 Terminology, shortcuts and icons
4.1 Terminology

4.1 Terminology
A list of the terms used in this document.

Block
A small sub-division of a flash device that can be programmed.
Device
A component on a target containing the application that you want to debug.
Dialog box
A small page containing tabs, panels and editable fields prompting you to enter information.
Editor
A view that controls the visual aspects of source code for a specific file type.
Erase
A feature of a flash device where memory cells are reset to a known value.
Flash device
A set of flash memory that has a single command interface.
Panel
A small area in a dialog box or tab to group editable fields.
Perspective
A page within the Eclipse window containing a set of related views, editors, menus, and
toolbars.
Program
A term used to describe the storing of data on a flash device.
Project
A group of related files and folders in Eclipse.
Resource
A generic term used to describe a project, file, folder, or a combination of these.
Send To
A term used to describe sending a file to a target.
Tab
A small overlay page containing panels and editable fields within a dialog box to group related
information. Clicking on a tab brings it to the top.
Target
A development platform on a printed circuit board or a software model that emulates the
expected behavior of Arm hardware.

View
A small page to display related information for a specific function.
Width
The smallest number of bits (8, 16, or 32) that can be natively accessed by a flash device.
Wizard
A group of dialog boxes to guide you through a common tasks, for example, creating new files
and projects.
Workbench
A window containing perspectives, menus, and toolbars.
Workspace

An area designated on your file system to store files and folders related to your projects.
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4.2 Keyboard shortcuts

A list of the most common keyboard shortcuts available for use with Eclipse.

F3
Click on an assembler label from a branch instruction or a C/C++ calling function and press F3
to move the editor focus to the position of the selected item.
F10
Use in conjunction with the arrow keys to access the main menu.
Alt+F4
Exit Eclipse.
Alt+Left arrow
Go back in navigation history.
Alt+Right arrow
Go forward in navigation history.
Ctrl+Semicolon
Provided with the Arm assembler editor to add comment markers to a selected block of code in
the active file.
Ctrl+End
Moves the editor focus to the end of the code.
Ctrl+B
Build all projects in the workspace that have changed since the last build.
Ctrl+Home
Moves the editor focus to the beginning of the code.
Ctrl+F
Opens the Find or Find/Replace dialog box to search through the code in the active editor. Some
editors are read-only and therefore disable this functionality.
Ctrl+F4
Close the active file in the editor view.
Ctrl+Fé6
Cycles through open files in the editor view.
Ctrl+F7
Cycles through available views.
Ctrl+F8
Cycles through available perspectives.
Ctrl+F10
Use in conjunction with the arrow keys to access the drop-down menu.
Ctrl+L
Move to a specified line in the active file.
Ctrl+Q
Move to the last edited position in the active file.
Ctrl+Space
Provides auto-completion on selected functions in editors.
Shift+F10
use in conjunction with the arrow keys to access the context menu.
Ctrl+Shift+F
Activates the code style settings in the Preferences dialog box and apply them to the active file.
Ctrl+Shift+L
Opens a small page with a list of all keyboard shortcuts.
Ctrl+Shift+R
Opens the Open resource dialog box.
Ctrl+Shift+T
Opens the Open Type dialog box.
Ctrl+Shift+/
Provided with the C/C++ editor to add comment markers to the start and end of a selected block
of code in the active file.
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Menu and toolbar icons

4 Terminology, shortcuts and icons

4.3 Menu and toolbar icons

These are the most common menu and toolbar icons available for use with Eclipse.

For information on icons, markers, and buttons not listed in the following tables, see the standard
Workbench User Guide or the C/C++ Development User Guide in the Help Contents.

If you leave the mouse pointer positioned on a toolbar icon for a few seconds without clicking, a tooltip
appears informing you of the purpose of the icon.

Perspective icons

View icons

View markers

Editor icons

Table 4-1 Perspective icons

Icon | Description Icon | Description
Ej? Open new perspective El C/C++
& DS-5 Debugger
Table 4-2 View icons
Icon | Description Icon | Description
— | | Display drop-down menu <J==“{> Synchronize view contents
= | Minimize [ |Maximize
&= |Restore =2 | Close
Table 4-3 View markers
Icon | Description | Icon | Description
: Bookmark Information
L4 | Task = | Search result
i | Error /& | Warning
Table 4-4 Editor icons
Icon | Description Icon | Description

Save the active file

Save all files

Print the active file

57 Close view

Create new configuration

Duplicate selected configuration

Delete selected configuration

Collapse configuration tree
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4.3 Menu and toolbar icons

Configuration icons

Table 4-5 Configuration icons

Icon | Description Icon | Description

o Open Run Configurations dialog box Open Debug Configurations dialog box

<

Outline icons

Table 4-6 Outline icons

Icon | Description Icon | Description
Hide fields Hide static members
Hide non-public members | - Sort alphabetically
. Class Namespace
Macro definition Enum
Enumerator Variable
Protected field Private field
Public field Include

Protected method Private method

Public method Struct
Type definition Union
Function Target configuration file
0 Include file m Memory
E Peripheral m Register
@ Bitfield @ Enumeration definition
G Map rules Tools information
Miscellaneous icons
Table 4-7 Miscellaneous icons
Icon | Description Icon | Description
Open a new resource wizard | - Open new project wizard
Open new folder wizard Open new file wizard
open search dialog box =% | Display context-sensitive help
% Add load region % Add execution region
% Add section Delete selected item
® Focus on active task % Displays product updates
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Navigation icons

4 Terminology, shortcuts and icons
4.3 Menu and toolbar icons

Table 4-8 Navigation icons

Icon | Description Icon | Description
Navigate back Navigate forwards
@ Navigate up one level . Print active page

Open help instruction page | - Synchronize TOC with active page

Bookmark active page

Help Contents icons

Table 4-9 Help Contents icons

Icon

Description

Icon | Description

Display list of all documents

Display list of documents in last search

Display list of context-sensitive help links to related topics

Display list of all bookmarks

&

Maximize frame

= Restore frame

Synchronize TOC with active page
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